1. Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.
    Information ausblenden

Gelöst [WAWI-22704] DHL Versenden - Nachnahme - Kundennummer wird nicht übergeben (Wawi 1.3.11.0)

Dieses Thema im Forum "Gelöste Themen JTL-Shipping Fehler und Bugs" wurde erstellt von knackig, 22. November 2017.

  1. knackig

    knackig Mitglied

    Registriert seit:
    17. November 2011
    Beiträge:
    390
    Zustimmungen:
    10
    Punkte für Erfolge:
    18
    Ort:
    Nordhessen
    Hallo,

    im JTL-Shipping, im Reiter "Nachnahme", habe ich folgende Daten eingepflegt:

    Note1: {{ Auftrag.Rechnung.Belegnummer }}
    Note2: {{ Auftrag.Kunde.Kundennummer }}

    An DHL wird aber folgendes übergeben (sichtbar im GKP und auf der Überweisung des Betrages):

    Verwendungszweck 1 RG-20171346
    Verwendungszweck 2 {{ Auftrag.Kunde.Kundennummer }}

    Schaut so aus, als würde die Kundennummer nicht richtig an DHL übergeben werden. Genutzt wird die Wawi 1.3.11.0.
     
  2. Rico Giesler

    Rico Giesler Super-Moderator Mitarbeiter

    Registriert seit:
    10. Mai 2017
    Beiträge:
    4.191
    Zustimmungen:
    291
    Punkte für Erfolge:
    83
    Habt ihr den zweiten Wert von Hand eingetragen oder über die Variablen ausgewählt? (der Kasten mit 3 Punkten)
    Wenn es von Hand war, dann bitte mal über die Variablen machen.
     
    Jan Weber gefällt das.
  3. knackig

    knackig Mitglied

    Registriert seit:
    17. November 2011
    Beiträge:
    390
    Zustimmungen:
    10
    Punkte für Erfolge:
    18
    Ort:
    Nordhessen
    Über die Variablen. Beide Werte wurden so eingetragen.
     
  4. Rico Giesler

    Rico Giesler Super-Moderator Mitarbeiter

    Registriert seit:
    10. Mai 2017
    Beiträge:
    4.191
    Zustimmungen:
    291
    Punkte für Erfolge:
    83
    Dabei scheint es sich um einen Fehler zu handeln.
    Normalerweise werden die Felder nach Auswahl über die Variablen am Ende gerendert und grau hinterlegt so dass man diese in der Übersicht nicht mehr anpassen kann.
    Ich gebe das mal an die Entwicklung weiter.
    Hier ist das Ticket dazu: https://issues.jtl-software.de/issues?query=WAWI-22704
    Hier könnt ihr voten und/oder Kommentare abgeben

    Was du mal versuchen kannst:
    Erneut die Variable über den Editor für Note 2 auswählen und dann an diesem Feld nichts mehr ändern. (also nicht mehr in der Übersicht in das Feld rein klicken oder ähnliches)
     
  5. knackig

    knackig Mitglied

    Registriert seit:
    17. November 2011
    Beiträge:
    390
    Zustimmungen:
    10
    Punkte für Erfolge:
    18
    Ort:
    Nordhessen
    Hi @Rico Giesler, bei der letzten Nachnahme-Bestellung habe ich mal was "verrücktes" ausprobiert... ich habe die Reihenfolge geändert. Also statt

    Note1: {{ Auftrag.Rechnung.Belegnummer }}
    Note2: {{ Auftrag.Kunde.Kundennummer }}

    habe ich folgendes an DHL geschickt:

    Note1: {{ Auftrag.Kunde.Kundennummer }}
    Note2: {{ Auftrag.Rechnung.Belegnummer }}

    Und im Verwendungszweck der Zahlung wird die Kundennummer korrekt angezeigt. Statt der Belegnummer steht aber der Name der Variable. Übergeben wird also nur Note1, Note2 wird nicht korrekt "entschlüsselt".

    Inzwischen wird die Version 1.3.13.0 verwendet.
     
  6. Jan Weber

    Jan Weber Super-Moderator Mitarbeiter

    Registriert seit:
    1. Juli 2015
    Beiträge:
    2.031
    Zustimmungen:
    82
    Punkte für Erfolge:
    48
    Beruf:
    Kundenbetreuung & Support
    Ort:
    Hürth

Diese Seite empfehlen

Verstanden Weitere Informationen

JTL-Software benutzt Cookies, teilweise von Drittanbietern, um Funktionalitäten auf unseren Webseiten zu ermöglichen.