In Bearbeitung Neue Produkte werden von der Wawi nicht nach POS synchronisiert.

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

patoc

Aktives Mitglied
20. Juni 2017
16
1
Hallo liebes Forum,

wir haben drei POS-Kassen im Einsatz (1.0.2.1) und die Wawi in der Version 1.5.25.0. Initial aufgesetzt hatten wir die Kassen vor knapp vier Wochen. Bis auf die Tatsache, dass der POS-Server immer wieder abstürzt scheint alles recht stabile zu laufen.

Nun wollten wir der Kasse via Wawi weitere Produkte hinzufügen und diese in die drei Kassen synchronisieren. Die "POS-Wurzel" ist gesetzt, und generell lief ja auch alles einwandfrei. Diese neuen Produkte wurden nun an eine Kasse mit ein paar Tagen Verzögerung und an die anderen beiden Kassen gar nicht übertragen.

Ein Löschen geht tadellos. Selbst das Löschen ganzer Kategorien geht. Aber das Hinzufügen belässt die Produkte / Kategorien immer im Status "wird aktualisiert" - siehe beigefügter ScreenShot.

Schlussendlich hat uns dieses Verhalten so viele Nerven und Zeit gekostet, dass wir auf einer der Kassen kurzerhand unter Wawi -> Admin -> Kasseneinstellungen -> Kassen die Kasse erst gesperrt, dann eine neu hinzugefügt und schließlich in JTL-POS neu authentifiziert haben. Das brachte für diese Kasse die Lösung. Aber das kann ja nicht wirklich die Lösung sein!?

Auf dem POS-Server wird immer allerhand angezeigt, die Zeilen huschen nur so durch, aber erkennen, dass die zwei Problemkassen synchronisieren würden konnten wir da nichts.

Also: Löschen von Produkten, Bilder und ganzen Kategorien durch Inaktivieren in der Wawi und Synchronisieren nach POS geht. Das rückgängig machen oder gar neue Produkte hinzufügen nicht.

Kennt jemand dieses Verhalten und weiß ggf. eine Lösung. Denn so kann man sich ja nie darauf verlassen, dass neu hinzugefügte Produkte auch wirklich in den Kassen ankommen... ;-(

Lieben Dank und Gruß!
 

Anhänge

Timm.Abraham

Aktives Mitglied
28. Juli 2017
51
4
Hallo Patoc,

leider kann ich das Verhalten nicht nachvollziehen und kann dir somit keine "akute" Hilfe leisten.

Was ich verstanden habe, du besitzt 3 Kassen und der Sync funktioniert nicht ... wenn ich diesen Fehler hätte würde ich mir folgende Fragen stellen
Wenn ich dein Problem lese stelle ich mir die Frage ob es eventuell am Netz liegen kann?

- Sind die Kassen mit dem POS Server per LAN / WLAN verbunden oder sind dies dezentrale Standorte die über eine Tunnel (VPN/Site2Site/...) angebunden sind ? Kannst du sicherstellen das es kein Problem von Bandbreite ist ?
- Wieviele Artikel (inkl. VarKombis) möchtest du denn synchronisieren ? - Wie oft aktualisierst du deine Artikel (eventuell ein fester Intervall alle XX Stunden) ?
- Hast du mal versucht einen Log-Abschnitt ganz zu lesen ? - Wenn ja ist der Server auch mal im Leerlauf ?
- Wie hoch ist der Abfrage-Intervall von der Kasse zum Server ?

Das wäre so meine ersten Ansätze den Fehler zu lokalisieren, ich hoffe es hilft dir weiter!

Viel Glück und schnellen Erfolg bei deiner Suche,

Timm
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.637
185
Hallo,

wir haben drei POS-Kassen im Einsatz (1.0.2.1) und die Wawi in der Version 1.5.25.0. Initial aufgesetzt hatten wir die Kassen vor knapp vier Wochen. Bis auf die Tatsache, dass der POS-Server immer wieder abstürzt
das sollte nicht passieren. Was ist die Fehlermeldung beim Absturz?

Aber das Hinzufügen belässt die Produkte / Kategorien immer im Status "wird aktualisiert" - siehe beigefügter ScreenShot.
Das kann an sich nur zwei Ursachen haben:
1. Der Abgleich wird gar nicht ausgeführt, z.B. falsches Auth-Token in der Wawi/POS
2. Die Kasse wurde mit einer anderen Wawi befüllt und dann auf eine andere Wawi umgestellt. So hat diese anderen Datenstand, deshalb klappt manches nicht.

Einen Fahler kann man auch nicht ausschließen. Wenn möglich erstellt bitte ein Support Ticket, das müsste per Fernwartung geprüft werden. Falls nicht schreibt mir bitte oben rechts per "Unterhaltung" wo und wann wir jmd. tel. erreichen können.
 

patoc

Aktives Mitglied
20. Juni 2017
16
1
Hallo zusammen,

herzlichen Dank für Eure Antworten!

@Timm: Eine Kasse ist im Hause, die anderen beiden an anderen Standorten via VPN (Sophos) angebunden, Bandbreite jeweils mindestens 50 MBit/s (zumindest laut Vertrag ;) ). Alle Kassen hängen stabil im LAN. VoIP-Telefonie, AnyDesk Remotezugriff, Kartenterminal etc. läuft alles stabil. Es sind knapp 1.300 Artikel. Synchronisiert wird alle 30 Sekunden (so in den Einstellungen auf POS hinterlegt). Der POS-Server steht eigentlich nie so richtig still ;) und ein " Log" konnte ich mir nicht so richtig komplett ansehen, da die Zeilen immer recht schnell drüber huschen und immer nur die letzten x Zeilen angezeigt werden ;-(.

@ofenheizer: POS ist aktuell, Wawi hinkt ein klein wenig hinterher - werden wir aber ggf. morgen wegen der Amazon-Biz-Umsatzsteuerrechnungen aktualisieren - ist halt immer ein rechter Akt, weil dann jeder Client aktualisiert werden muss - da kommen locker 15 zusammen...

@Janusch: Fehlermeldung bei POS-Server-Absturz ist nichtssagend - er schlägt mir Debuggen vor... ich schaue, dass ich das nächste Mal einen ScreenShot machen kann. Der Support meinte heute, dass das Thema wohl bekannt sei und adressiert wird?! Zu den "Ursachen": Das können wir beides ausschließen! Token passt, denn sonst würden ja auch nicht SOFORT Produkte auf POS gelöscht werden, wenn ich das Häkchen in der Wawi vor dem Produkt für die jeweilige Kasse entferne. Wawi ist seit Jahren die gleiche DB - wir updaten nur die Versionen. Und die Kassen laufen seit Anfang September, in dieser Zeit haben wir auch kein Wawi-Update mehr durchgeführt, nur unmittelbar vor der POS-Installation.

Einzig, was in solchen Fällen geholfen hat (zwei Kassen waren definitiv betroffen) war:

1. Kasse in der Wawi deaktivieren
2. Neue Kasse anbinden
3. Authenfizierung in POS löschen und neu hinterlegen

Was dann allerdings passiert, ist dass alle Kategorien sich in POS doppeln. Die alten Kategorien enthalten dann keinen Produkte mehr. Die Kategorien und Subkategorien mussten wir dann manuell löschen (vorher Wawi-Abgleich deaktiviert). Was dann aber passiert ist, dass die Kategoriebilder verschwinden... Auf der Kasse, die wir heute angefasst haben ist es uns bis jetzt nicht gelungen, die Bilder wieder zum Laufen zu bringen. Auch via Wawi alle Kategorien (ab Wurzel) deaktivieren und wieder reaktivieren hat nichts gebracht.

Hier ist also echt irgendwie der Wurm drin. Und wie gesagt von Wawi zu POS geht Löschen wunderbar. Aber von Wawi zu POS Produkte ändern, Kategoriebilder pushen oder Produkte hinzufügen geht bei KEINER der Kassen, wenn da mal der Wurm drin ist. Nicht mal bei der Kasse hier im Hause, wo alles in einem Gigabit-LAN hängt.

Herzliche Grüße und Dank!
 

Timm.Abraham

Aktives Mitglied
28. Juli 2017
51
4
Hallo Patoc,

ich hoffe der Support konnte dein Problem zwischenzeitlich lösen.
Wenn nicht würde ich den Intervall der Kassen einmal etwas hochsetzen so das der Abgleich nur alle 90 oder 120 Sekunden gemacht wird.
Eventuell ist hier weniger mehr :)

Grüße,
 
  • Gefällt mir
Reaktionen: gigi80

patoc

Aktives Mitglied
20. Juni 2017
16
1
Hallo Timm,

leider konnte mir der Support bisher nicht helfen ;-(

Das mit der Abgleichs-Frequenz probiere ich aus!

Lieben Dank!
 

Stefan_F

Moderator
Mitarbeiter
21. Juli 2017
165
30
Hallo zusammen,

das Nachstellen gestaltet sich sehr schwierig. Ich würde dir, patoc, gleich eine private Nachricht schicken, sodass wir das Ganze möglichst schnell hinbekommen.

Gruß Stefan
 

bbfdesign

Offizieller Servicepartner
SPBanner
28. September 2013
120
8
Moin,

ich warte ebenfalls seit Wochen auf einen Button bei der Wawi Anbindung mit der man einmal die Kategorien und Artikel löschen kann. Wir haben bei einem unserer Kunden mittlerweile 10 Kassen im Einsatz (Filialen) und ich habe die Situation das es 1800 +x Kategorien gibt mit über 27000 Artikeln. Es ist ein unding, dass man hier nicht sauber - wie man es z.B. aus dem Shop gewöhnt ist - einfach vor der Wawi Anbindung mit einem einfachen klick diese Daten zurück setzten kann.

Es ist keine Option die Kassen neu aufzusetzten, da historisch alle Belege und Berichte die bis dahin erstellt wurden weg wären.

Ich hoffe inständig, dass es hier - am besten gestern - endlich eine saubere Lösung geben wird.

Die Antworten auf das Ticket sind jedoch wenig schlüssig, wann und wie es hier eine Lösung gibt.

Ich jedoch brauche hier DRINGEND eine Lösung.

Wir haben die Veloconnect Schnittstelle fertig und können nun sauber die Daten synchronisieren.

Gruß Björn
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.637
185
Hallo Björn,
ich verstehe dein Problem, jedoch ist es keine Lösung für uns, da die Schnittstelle 100% arbeiten muss.
Man kann eine Kasse am Anfang mal zurücksetzen beim Einrichten, aber im laufenden Betrieb ist das unzumutbar und bringt weitere Probleme mit.

Ich kann hier nur empfehlen in der Wawi mit einer Wurzelkategorie für POS zu arbeiten. Dort mit einem Klick kann der gesamte Bestand aktiviert oder gelöscht werden. Ist das nicht der Fall, dann sofort zum Hörer greifen und wir untersuchen das ganze. Auch jetzt wo das Problem auftritt sind wir sehr dran interessiert dies zu Untersuchen um es aus der Welt zu schaffen.
Nur so kann man uns unterstützen um das ganze Rund und stabil zu machen. Ein Button alles löschen bringt uns hier nicht weiter wenn die Probleme nicht erkannt werden.

In der aktuellen Situation kann man die relevanten Teile der POS als CSV exportieren, Kasse zurück setzen und wieder importieren. Es dauert etwas länger sollte aber im optimal Fall nie notwendig sein.
 

TTToys

Neues Mitglied
25. August 2020
7
2
Hi zusammen,

ich habe seit gestern das selbe Problem. WaWi 1.5.30.1 JTL-POS 1.0.2.5
Die Verbindung von JTL-POS zur WaWi scheint zu funktionieren da im Dashboard die aktuellen Umsätze richtig angezeigt werden.
Was nicht geht ist die Verbindung von der WaWi zur POS denn Artikel neu anlegen, Preise ändern oder Artikel löschen wird nicht an die POS übermittelt.

Ich kann leider nicht abschätzen was passiert wen ich die Ksse neu anbinden würde. Denn was nicht passieren darf ist das die Buchungungsdaten aus der Kasse verschwinden!!

@Janusch
Ich werde dein Angebot morgen früh wahrnehmen und mich telefonisch bei euch melden.

Gruß

Detlev
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.637
185
Hallo,
ja bitte unbedingt melden, die Kollegen untersuchen das genauer.

Im POS Server Fenster kann man beobachten was passiert wenn die Kasse mit diesem kommuniziert.
Falls da Fehler auftauchen bitte diesen per Copy&Paste rauskopieren.
 
  • Gefällt mir
Reaktionen: Weedmaster-Flash

ekpegleg

Aktives Mitglied
20. April 2016
65
5
Berlin
Hi zusammen,

ich habe seit gestern das selbe Problem. WaWi 1.5.30.1 JTL-POS 1.0.2.5
Die Verbindung von JTL-POS zur WaWi scheint zu funktionieren da im Dashboard die aktuellen Umsätze richtig angezeigt werden.
Was nicht geht ist die Verbindung von der WaWi zur POS denn Artikel neu anlegen, Preise ändern oder Artikel löschen wird nicht an die POS übermittelt.

Ich kann leider nicht abschätzen was passiert wen ich die Ksse neu anbinden würde. Denn was nicht passieren darf ist das die Buchungungsdaten aus der Kasse verschwinden!!

@Janusch
Ich werde dein Angebot morgen früh wahrnehmen und mich telefonisch bei euch melden.

Gruß

Detlev
Wir haben ähnliche Probleme, das Artikel nicht zur POS übertragen werden und der Status auf "wird aktualisiert" stehen bleibt.

Morgen werde ich auch mal bei JTL anrufen müssen. Auch die externe Auftragsnummer sowie die Zahlart wird falsch übertragen in die offenen Aufträge.
 

TTToys

Neues Mitglied
25. August 2020
7
2
Hallo,

bei uns sind die Probleme aktuell behoben. Seit einigen Tagen läuft es fehlerfrei. Sowohl Artikel von der Wawi an die Kasse, als auch Aufträge von der Kasse zur Wawi.

Zuvor erfolgte die Übertragung zwar manchmal nicht zeitnah, sondern mit einigen Stunden Verzögerung, aber wie gesagt, das ist seit ein paar Tagen auch nicht mehr vorgekommen.

Gruß

Detlev
 

gigi80

Sehr aktives Mitglied
3. Juni 2016
244
26
Hallo,

bei uns sind die Probleme aktuell behoben. Seit einigen Tagen läuft es fehlerfrei. Sowohl Artikel von der Wawi an die Kasse, als auch Aufträge von der Kasse zur Wawi.

Zuvor erfolgte die Übertragung zwar manchmal nicht zeitnah, sondern mit einigen Stunden Verzögerung, aber wie gesagt, das ist seit ein paar Tagen auch nicht mehr vorgekommen.

Gruß

Detlev
Welche Versionen nutzt du?
POS:
Wawi:
 

TTToys

Neues Mitglied
25. August 2020
7
2
POS: 1.0.2.5 (3012)
Wawi: 1.5.30.1

Wobei seit heute 11 Uhr der Abgleich auch wieder nicht geht. Da das aber in letzter Zeit, wie gesagt öfter vorkam und dann irgendwann wieder ging, bin ich da aktuell recht entspannt.

Aber irgendwo hakt es da scheinbar doch generell noch...
 

exuled

Offizieller Servicepartner
SPBanner
8. August 2019
49
10
Hallo,

eben getestet:
POS 1.0.2.8 mit Wawi 1.5.31.0 synchronisiert sehr gut auch mit vielen Änderungen >1.000 Artikel.

Gruß
Chris
 

TTToys

Neues Mitglied
25. August 2020
7
2
Hallo,

hab auch grad auf die neue POS 1.0.2.8 aktualisiert und der Ableich lief sofort los. So wie es sein soll.

Gruß

Detlev
 
  • Gefällt mir
Reaktionen: gigi80
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Angeboterstellung USt. neue Artikel User helfen Usern - Fragen zu JTL-Wawi 0
Neu Neue Kundengruppe VK = EK User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung L&L neue Version - Abwärtskompatibilität gibt es wohl nicht Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 7
In Bearbeitung Neue Ebay Kategorien / Massenupdate aber nicht möglich eBay-Anbindung - Fehler und Bugs 3
In Bearbeitung Verbesserungsvorschlag: eBay-Vorlage: Neue Artikelmerkmale farbig markieren eBay-Anbindung - Ideen, Lob und Kritik 7
In Bearbeitung eBay neue Zahlungsawicklung - Kosten in "normaler" eBay-Rechnung enthalten? Smalltalk 3
Gelöst Warnung per Email wenn sich der neue Lieferanten EK vom bereits hinterlegten Einkaufspreis (Netto) Unterscheidet JTL-Workflows - Ideen, Lob und Kritik 6
Neu Auftragserstelldatum + Lieferdatum neue Rechnungsvorlage Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Müssen neue Rechnungsvorlagen erstellt werden beim Update auf neuste Version? User helfen Usern - Fragen zu JTL-Wawi 2
In Bearbeitung Neue Angebote an Amazon.de gesendet: jedoch weis Amazon nichts davon User helfen Usern - Fragen zu JTL-Wawi 1
Neu Das neue Plugin Google Analytics JTL-Shop - BETA - Feedback und Bugmeldungen 15
In Bearbeitung 3 neue Problemchen seit 1.0.2.0 JTL-POS - Fehler und Bugs 11
Gelöst neue Variation bei einer Laufende eBay Angebot hinzufügen eBay-Anbindung - Fehler und Bugs 1
Neu Neue Bestellvorschläge - Zulauf nur bis zu einem bestimmten Datum berücksichtigen Umfragen rund um JTL 9
In Bearbeitung Neue Platform in tplattform für Otto.de JTL-Wawi - Fehler und Bugs 3
Neu neue TAB´s nicht mehrsprachig möglich Allgemeine Fragen zu JTL-Shop 0
Neu Neue Warenpost DHL JTL-ShippingLabels - Fehler und Bugs 4
Neu Selbsterstellte Produktseiten neue Keywords hinzufügen funktioniert nicht Amazon-Anbindung - Fehler und Bugs 5
Neu Nach Update viele Produkte im Shop gelöscht JTL-Wawi - Fehler und Bugs 0
Neu Anzahl Top-Produkte in der Mobile Ansicht Templates für JTL-Shop 8
In Bearbeitung Produkte die auf Lager sind zu Amazon User helfen Usern - Fragen zu JTL-Wawi 2
Neu Ausverkaufte Produkte Dunkelgrau makieren. Shopify-Connector 5
Neu Maximal 5 Produkte einer Art im Warenkorb User helfen Usern - Fragen zu JTL-Wawi 2
Neu Nach Shopabgleich Produkte doppelt im Shop Gambio-Connector 1
Neu Bestimmte Produkte in bestimmte Länder NICHT liefern User helfen Usern - Fragen zu JTL-Wawi 0
In Diskussion Verschiedene Drucker für unterschiedliche Internetmarke Produkte JTL-ShippingLabels - Ideen, Lob und Kritik 4
Neu Bild-Zuordnung Child-Produkte in WooCommerce (über JTL Connector) WooCommerce-Connector 6
Gelöst Connector übermittelt keine Produkte mehr WooCommerce-Connector 4
Inaktiv Problem: Selbsterstellte Produkte automatisch auf Amazon UK, Spanien usw. Gelöste Themen in diesem Bereich 2
Neu Eine Artikelnummer für viele Produkte Schnittstellen Import / Export 6
Neu Wie können URLs gezielt von der Sitemap ausgeschlossen werden? Per Plugin? Betrieb / Pflege von JTL-Shop 0
Neu Bilder werden nicht immer an Shop übertragen WooCommerce-Connector 0
Neu Es konnte keine Verbindung zur TSE Einheit hergestellt werden! ErrorCode: 2 (ERR_CONNECT) JTL-POS - Fragen zu Hardware 0
In Bearbeitung Amazon Bestellungen werden nicht in JTL importiert Amazon-Anbindung - Fehler und Bugs 1
Verwiesen an Support Auftrag soll gesplittet werden, aber wie??? // Fehlermeldung Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 3
Gelöst Artikel können nicht ion den Warenkorb gelegt werden Gelöste Themen in diesem Bereich 5
Neu Die angegebene Straße kann nicht gefunden werden JTL-ShippingLabels - Fehler und Bugs 2
Neu VCS Lite / Rechnungen werden nicht hochgeladen User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung einzustellende Angebote werden nicht eingestellt. Einrichtung und Installation von JTL-eazyAuction 3
Neu Variationsartikel nur auf ebay -> Onlineshop sollen Artikel einzeln angezeigt werden User helfen Usern - Fragen zu JTL-Wawi 1
Neu Sitemap Konnte nicht abgerufen werden in Search Console Allgemeine Fragen zu JTL-Shop 0
Neu Geparkter Bon kann nicht verarbeitet werden JTL-POS - Fehler und Bugs 3
Neu Rechnungen werden plötzlich im Duplex gedruckt User helfen Usern - Fragen zu JTL-Wawi 2
In Bearbeitung Bestellvorschläge werden auch für gesperrte Aufträge erstellt JTL-Wawi - Fehler und Bugs 1
Neu Felder mit definierten Darstellungsbedingungen werden beim Druck nicht mehr angezeigt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
In Bearbeitung Trotz Update 1.5.32.0 können Bestellungen im SellerCentral nicht geöffnet werden. Amazon-Anbindung - Fehler und Bugs 4
In Bearbeitung B2B Preis senden kann bei FBA-Artikel nicht verwendet werden - keine Kaufmöglichkeit für Amazon-Businesskunden? Amazon-Anbindung - Ideen, Lob und Kritik 5
Neu Retoure einbuchen ohne den Bestand zu erhöhen - zB für Artikel die sofort entsorgt werden Arbeitsabläufe in JTL-Wawi 6
Neu es kann keine Verbindung zwischen JTL-WAWI und POS hergestellt werden. Einrichtung / Updates von JTL-POS 6
Neu Artikel werden nicht in Woocomerce aktualisiert WooCommerce-Connector 1
Ähnliche Themen