Neu Die UmsatzsteuerID ist durch Prüfung ungültig.

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

powerpreis24

Mitglied
8. Dezember 2018
8
1
Hallo liebe Community,

wir haben ein dringendes und wichtiges Problem.
Bei Anlage eines neuen Kundenkontos in unserem Shop gibt es Probleme bei der Prüfung der UstID (in dem Fall Österreich).

Wir haben bereits die Foren-Einträge durchgeschaut und verschiedene Einstellungen ausprobiert.
Bis jetzt leider erfolglos.

Folgende Zusammensetzung:
  • Shop-Version: 4.05 (Build: 6)
  • Storefront > Formulare > Einstellungen > Firma abfragen: ja, optionale Angabe
  • Storefront > Formulare > Einstellungen > UstID abfragen: ja, optionale Angabe (nicht jeder Kunde ist bei uns eine Firma)
  • Storefront > Formulare > Einstellungen > UstID des Shops: DEXXXXXXXXX (DE + 9 Ziffern)
  • Storefront > Formulare > Einstellungen > USt-ID Prüfung des Bundeszentralamts für Steuern aktivieren: ja
Unsere UStID, sowie die österreichische ATU-Nummer (des ausgewählten Kunden) sind geprüft und korrekt.

Wir bitten euch um Unterstützung bei der Lösung dieses Problems.
Einige Kunden wollen Kunden-Accounts bei uns anlegen und kommen nicht weiter.

Ebenfalls taucht beim Ausfüllen des Feldes folgende Fehlermeldung auf: Felder mit einem * müssen ausgefüllt werden.
Dabei ist das Feld "UST-IDNR." in unserem Formular kein Pflichtfeld, sondern eine optionale Angabe. Allerdings wird genau dieses Feld (in dem die ATU-Nummer eingetragen ist) als rot gekennzeichnet und das Formular lässt einen nicht weiter.

Weitere Info: Wenn es irgendwie von Bedeutung sein kann, liefert die Überprüfung der gleichen ATU-Nummer über WaWi eine 222 (Fehler-) Meldung. Laut Foren-Einträgen von früher, handelt es sich bei diesem Return (222) um eine gültige Nummer.

Wenn jemand von euch gleiches/ähnliches Problem hat, bitten wir euch um Unterstützung.
 

Anhänge

  • Gefällt mir
Reaktionen: MichaelH

JWittl

Aktives Mitglied
4. August 2017
25
5
Hallo,

dem Problem schließe ich mich gleich mal mit an.

Wir/unsere Kunden (vorwiegend aus Österreich) haben das selbe Problem bei der optionalen Eingabe der UstID in unserem Shop.
Wir verwenden die selben Einstellungen wie oben, nur mit der Shopversion 4.06 Build 9.

Die nachträgliche Prüfung der UstID über die WAWI (1.3.20) gibt bei uns auch den Wert (ErrorCode) 222 zurück.

Ungern möchten wir die automatische UstID Prüfung beim anlegen eines Kundenaccounts im Shop deaktivieren.
Was wir aber schon temporär machen mussten, um Kunden die Registrierung mit UstID zu ermöglichen.

Wir wären auch für jeden Hinweis dankbar.
 

MichaelH

Sehr aktives Mitglied
17. November 2008
11.249
512
Wir haben uns effektiv mit einer manuellen Programmierung beholfen.

Die 1. 2 Stellen müssen Alpha sein, die 5. Stelle numerisch als Minimalprüfung damit nicht fälschlicherweise netto bestellt werden kann.
So ist es vermutlich eine UID und keine Steuernummer, Geburtsdatum oder Name.
Die Prüfung selbst machen wir dann auf WWW, denn auch in der WAWI funktioniert die ja nicht wenn man Österreicher ist.

Ab WAWI 1.4 funktioniert dann auch die Prüfung im WAWI-Kundenstamm, allerdings ohne Dokumentation.
Daher: https://forum.jtl-software.de/threa...speichert-button-status-geht-verloren.116226/

Dort solltet ihr auch was dazu schreiben wenn ihr eine Lösung wollt. :)
 

MBesancon

Sehr aktives Mitglied
Mitarbeiter
1. Oktober 2010
1.958
139
Erkelenz
Die nachträgliche Prüfung der UstID über die WAWI (1.3.20) gibt bei uns auch den Wert (ErrorCode) 222 zurück.
Das wird mit der Version 1.4 behoben. Die Meldung 222 bedeutet das die Steuernummer gültig ist, aber das der Abruf ab dem nächsten Jahr ausschließlich per https erfolgen kann. Derzeit nutzt die WaWi zur Prüfung noch eine http-URL.
 

JWittl

Aktives Mitglied
4. August 2017
25
5
Wir haben uns effektiv mit einer manuellen Programmierung beholfen.
Habt ihr da wirklich etwas eigenes implementiert?
Soweit ich das richtig sehe, prüft der Shop -zumindest kann ich das für den von uns verwendeten 4.06.9 sagen- die Ust-ID Eingabe auf Präfix (1. 2 Stellen), Länge und Zeichenformatierung.
Bei AT wird zusätzlich geprüft, ob das erste Zeichen nach dem Präfix ein 'U' ist. Das sollte als Vor- /Minimalprüfung erstmal genügen.
Diese Prüfung findet auch statt, wenn "USt-ID Prüfung des Bundeszentralamts für Steuern aktivieren" deaktiviert ist.

Das wäre also im großen und ganzen schonmal ok, um nicht irgendwelchen Unsinn eintragen zu können.
Man muss also keine Bauchschmerzen haben, wenn "USt-ID Prüfung des Bundeszentralamts für Steuern aktivieren" erstmal deaktiviert ist, um den Kunden zumindest eine reibungslose Registrierung -sofern sie die UST-ID dann auch korrekt eintragen- ermöglichen zu können.
Eine manuelle Prüfung in der WAWI oder per WWW sollte dann aber zwingend erfolgen.

Ich frag mich aber trotzdem, wieso -vorwiegend Österreichische- Kunden das Problem bei der Registrierung haben, wenn "USt-ID Prüfung des Bundeszentralamts für Steuern aktivieren" aktiv ist.
Wir haben noch einen Testshop (4.09.11 CFE), auf dem ich dann mal versucht hab, mich mit den exakt selben Kundendaten zu registrieren, mit denen sich Kunden im Live Shop nicht registrieren konnten, und dort klappte es auf Anhieb. Selber Browser, gleiche Angaben und fast gleiche Uhrzeit. Somit können wir das Problem leider auch nicht so ganz nachvollziehen.
Da uns aber schon gehäuft Kunden bei einer erfolglosen Registrierung wegen der Ust-ID angerufen haben, handelt es sich jedenfalls nicht um das Problem eines einzelnen und kann auch nicht damit abgetan werden, dass derjenige einen Fehler bei der Eingabe gemacht hätte.

Das Deaktivieren von "USt-ID Prüfung des Bundeszentralamts für Steuern aktivieren" und die nachträglich manuelle Prüfung in der WAWI ist zwar wirklich keine Dauerlösung aber im Moment der beste Mittelweg denke ich.

Dort solltet ihr auch was dazu schreiben wenn ihr eine Lösung wollt. :)
Danke schonmal für deine Antwort! :) Durch deine Info mit der manuellen Programmierung bin ich erst darauf gestoßen, dass der Shop selbst so eine Minimalprüfung durchführt;)
 
  • Gefällt mir
Reaktionen: MichaelH

MichaelH

Sehr aktives Mitglied
17. November 2008
11.249
512
"Habt ihr da wirklich etwas eigenes implementiert? "

Ja, denn wir hatten Probleme und ich hatte genug davon. Unsere Prüfung ist sehr einfach, aber seit da haben wir keine Probleme mehr mit Steuernummer, Name oder Geburtsdatum in der UID.
 

JWittl

Aktives Mitglied
4. August 2017
25
5
Ja, denn wir hatten Probleme und ich hatte genug davon. Unsere Prüfung ist sehr einfach, aber seit da haben wir keine Probleme mehr mit Steuernummer, Name oder Geburtsdatum in der UID.
"Keep it as simple as possible" ;)

Ich schau jetzt mal wie es sich mit deaktivierter Ust-ID Prüfung über das Bundeszentralamt verhält. Falls es dennoch negative Resonanz geben sollte, müsste wohl auch (d)eine einfachere Lösung her;)
 

MichaelH

Sehr aktives Mitglied
17. November 2008
11.249
512
Mit Juli/August 2018 hatten wir gehäuft falsche UIDs und Aufträge in Netto von Verbrauchern, mehr denn je.

Grund: Die Vorschlagswerte die von Browsern gesetzt werden, also vorbefüllte Felder, vielleicht nach einem Update der Browser Chrome, Edge ... ?
Firmenname oftmals das Geburtsjahr.
UID der Familienname

Mit Shop4 erwartete ich mir endlich ein Ende der Probleme, umgestellt 1.9..
War aber nicht, es ging so weiter wie zuvor.

Test hin, Test her, irgendwie war was faul.
Daher: Ende, einfache Lösung musste her.

Und nun geht's und Ruhe ist, das kleine Geld war es mir Wert um hier Geld zu sparen in Form von sinnloser Arbeit und Mails und Nachzahlungen / Änderung von Auftrag/Rechnung die wir von den Kunden einfordern mussten die oftmals gar nicht wussten oder verstanden um was es überhaupt geht, weil sie ja nicht aktiv etwas eingegeben / eingetippt hatten. Da ging viel Zeit sinnlos drauf.
 
  • Gefällt mir
Reaktionen: fa.ars

JWittl

Aktives Mitglied
4. August 2017
25
5
Falls es dennoch negative Resonanz geben sollte, müsste wohl auch (d)eine einfachere Lösung her;)
Ein Nachtrag hierzu: Die 'primitive' Lösung von MichaelH ist wohl am besten.

Musste gerade feststellen, dass der Shop '000000000000000000000000' als Ust-ID akzeptiert. :thumbsdown:
Es wird zwar in der class.JTL-Shop.UstID.php erstmal super auf den Prefix geprüft, ist dieser aber nicht vorhanden, wird standardmäßig einfach "true" zurückgegeben -ohne diesen z.B. auf Ziffern oder die Ust-ID (grob) auf Länge zu prüfen ..
 
  • Gefällt mir
Reaktionen: MichaelH

Printmedia

Aktives Mitglied
3. April 2013
20
4
Hallo,

ist in der Wawi 1.4 auch wieder vorgesehen, eine amtliche Bestätigung der "qualifizierten Prüfung" anzufordern?
 

Rainer S

Moderator
Mitarbeiter
8. August 2018
472
61

powerpreis24

Mitglied
8. Dezember 2018
8
1
Wie sieht es denn nun mit einer Lösung für 4.05 aus?

Für uns ist der Status-Code, den man in der WaWi bekommt weniger wichtig.
Wir können auch damit leben, wenn die WaWi "Banane" ausgibt. Solange das "Nummer gültig" bedeutet, soll es so sein.
Aber im Shop bei einer Registrierung kommt der Kunde nicht weiter.

Wie sieht die Lösung seitens JTL aus?
Warum schreibt man keinen Fix?
 

Mirko.Schmidt

Moderator
Mitarbeiter
14. August 2015
1.801
127
Welcher Fehler kommt den genau da? Vielleicht liegt es an dem Problem (das TLS < 1.2 verwendet wird) welches Rainer S verlinkt hat, dann würde ein Update auf die aktuellste Shop Version 4.06.11 helfen. Für die 4.05 wird nichts mehr extra gefixt, wenn nur noch Sicherheitslücken. Die 4.06 ist ja als Stable deklariert.
 
Zuletzt bearbeitet:

powerpreis24

Mitglied
8. Dezember 2018
8
1
Welcher Fehler kommt den genau da? Vielleicht liegt es an dem Problem (das TLS < 1.2 verwendet wird) welches Rainer S verlinkt hat, dann würde ein Update auf die aktuellste Shop Version 4.06.11 helfen. Für die 4.05 wird nichts mehr extra gefixt, wenn nur noch Sicherheitslüccken. Die 4.06 ist ja als Stable deklariert.

Es kommt der Hinweis, dass die Nummer ungültig ist.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
In Bearbeitung Amazon-Bestellung kann nicht mehr über die Wawi im Sellercentral aufgerufen werden. Amazon-Anbindung - Fehler und Bugs 0
Gelöst Gelöst: Artikelmerkmale werden nicht in die EBAY Angebotsvorgale übernommen Einrichtung und Installation von JTL-eazyAuction 2
Neu Welche Auflösung für die vier wechselnden Hintergrundbilder im (externen) Display? Allgemeine Fragen zu JTL-POS 3
Neu MHD bei Lagerbestand über die Ameise nachträglich hinzufügen User helfen Usern - Fragen zu JTL-Wawi 3
Neu [4.06.17] Fehlercode 108, "Fehler: Die Datei für die Klasse des AdminWidgets existiert nicht." JTL-Shop - Fehler und Bugs 4
Neu Seriennummer wird nicht in die Dokumente Auftrag/Lieferschein/Rechnung übernommen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Die Währung wechselt nicht von EUR auf CHF Einrichtung von JTL-Shop 1
Neu Fehler bei Neuinstallation --> CreateProcess schluf fehl; Code 2. Das System kann die angegebene Datei nicht finden. Installation von JTL-Wawi 4
Neu Worst Case eingetreten- SQL Server2019 Testzeitraum Ende, kein Zugriff mehr auf die Datenbank, Datenbank lässt sich nicht wiederherstellen (mit Bild) Installation von JTL-Wawi 12
In Bearbeitung Warum werden die Release Info`s nicht mehr gepflegt JTL-POS - Ideen, Lob und Kritik 6
Neu JTL-Wawi überträgt die Grundpreise falsch Modified eCommerce-Connector 4
Neu Speichern von Rechnungen über die Extern.dll mit Mandant_3 Schnittstellen Import / Export 0
Neu Server für die WAWI (mal wieder dieses Thema aber mit speziellen Fragen) User helfen Usern 3
Neu Artikel auf Bestellvorschlägen, die bereits gepickt sind JTL-Wawi - Fehler und Bugs 0
Neu Amazon Sperrt JTL Kunden die Blind die Vorlagen Verwenden User helfen Usern 36
Neu Wie handhabt ihr die Preisverwaltung von AW Werten & Löhnen? User helfen Usern - Fragen zu JTL-Wawi 10
Neu Kunden exportieren die einen bestimmten Artikel gekauft haben User helfen Usern - Fragen zu JTL-Wawi 2
In Bearbeitung Auswahl der Favoriten im Kassierprozess lässt die POS abstürzen JTL-POS - Fehler und Bugs 2
Neu Artikelbeschreibung HTML editor Zerschiesst die Ansicht ein wenig JTL-Wawi - Fehler und Bugs 6
Neu Meine Firmendaten hatte ich 2016 geändert. Jetzt haben alle Rechnungen vor 2016 auch die neue Firmenadresse drin Arbeitsabläufe in JTL-Wawi 11
Offen POS ändert nicht die MW Steuer auf 16% / Preise ändern sich nicht in POS Allgemeine Fragen zu JTL-POS 3
Gelöst Die neue Warenpost ab 01.07.2020 - Einrichtung in JTL Wawi, JTL ShippingLabels und das Drucken eines Labels via Drucker - Aber wie? JTL-ShippingLabels - Ideen, Lob und Kritik 2
Neu FedEx liest nicht automatisch die Importdatei ein JTL-ShippingLabels - Fehler und Bugs 2
Offen Wie bekommt man die Preise nach der Umstellung auf 16% in den Shop? PrestaShop-Connector 2
Neu Verbindung zur Datenbank nicht möglich - Server neu starten ist die Lösung User helfen Usern - Fragen zu JTL-Wawi 2
In Diskussion Druckvorlagen ... fehlende Variablen die benötigt werden (Sammelthema) Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 24
Offen Gesucht: Die Variable "Paketgewicht" beim Ereignis "Paket erstellt" JTL-Workflows - Fehler und Bugs 1
Neu DHL Wunschpaket - Wunschort und -tag werden in der Zusammenfassung nicht ausgegeben oder an die JTL Wawi weitergegen Allgemeine Fragen zu JTL-Shop 3
Neu Die richtige Variable für 'Position / Artikelname'? User helfen Usern - Fragen zu JTL-Wawi 2
Neu E-Mail Vorlage Auftragsbestätigung mit Produktbildern, die proportional sind und nicht verzerrt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Warum berechnet der Shop hier die USt. (Kunde mit USt. Id in Italien) Allgemeine Fragen zu JTL-Shop 1
Neu Wann erscheint die WaWi 1.6 User helfen Usern - Fragen zu JTL-Wawi 6
In Bearbeitung Probleme mit dem ebay-Abgleich - "Die Eingabezeichenfolge hat das falsche Format" JTL-Wawi - Fehler und Bugs 6
Neu Antworten auf eine andere als die neueste Nachricht Servicedesk (Beta) 2
Neu LS-POS und die Änderung der Mehrwertsteuer Fragen rund um LS-POS 4
In Bearbeitung Drittshop Connector überträgt die Ausgabewege-Artikelname nicht Technische Fragen zu den JTL-Connectoren 1
Neu Stückliste aus Artikeln die Konfigurationsartikel besitzen User helfen Usern - Fragen zu JTL-Wawi 2
Gelöst "Die ausgewählte Kategorie unterstützt keine Variationen" eBay-Anbindung - Fehler und Bugs 2
Neu Repricer senkt stetig die Preise JTL-Wawi - Fehler und Bugs 1
Gelöst Diese bestellung darf nicht gelöscht werden. eine transaktion, die in einem mars-batch getartet wurde, ist am ende de baches immer noch aktiv JTL-Workflows - Fehler und Bugs 2
In Bearbeitung Alle Verkäufe über JTL-POS auch in die Wawi übertragen ? Allgemeine Fragen zu JTL-POS 2
In Bearbeitung Connector deaktiviert die Archivbarkeit von Schlagwörtern WooCommerce-Connector 2
Gelöst Ctrl+C (Wert Kopieren) - Kopiert die Ganze information von einem Artikel 1.15.21.3 JTL-Wawi - Fehler und Bugs 11
Neu Zeichen wie ® lassen die Warenwirtschaft abstürzen JTL-Wawi - Fehler und Bugs 2
Neu Arithmetischer Überlauffehler für tinyint-Datentyp, Wert = -1. Die Anweisung wurde beendet. Einrichtung und Installation von JTL-eazyAuction 16
Neu Schnittstelle übermittelt alle Aufträge die mit "Kauf auf Rechnung" getätigt wurden direkt mit "ist bezahlt" markiert WooCommerce-Connector 1
In Bearbeitung Die Transaktion konnte nicht über die TSE gestartet werden. other_error_host_authentification_failed JTL-POS - Fehler und Bugs 8
Neu Zahlungs CSV import über die Ameise User helfen Usern - Fragen zu JTL-Wawi 3
Neu Wo gebe ich die Synonyme für meine Artikel ein? Modified eCommerce-Connector 4
Neu Kann mir jemand die Auswertung erklären? Allgemeine Fragen zu JTL-Shop 3
Ähnliche Themen