Neu Bestände werden falsch übermittelt

nicolass

Aktives Mitglied
14. März 2019
37
1
Hallo liebe JTL-Gemeinde,

wir nutzen die JTL-Wawi 1.5.17.1 in Verbindung mit dem Connector zu einem Shopware 5 Shop (5.6.4).
Seit dem letzten Update bemerken wir immer wieder Bestandsprobleme.

In der JTL-Wawi sind zum Beispiel Artikel bereits ausverkauft. Alle Einstellungen hierfür (mit Lagerbestand arbeiten, etc.) sind gesetzt.
Leider auch nach mehrmaliger Aktualisierung des Workers sind diese weiterhin im Onlineshop verfügbar.

Woran kann das liegen? Leider kommt es nun gehäuft zu Bestellungen von Artikeln die eigentlich nicht mehr auf Lager sind und somit ausverkauft sein sollten.

Viele Grüße
Nicolas
 

McAvity

Sehr aktives Mitglied
7. September 2016
591
144
@nicolass

Wie sieht das aus wenn Du den Worker deaktiviert und von Hand den Shopabgleich startest? Werden dann die Artikelmengen richtig übertragen?

Wie sieht es auch mit Logfiles aus? Hast Du da etwas feststellen können?

MfG

McAvity
 

nicolass

Aktives Mitglied
14. März 2019
37
1
@McAvity danke für deine Antwort!
Leider habe ich aktuell kein Fallbeispiel mehr. In den Logs ist mir bislang nichts ungewöhnliches aufgefallen. Diese laufen aber erst seit heute nach dem Vorfall.
Ein händischer Shopabgleich hat in der Vergangenheit mal kurzfristigen Erfolg gebracht und die Bestände abgeglichen und aktualisiert.

Gibt es noch andere Anhaltspunkte?
 

McAvity

Sehr aktives Mitglied
7. September 2016
591
144
@nicolass

Manchmal stirbt der Worker halt den "stillen Tod".
Da sieht es so aus als ob alles läuft, tut es aber nicht. Somit dann auch kein Shopabgleich.
Vielleicht solltest Du erwägen manuell einen Komplettabgleich des Shops durchzuführen.

Btw. lässt Du den Worker als Dienst laufen?

MfG

McAvity
 

nicolass

Aktives Mitglied
14. März 2019
37
1
Hallo @McAvity ,

danke für deine Antwort. Der Worker läuft als Hintergrund-App, nicht als Dienst. Gibt es da eine Möglichkeit?
Wir werden nun einen Komplettabgleich durchführen und dann müssen wir auf das funktionieren des Workers hoffen.

Vielen Dank im Voraus.
 

McAvity

Sehr aktives Mitglied
7. September 2016
591
144
Der Worker läuft als Hintergrund-App, nicht als Dienst.

Du steuerst den Worker also über das Dashboard in JTL-Wawi bzw. siehts dort ob der läuft, richtig?

Dann schau Dir doch mal bitten folgende Seite von @css-umsetzung an: https://css-umsetzung.de/Workerueberwachung/ bzw. auch den Thread im JTL-Forum an, aus dem dieser entstanden ist: https://forum.jtl-software.de/threads/worker-ueberwachung.94039/

Vielleicht äußerst sich ja auch @css-umsetzung dazu, ob das noch alles aktuell ist.

Ansonsten gibt es einige Threads bzw. Webseiten, die etwas zum Thema des Workers als Dienst geschrieben haben:

https://forum.jtl-software.de/threads/wawi-6821-worker-als-dienst.94633/
https://ebakery.de/jtl-wawi-worker-als-dienst-starten/

MfG

McAvity
 

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
4.897
873
Berlin
Also een Worker kannst du mit nssm locker als Dienst laufen lassen, ich gehe hier nicht den ebakery Weg da ich das für zu umständlich halte. Mein Weg, funktioniert in zahlreichen Umgebungen tadellos.

Meine Überwachung geht auch, ich selbst nutze die aber nicht da der Worker (es laufen drei auf meinem Server) keinerlei Probleme macht.
 
  • Gefällt mir
Reaktionen: McAvity

nicolass

Aktives Mitglied
14. März 2019
37
1
Hallo Zusammen,

ich habe jetzt genau einen Fall gefunden. Im Wawi 0 verfügbar. Im Onlineshop dennoch 10 verfügbar. Wie kann ich nun prüfen wo der Fehler in der Übertragung liegt?

Bildschirmfoto 2020-04-14 um 16.49.22.png
Bildschirmfoto 2020-04-14 um 16.49.44.png

Viele Grüße
Nicolas
 

nicolass

Aktives Mitglied
14. März 2019
37
1
@McAvity

Danke für die Hilfe! Wie kann ich nun das Problem erkennen? Übers Wochenende ist dies schon wieder bei zig Artikeln passiert. Eigentlich Ausverkauft - online noch verfügbar!
 

nicolass

Aktives Mitglied
14. März 2019
37
1
Hallo Zusammen,

ich habe jetzt genau einen Fall gefunden. Im Wawi 0 verfügbar. Im Onlineshop dennoch 10 verfügbar. Wie kann ich nun prüfen wo der Fehler in der Übertragung liegt?

Den Anhang 38991 betrachten
Den Anhang 38992 betrachten

Viele Grüße
Nicolas

Hallo, heute wieder selber Fehler mit diesem Artikel. Eigentlich haben wir einen Bestand von 0 gehabt nach manuellem Abgleich. Das hat soweit auch gepasst. Es gab auch keinen Wareneingang. Dennoch konnte gestern Abend ein Kunde diesen Artikel wieder bestellen. Wo können solche Fehler herkommen?
 

McAvity

Sehr aktives Mitglied
7. September 2016
591
144
@nicolass

Sorry für die späte Antwort.
Habt ihr denn mal im Logfile der Wawi geschaut, was für ein Wert bei dem Artikel geschickt wird?
Dann müsstet Ihr Euch im Connector- Log die entsprechenden Ein- und Ausgaben raussuchen.

Seid Ihr denn zu 100% sicher, dass da nicht von irgendwo anders her (z.B. vorherige Wawi, Produktdatenimport o.a.) diese Artikelmenge in den Shop importiert werden könnten?

MfG

McAvity
 

nicolass

Aktives Mitglied
14. März 2019
37
1
@McAvity

Ich habe schon wieder einen Fall. Ein Kunde konnte ein Produkt bestellen, welches aber gar nicht auf Lager ist. Letzter Warenausgang war gestern 3 Stück um 10:43 Uhr. Lagerbestand dann 0 - siehe Screenshot.
Bildschirmfoto 2020-04-21 um 13.45.46.png

Heute um 11:36 Uhr kommt eine Bestellung mit dem Artikel..

Bildschirmfoto 2020-04-21 um 13.46.24.png

Wie kann das sein? Welche Logs soll ich mit anhängen? Ich hab hier keinen Durchblick..

Viele Grüße
Nicolas
 

nicolass

Aktives Mitglied
14. März 2019
37
1
@McAvity

Der Worker läuft durchgehend. Wir haben ein JTL- Hosting. Aber auf den Worker gibts hier wohl seitens JTL kein Support.

Viele Grüße
Nicolas
 

McAvity

Sehr aktives Mitglied
7. September 2016
591
144
@nicolass
Ich würde dann im Log danach suchen, ob gestern Vormittag der Bestand von 0 von der Wawi an den Shop übermittelt wurde. Zudem würde ich mal prüfen, welche Bestand aktuell im Shop als verfügbar angezeit wird.
Überverkäufe habt Ihr ja deaktiviert nehme ich an, oder?

MfG

McAvity
 

nicolass

Aktives Mitglied
14. März 2019
37
1
@McAvity

Okay. Ich habe soeben in die Logs geschaut, leider sind diese aber zu dem Zeitpunkt noch nicht aktiv gewesen. Der Bestand hätte ja eigentlich mit der Bestellung und der damit entstandenen Bestandsreservierung bereits auf 0 gesetzt werden müssen. In der gestrigen Log (nach dem Versandprozess) habe ich nichts gefunden. Erst nach der erneuten Bestellung des Kundens von heute, da wurde dann im darauffolgenden Worker-Prozess der Bestand auf 0 gesetzt und ist jetzt ausverkauft. So wie es eigentlich schon nach der Bestellung die bereits versendet wurde hätte passieren sollen. Überverkäufe sind deaktiviert.

Viele Grüße
Nicolas
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Reservierte Bestände löschen? JTL-Wawi - Fehler und Bugs 0
Neu Ameise Preise / Bestände QuickSync Artikel arbeitet angeblich nicht mit Lagerbestand User helfen Usern - Fragen zu JTL-Wawi 1
Neu FBA Bestände lassen sich nicht von WaWi Artikel entfernen Amazon-Anbindung - Fehler und Bugs 0
Neu Amazon bestände mit Dropshipping artikel + Lagerartikel (Stückliste) Onlineshop-Anbindung 0
Neu Kommentare aus Artikel Bestände auf Liste Drucken User helfen Usern - Fragen zu JTL-Wawi 2
Gelöst Bestände in WMS zurücksetzen Installation von JTL-WMS / JTL-Packtisch+ 1
Neu Keine Artikeldaten an Shopware übermitteln? Nur Bestellungen und Bestände Shopware-Connector 1
Neu Rechnungen werden nach den Wartungsarbeiten 7.12. nicht mehr an Amazon übertragen Amazon-Anbindung - Fehler und Bugs 2
Neu Bestellungen werden nicht übernommen Amazon-Anbindung - Fehler und Bugs 4
Neu JTL-Wawi 1.6.32.1: Artikelstammdaten einiger Artikel kann nicht angezeigt werden JTL-Wawi - Fehler und Bugs 0
Gelöst custom.css konnte nicht geladen werden Templates für JTL-Shop 2
Neu Auftragsnummern werden übersprungen JTL-Wawi - Fehler und Bugs 1
Neu Zeichen werden nicht angezeigt... Im Frontend - nach Schrift Änderung!? JTL-Shop - Fehler und Bugs 0
Neu Neue Produkte werden nicht im Shop angezeigt. Shopware-Connector 4
Neu Datenbank konnte nicht angelegt werden. Installation von JTL-Wawi 4
In Bearbeitung JTL-POS Rechnungen werden nicht gedruckt JTL-POS - Fehler und Bugs 10
Neu Lastschiftaufträge werden fälschlich als bereits gezahlt gesetzt. JTL-Wawi - Fehler und Bugs 0
Neu JTL auf virtuellen Server installiert, es soll dann auf mehreren Rechner die mit dem Server verbunden sind genutzt werden. Individuelle Listenansichten in der JTL-Wawi 5
Neu Shopify Trackingnummern werden verzögert / gar nicht in die Bestellungen geladen JTL-Wawi - Fehler und Bugs 0
Neu Variablen _variables.scss werden im Kind-Template nicht angezeigt Templates für JTL-Shop 2
In Bearbeitung WORM_ERROR_AUT HENTICATION_PIN_BLOCKED - Beleg konnte nicht signiert werden. JTL-POS - Fehler und Bugs 2
Neu Artikel werden nicht auf eBay entfernt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shopware 5 Bilder werden nicht aktualisiert bzw. falsche zugeordnet Shopware-Connector 0
Gelöst Lister gibt Daten falsch nach Amazon, Nakommaproblem und werden nicht gelistet Amazon-Lister - Fehler und Bugs 2
Neu Lieferscheine werden nicht gedruckt bei Auslieferung User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung "JTL-POS muss beendet werden!" JTL-POS - Fehler und Bugs 12
Neu Kundengruppen werden vom Connector nicht mehr in die Wawi übertragen JTL-Wawi - Fehler und Bugs 0
Neu Kategorie Metadaten werden nicht übertragen WooCommerce-Connector 0
Neu Wawi 1.6 Freipositionen mit Menge 0 werden nicht mehr in der Rechnung ausgegeben JTL-Wawi - Fehler und Bugs 0
Beantwortet WAWI 1.6.32.0 Rechnungsänderungen werden in der Rechnung nicht übernommen JTL-Wawi - Fehler und Bugs 23
Neu Editierte OPC inhalte werden nicht angezeigt Installation / Updates von JTL-Shop 2
Neu Plugin Migrations werden beim deinstallieren nicht zurück gesetzt JTL-Shop - Fehler und Bugs 0
Neu FBA Aufträge werden mehrfach erstellt. Amazon-Anbindung - Fehler und Bugs 2
Neu Maßeinheiten / Verkaufseinheiten werden übertragen aber nicht am Produkt hinterlegt Modified eCommerce-Connector 0
Gelöst Im Warenkorb werden "alle" Versandarten angezeigt und auswählbar Einrichtung JTL-Shop5 1
Neu WAWI 1.6.32.0 Das Feld "Anmerkung" un Aufträgen kann bei VCS Bestellungen nicht mehr genutzt werden User helfen Usern - Fragen zu JTL-Wawi 2
Neu Kasse druckt Bon + Lieferschein, Lieferschein soll nicht an dem Bondrucker ausgegeben werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Willkürlich werden keine Rechnungen mehr gedruckt Arbeitsabläufe in JTL-Wawi 1
Neu Preise werden nicht angeglichen Shopware-Connector 0
Neu Einzelne Produkte in der Wawi können nicht bearbeitet werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu EU-Steuereinstellungen für Lieferschwelle werden bei Produkten nach Abgleich in Gambio wieder zurück gesetzt. Gambio-Connector 0
Neu JTL Shop 5 Filter werden im Inhaltsbereich nicht angezeigt Allgemeine Fragen zu JTL-Shop 2
In Bearbeitung Hersteller werden nicht angezeigt WooCommerce-Connector 1
Neu Werden Stornierungen in WaWi übertragen? Allgemeine Fragen zu JTL-Shop 6
Neu Vorlagen werden bearbeitet nicht angezeigt!? User helfen Usern - Fragen zu JTL-Wawi 1
Neu Lieferzeiten werden nicht mehr angezeigt (German Market) WooCommerce-Connector 0
Neu WaWi 1.6.31.2 - Aufträge können nicht gespeichert werden da er Schreingeschützt ist JTL-Wawi - Fehler und Bugs 2
Neu Fehler bei der Auftragserstellung: Für die aktuelle Transaktion kann kein Commit ausgeführt werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Amazon-Gutschriften werden nicht mehr eingelesen Amazon-Anbindung - Fehler und Bugs 1
Neu Artikel in Konfigurationsgruppen werden nicht ausgeliefert JTL-Wawi - Fehler und Bugs 0

Ähnliche Themen