Neu JTL Wawi ODBC Verbindung funktioniert nicht (bzw. nur teilweise)

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

mxwx

Neues Mitglied
8. Oktober 2020
7
0
Hallo zusammen,

ich teste gerade JTL Wawi und habe etwas Probleme die Datenbankverbindung zuverlässig hinzubekommen. Ich vermute ich habe irgendwo ein TLS 1.0 Problem, will aber auf keinen Fall TLS 1.0 nutzen.

Meine Konfiguration ist wie folgt. Auf einen Laptop (Windos 10) habe ich den JTL Wawi Client installiert, auf einer virtuellen Maschiene die MSSQL Datenbank (Microsoft SQL Server Express (64-bit)). Soweit so gut, ich kann ohne Probleme z.B. mittels Microsoft SQL Server Management Studio zur Datenbank verbinden:

001.PNG

Eine Verbindung mit der JTL-Wawi-Datenbankverwaltung klappt ebenfalls ohne Probleme:

002.PNG

eine Verbindung aus JTL-Wawi heraus scheitert aber:

003.PNG

004.PNG

Dieses Fehlerbild habe ich auch bzw. kann ich reproduzieren, wenn ich im ODBC-Manager versuche eine Verbindung mit dem ODBC Treiber "SQL-Server" herzustellen:

005.PNG

wenn ich hingegen im ODBC-Manager eine Verbindung mittels des ebenfalls installierten "ODBC Driver 17 for SQL Server" erstelle, klappt alles problemlos.

006.PNG

Ich vermute, dass JTL-Wawi versucht ebenfalls eine Verbindung mittels "SQL Server" herzustellen, die dann wegen fehlender TLS 1.0 Unterstüzung scheitert. Ich frage mich zum einen, ob und wenn ja warum, JTL-Wawi-Datenbankmanager die Verbindung mittels (in meinem Fall) "ODBC Driver 17..." statt dem veralteten ""SQL Server" herzustellen und JTL-Wawi dann im Anschluß nicht ebenfalls den neueren Treiber nutzt.

Noch viel interessanter fände ich, wie ich JTL-Wawi zwinge entweder eine vorher im ODBC-Manager erstellte und funktionierende ODBC Verbindung wiederzuverwenden bzw. JTL-Wawi zwinge einen bestimmten ODBC-Treiber zu verwenden.

Ich wäre echt dankbar, wenn mir bei diesem, warscheinlich echt kleinen Problem, jemand auf die Sprünge helfen würde. Wir wollen JTL-Wawi letztlich als Mehrplatzsystem betreiben sind u.A. deshalb darauf angewiesen, dass die Datenbank auf einer separaten Maschine läuft.

Vielen Dnak schonmal und beste Grüße.
 

SebiW

Sehr aktives Mitglied
2. September 2015
1.327
383
Soweit ich weiß benötigt die Wawi doch schon länger keine ODBC Verbindung mehr? Wann kriegst Du die beschriebene Fehlermeldung? Hast Du das Profil mit den gleichen Benutzer erstellt, mit dem Du auch die Wawi startest?
 

mxwx

Neues Mitglied
8. Oktober 2020
7
0
Hallo SebiW,

danke für die Antwort.

Ohne ODBC wäre mir natürlich ebenfalls noch lieber, habe mich in JTL-Wawi noch nicht so tief eingearbeitet, dass ich da was belastbares zu sagen könnte.

Zu deiner Frage. Während der Installation wird sowohl die Datenbank selbst, als auch der Mandant problemlos installiert. Anschließend melde ich mich mit admin/pass an und nach einer Pause erhalte ich den Login-Dialog für die Datenbank. Dort gebe ich die selben Daten an wie bei der Installation sa/meingeheimespasswort . Innerhalb von JTL-Wawi erhalte ich dann anschließend das SSL bzw TLS Problem. Wenn ich dann anschließend im JTL-Wawi-Datenbankmanager die selben Angaben mache, klappt es problemlos. Zum Test habe ich dann auch noch über den den ODBC-Manager von Windows versucht entsprechende Profile einzurichten. Wenn ich den bei Windows mitinstallierten "SQL Server" ODBC Treiber nutze erhalte ich die selbe Fehlermeldung wie in JTL-Wawi, nutze ich den nachinstallierten "ODBC Driver 17 ..." klappt alles wunderbar.

Wo bzw. wie kann ich den die Datenbankkonfiguration innerhalb von JTL-Wawi nachträglich noch beeinflussen - ausser mit dem JTL-Wawi-Datenbankmanager? Mich wundert halt auch, dass die Verbindung im Datenbankmanager funktioniert, in der Wawi aber nicht.
 

SebiW

Sehr aktives Mitglied
2. September 2015
1.327
383
Wenn Du die Wawi normal startest sollte eine von 2 Sachen passieren:
1. Entweder Du kriegst die Fehlermeldung, dass kein Profil vorhanden ist, dann sschlägt er Dir im Normalfall gleich die Datenbankverwaltung vor.
2. Er zeigt ne Runde nichts an, es kommt aber keine Fehlermeldung. Wenn Du dann rechts unten auf die Zahnräder klickst startest Du die Datenbankverwaltung.
Da kannst Du dann Dein Profil einrichten, die Verbindung prüfen und das ganze sollte laufen.
Normalerweise wird die Verbindung über IP,Port/Instanzname eingegeben.
 

mxwx

Neues Mitglied
8. Oktober 2020
7
0
Danke für den Hinweis. Ich versuche einfach mal die bestehende Installation im Login-Dialog mit den Zahnrädern nochmaöl zu machen. Fallls das nicht klappt, lösche ich mal die Datenbanken, deinstalliere und installiere JTLWawi nochmal und melde mich dann wieder ...
 

mxwx

Neues Mitglied
8. Oktober 2020
7
0
... so komme ich auch leider nicht weiter.

nach Deinstallation von Datenbank und JTL-Wawi und erneuter Installation kommtnach dem Start der Wawi der Hinweis, dass die Datenbank fehlt - soweit so nachvollziehbar. Als nächstes wird dann automatisch der Datenbankmanager gestartet. Die Datenbankinstallation läuft komplett durch:

007.PNG

Für mich sieht die Installation der Datenbank auch soweit ok aus:

008.PNG

Danach geht es mit der Anmeldung (admin/pass) in der Wawi weiter. Danach versucht die Wawi offensichtlich mit der Datenbank zu verbinden:

Die Fehlermeldung nach ca 45 Sekunden:

009.PNG

Nach klicken auf OK kommt als nächstes wieder der Login Dialog für die Datenbank. Die dort eingegebenen Daten funktioniern im Datenbankmanager problemlos, in der Wawi gibt es die oben sichtbare Fehlermeldung.

010.PNG

ich bin etwas ratlos, zumal es mit dem Datenbankmanager problemlos klappt mit der Wawi halt nicht.
 

mxwx

Neues Mitglied
8. Oktober 2020
7
0
... achso, Wenn ich bei den Serverparametern statt 192.168.2.38/JTLWAWI bzw. 192.168.2.38\JTLWAWI eingebe funktioniert die Verbindung auch im Datenbankmanager nicht. 192.168.2.38 (ohne JTLWAWI) funktioniert aber tadellos. Die Dateien auf dem Datenbankserver werden mit Angabe nur der Ip-Adresse aber m.E. ohne Probleme. Die Dateien eazybusiness.mdf und eazybusiness_log.ldf werden angelegt und offnesichtlich auch mit u.a. Tabellen gefüllt.
 

SebiW

Sehr aktives Mitglied
2. September 2015
1.327
383
Welcher Port ist denn für die Kommunikation im SQL Server freigegeben? Bzw ist TCP/IP überhaupt aktiviert? Dafür musst Du den Konfigurationsmanager auf dem SQL Server starten, dort findest Du unter SQL Server Netzwerkkofiguration die Protokolle. Doppelklick auf TCP/IP, unter IP-Adressen werden die die Adressen und Ports angezeigt. Hier muss die IP Adresse Deines Servers und der dazugehörige Port auf "Active Ja" stehen. Ich würde auch vorschlagen mit einem festen Port zu arbeiten, beim kleinen SQL Server ist das normalerweise ein voreingestellter dynamischer.
Danach solltest Du Dich mit SQLSERVER,PORT\INSTANZNAME also zb 123.456.789.9,1433\JTLWAWI verbinden können.
 

mxwx

Neues Mitglied
8. Oktober 2020
7
0
Danke für die Antwort. ein angehängtes \JTLWAWI funktioniert bei mir erstmal nicht. Den Standardport 1433 kann ich angeben oder weglassen, beides klappt problemlos. Die Datenbank inkl. Tabellen werden ja auch bei der Initialisierung angelegt. Wo kann ich denn ggf. mal nachsehen, was z.B. der Datenbankmanager als Profil für die Verbindung der Wawi wegschreibt. Vielleicht sehe ich da ja das Problem. Gibt es da ein Text-, Ini- oder xml-File die der Datenbankmanager für die Wawi schreibt?
 

mxwx

Neues Mitglied
8. Oktober 2020
7
0
Ich habe heute nochmal etwas Zeit gehabt mir das Problem anzuschauen. Ich ahbe den Eindruck, dass das Problem ist, dass versucht wird eine TLS 1.0/1.1 Verbindung aufzubauen. Das kann nicht klappen, weil der Server das nicht unterstützt (darf). Kann es sein, dass der JTL Datenbankmanager da flexibel rangeht und ggf. den TLS SECLEVEL entsdprechend erhöht und die Wawi das unflexibel handhabt und TLS 1.2 (noch) nicht kann?
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu JTL Wawi zurücksetzen ohne Verlust von Rechnungen und Kundendaten User helfen Usern - Fragen zu JTL-Wawi 1
Neu Upgrade MSSQL Express 2017 auf MSSQL Express 2019 - JTL-Wawi 1.5.33.0 Installation von JTL-Wawi 0
Neu JTL WAWI & JTL-Packtisch druckt falschen EAN Code bei Etikettendruck Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Nach Update JTL Wawi auf 1.5.34.0: Sortierungskonflikt / Kollationen verändert JTL-Wawi - Fehler und Bugs 5
Neu Kompatibilität JTL Shop 4.06 (Build9) mit JTL Wawi 1.4 oder 1.5 Allgemeine Fragen zu JTL-Shop 1
Gelöst Lizenzschlüssel lässt sich nicht in JTL Wawi eintragen Gelöste Themen in diesem Bereich 6
Neu Lieferschwelle in Wawi eingerichtet JTL-Shop berechnet trotzdem die deutsche USt. Steuer User helfen Usern - Fragen zu JTL-Wawi 0
Neu Import Avocado-Auftragsdaten in JTL Wawi Schnittstellen Import / Export 0
Neu JTL Wawi Apple M1 Chip? Installation von JTL-Wawi 0
Neu Problem Erstimport der Kunden Shopware 5.6.9 zu JTL-Wawi 1.5.33 Shopware-Connector 5
Neu Keine Zahlungsart an JTL WaWi übertragen bei bei Nullbon (Umtausch gegen Artikel gleichen Warenwertes) JTL-POS - Fehler und Bugs 1
Neu Jtl shop + jtl wawi Ende der Probleme? Allgemeine Fragen zu JTL-Shop 0
Neu JTL Wawi 1.5.32.0 Amazon selbsterstelle Produktseite Fehler 8115 User helfen Usern - Fragen zu JTL-Wawi 1
Neu Allgemeine Fragen zu JTL WaWi Client (Mehrplatzinstallation) User helfen Usern - Fragen zu JTL-Wawi 1
Neu Mehrere Positionen an JTL Wawi senden (richtige Steuern übermitteln) WooCommerce-Connector 0
Neu JTL Wawi - WooCommerce Fehler beheben Dienstleistung, Jobs und Ähnliches 0
Neu Hilfe bei Umzug der JTL WAWI und des Servers gesucht Dienstleistung, Jobs und Ähnliches 1
Neu Frage zur Installation der JTL-Wawi-Datenbank auf einem MS-SQL-Server unter CentOS Installation von JTL-Wawi 5
Neu JTL Shop Kundennummer in Wawi Workflow | Automatische Kupon erstellung per Workflow User helfen Usern - Fragen zu JTL-Wawi 0
Neu Kunden/Bestellung --> Shopware 5 nach 6 Migration mit JTL Wawi Shopware-Connector 0
Neu JTL Wawi mit Windows Domain - Netzwerkinstallation - Verteilung von Updates automatisieren Installation von JTL-Wawi 4
Neu JTL-Shop ist nicht gleich WAWI Sonderpreis aber Sonderpreis aufs Etikett drucken Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Shopware --> JTL Wawi Auftrag abruf schlägt fehl Shopware-Connector 0
Neu Mindest- und Maximalbestände pro Warenlager - JTL-Wawi 1.6 (Video) Umfragen rund um JTL 7
Neu JTL-WAWI Hosting + Datenbankzugriff User helfen Usern - Fragen zu JTL-Wawi 1
Neu FAQ - Amazon VAT Calculation Service (VCS) & JTL-Wawi - 3 Vorteile für Online Händler (Video) Umfragen rund um JTL 37
In Bearbeitung JTL-WAWI + FFN hängt beim Start und in Log JTL-Wawi - Fehler und Bugs 1
Neu es kann keine Verbindung zwischen JTL-WAWI und POS hergestellt werden. Einrichtung / Updates von JTL-POS 6
Neu Schriftgröße von JTL Wawi vergrößern User helfen Usern - Fragen zu JTL-Wawi 2
Gelöst JTL Shop 5 Keine Verbindung zur WAWI möglich. Die Shop-URL verweist nicht auf einen gültigen Shop! Bitte prüfen Sie die Connector-Konfiguration Gelöste Themen in diesem Bereich 6
In Bearbeitung Falsche MHD/Charge auf Lieferschein bei Warenausgang über JTL-Packtisch+ [WAWI-50270] JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 13
Neu Auftrag aus JTL-WaWi laden und bearbeiten geht nicht. Storno ist auch ziemlich verwirrend. JTL-POS - Fehler und Bugs 1
In Bearbeitung JTL Wawi + Shop in Testumgebung - Konfigurator aktivieren? Installation von JTL-Wawi 2
Neu JTL POS mit gehosteter Wawi verwenden Einrichtung / Updates von JTL-POS 5
Neu Eigene Felder auf Rechnung JTL Wawi 1.5.31 Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Wawi Artikel werden nicht in JTL POS angezeigt Gelöste Themen in diesem Bereich 1
Neu JTL WAWI Sofortautfräge im Shopkonto JTL-Wawi - Ideen, Lob und Kritik 0
Neu Ändern eines Auftrages in JTL POS aus JTL-Wawi Allgemeine Fragen zu JTL-POS 2
In Bearbeitung [BUG] JTL-Worker läd bei jedem Amazon Abgleich *ALLE* VCS-Lite Rechnungen erneut hoch - JTL-Wawi 1.5.30.3 Amazon-Anbindung - Fehler und Bugs 6
Abgelehnt [BUG] JTL-Worker läd bei jedem Amazon Abgleich *ALLE* VCS-Lite Rechnungen erneut hoch - JTL-Wawi 1.5.30.3 Amazon-Anbindung - Fehler und Bugs 1
Neu JTL WAWI ./. 3CX JTL-Wawi - Ideen, Lob und Kritik 0
Neu API notification JTL WAWI to Shop WooCommerce-Connector 0
Neu How to connect example connector plugin to JTL wawi Allgemeines zu den JTL-Connectoren 1
Neu Kundenspezifischer Staffelpreis (Sp) wird nicht berücksichtigt, wenn der SP des Kunden größer als der SP in Registerkarte 'JTL-Wawi' ist JTL-Wawi - Fehler und Bugs 0
Neu Empfohlene Hardware (Tablet) JTL-POS & JTL-Wawi -> Vor- und Nachteile der Systeme JTL-POS - Fragen zu Hardware 3
In Bearbeitung JTL WAWI Auftrag Import funktioniert nicht JTL-Wawi - Fehler und Bugs 1
Neu Fehlermeldung nach Update auf JTL-WAWI 1.5.30.1 JTL-Wawi - Fehler und Bugs 3
In Bearbeitung [BUG] Amazon VCS-Lite in Zahlungen wird die Rechnungsnummer nicht eingetragen - JTL-Wawi 1.5.29.2 User helfen Usern - Fragen zu JTL-Wawi 5
Neu Upload-Dateien in Aufträgen in JTL-Wawi Arbeitsabläufe in JTL-Wawi 1
Offen Shopware 5 -> JTL WaWi : Lieferadresse wird nicht übernommen Onlineshop-Anbindung 4
Ähnliche Themen