Neu Mehrere Versandart - Problem

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Nico G

Neues Mitglied
20. September 2020
9
0
Hallo,

In dem Shop habe ich 2 Versandart angelegt, ebenso wie in WAVI.
Bei den Artikeln sind entsprechend den verschiedenen Artikeln auch die entsprechenden Versandarten hinterlegt.
Wenn ich nun einen Artikel in den Warenkorb lege und die Bestellung durchspiele wird auch die richtige Versandart angezeigt.
Habe ich nun jedoch 2 Artikel mit jeweils unterschiedlichen Versandarten im Warenkorb und versuche die Bestellung durchzulaufen wird bei dem Bestellprozess "Versand und Zahlungsart" immer folgender roter Text gezeigt: " Es steht keine Versandart für Ihre Bestellung zur Verfügung. Bitte kontaktieren Sie uns direkt, um diese Bestellung abzuwickeln. "

Wie kann ich dieses Problem beheben?

Danke und viele Grüße,
Nico
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.161
284
Hey,

du musst zwischen "Versandklassen" und "Versandarten" unterscheiden.

Versandarten sind für bestimmte "Versandklassen und Versandklassenkombinationen" gültig. Nehmen wir also an du hast zwei Versandklassen VKa und VKb. Jetzt legst du zwei Versandarten VAa und VAb an. Den beiden ordnerst du entsprechend zu:
- Versandart VAa bekommt Versandklasse VKa
- Versandart VAb bekommt Versandklasse VKb

Erstmal schön. Hast du jetzt allerdings Artikel beider Versandklassen im Warenkorb, dann tritt genau dein Problemfall ein: keine der beiden Versandarten ist gültig. Es wird eine Versandart benötigt, die gültig ist für die Versandklassenkombination "VKa, VKb".
Da kannst du jetzt entweder eine dritte für anlegen, oder du sagst z.B. "Versandart VAb ist auch für die Kombination gültig und damit dann für folgende Versandklassen: "VKb; VKa, VKb" (bedeutet: Für VKb alleine und für VKa UND VKb im Warenkorb).
 
  • Gefällt mir
Reaktionen: Nico G

Nico G

Neues Mitglied
20. September 2020
9
0
Hallo,

vielen dank für die schnelle Antwort.
Das habe ich soweit verstanden und auch konfiguriert bekommen.
Nun bekomme ich zwar die Meldung nicht mehr, jedoch gibt es nun noch ein neues Problem.
Nehmen wir an eine Kunde hat
1. Produkt als Sperrgut mit Versandkosten 15€ im Warenkorb
2. Produkt mit normalem Versand für 6 € im Warenkorb.

Wenn ich nun den Bestellprozess durchlaufe wird nur der Versand für 6 € Angezeigt und berechnet.
Was genau muss ich tun damit für beide Produkte der jeweils eigene Versandpreis berechnet wird ( wird ja auch in 2 Paketen verschickt).

Schon mal vielen Dank
Nico
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.161
284
Das ist korrekt wie MichaelH es schreibt.
Jede Bestellung im JTL- Shop kann nur eine Versandart haben. Also entweder bildest du passende Versandart-Gesamtpreise über Versandklassenregelung ab, oder du nutzt das Funktionsattribut für individuelle Artikel-Versandpreise, welche als Position (nicht als Versandart) der Bestellung hinzugefügt werden. Siehe dazu:
- In den Beispiel-Szenarien bei "Artikelabhängiger Versand" https://guide.jtl-software.de/jtl-shop/systemverwaltung/versandarten-einrichten/#beispiel-szenarien
- Beim Funktionsattribut "versandkosten" https://guide.jtl-software.de/jtl-s...n/#uebersicht-funktionsattribute-fuer-artikel
 

Nico G

Neues Mitglied
20. September 2020
9
0
Erst einmal danke für die Tipps.
Ich habe das nun auch so ungesetzt und das funktioniert auch soweit gut.
Nun ergeben sich jedoch 2 neue Fragen.
1: Wieso wird, nachdem ich ein Produkt in den Warenkorb gelegt habe, in die Gesamtsumme noch kein Versand eingerechnet wenn ich den Warenkorb anschaue, sondern erst dann wenn ich den Bestellprozess durchlaufe? Ich ging davon aus das schon im Warenkorb auch die Versandkosten als Position mit angezeigt werden müssen.
2. Durch die Artikelabhängigen Versandkosten gibt es nun eine sehr komisch Zusammenstellung der Versandkosten. Einmal gibt es nun im Bestellprozess eine Position "Versandkostenfrei" (welche, wie ich annehme durch die Versandart ohne Preis in WAVI kommt) und eine mit den Artikelabhängigen Versandkosten (welche ja die wirklichen Versandkosten sind). Hier bin ich fast der Meinung das dies eine Art Bug ist und vor allem kann man ja so eventuell belangt werden weil man Versandkostenfrei mit ausgewiesen hat. Siehe auch den Screenshot

Screenshot 2020-11-19 100444.jpg

Gibt die JTL Software was verschieden Versandart angibt echt so wenig her und macht es so kompliziert?

Das ist keinesfalls böse gemeint, ich bin selbst auch Softwareentwickler und frage mich wieso man das so kompliziert gemacht hat wo es doch eigentlich recht einfach vom Grunde her ist.

Wie kann ich das nun so hinbekommen das ich bei Artikelabhängigen Versandkosten nicht auch die Position "Versandkostenfrei" drin habe?

Wie immer danke ich euch schon mal für die Hilfe.
Nico
 

Nico G

Neues Mitglied
20. September 2020
9
0
Ist lange her, dass ich dies verwendet hatte und ja es war alles andere als einfach.

Schau dir auch dies mal an oder andere Plugin die das vielleicht elegant gelöst haben:
https://css-umsetzung.de/shop/CSS-Versandoption-Plus
Ich danke Dir schon mal für den Tip mit dem Plugin. Ehrlich gesagt wollte ich aber keine extra 200 € ausgeben um eine Funktionalität zu bekommen, welche in einem Shopsystem doch grundlegend ordentlich funktionieren sollten.
Bei einem Onlineshop ist der Versand ja eine essenzielle Grundfunktion.

Gibt es in der JTL Shop Software salbt wirklich keine Möglichkeit das ordentlich zu konfigurieren, so das:
1. die Versandkosten im Warenkorb schon dann angezeigt werden wenn ich ein Produkt in den Warenkorb lege
2. ich in WAVI verschiedene Versandarten für verschiedene Produkte interlegt habe diese auch extra aufgeführt werden (z.b. unterschied Sperrgut und normales Paket)
3. durch den "Hack" mit dem oben beschriebenen Artikelabhängigen Versandkosten nicht auf einmal Versandkostenfrei und darunter X€ Versandkosten angezeigt werden

Gerade bin ich da schon echt ein wenig geschockt das eine solch grundlegende Funktionalität nur durch "Hacks" halbherzig funktioniert.

Was ich auch gerade noch herausgefunden habe:
Lege ich ein Produkt in den Warenkorb und lasse mir dann den Warenkorb anzeigen wird erstmal keine Position für den Versand angezeigt oder in die Gesamtsumme einberechnet. Wenn ich nun den Bagatellprozess anfange zu durchlaufen und zu dem Punkt komme wo ich die Versandart und die Bezahlart wählen muss, dann wieder oben auf den Warenkorb klicke, dann habe ich auf einmal auch im Warenkorb die Positionen für den Versnad mit drin und auch die Gesamtsumme wird dann entsprechend angepasst.
Dies ist ein BUG, der (soweit mir bekannt) in Deutschland sogar rechtliche Konsequenzen haben kann. Meines Wissens nach muss schon im Warenkorb immer die Gesamte Summe inkl. Versandkosten angezeigt werden und nicht erst im Bestellprozess, sofern es keine Auswahl von verschiedenen Versandarten gibt (was ja bei mir der Fall ist).
Noch dazu habe ich ja nun Artikelabhängige Versandkosten hinterlegt, sprich die sind Fix und es kann keine Auswahl vom Käufer getroffen werden selbst wenn ich verschiedenen Versender hätte.

Wie geht JTL den mit solchen Bugs um, werden die schnell gefixt?
Mein Shop ist ja auch direkt bei JTL gehostet.

Danke
 

MichaelH

Sehr aktives Mitglied
17. November 2008
11.603
643
Ich stimme dir zu, aber wenn jede Shop-Software alles immer perfekt könnte, dann würde es keine Plugin für die Shops geben ...

Vielleicht / vermutlich gibt es eine Lösung für dein Problem, Bug wird es keiner sein, denn die Funktion gibt es schon seit > 10 Jahren schon in Shop3 und auch in Shop4 und wenn es ein Bug wäre ... manchmal hat JTL einfach eine andere Sichtweise auf die Dinge und lässt Lücken offen, weil es zu viele verschieden Erwartungen gibt und der Aufwand zu groß wäre diese alle abzudecken, womit dann die Plugin ins Spiel kommen und die Lücke füllen.

Ich kann auch ein Lied davon singen ... wenn ich so an lange endlose und erfolglose Diskussionen von meiner Seite denke.

Wenn es eine Lösung gibt, nimm sie und denk nicht über 200 Euro nach, wenn es dein Problem tatsächlich löst, spar dir Zeit und Nerven und kümmere dich lieber ums Verkaufen ! :)
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.161
284
Hi @Nico G

bzgl. 1: Das haben wir für den JTL-Shop5 umgesetzt, allerdings nicht als Position. Wäre mir nun auch neu, dass es unbedingt eine Position sein muss; die Info an sich ist soweit ich weiss wichtig. Wir konnten da jetzt auch kein rechtskräftiges Urteil finden. Wenn du da andere Rechtsbelege hast gerne her damit :)
Wie folgt haben es die it-rechtskanzlei und der Händlerbund abgenommen:
1606403599609.png
bzgl 2.: Das ist so vom Systemkonzept her leider nicht möglich. Du kannst nur mit Versandklassen arbeiten und diese entsprechend über Versandarten im Shop verwalten.
bzgl 3.: Das Problem entsteht tatsächlich nur, wenn man NUR ein Produkt kauft, welches das Attribut nutzt. Hast du einen gemischten Warenkorb, dann sieht das auf einmal logisch aus, weil du einmal Versandkosten für die normalen Produkte hast + die "Spezialkosten" für Produkt-X. Wenn nur Attribut-Produkte im WK sind, dann kommt wieder unsere technische Hürde zum Zuge: Wir brauchen eine Versandart und diese ist für den Fall in der Regel auf 0,00€ gesetzt, da ja eben die Kosten über das Attribut laufen. Wir halten die "versandkostenfrei"-Anzeige in dem Fall auf jeden fall auch für einen Fehler. Aufgenommen: https://issues.jtl-software.de/issues/SHOP-4712
 

Nico G

Neues Mitglied
20. September 2020
9
0
Hi @Nico G

bzgl. 1: Das haben wir für den JTL-Shop5 umgesetzt, allerdings nicht als Position. Wäre mir nun auch neu, dass es unbedingt eine Position sein muss; die Info an sich ist soweit ich weiss wichtig. Wir konnten da jetzt auch kein rechtskräftiges Urteil finden. Wenn du da andere Rechtsbelege hast gerne her damit :)
Wie folgt haben es die it-rechtskanzlei und der Händlerbund abgenommen:
Den Anhang 51809 betrachten
bzgl 2.: Das ist so vom Systemkonzept her leider nicht möglich. Du kannst nur mit Versandklassen arbeiten und diese entsprechend über Versandarten im Shop verwalten.
bzgl 3.: Das Problem entsteht tatsächlich nur, wenn man NUR ein Produkt kauft, welches das Attribut nutzt. Hast du einen gemischten Warenkorb, dann sieht das auf einmal logisch aus, weil du einmal Versandkosten für die normalen Produkte hast + die "Spezialkosten" für Produkt-X. Wenn nur Attribut-Produkte im WK sind, dann kommt wieder unsere technische Hürde zum Zuge: Wir brauchen eine Versandart und diese ist für den Fall in der Regel auf 0,00€ gesetzt, da ja eben die Kosten über das Attribut laufen. Wir halten die "versandkostenfrei"-Anzeige in dem Fall auf jeden fall auch für einen Fehler. Aufgenommen: https://issues.jtl-software.de/issues/SHOP-4712

Hallo @JulianG,

Danke für die Antwort. Leider ist Shop5 aber noch nicht nicht fertig und so ist ja unser Shop (welcher auch bei euch gehostet ist) noch Shop4 ;)
Was die Versandarten vs. Versandklassen angeht verstehe ich diesen "Zwischenlayer" Versandklassen und dessen Zweck eh nicht wirklich. Aus Entwicklersicht würde ich es ganz klar so entwickeln das ich Versandarten habe und jedem Produkt muss eine Versandart hinzugefügt werden.
An die Versandart würde ich noch eine Option hängen welche angibt ob bei der Versandart Produkte mit gleich hinterlegter Versandart zusammen in einem "Paket" Versand werden dürfen oder nicht.
Wird nun im Shop ein oder mehrere Produkte in den Warenkorb gelegt prüfe ich welcher Versandart hinterlegt ist und berechne entsprechend den Versandpreis und zeige ihn an.
Sollten Produkte eine Versandart haben welche die Option "gemeinsam Versenden" aktiviert hat würde ich für diese Produkte nur einen Versandposten anzeigen. Sind auch Produkte im Warenkorb bei welchem die Option "gemeinsam Versenden" an der Versandart deaktiviert ist würde ich für jedes dieser Produkte einen extra Vresandpreisposten anzeigen und Berechnen. Ist eigentlich recht einfach und wäre rein entwicklungstechnisch auch sehr einfach umzusetzten.

Was aber viel schlimmer ist und mir gerade erst aufgefallen ist:
Wenn ich in WAWI einer Versandart (aktuell) 5% MwSt angebe und einer 2. Versandart (aktuell) 16% MwSt angebe geht dies ja.
Lege ich nun in meinen Warenkorb ein Produkt für 29,90 € welches 16% MwSt hat und ein Produkt für 17,90 €, welches 5% MwSt hat, dann wird die MwSt für die beiden Versandarten im Bestellprozess falsch berechnet. Beide Versandposten werden mit 16% MwSt Berechnet.
Das Problem ist hier auch ganz klar eine Fehlende Einstellung im Shop und die Einstellungen der Versandart aus WAWI (angegebene MwSt der Versandart) werden einfach gar nicht wirklich gezogen da der Shop diese übergeht.
Die Einstellung im Shop dazu ist folgende:
2020-11-27 23_57_04-Window.png

Das Ergebnis einer solchen Bestellung sieht dann z.b. so (falsch) aus:

Screenshot 2020-11-28 000135.jpg

Genau HIER gibt es nun aber Rechtlich richtig Probleme (laut Aussage unseres zuständigen Finanzamtes). Dies hat uns auf Nachfrage (ich war etwas verwundert über die MwSt. Auflistung im Shop4 bei einer Testbestellung und habe beim Finanzamt nachgefragt wie genau die MwSt von Versandkosten für MwSt geminderte Waren anzugeben und zu berechnen sind) folgende Aussage gegeben:
Die Versandkosten müssen IMMER den gleichen MwSt Satz haben wie das Produkt selbst, wenn es, wie in unserem Fall, auch getrennt Versand wird.
Macht man dies nicht (wird auf der Rechnung ja auch so ausgewiesen wie im Screenshot oben) wäre dies Täuschung und Steuerbetrug.

Nun meine Frage, wie bekomme ich das in dem aktuellen Shop 4 so hin das dieser (und ich denke auch alle anderen Nutzer die ein Scenario wie wir haben) Gesetzeskonform ist und ohne Steuerbetrug zu begehen?
Leider habe ich keinen Weg gefunden die Berechnung der MwSt für den Versand (im Shop) auch mit dem in WAWI eingestellten Steuersatz an der entsprechenden Versandart im Shop umzusetzen.

Das Obige Beispiel wäre wie folgt richitg:
Baumständer kostet 29,90 €, davon sind 4.12 € MwSt (16%)
Fichte kostet 17,90 € davon sind 0,85 € MwSt (5%)
Versand Baumständer sind 6,00 € davon sind 0,83 € MwSt (16%)
Versand Fichte sind 14,90 davon sind 0,71 € MwSt (5%)

inkl 16% Ust (gesamt) wären somit 4,95 €
inkl 5% Ust (gesamt) wären somit 1,56 €


Mir ist klar das die Gesamtsummer bei falscher sowie richtiger Berechnung wieder auf das gleiche raus kommt jedoch wird im Shop rechtlich falsche MwSt ausgewiesen! Als Shopbetreiber ist man somit dabei rechtlich belangbar!

Gibt es hierfür eine wirklich schnelle Lösung von Seiten JTL ? Das wäre echt super ;) (und wir Shopbetreiber wären nicht durch eine Falschberechnung / Falschausweisung der enthaltenen MwSt rechtlich angreifbar).


Vielen lieben Dank
Nico
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Feature - B2B-Preise für mehrere SKU pflegen Amazon-Anbindung - Ideen, Lob und Kritik 0
Gelöst Amazon Lister - mehrere Vorlagen Amazon-Lister - Ideen, Lob und Kritik 2
Neu Mehrere E-Mail adressen? Arbeitsabläufe in JTL-Wawi 0
Neu Mehrere Rechnungen zusammen (mit einer TAN) bezahlen / Sammelüberweisung Arbeitsabläufe in JTL-Wawi 0
Neu Workflow erstellen und mehrere Dateien mit Abfrage in dem Mailanhang packen möglich? User helfen Usern - Fragen zu JTL-Wawi 0
Neu Mehrere Artikel an versch. Tagen zurückgesandt Arbeitsabläufe in JTL-Wawi 4
Neu Preise ändern mehrere Vertriebswege Stored Procedures User helfen Usern - Fragen zu JTL-Wawi 0
Neu Kundedaten-Import: mehrere Lieferadressen funktioniert nicht JTL-Ameise - Fehler und Bugs 1
Neu Warenbestand pflegen – mehrere Artikel, ein Produkt, ist das möglich? Allgemeine Fragen zu JTL-Shop 6
Neu Mehrere Ebay Accounts, unterschiedliche Artikelnamen? User helfen Usern - Fragen zu JTL-Wawi 1
Neu Mehrere Sonderpreisregeln JTL-Wawi - Ideen, Lob und Kritik 0
In Bearbeitung Mehrere If Abfragen im Ebay-Template setzen eBay-Designvorlagen - Ideen, Lob und Kritik 6
Gelöst Mehrere Artikel auf einer Pickliste Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 2
Issue angelegt Zulauf wird im Shop nicht angezeigt / mehrere Lieferantenbestellungen hierfür JTL-Shop - Fehler und Bugs 7
In Diskussion Wawi 1.5.25 - Workflow - mehrere Replace in einem Workflow-Durchgang JTL-Workflows - Ideen, Lob und Kritik 4
Neu VK-Summe der Komponenten für mehrere Artikel ausführen Arbeitsabläufe in JTL-Wawi 3
Neu Mehrere Positionen an JTL Wawi senden (richtige Steuern übermitteln) WooCommerce-Connector 0
Neu Umbrüche bzw. mehrere Spalten bei Artikeln Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
In Diskussion mehrere suchbegriffe bei assign Vergleichswert JTL-Workflows - Fehler und Bugs 4
Neu Mehrere Firmen und Filialen als Lager Arbeitsabläufe in JTL-Wawi 0
Neu Mehrere Ebay-Accounts / Eazyauction E-Mails User helfen Usern - Fragen zu JTL-Wawi 2
In Bearbeitung Zeitvorwahl mehrere Artikel User helfen Usern - Fragen zu JTL-Wawi 3
In Bearbeitung ebay-Bilder Massenänderung bei für mehrere Plattformen User helfen Usern - Fragen zu JTL-Wawi 6
Neu Neue Versandart anlegen Allgemeine Fragen zu JTL-Shop 3
Neu Vorauswahl der Versandart, Zahlungsart etc. beim Erstellen eines neuen Auftrages. User helfen Usern - Fragen zu JTL-Wawi 3
In Diskussion ShippingLabel - Versandart ändern nach Ausdruck zeigt keine Wirkung JTL-ShippingLabels - Ideen, Lob und Kritik 2
Neu Versandart nachträglich ändern User helfen Usern - Fragen zu JTL-Wawi 3
Neu Rabat bei bestimmter Versandart auf Kategorie Allgemeine Fragen zu JTL-Shop 1
Neu Versandart-Position "springt" nach Kontrollaufruf JTL-Wawi - Fehler und Bugs 0
In Diskussion Versandart nach Gewicht anpassen JTL-ShippingLabels - Ideen, Lob und Kritik 0
Gelöst Workflow: Versandart ändern mit oder ohne FSK18 JTL-Workflows - Ideen, Lob und Kritik 7
Neu USt. bei Versandart von EU Händler Kunde JTL-Wawi - Fehler und Bugs 0
Neu E-Mail versenden bei bestimmer Versandart Workflow Arbeitsabläufe in JTL-Wawi 5
In Diskussion Versandart mit Workflow anpassen JTL-Workflows - Fehler und Bugs 4
Issue angelegt Paypal Problem mit Versandart Plugins für JTL-Shop 4
Neu SQL Abfrage Versandart Maxgewicht User helfen Usern - Fragen zu JTL-Wawi 1
Neu Versandart mit einem Workflow nach dem Import der Bestellung automatisch ändern User helfen Usern - Fragen zu JTL-Wawi 2
Neu Versandart nach Rechnungserstellung ändern User helfen Usern - Fragen zu JTL-Wawi 4
Neu Versandart mit 4 Nullen...??? User helfen Usern - Fragen zu JTL-Wawi 4
Gelöst Versandart = Abholung Gelöste Themen in diesem Bereich 2
Neu Versandart Abholung lässt sich nicht abschließen - Bestellungen landen in Ordner fehlerhaft. User helfen Usern 0
Neu Idealo Export: Problem mit Umlauten Allgemeine Fragen zu JTL-Shop 2
Neu Workflow Problem/Bug Arbeitsabläufe in JTL-Wawi 0
Neu Server error 500 nach Warenkorb im Bestellvorgang ( nicht jeder Kunde hat dieses Problem ) JTL-Shop - Fehler und Bugs 0
Neu Problem Update von Version 4 auf 5 - Admin Seite weiß Installation / Updates von JTL-Shop 0
Neu Problem bei instalation SQL "does not support the language of the OS" Installation von JTL-Wawi 6
Neu [Shop4] Problem mit einer Versandarten und der Bezeichnung im Shop (Dopplung) Technische Fragen zu Plugins und Templates 1
Neu Problem mit der Signatur Servicedesk (Beta) 0
Neu Problem Update von Version 4 auf 5 - Plugin Manager - Admin Seite weiß Installation / Updates von JTL-Shop 2
Neu Startseite Shop5 kleines Problem Einrichtung von JTL-Shop4 4
Ähnliche Themen