Neu JTL Shop 3.20 ALL-INKL auf PHP 5.5, 5.6 oder 7.0 umsteigen? Update!

ROGUE

Gut bekanntes Mitglied
11. September 2013
332
24
Hallo,

folgendes steht im ALL-INK Bereich wenn man sich einloggt (siehe Screenshots)

Kann ich ohne Bedenken auf 5.5, 5.6 oder 7.0 umsteigen?
Muss man da noch was beachten?

Vielen Dank im Voraus.
Gruß
 

Anhänge

ROGUE

Gut bekanntes Mitglied
11. September 2013
332
24
Hi,

bitte in diesem Thread den 2. Beitrag beachten.
Dann muss noch sichergestellt sein das dein Hoster auch für die neue PHP-Version den ioncubeloader aktiviert.
Vielen Dank für die schneller Rückmeldung. Ja, als erstes bin ich auch dort gelandet bei diesem Thread, bin aber nicht schlauer geworden. Also einfach darauf achten, dass bei der neuen Version ioncubeloader aktiviert ist!? Welche Version sollte man am besten nehmen? 5.5, 5.6 oder 7.0?
 

mike59999

Sehr aktives Mitglied
16. Oktober 2012
775
49
Darmstadt
Hab gerade im Wiki nachgesehen dort wurden die Vorraussetzungen aktualisiert. -> https://guide.jtl-software.de/jtl/JTL-Shop:Installation:Neuinstallation
Der Shop 3 ist bis Version 5.6 lauffähig diese Version würde ich dir auch empfehlen da hier die Performance noch etwas im Vergleich zu 5.5 verbessert wurde.
Was ich fast vergessen hätte wenn du Plugins von Drittanbietern/Servicepartnern einsetzt bitte auch prüfen das diese unter PHP 5.5 / 5.6 laufen.
Hier kann es eventuell sein das diese wegen der neuen Ioncubeversion nicht laufen der Herausgeber sollte jedoch auch eine Version haben die für PHP 5.6 geeignet ist.
 

ROGUE

Gut bekanntes Mitglied
11. September 2013
332
24
Hab gerade im Wiki nachgesehen dort wurden die Vorraussetzungen aktualisiert. -> https://guide.jtl-software.de/jtl/JTL-Shop:Installation:Neuinstallation
Der Shop 3 ist bis Version 5.6 lauffähig diese Version würde ich dir auch empfehlen da hier die Performance noch etwas im Vergleich zu 5.5 verbessert wurde.
Was ich fast vergessen hätte wenn du Plugins von Drittanbietern/Servicepartnern einsetzt bitte auch prüfen das diese unter PHP 5.5 / 5.6 laufen.
Hier kann es eventuell sein das diese wegen der neuen Ioncubeversion nicht laufen der Herausgeber sollte jedoch auch eine Version haben die für PHP 5.6 geeignet ist.
Vielen Dank. ALL-INKL hat mir auch 5.6 empfohlen. Das Thema kann geschlossen werden.
 

John

Sehr aktives Mitglied
3. März 2012
1.128
37
Naja, so ganz zu kann das Thema noch nicht...spätestens am 31.12.2018 ist der Support für PHP 5.6 zu Ende und dann wirds mit Shop3 ein Problem geben, oder nicht?
 

MX-TEC

Aktives Mitglied
14. Januar 2016
9
0
Hallo,

ich stieß auf der Suche nach Updatemöglichkeiten auf diesen Thread. Kann mir jemand kurz umreißen wie sich das zukünftig verhält? Wenn der php support eingestellt ist, muss man dann wechseln, oder laufen die Installationen dann trotzdem, nur die Wartung, falls z.Bsp.bugs o.ä.entstehen, fehlt?
Ich bin da etwas raus aus der Materie.(ich habe den Shop 3.18 mit einer Erweiterung von der CIN-gmbh für ein dropdownmenü der Kategorienauswahl, die Wawi 99923 unter sql2005.)
- läuft das prinzipiell Jahre weiter, oder muss man etwas ändern (und dann lieber jetzt gleich, als dann ende 2018 nochmal?)
- oder ist ein update auf den Shop 4 nur eine Art verbesserung, ohne daß man wieder Tage vorm Rechner sitzt weil man alles mögliche anpassen muss?)

MfG

Henry
 

FMoche

Moderator
Mitarbeiter
15. Dezember 2014
737
83
Halle (Saale)
Bei einem 3.18er Shop ist die PHP-Version dein kleinstes Problem.
Das ganze läuft dann nämlich genau so lange gut, wie dir niemand etwas Böses will und dir durch eine der lange bekannten Sicherheitslücken deine DB löscht und/oder Kundendaten abzieht.
 

ram1

Sehr aktives Mitglied
22. Juli 2009
1.113
6
Also ich habe den Satz jetzt 5x gelesen und er klingt für mich noch immer so, als ob das grössere Sicherheitsproblem nun beim 3er Shop als solcher liegt?!

Unglücklich formuliert?
 

MX-TEC

Aktives Mitglied
14. Januar 2016
9
0
Ohhh.....besten dank für den Hinweis Ab welcher Version ist das behoben? was macht sinn, was ist evtl. blinder aktionismus. Jetzt alles highendneu zu machen heißt sicher teuer shop 4 erwerben oder?
 

MX-TEC

Aktives Mitglied
14. Januar 2016
9
0
(fast) alles klar, Danke. Eine Frage zur subscription, die war leider im April abgelaufen. Jetzt sah ich beim 3.20b5-downloadversuch den hinweis "Bitte beachten Sie, dass bei einer ungültigen Subscription und dem Update auf eine höhere Shop-Version der Abgleich zwischen Wawi und Shop nicht mehr funktionieren wird." Gibt es eine Möglichkeit dies wieder zu reanimieren? Ich fand im Shop keine Subscription für den shop3.
 

MX-TEC

Aktives Mitglied
14. Januar 2016
9
0
.....mir war doch so, als ob ich das verlängert hätte oder wollte oder irgendwie.....hab eben meinen emailverlauf durchgelesen. Beim Kauf des shop 3 wurde mit Subscriptionsverlängerung für 125Eur/Jahr geworben. Ich fragte im April 2016 2 tage vor Ablauf bei JTL an, da ich keinen Link für die 125Eur fand.(in 2015 kostete die subs.125eur) Mir wurde in diesem Jahr geschrieben, sie kostet 250eur. Fand ich nicht ganz fair....Das hin und her ging über den Termin hinaus und dann hab ich es gelassen - hatte auch den A....llerwertesten voll Arbeit....
 

MX-TEC

Aktives Mitglied
14. Januar 2016
9
0
Hallo,

@ ram1
jo, hatte ich gefunden. Problem wird die Verbindung zur Wawi sein. Dem Hinweis, wenn man den download starten will, nach, funktioniert die Verbindung dann nicht mehr bei fehlender Subscription).
Du verwendest auch den 3.18 mit 99923 - hast du irgendwelche Fehler ausmachen können? Ich lass sonst alles wie es ist, es funktioniert ja.
 

MX-TEC

Aktives Mitglied
14. Januar 2016
9
0
Oh, Überschneidung......die Verbindung zur Wawi funktioniert dann doch? entgegen dem angezeigten Hinweis? das wäre spitze