Offen Shop 3.19 mit PHP 5.5 nötig - Support für PHP 5.4 endet in 09.2015 - Es wird Zeit!

John

Sehr aktives Mitglied
3. März 2012
1.128
37
Hi,

vor lauter Vorfreude auf die Wawi 1.0 und Shop4 scheint mir das Thema PHP 5.5 nicht im Fokus zu stehen, dabei wird es langsam wirklich Zeit und es dürfte gefühlte 95% der Shop3 Anwender betreffen ;)

Der essentielle Security Support für PHP 5.4 endet am 14.09.2015 (siehe Zwölf Sicherheitslücken in PHP geschlossen, Support für Version 5.5 ausgelaufen | heise online )und sowie ich das aus den FAQs gelesen habe, läuft der standard 3.19 Shop nur mit PHP 5.4. Für Version 5.5 ist ein "alternatives Downloadpaket von JTL nötig"

Gibt es von JTL bereits eine einfache Anleitung/Download/whatever, um einen Shop 3.19b4 für PHP 5.5 flott zu machen?

John
 

david

Administrator
Mitarbeiter
16. Juli 2010
2.223
111
AW: Shop 3.19 mit PHP 5.5 nötig - Support für PHP 5.4 endet in 09.2015 - Es wird Zeit

Hey John,

das alternative Downloadpaket erhältst du von unserem Support. Es unterscheidet sich darin, dass es mit IonCubeEncoder Version 8 encoded wurde und damit PHP5.3, 5.4, 5.5 und 5.6 unterstützt (entsprechenden IonCube-Loader vorausgesetzt).
 

John

Sehr aktives Mitglied
3. März 2012
1.128
37
AW: Shop 3.19 mit PHP 5.5 nötig - Support für PHP 5.4 endet in 09.2015 - Es wird Zeit

OK, danke David, dann mache ich mal ein Ticket auf.

Wieso macht Ihr den Zugriff auf die Dateien so schwierig? Ist es nicht im Interesse von JTL, daß die Shops auf PHP Versionen laufen, die mit patches versorgt werden? Ich finde es befremdlich, etwas so wichtiges per Ticket abzuwickeln...
 

david

Administrator
Mitarbeiter
16. Juli 2010
2.223
111
AW: Shop 3.19 mit PHP 5.5 nötig - Support für PHP 5.4 endet in 09.2015 - Es wird Zeit

Wieso macht Ihr den Zugriff auf die Dateien so schwierig? Ist es nicht im Interesse von JTL, daß die Shops auf PHP Versionen laufen, die mit patches versorgt werden? Ich finde es befremdlich, etwas so wichtiges per Ticket abzuwickeln...
Das ist im Prinzip eine Notlösung, solange noch PHP5.2 Hostings mit JTL-Shop3 existieren, die bisher nicht aktualisiert werden konnten.
Ausserdem ist unsere Softwareverteilung via Kundencenter bisher nicht auf den Spezialfall verschiedener Builds je Softwareversion ausgelegt - wir möchten diesen Spezialfall auch gern wieder abschaffen.

Mit Shop4 erhöhen sich auch die Server-Anforderungen auf PHP5.4 (Minimum), da gibt es dann nur noch 1 Downloadpaket - ganz einfach :)
 

Fabrice

Aktives Mitglied
4. September 2012
55
1
AW: Shop 3.19 mit PHP 5.5 nötig - Support für PHP 5.4 endet in 09.2015 - Es wird Zeit

Oh! Es gibt ein alternatives Paket? Das hätte ich gern. Einfach ein Supportticket aufmachen?
 

John

Sehr aktives Mitglied
3. März 2012
1.128
37
AW: Shop 3.19 mit PHP 5.5 nötig - Support für PHP 5.4 endet in 09.2015 - Es wird Zeit

Ja, einfach ein Ticket aufmachen.

Das Paket ist jedoch ein Vollinstallationspaket, welches man nach dieser Anleitung zum Update nutzen kann:
JTL-Shop3-Update ? JTLWiki

Ich habe am Wochenende auf PHP 5.5 gewechselt. Mit dem Update lief es problemlos.
 

dermo

Aktives Mitglied
20. August 2013
318
0
Bochum
AW: Shop 3.19 mit PHP 5.5 nötig - Support für PHP 5.4 endet in 09.2015 - Es wird Zeit

und das gibts schon fast ein jahr :D
 

Fabrice

Aktives Mitglied
4. September 2012
55
1
AW: Shop 3.19 mit PHP 5.5 nötig - Support für PHP 5.4 endet in 09.2015 - Es wird Zeit

Bei meinen dies betreffenden Supporttickets an JTL wurde ich darauf leider nicht hingewiesen.. Ich wurde bisher nur auf die nächste Version vertröstet.