Gelöst Fehler beim "EazyShipping direkt aus dem Wareneingang" [WAWI-25321]

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

jendris

Sehr aktives Mitglied
1. April 2011
753
29
#1
Ich muß das Problem kurz detailliert darstellen damit es deutlich wird:

Wir buchen eine Lieferantenbestellung ein. Ein Artikel wurde mit Menge 10 geliefert.
Menge 10 eingegeben - Artikel gescannt und nun kann direkt verpackt werden, wenn ein offener Auftrag vorliegt.
Laut Wiki soll es so sein, dass ein Auftrag nur dann direkt aus dem WE verpackt werden kann, wenn dieser Auftrag nur eine Position hat.

Ich stelle nun fest, dass wenn ein Artikel zwar nur eine Position hat, aber 2 mal bestellt wurde, trotzdem auf "verpacken" geklickt werden kann. Das hat zur Folge, dass der Artikel nur einmal versendet wird, weil ja kein zweites Mal gescannt wird und diese interne "Sperre" ja auch sicher ihre Berechtigung hat. Warum wird dieser Auftrag nicht auf die Pickliste gesetzt?

Wir hatten tatsächlich in letzter Zeit mehrfach Anfragen wegen zu wenig verpackter Ware, und nun habe ich es hier direkt vor mir auf dem Schirm und bekomme die Reklamationen somit bestätigt.

Was läuft da falsch?
 

Stephan Handke

Moderator
Mitarbeiter
2. Juli 2009
2.887
116
Hürth
#2
Da läuft nichts falsch. Genau so ist es bisher gewollt.

EazyShipping funktioniert funktioniert mit Aufträgen mit genau einer Bestellposition - eine Bestellposition kann dabei auch eine Artikelanzahl größer 1 haben.

Ist die Anzahl größer 1 sollte natürlich die Menge bestätigt werden müssen. Das ist bei euch nicht der Fall?
 

jendris

Sehr aktives Mitglied
1. April 2011
753
29
#3
Wie meinst Du das, bestätigt?
Normalerweise, so kenn ich es aus der Pickliste, musst Du den Artikel 2 mal scannen, oder oben den Plusbutton bedienen, damit er verpackt werden kann.
Hier ist der grüne Versandbutton sofort aktiv.
 

jendris

Sehr aktives Mitglied
1. April 2011
753
29
#6
Mir ist das auch erst jetzt, nachdem ich auf die Stable 1.3 upgedatet habe, erstmalig aufgefallen.
Soeben habe ich wieder eine Kundenreklamation bekommen, dass ein Artikel von 2 bestellten fehlt.
Das das Ticket angelegt wurde ist gut, aber was heist denn "mittelfristig"? Gilt solch ein massiver Bug nicht als absolut dringlich?
Immerhin wird hier der Versand manipuliert, ohne das es kontrollierbar ist.

Erstaunlich, dass es noch keinem anderen Nutzer aufgefallen ist.
 

jendris

Sehr aktives Mitglied
1. April 2011
753
29
#8
Also mir ist das ein wenig unangenehm, dass jetzt zu schreiben, aber ich habe eben mal ganz gezielt diesen Fall provoziert.
Und nun wurde der Versand für einen Auftrag mit 2 identischen Artikel übersprungen und auf die Pickliste gesetzt, wo er dann mit 2 Scans verpackt werden konnte.

Also ich werde das nochmal versuchen nachzustellen. Ich hatte zuvor die Datenbank bereinigt und optimiert. Aber daran wird’s wohl nicht gelegen haben...?o_O
 

Stephan Handke

Moderator
Mitarbeiter
2. Juli 2009
2.887
116
Hürth
#9
Ich tippe darauf, dass du bei dem Fall die Artikelmenge "2" nicht im Vorfeld eingetragen hast? Dann steht für den Auftrag nicht genug Menge zur Verfügung und er wird übersprungen. Du musst erst die Menge eintragen, dann den Scan durchführen.
 

jendris

Sehr aktives Mitglied
1. April 2011
753
29
#10
nene, ich hatte direkt gewartet, bis ein Auftrag mit Menge 2 zum Verpacken dran ist. (Auftragsnummer aufsteigend sortieren, nach doppeltem Betrag schauen).
Kurz bevor der dann dran war, habe ich Menge 10 eingegeben. Dann kam noch ein einzelner, und danach wieder ein einzelner.
Die erwartete Auftragsnummer wurde dabei überspungen. Und tauchte dann auf der Pickliste auf.
Es war schon genug Bestand vorab zur Verfügung gestellt worden.

Also sogesehen alles korrekt. Oh man.o_O
 

jendris

Sehr aktives Mitglied
1. April 2011
753
29
#11
So, nun hat das Nachstellen doch mal geklappt.

upload_2018-3-16_11-6-37.png

Vorab wurde 5 Artikel in den Wareneingang gebucht. Dann wurde einer verpackt, danach kam dann dieser Auftrag.
Hier kann man auf Versenden klicken, und es wird sofort ein Etikett gedruckt. Es existiert keine Sicherung, dass es sich hier um 2 Artikel handelt.
 

jendris

Sehr aktives Mitglied
1. April 2011
753
29
#12
Es gibt noch ein weiteres Phänomen, wenn ein Artikel vorab mit max. Menge 10 eingebucht wird.
Das WMS hängt sich in regelmäßigen Abständen ca. 1 mal auf 5 Bestellungen auf, weil der Versandvorgang abgeschlossen werden muß.
Das ganze dauert dann ca. 1-2 Minuten in denen man nicht arbeiten kann.

Wird der Artikel einzeln eingescannt passiert das o.g. nicht.


upload_2018-3-16_11-36-41.png
 

Anhänge

Stephan Handke

Moderator
Mitarbeiter
2. Juli 2009
2.887
116
Hürth
#13
Fazit: Ist die Menge größer als 1, soll das direkte Verpacken nicht möglich sein.

Plane ich so ein. Vielen Dank für die Screenshots. Das zweite Problem wird sich durch den Fix und neue Stored Procedures in JTL- Wawi 1.4 von selbst lösen.
 

jendris

Sehr aktives Mitglied
1. April 2011
753
29
#14
Und was macht man in der Zwischenzeit? Die 1.4 wird ja nicht in den nächsten Tagen erscheinen.
Also so ist das Arbeiten mit dem WMS nicht gerade angenehm.

Am besten man scannt den Wareneingang nur noch einzeln ab, wäre das der richtige Weg?
Oder das direkte Verpacken unterbinden, und nur noch von der Pickliste versenden?

Ich guck mir auch das nochmal an.

Mit der 1.2 gabs diese Probleme alle nicht. o_O
 
Zuletzt bearbeitet:

jendris

Sehr aktives Mitglied
1. April 2011
753
29
#16
Mir wäre es in der 1.2 aufgefallen. Ich habe es dort ja aktiv genutzt. Aber mit jedem Update, und sei es noch so STABLE, kommen halt immer irgendwelche Seuchen durch die Hintertür.
 

Stephan Handke

Moderator
Mitarbeiter
2. Juli 2009
2.887
116
Hürth
#17
Ich habe es aktuell mit Version 1.4.2.0 getestet. Hier ist es nicht nachstellbar.

3 Artikel im Auftrag - im Wareneingang eine Menge von größer 3 eingebucht. Ich muss den Artikel im darauffolgenden Dialog zusätzlich noch 2x bestätigen.
 

jendris

Sehr aktives Mitglied
1. April 2011
753
29
#18
War das der einzige Auftrag?
Versuch doch mal einen Auftrag mit Menge 3 und noch 5 oder 6 weitere Aufträge mit Menge 1.
Vorab im Wareneingang z.B. Menge 20 eingeben.
Das ist die Situation bei mir, oder besser, war sie. Ich habe das direkte Versenden aus dem Wareneingang inzwischen abgeschaltet. Bringt nichts. Ist kaputt.
 

Stephan Handke

Moderator
Mitarbeiter
2. Juli 2009
2.887
116
Hürth
#19
Nochmal mit Version 1.4.2.0 getestet

6 Aufträge mit Mengen zwischen 1 und 5 - alles größer 1 muss extra gezählt / bestätigt werden. Alles mit Menge 1 funktioniert korrekt.

Sollte es bei euch anders sein, am besten ein Ticket über das Kundencenter erstellen, gerne auch mit einem Screencapture oder Handy ein Video machen, wo man sich das Problem ansehen kann.

Spätestens mit Version 1.4 ist das Problem aber gefixt, falls es tatsächlich ein Problem geben sollte.
 

jendris

Sehr aktives Mitglied
1. April 2011
753
29
#20
Tja, nützt mir natürlich gar nichts, wenn es mit der 1.4 funktioniert.
Was soll das bringen, wenn ich jetzt noch nen Video mache? Der Screenshot oben ist eindeutig.
Wenn ihr es in der 1.3 nicht nachstellen könnt, ändert es ja nichts daran, dass ich auf die 1.4 updaten muß, wenn ich "Easy Shipping aus dem Wareneingang"
nutzen möchte. Die 1.3 werdet ihr wohl kaum noch fixen um mir das nächste "Unstabled Update" auf 1.4 zu ersparen.

Also spare ich mir den Aufwand und lasse die Funktion deaktiviert. o_O