Fehler beim Rendering der Attribute bei SCX Abgleich

  • Wichtiger Hinweis Liebe Kunden, solltet Ihr den DATEV Rechnungsdatenservice 2.0 nutzen, dann müsst Ihr bis zum 30.06.2024 JTL-Wawi 1.9 installieren. Danach wird die Schnittstelle für ältere Versionen nicht mehr unterstützt.

Intronic

Aktives Mitglied
28. Februar 2012
34
4
Hallo,

wir haben ganz frisch SCX für Kaufland.de und Voelkner.de eingerichtet. Ein erster Upload von 15 Variationen (Kindartikeln) eines Artikels hat erfolgreich für beide Plattformen funktioniert. Nun haben wir in der gleichen Vorgehensweise Kindartikel eines anderen Artikel angelegt und übertragen, erhalten aber für jeden Artikel und für beide Marktplätze folgende Fehlermeldung:

Code: AttribueRendering
Nachricht: Fehler beim Rendering der Attribute

Im Log steht die Meldung:
Mindestens ein Fehler ist aufgetreten.: Der Wert darf nicht NULL sein.
Parametername: value

Erweiterte Meldung:
bei jtlDatabase.Templates.Template.RenderAndThrow(String cTemplate, IRenderData renderData)
bei jtlCore.Classes.Sync.SyncCoreService.RenderScxAttributes(String template, jtlArtikel artikel)
bei JTL.Wawi.Sync.Core.Domain.Scx.Calls.Offer.Service.ScxAttributeRenderService.Render(List`1 artikelList, ISalesChannelOffer salesChannelOfferEntity)

Ich bin nicht sicher, ob es hierbei wirklich um die Attribute unserer Artikel geht, oder evtl. um irgendwelche anwendungsinternen Attribute.
Die Attribute unserer Artikel sehen so aus - nicht ungewöhnliches denke ich.

Attribute.png

Ich stehe komplett auf dem Schlauch. Hat jemand einen Ratschlag hierzu? :(
Viele Dank vorab!

Viele Grüße
Christoph
 

Intronic

Aktives Mitglied
28. Februar 2012
34
4
Problem gefunden. Sollte jemand einmal das gleiche Problem haben: Diese Fehlermeldung wird geworfen, wenn man in SCX einen Attributwert mit einer fehlerhaften Dotliquid-Syntax angibt 😉

Viele Grüße
Christoph
 

Intronic

Aktives Mitglied
28. Februar 2012
34
4
Hallo Peter,

bitte entschuldige die späte Antwort. Welche Einstellung genau meinst du, bzw. worin besteht Dein Problem?

Viele Grüße
Christoph
 

PeterKaepernick

Neues Mitglied
21. März 2024
8
1
Hallo Christoph,

wenn ich im Menüpunkt Platteformen/eBay/Designvorlagen bin und eine beliebige, auch originale Designvorlage öffne, dann bekomme ich im Fußbereich immer eine Fehlermeldung.

Liquid error: Der Wert darf nicht NULL sein. Parametername:key.

Ich weiß nicht, wo ich diesen Parameter finde und ändern (was steht da drin?) kann. Offensichtlich habe ich etwas bei den globalen Textbausteinen "zerstört".
Kann mann diese Globalen Textbausteine wieder auf die Ausgangslage stellen?

Ich verwende die JTL-Wawi-Version 1.8.12.2 mit der Revision 1.8.12.2_0314-1513_7f48a5214de

Viele Grüße
Peter
 

Anhänge

  • Fehlernmeldung.jpg
    Fehlernmeldung.jpg
    268,2 KB · Aufrufe: 2
Ähnliche Themen
Titel Forum Antworten Datum
Neu Fehler beim Artikelimport Sondertyp JTL-Ameise - Fehler und Bugs 3
[WAWI-API] Fehler beim Updaten eines Item-Customfield JTL-Wawi 1.8 2
Neu Fehler beim Import (Ameise) von Brutto-VK JTL-Ameise - Ideen, Lob und Kritik 9
Neu Fehler beim Hochladen der Datei JTL-Shop - Fehler und Bugs 0
Fehler beim erstellen von Aufträgen JTL-Wawi App 2
Fehler beim importieren eines Backups JTL-Wawi 1.8 2
Neu Fehler beim Bearbeiten von PLZ & Ort im Kundenkonto (Update 5.3.0) JTL-Shop - Fehler und Bugs 6
Neu Fehler beim Zahlungsabgleich - Zahlungsmodul - Wawi 1.5.55.6 Gelöste Themen in diesem Bereich 14
Neu Fehler beim erstellen von Aufträgen. Digitale Unterschrift im Auftrag. JTL-Wawi - Fehler und Bugs 0
In Diskussion Fehler beim Versenden von E-Mails: "Could not convert socket to TLS" JTL-POS - Fehler und Bugs 2
Fehler beim Datenbank - JTL WAWI Connector WooCommerce-Connector 1
Neu SQL Fehler - Woher stammt diese Abfrage JTL-Shop - Fehler und Bugs 0
Neu Benachrichtigung anfordern - Fehler: Der eingegebene Bestätigungscode ist nicht bekannt JTL-Shop - Fehler und Bugs 0
Neu ebay Fehler 240 - nicht öffentliche Bieter-/Käuferliste eBay-Anbindung - Fehler und Bugs 5
Neu Der Remoteserver hat einen Fehler zurückgegeben: (500) Interner Serverfehler wir bitten Hilfe Gambio-Connector 6
JTL WAWI 1.8.12.2 Shopware 6 / Connector Abgleich Fehler Gelöste Themen in diesem Bereich 3
Neu PLZ Prüfung Fehler - Shop 5.3.1 JTL-Shop - Fehler und Bugs 2
Neu Fehler JTL\\Catalog\\Category\\MenuItem::getImageWidth(): Return value must be of type int, null returned JTL-Shop - Fehler und Bugs 3
Neu Sitemap ist HTML - Sitemap kann gelesen werden, enthält aber Fehler / Google Web Master Tool Allgemeine Fragen zu JTL-Shop 6
Barcodescanner Fehler mit ein "U" am Ende JTL-Wawi 1.8 0
Neu Fehler bei Sprach- und Währungsumstellung Allgemeine Fragen zu JTL-Shop 0
Nach Aufruf von Stored Procedure 'Kunde.spKundeUpdate' schwere Fehler in JTL (z.B. Kundenliste, Workflow-Editor) JTL-Wawi 1.8 2
Neu Fehler: Footer/Boxen - Kategoriefilter löscht Boxensortierung Allgemeine Fragen zu JTL-Shop 0
Neu Stripe - Fehler icomoon.ttf Plugins für JTL-Shop 0
Neu Gravierender Fehler in der Shop Software Betrieb / Pflege von JTL-Shop 3
Neu Fehler bei Bearbeitung von Designvorlagen eBay-Designvorlagen - Fehler und Bugs 0
Neu Smarty-Fehler im Logfile JTL-Shop - Fehler und Bugs 1
Neu Fehler: Sonderpreis falsch formatiert, wird nicht importiert; obwohl importiert genau wie exportiert User helfen Usern - Fragen zu JTL-Wawi 0
Neu Microsoft Remote Desktop Fehler Cloutapp Desktop und Lauscher JTL-Wawi - Fehler und Bugs 3
Neu OPC - Video Portlet Fehler (v.5.3.0) JTL-Shop - Fehler und Bugs 2
Neu Logfile: SQL Fehler, aber warum? JTL-Shop - Fehler und Bugs 2
Neu Google Listings & Ads image Fehler WooCommerce-Connector 2
Installations Fehler (SQLSTATE[HY000] [2002] No such file or directory ) Einrichtung JTL-Shop5 1
Neu JTL-Shop 5.3.0 RC3 Fehler nach Update Portlet Banner, fehlendes Produkt JTL-Shop - Fehler und Bugs 0
In Diskussion Gesamt Ban Rabatt zuweisen - Fehler? JTL-POS - Fehler und Bugs 4
Kein Fehler von 1.6.39 zu 1.8.12 JTL-Wawi 1.8 4
Umzug Datenbank Fehler aufgrund unterschiedlicher Versionen Einrichtung JTL-Shop5 1
Neu SQL-Fehler bei Volltextsuche und Sonderzeichen JTL-Shop - Fehler und Bugs 0
Neu E-Mail mit Strato - Fehler normal? Betrieb / Pflege von JTL-Shop 6
Neu jtl wawi Versanddatenexport Originalmeldung: In der Sendung trat mindestens ein harter Fehler auf. Code: 1101 Schnittstellen Import / Export 2
Neu 21916639, 21916585, 21916664 Fehler Gelöste Themen in diesem Bereich 4
Neu Inaktive Artikel werden mit 404 Fehler bei Google Search angezeigt Allgemeine Fragen zu JTL-Shop 2
Sprung von 1.5.55.6 auf 1.9.4.1 - Wawi sehr langsam beim öffnen von Angeboten/Aufträgen JTL-Wawi 1.9 9
Fenster beim Druck aus der Wawi JTL-Wawi 1.8 1
Neu Probleme beim Installieren und Updaten von Plugins Plugins für JTL-Shop 0
Fehlermeldung beim Öffnen der Firmeneinstellung JTL-Wawi 1.8 2
Neu Probleme beim Abfrage kopieren von SQL Management Studio User helfen Usern - Fragen zu JTL-Wawi 1
Konsignationslager beim / für Kunden einrichten, aber wie? :) JTL-Wawi 1.8 2
Neu beim Umstieg von unicorn auf SCX Bilder aktivieren Otto.de - Anbindung (SCX) 1
Neu Überverkäufe aktiviert doch beim Artikel steht Ausverkauft JTL-Shop - Fehler und Bugs 1

Ähnliche Themen