Neu Fehler beim Update des Shops - DB Migration

Aragon

Neues Mitglied
31. Juli 2024
1
0
Hi,
ich hatte jetzt schon öfter das Problem, das beim Updaten des Shops nach Einspielen der Update Dateien folgende Fehlermeldung entstanden ist:
Fehler bei Update: "another entry already present in teinstellungen and overwrite is disabled" in: */update/migrations/20220503122842_create_setting_for_top_selling.php

Gibt es hier als einzige Möglichkeit nur das manuelle Entfernen aus der Datenbank per SQL?

delete from database.teinstellungen where cName = 'global_bestseller_tage';
delete from database.teinstellungenconf where cName = 'Maximale Anzahl Tage für Bestseller';

In der Fehlermeldung steht ja "overwrite is disabled" - kann man das denn aktivieren und wenn ja, wie?
In den verschiedenen Dokus konnte ich leider hierzu nichts finden:
https://jtl-devguide.readthedocs.io/projects/jtl-shop/de/latest/shop_administration/shop_cli.html
Gibt es hier beim Befehl "Migrate" vielleicht einen versteckten Parameter? -o für overwrite oder so?

Oder irgendeine Konstante, die man davor in der Shop-Config hinterlegen kann?

Würde mich freuen, wenn hier jemand weiß, ob und wie das Ganze zu lösen ist. 😀

mfg
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.651
2.702
Berlin
Firma
css-umsetzung
Du kannst wenn es Fehler gibt, diese nur einzeln lösen, indem du eben schaust was das eigentliche Problem ist.

Da gibt es leider keine anderen Möglichkeiten.
 

Ähnliche Themen