In Bearbeitung Fehler beim Abgleich Zahlung senden Shopware JTL

tunershop

Aktives Mitglied
13. Oktober 2016
60
2
Hallo,
in einigen Threads habe ich den Fehler gefunden, nur passt die Lösung bei mir nicht.
Aktuell habe ich den Abgleich komplett neu gemacht. All Artikel, alle Kunden, alle Bestellungen von Shopware nach JTL. Alle Bestellungen als "Auftrag ohne Versand abschließen" erledigt. Dann erster Abgleich JTL nach Shopware. Er will Zahlungen ablgiehcne un bekommen folgenden Fehler:

Exception: Entity of type 'Shopware\Models\Customer\Customer' for IDs id(3351) was not found
Entity of type 'Shopware\Models\Customer\Customer' for IDs id(3351) was not found
Versand/Zahlung-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
bei jtlCore.ControllerClasses. Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskCustomerOrderChange.HjuB9e4qeQy(List`1 )
bei jtlTools.Linq.EnumerableExtensions.ExecuteInSetsOf[TInput](IEnumerable`1 source, Action`1 action, Int32 max)
bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskCustomerOrderChange.Run()
bei JTL.Connector.Business.SyncRunner.Run()

Log im Anhang


So wie ich das sehe, findet er einen Kunden nicht. Wem gehört die ID? JTL oder Shopware? In Shopware habe ich solch eine Kunden ID nicht. Trotz Rücksetzung ders Connectors und erneutem Ableich, will JTL wieder die "alten" Sachen abgleichen
 

Anhänge

Immanuel

Moderator
Mitarbeiter
24. August 2016
627
110
Hallo @tunershop,

ich habe mir den Log gerade mal angesehen. Der Fehler tritt wie du schon richtig erkannt hast, immer bei dem Senden des Bestell-Status zum Shop auf. Es sollte wahrscheinlich eine Bestellung geupdatet werden, die mit einem Kunden verknüpft ist, welcher nicht mehr existiert (userID = .3351). Du könntest versuchen den Bezug zum User in der entsprechenden Bestellung aufzulösen. Einfach in der Tabelle s_order die userID auf null setzen wo userID = 3351 ist. Das ist natürlich alles ohne Gewähr und auf eigene Gefahr.
 

tunershop

Aktives Mitglied
13. Oktober 2016
60
2
Hab ich so auch rausgelesen.
leider ist keine User ID in den MySQL Bestellung zu finden.
Daher Trick17


Neuen Mandanten
Alle Artikel importieren
BACKUP
Alle Bestellungen importieren
Gerade erstelltes BACKUP einspielen
Somit sind alle alten Bestellungen im Connector als "erledigt" markiert und es werden nur ab dem Zeitpunkt neuere eingelesen
 

tunershop

Aktives Mitglied
13. Oktober 2016
60
2
Trick 17 funktioniert nicht.

Daher einen mal ausgenullt. Schein zu laufen.

Leider wird ein abgeschlossener Auftrag im Shopstatus nicht verändert. Es bleib "In Beartbeitung" statt "versnedet"
 
Zuletzt bearbeitet:

tunershop

Aktives Mitglied
13. Oktober 2016
60
2
Sollen wir die ausnullen?
Es wurde kein Auftrag zur einer Zahlung gefunden ( Shop-ID: 4098).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 4096).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 4097).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 4099).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1133).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 2947).

Es wird nun seit einer Woche kein Versandstatus übergeben. Müssen alles manuell machen
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
627
110
Hallo @tunershop,

was meinst du mit ausnullen? Es wurden scheinbar Zahlungen in die Wawi importiert, zu denen es kein Auftrag in der Wawi gibt.

Es wird nun seit einer Woche kein Versandstatus übergeben. Müssen alles manuell machen
Wird der Call zur Änderung des Versandstatus (DeliveryNote push) von der Wawi nicht angestoßen oder wird der Call abgesetzt aber die Änderung kommt nicht im Shop an?

Bitte sende mir per PM die Connector Logs nach einem fehlgeschlagenen Versand-Status Abgleich zu. Wie du an diese kommst, steht hier beschrieben (unter 2. Log-Dateien des Connectors).
 

tunershop

Aktives Mitglied
13. Oktober 2016
60
2

Immanuel

Moderator
Mitarbeiter
24. August 2016
627
110
Es müsste erstmal herausgefunden werden ob das Senden des Verstand-Status zum Shop durch die Wawi angestoßen wird oder nicht. Dann kann man weiter schauen woran es liegt.
 

pgolub

Aktives Mitglied
22. Juli 2016
36
0
Ich habe selbiges Problem. Kann ich irgendwie der Wawi sagen dass er den noch nicht gesendeten Status nicht abgleichen soll ?

Die Fehlermeldungen lautet Shopseitig
Code:
[2019-05-29 23:09:55] rpc.DEBUG: Params: [{"customerOrderId":["",101131],"paymentStatus":"unpaid","orderStatus":"cancelled"},{"customerOrderId":["",101205],"paymentStatus":"unpaid","orderStatus":"cancelled"},{"customerOrderId":["",101216],"paymentStatus":"completed","orderStatus":"cancelled"},{"customerOrderId":["",101217],"paymentStatus":"unpaid","orderStatus":"cancelled"},{"customerOrderId":["",101239],"paymentStatus":"unpaid","orderStatus":"cancelled"},{"customerOrderId":["",101259],"paymentStatus":"completed","orderStatus":"cancelled"},{"customerOrderId":["",101264],"paymentStatus":"unpaid","orderStatus":"cancelled"},{"customerOrderId":["",101275],"paymentStatus":"unpaid","orderStatus":"cancelled"},{"customerOrderId":["",101277],"paymentStatus":"unpaid","orderStatus":"cancelled"},{"customerOrderId":["",101305],"paymentStatus":"completed","orderStatus":"cancelled"}] [] []
 

Anhänge

tunershop

Aktives Mitglied
13. Oktober 2016
60
2
Ich habe alles was so nicht zugeordnet werden sollte in der Datenbank auf den UserID 0 gesetzt. Dies ID0 war mein eigener Account. Oder Du machst ein Testaccount auf, suchst die User ID und setzt diese dann an die Fehlermeldungen
 

tunershop

Aktives Mitglied
13. Oktober 2016
60
2
Seit 2 Wochen wird der Bestellstatus wieder nicht geändert, weil die Aufträge nicht gefunden werden

Es wurde kein Auftrag zur einer Zahlung gefunden ( Shop-ID: 724).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 751).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 761).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 764).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 768).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 790).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 802).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 804).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 809).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 820).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 824).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 835).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 837).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 841).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 861).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 893).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 895).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 903).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 930).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 935).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 944).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 948).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 962).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 983).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 993).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1003).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1004).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1009).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1011).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1031).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1053).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1054).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1066).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1067).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1074).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1081).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1084).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1093).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1098).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1099).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1100).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1101).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1102).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1103).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1104).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1106).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1113).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1117).
Es wurde kein Auftrag zur einer Zahlung gefunden (Shop-ID: 1119).

Die Id's konnte ich bei den wenigsten zuordnen und sind auch Bestellungen im Shop selbst. User ID mal geändert, bringt aber nichts. Im Shop ist der Auftrag als bezahlt markiert und komplett abgeschlossen. Keine Ahnung, warum JTL dahin etwas aktualisieren will
 
Zuletzt bearbeitet:

Immanuel

Moderator
Mitarbeiter
24. August 2016
627
110
Hallo @tunershop,

diese Meldung erscheint warscheinlich, wenn Zahlungen von Aufträgen (Bestellungen) aus dem Shop in die Wawi importiert werden, dazu aber kein Auftrag in der Wawi existiert. Das kann bspw. passieren, wenn als bezahlt markierte Bestellungen im Shop gelöscht wurden, bevor sie in die Wawi importiert werden konnten. Das hat wahrscheinlich nichts mit dem Setzen des Bezahl-Status durch die Wawi im Shop zu tun.
 

tunershop

Aktives Mitglied
13. Oktober 2016
60
2
Das hab ich mir gedacht. Löst nur das Problem nicht. Wie kann ich diese Zahlungen löschen. Damit andere Dinge im Shop wieder abgeglichen werden