Gelöst Bilder von Variationskombinationen werden nicht angezeigt (im Master vom 07.07.)

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Dull

Aktives Mitglied
14. Juli 2014
96
4
Passau
Hi,

haben gerade gesehen dass im aktuellen Shop5 Master (vom 07.07.) die Bilder der Childartikel von Variationskombinationen nicht angezeigt werden. Die Variation kann jetzt zwar ausgewählt werden und lädt, aber dann wird ein Platzhalterbild angezeigt. Das Bild vom Vaterartikel wird auf dessen Seite korrekt angezeigt.
 

Anhänge

Rainer S

Moderator
Mitarbeiter
8. August 2018
612
90
Wenn hier nur das Platzhalterbild angezeigt wird ist das eigentlich ein Zeichen dafür das hier keine Bilder übertragen wurden vom Kindartikel. Bilder aus der Wawi für die kindartikel nochmal an den shop senden.
 

Dull

Aktives Mitglied
14. Juli 2014
96
4
Passau
Wenn hier nur das Platzhalterbild angezeigt wird ist das eigentlich ein Zeichen dafür das hier keine Bilder übertragen wurden vom Kindartikel. Bilder aus der Wawi für die kindartikel nochmal an den shop senden.
Das hatte ich schon versucht, hat aber leider nichts geändert ^^
Aber ich versuch das jetzt nocheinmal, nicht dass sich versehentlich irgendwas überschnitten hat...

@jürgenk Ich arbeite momentan im aktuellsten Master-Core von gestern Abend bzw. heute Morgen (https://gitlab.com/jtl-software/jtl-shop/core/-/commits/master/) ;)



EDIT: Auch beim zweiten Komplettabgleich tauchen die Bilder leider immer noch nicht auf :/
 
Zuletzt bearbeitet:

M.Stickel

Moderator
Mitarbeiter
9. Februar 2016
283
35
Hi, schau auch mal bitte ob der Ordner "media/image/*" beschreibbar ist. Du kannst auch im Backend unter Administration->Fehlerbehebung->Bilder nochmal schauen ob die Bilder richtig erzeugt wurden.
 
Zuletzt bearbeitet:

JulianG

Administrator
Mitarbeiter
14. November 2013
1.046
231
Was mich hier wundert ist, dass du sagst es sind nur Kindartikel betroffen. Kindartikel/Variationskombinationen sind ganz normale Artikel. In den meisten Punkten, auch bei Bildern, gibt es keinen Unterschied. Also vielleicht gehen doch alle Artikelbilder nicht, oder du hast zufällig nur Varkombis erwischt und es gehen auch andere Artikelbilder nicht, oder es sind normale Variationsartikel (keine Varkombis), oder es ist noch was ganz anderes...

Wird hier nginx eingesetzt?
Ändert sich was am Fehlerbild, wenn du unter Administration->Fehlerbehebung->Bilder die Artikelbilder generierst?
Bei Schreibrechten außerdem wichtig das Verzeichnis /media/image und alle Unterordner.
Welche Wawi-Version ist im Einsatz?
 

Dull

Aktives Mitglied
14. Juli 2014
96
4
Passau
Sowohl die Schreibrechte, als auch Administration->Fehlerbehebung->Bilder die Artikelbilder generieren haben leider nichts geändert.

Es betrifft tatsächlich nur die Childartikel, die Bilder von den Vaterartikeln sind vorhanden. Ich denke das hängt damit zusammen, dass in einer älteren Masterversion die Varkombis bei Auswahl im Shop nicht geladen wurden (nur mal meine Vermutung). Könnte es evtl. helfen den kompletten Bilderordner einfach zu löschen und dann den Komplettabgleich durchzuführen?

Wir verwenden die Wawi-Version 1.5.18.2, nginx sagt mir jetzt nichts ^^
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.046
231
Hattest du schon mal vor nem Komplettabgleich im Shop-Backend die Artikeldaten zurückgesetzt? Beim Abgleich der Bilder wird geprüft, ob die Originalbilder (im media/image/storage Verzeichnis) schon existieren und wenn ja, werden sie für weniger Overhead auch nicht gesendet. Wenn da jetzt zuvor irgendwas schiefgegangen ist und bei der Prüfung kommt raus sie wären da, sind sie aber gar nicht... dann nutzt der Komplettabgleich nichts.
Also falls noch nicht passiert bitte einmal im Shop-Backend bei System->Zurücksetzen den ersten Punkt " Artikel, Kategorien und Merkmale löschen (Komplettabgleich mit JTL-Wawi füllt diese Daten wieder auf) " durchführen und dann via Komplettabgleich (alles alles) den Shop nochmal neu befüllen.
 

Dull

Aktives Mitglied
14. Juli 2014
96
4
Passau
Hattest du schon mal vor nem Komplettabgleich im Shop-Backend die Artikeldaten zurückgesetzt? Beim Abgleich der Bilder wird geprüft, ob die Originalbilder (im media/image/storage Verzeichnis) schon existieren und wenn ja, werden sie für weniger Overhead auch nicht gesendet. Wenn da jetzt zuvor irgendwas schiefgegangen ist und bei der Prüfung kommt raus sie wären da, sind sie aber gar nicht... dann nutzt der Komplettabgleich nichts.
Also falls noch nicht passiert bitte einmal im Shop-Backend bei System->Zurücksetzen den ersten Punkt " Artikel, Kategorien und Merkmale löschen (Komplettabgleich mit JTL-Wawi füllt diese Daten wieder auf) " durchführen und dann via Komplettabgleich (alles alles) den Shop nochmal neu befüllen.
Habe das über Nacht einmal versucht, leider ohne Erfolg :(
Werde den Master heute einfach mal auf den aktuellsten Stand bringen, evtl. hilft das ja was ^^
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.046
231
Wenn auch das nicht klappt starte gerne mal eine private Unterhaltung mit mir, dann würd ich mir das gerne mal auf dem System selber anschauen.
 

Dull

Aktives Mitglied
14. Juli 2014
96
4
Passau
Lösung:
Also wie sich herausgestellt hat lag das Problem nicht beim Shop sondern in der Wawi. Dort war der Haken für den betroffenen Shop nicht gesetzt bzw. wurde nicht von "Alle Ausgabewege" übernommen. Das allerdings eben nur für die Child Artikel.

Der Fehler scheint beim Anbindungsprozess zum Shop zu liegen. Da haben wir lediglich die Root-Kategorie eingestellt, dann geöffnet und den Haken für den Shop inkl. "Alle Unterkategorien/Arikel" gesetzt... Wäre natürlich besser wenn die Wawi die Childs dann auch beachtet ^^
 
  • Gefällt mir
Reaktionen: JulianG

FFInke

Mitglied
18. Oktober 2019
16
0
Lösung:
Also wie sich herausgestellt hat lag das Problem nicht beim Shop sondern in der Wawi. Dort war der Haken für den betroffenen Shop nicht gesetzt bzw. wurde nicht von "Alle Ausgabewege" übernommen. Das allerdings eben nur für die Child Artikel.

Der Fehler scheint beim Anbindungsprozess zum Shop zu liegen. Da haben wir lediglich die Root-Kategorie eingestellt, dann geöffnet und den Haken für den Shop inkl. "Alle Unterkategorien/Arikel" gesetzt... Wäre natürlich besser wenn die Wawi die Childs dann auch beachtet ^^
Hi,
bei mir ist momentan ein ähnliches Problem. Neue Artikel die wir hochladen sind komplett vollständig. Bei allen alten Artikeln erscheint auch die graue Kamera. Wo hast du den Haken in den Einstellungen gesetzt ? Vielleicht Hilft mir das ja auch weiter.

VG
 

FFInke

Mitglied
18. Oktober 2019
16
0
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Bilder von Variations-Werten in eBay Designvorlage ausgeben eBay-Designvorlagen - Ideen, Lob und Kritik 2
Neu Bilder von Variationen / Var. Kombis in Shop und Amazon. Wie richtig einstellen? User helfen Usern - Fragen zu JTL-Wawi 16
Neu Bilder werden von Shopware gelöscht! Shopware-Connector 4
Neu Bilder mit geringer Auflösung finden Betrieb / Pflege von JTL-Shop 2
Neu JTL Shop 5 - Bildformat Square - Nur quadratische Bilder möglich?! JTL-Shop - BETA - Feedback und Bugmeldungen 8
Neu Bilder steuern die zu google exportiert werrden Allgemeine Fragen zu JTL-Shop 0
Gelöst Kein Export der Artikel ohne Bilder möglich JTL-Ameise - Fehler und Bugs 2
Neu Globale Bilder (z.B. Testurteile/Siegel) bei ausgewählten Artikeln hinterlegen User helfen Usern - Fragen zu JTL-Wawi 2
Neu Neue Bilder werden seit 1.5.31.0 nicht mehr (immer) gedruckt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
Neu Bilder kommen nicht in meinen Woocommerce Shop rein WooCommerce-Connector 1
Neu keine Bilder in JTL-POS Allgemeine Fragen zu JTL-POS 0
Neu Bilder werden nicht immer an Shop übertragen WooCommerce-Connector 0
Neu Bilder in Plugin-Template importieren Plugins für JTL-Shop 1
Neu Bilder importieren CSV Einrichtung / Updates von JTL-POS 3
In Bearbeitung ebay-Bilder Massenänderung bei für mehrere Plattformen User helfen Usern - Fragen zu JTL-Wawi 6
In Bearbeitung Alle Bilder für alle Plattformen aktivieren User helfen Usern - Fragen zu JTL-Wawi 16
In Bearbeitung Bilder bei Variationen? User helfen Usern - Fragen zu JTL-Wawi 9
Neu Bilder werden nicht mehr an den Online Shop übertragen (Statustext Bilder Online-Shop Übertragung ausstehend) WooCommerce-Connector 1
In Bearbeitung Bilder: Verknüpfung zu onlineshop entfernen und durch Ebaybilder ersetzen User helfen Usern - Fragen zu JTL-Wawi 6
Neu Bilder in falscher Reihenfolge User helfen Usern - Fragen zu JTL-Wawi 6
Verwiesen an Support [1.5.31.0] Kann keine Bilder mehr hinzufuegen. JTL-Wawi - Fehler und Bugs 1
In Bearbeitung Bilder nach Änderung der Beschreibung weg. User helfen Usern - Fragen zu JTL-Wawi 4
In Bearbeitung Import Ameise - Artikelbilder je Plattform - Einzelne Bilder löschen User helfen Usern - Fragen zu JTL-Wawi 3
Neu Bilder werden nicht mehr aktualisiert Shopware-Connector 7
Neu Artikel Bilder werden beim Anklicken nicht vergrößert, Fehlermeldung erscheint, Update 1.5.19.0 Allgemeine Fragen zu JTL-Shop 6
Neu Worker Abgleich für "Bilder/Beschreibung" User helfen Usern - Fragen zu JTL-Wawi 1
Neu Bilder in Variationen Shop und ebay User helfen Usern - Fragen zu JTL-Wawi 9
Neu Alle Bilder aller Väter an alle Kinder vererben JTL-Ameise - Fehler und Bugs 19
Neu Bilder Upload Shopware-Connector 1
Gelöst Bilder Rahmen proportional füllen in List und Label Gelöste Themen in diesem Bereich 1
In Diskussion Artikelabgleich - Bilder werden nicht ersetzt, sondern zusätzlich hochgeladen WooCommerce-Connector 2
Gelöst Bilder werden bei Datenabgleich nicht übertragen Gelöste Themen in diesem Bereich 4
Gelöst Bilder zu anderen Auktionen eBay-Anbindung - Fehler und Bugs 2
Gelöst Keine Bilder unter "Mehr dieser Warengruppe" eBay-Designvorlagen - Fehler und Bugs 4
Neu Shopware Gratisartikel / Funktionsartikel von JTL ausschließen? Shopware-Connector 0
Neu Keine Verbindung von der Wawi zum Shop 5 JTL-Shop - Fehler und Bugs 3
Neu Export von Rechnungspositionen in csv-Datei Schnittstellen Import / Export 0
Neu Artikelmport von CSV-Datei mit Kategorien/Subkategorien in bestimmte Unterkategorie in der Wawi JTL-Ameise - Ideen, Lob und Kritik 1
Neu Amazon VCS kein Upload von Rechnungen möglich?! Amazon-Anbindung - Fehler und Bugs 3
Neu Shop 5 Umstellung von Subdomain auf Hauptdomain Allgemeine Fragen zu JTL-Shop 10
Neu Datei im Netzwerk verschieben, mit Angabe von User/PW User helfen Usern 0
Neu JTL-Packtisch: Druck von Pickliste: alle Artikel auf 1 Seite User helfen Usern - Fragen zu JTL-Wawi 6
Neu Bug: Eingabe von Preismodifikatoren JTL-Ameise - Fehler und Bugs 3
Gelöst NiceLabel Produktetiketten von JTL WMS aus drucken Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 5
Neu Workflow für "Kunde von Firma" Arbeitsabläufe in JTL-Wawi 3
Neu Umstieg von Afterbuy auf JTL Fragen an die Community User helfen Usern - Fragen zu JTL-Wawi 0
Neu Server-Error beim Export von Shopping-Feeds (Google, Idealo etc.) JTL-Shop - Fehler und Bugs 0
Neu Inkonsistentes Verhalten beim Löschen von Artikeln JTL-Wawi - Fehler und Bugs 1
Neu Upload von Rechnungen/Rechnungskorrekturen für Amazon Arbeitsabläufe in JTL-Wawi 0
Neu Vorschlag: Geändert am und von JTL-Wawi - Ideen, Lob und Kritik 5
Ähnliche Themen