Gelöst Artikel werden aus der Wawi nicht in der POS aktualisiert.

Robert B.

Neues Mitglied
20. Januar 2021
8
0
Artikel, die ich in der Wawi verändere werden in der POS nicht aktualisiert.
Ich kann den Artikel aus dere POS entfernen (quasi offline nehmen) aber nicht wieder in die POS einspielen.
In den Artikelstammdaten unter "Onlineshops/ JTL-POS" wird dauerhaft "wird aktualisiert" angezeigt.

Der Worker läuft.
Die POS und die Wawi sowie der Worker wurden mehrfach neu gestartet.

Was ist die Lösung?
 

ekpegleg

Gut bekanntes Mitglied
20. April 2016
104
6
Berlin
Das Problem sollte eigentlich gefixt sein.
IST ES ABER NICHT
Bei uns stehen auch eine ganze Reihe von Artikeln auf "wird aktualisiert"
Ich kann nicht tausende Artikel ständig DEAKTIVIEREN um sie dann wieder zu AKTIVEN
jtlwawi 1.5.38.1, jtlpos 1.0.3.5
 

lweber

Lars Weber
Mitarbeiter
13. November 2013
497
109
Hallo @Robert B. @ekpegleg

hier einmal schauen ob Artikel in mehreren Kategorien für die POS enthalten sind oder es sich im Stücklisten handelt und die Komponenten nicht für die Kasse aktiv sind oder die Kategorie in der sich die Komponenten befinden nicht aktiv ist. Ansonsten dazu bitte ein Ticket im Kundencenter erstellen, dann müssten wir uns das genauer anschauen.

Viele GRüße

Lars Weber
 

ekpegleg

Gut bekanntes Mitglied
20. April 2016
104
6
Berlin
Danke Lars.
Ich habe in der Hauptkategorie die Kasse einmal deaktiviert ohne Unterordner und dann wieder aktiviert. Nun hat er alle Artikel aktualisiert.

Gruss Enrico
 

lweber

Lars Weber
Mitarbeiter
13. November 2013
497
109
Hallo @ekpegleg ,

sobald du eine Kategorie für die Kasse deaktivierst, wird automatisch alles was darunter ist deaktiviert, du hast keine Einstellmöglichkeit, dass auf nicht alle zu beziehen. Es ist Grundsätzlich aber sinnvoll in deinem Fall mal alle zu deaktivieren und wieder zu aktivieren.

Viele Grüße
 

b-tool.ch

Aktives Mitglied
14. Juni 2018
29
4
Hallo

Wir haben ähnliche Probleme, die noch seltsamer sind:
Momentan machen wir Versuche mit einer Kategorie mit acht Artikeln ohne Unterkategorie.
Neben der POS Kasse haben wir einen Onlineshop.
Die Kategorie und 7 Artikel sind im Onlineshop aktiv.

-Kategorie wird für POS aktiviert, inkl. alle Artikel (keine Unterkategorien vorhanden):
Sieht erstmal gut aus: Alle Artikel haben bei POS ein Häkchen und den Vermerk "wird aktualisiert".
Es passiert aber (auch nach langer Zeit) nichts.

-Die Kategorie wird für POS wieder deaktiviert (alle Unterkategorien/Artikel löschen - keine Auswahlmöglichkeit):
Der Hinweis, dass auch alle Unterkategorien/Artikel gelöscht werden erscheint und wird mit "Ja" bestätigt.
Die Artikel haben aber bei POS immer noch ein Häkchen und den Vermerk "wird aktualisiert".
AUCH BEIM ONLINESHOP HABEN DIE ARTIKEL NUN DEN VERMERK "wird aktualisiert" (sie werden beim Onlineshop-Abgleich offenbar erneut an den Shop übertragen und haben anschließend den Vermerk "aktuell").
Werden die Artikel für POS deaktiviert, haben sie den Vermerk "wird gelöscht" (beim Onlineshop immer noch "aktuell").

Der Vermerk "aktuell" wird bei POS nie mehr angezeigt - je nach Status ist es "wird aktualisiert" oder "wird gelöscht".

Außerdem macht der Worker alle 60 Sekunden einen Amazon- und einen eBay-Abgleich (obwohl wir Amazon und eBay nie eingerichtet oder benutzt haben)!
Sonst macht der Worker nichts.

Als Kasse benutzen wir ein sunmi T2s mit JTL POS 1.0.4.14
JTL Wawi läuft in der Version 1.5.38.1

Hat jemand Tipps, wie wir das hinkriegen? Ansonsten läuft unsere Wawi mit über 170'000 Artikeln stabil.
Grüße aus der Schweiz von Daniel
 

ofenheizer

Sehr aktives Mitglied
26. Oktober 2012
305
63
Asl erstes würde ich mal die Wawi auf den aktuellsten Stand bringen, da hat sich doch einiges getan in Verbindung mit der POS.
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.845
235
Hallo,

Der Vermerk "aktuell" wird bei POS nie mehr angezeigt - je nach Status ist es "wird aktualisiert" oder "wird gelöscht".
dieser Status gilt nicht für POS. Dieser ist nur für Online- Shop, da die POS Schnittstelle ganz anders funktioniert. Der Fehler ist das es immer noch dort angezeigt wird.
Ja und unbedingt immer auf die neuste Wawi - Version aktualisieren.
 

b-tool.ch

Aktives Mitglied
14. Juni 2018
29
4
Wir haben nun auf 1.5.47.2 aktualisiert und haben ein weiteres Problem eingehandelt (und die Probleme beim Anbinden der Kasse bestehen weiterhin).
Während des Updates ist während der Performanceoptimierung des einen Mandanten ist die Verbindung zur Datenbank unterbrochen worden.
Obwohl auf den ersten Blick trotzdem alles gut aussah und funktionierte, erhalten wir nun beim Abgleich mit dem Onlineshop-Abgleich folgende Fehlermeldung:
Fehler:
Exception: Call to a member function getIso() on null
Call to a member function getIso() on null
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei product.push: Call to a member function getIso() on null

Call to a member function getIso() on null

Response: {"result":null,"error":{"code":0,"message":"Call to a member function getIso() on null","data":"Exception 'Error' (Code: 0) with message 'Call to a member function getIso() on null' in \/var\/www\/webroot\/ROOT\/engine\/ Shopware\/Plugins\/Local\/Frontend\/jtlconnector\/src\/Mapper\/Product.php:644"},"jtlrpc":"2.0","id":"unknown"}
Exception bei product.push: Call to a member function getIso() on null

Call to a member function getIso() on null

Response: {"result":null,"error":{"code":0,"message":"Call to a member function getIso() on null","data":"Exception 'Error' (Code: 0) with message 'Call to a member function getIso() on null' in \/var\/www\/webroot\/ROOT\/engine\/Shopware\/Plugins\/Local\/Frontend\/jtlconnector\/src\/Mapper\/Product.php:644"},"jtlrpc":"2.0","id":"unknown"}
bei jtlCore.ControllerClasses. Connector.Abgleich.Connector.YOe5Ujcrfds(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.pOD5Ub66aRf(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.YOe5Ujcrfds(String , Object , Boolean , NetworkCredential )
Die erneute Performance-Optimierung (und Bereinigung und Reparatur) über die Datenbankverwaltung (Start - Datenbank) hat auch nichts gebracht.
Beim andern Mandanten funktioniert alles tiptop.
Die Suche im Forum war leider auch erfolglos.

Kann jemand helfen?
Grüße, Daniel
 

lweber

Lars Weber
Mitarbeiter
13. November 2013
497
109
HAllo @b-tool.ch ,

wurde wie schon von Shopworker vorgeschlagen, das Backup eingespielt und erneut das Update durchgeführt?

Es müsste ja nur von dem betroffenen Mandanten das Backup eingespielt werden, und dann beim anmelden der Wawi diesen Mandanten auswählen, dann wird das Update erneut durchgeführt.

Grüße
 

b-tool.ch

Aktives Mitglied
14. Juni 2018
29
4
Das habe ich versucht - leider blieb nun die Datenbank während der Wiederherstellung hängen.
Das hat zur Folge, dass auch die JTL Datenbankverwaltung hängt.

Die Widerherstellung im SQL Server Management Studio (RESTORE DATABASE eazybusiness WITH RECOVERY) liefert dei Meldung:
...The database cannot be recovered because the log was not restored...

ein Versuch mit :
USE master;
GO
ALTER DATABASE eazybusiness
SET SINGLE_USER
WITH ROLLBACK IMMEDIATE;
liefert die Meldung:
...ALTER DATABASE is not permitted while a database is in the Restoring state...

Wir versuchen nun Kontakt mit unserem SQL-Experten aufzunehmen, da ich keinen direkten Zugriff auf die Harddisk des Servers habe und somit auch nicht herausfinden kann, wie die letzte Backup-Datei heißt.
Versuche mit "DROP DATABASE" scheinen mir etwas heikel, da ich kein SQL-Experte bin.

Die Idee mit dem Einspielen des Backups wäre eigentlich super...

Daniel
 

b-tool.ch

Aktives Mitglied
14. Juni 2018
29
4
Hallo
Unser sql-Supporter konnte das Backup wiederherstellen und diesmal ist das Updaten des Mandanten problemlos bis zum Ende durchgelaufen.

DAS PROBLEM BEIM SENDEN DER ARTIKEL BESTEHT ABER WEITERHIN:
Abgleich-Protokoll:
Bitte beachten Sie, dass JTL-Wawi federführend ist!
Im Shop-Backend vorgenommene Änderungen können nicht mehr automatisiert abgeglichen werden und führen somit zu Datenverlust.
Prüfe Endpointkonfiguration.
Abgleich gestartet für 'b-tool Onlineshop'.
Empfangen: Kunden (4 Stück)
Empfangen: Aufträge (3 Stück)
Empfangen: Zahlungen (2 Stück)
Onlineshop-Abgleich beendet für 'b-tool Onlineshop'.

Fehler:
Exception: Call to a member function getIso() on null
Call to a member function getIso() on null
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei product.push: Call to a member function getIso() on null

Call to a member function getIso() on null

Response: {"result":null,"error":{"code":0,"message":"Call to a member function getIso() on null","data":"Exception 'Error' (Code: 0) with message 'Call to a member function getIso() on null' in \/var\/www\/webroot\/ROOT\/engine\/ Shopware\/Plugins\/Local\/Frontend\/jtlconnector\/src\/Mapper\/Product.php:644"},"jtlrpc":"2.0","id":"unknown"}
Exception bei product.push: Call to a member function getIso() on null

Call to a member function getIso() on null

Response: {"result":null,"error":{"code":0,"message":"Call to a member function getIso() on null","data":"Exception 'Error' (Code: 0) with message 'Call to a member function getIso() on null' in \/var\/www\/webroot\/ROOT\/engine\/Shopware\/Plugins\/Local\/Frontend\/jtlconnector\/src\/Mapper\/Product.php:644"},"jtlrpc":"2.0","id":"unknown"}
bei jtlCore.ControllerClasses. Connector.Abgleich.Connector.YOe5Ujcrfds(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.pOD5Ub66aRf(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.YOe5Ujcrfds(String , Object , Boolean , NetworkCredential )
Immerhin werden die Aufträge und Zahlungen empfangen, bevor der Abgleich beim Senden der Artikel abstürzt.

Leider habe ich keine Ahnung woher der Fehler kommt. Der Connector möchte 685 Artikel senden (obwohl wir seit dem letzten Abgleich kaum Artikel verändert haben; wir machen vor den Updates jeweils einen Abgleich), hängt dann eine gewisse Zeit, bis der Abgleich mit obiger Fehlermeldung beendet wird. Sonst scheint alles zu funktionieren.
Kann jemand helfen?

Danke für die bisherigen Tipps, Daniel

P.S. eventuell sollte meine Anfrage in einen neuen Thread verschoben werden, da es ja nicht mehr um Probleme mit POS geht (ich habe die POS-Filiale vor dem Update gelöscht).
 
Zuletzt bearbeitet:
Ähnliche Themen
Titel Forum Antworten Datum
Neu Artikel kann nicht auf Amazon eingestellt werden - [Herkunftsland = null] Amazon-Lister - Fehler und Bugs 1
Neu Artikel werden dupliziert JTL-Wawi - Fehler und Bugs 0
Gelöst Bonvorlage - Anmerkung Artikel werden gedruckt Gelöste Themen in diesem Bereich 2
In Bearbeitung Wurzelkategorie - Artikel werden nicht nach POS übertragen Allgemeine Fragen zu JTL-POS 1
Shop5 Export Idealo Artikel mit Umlauten werden in Idealo mit Sonderzeichen dargestellt Einrichtung JTL-Shop5 6
Neu Problem beim Shopware Abgleich/Artikel werden nicht übertragen Shopware-Connector 0
Neu Inaktive Artikel werden im Shop angezeigt Arbeitsabläufe in JTL-Wawi 2
Neu ALLE Artikel werden bei jedem Abgleich nochmals an den Shop geschickt Arbeitsabläufe in JTL-Wawi 0
Neu Artikel werden beim Upload immer erst gelöscht Shopware-Connector 0
Neu Artikel können nicht gesendet werden - Call to a member function getIso() on null Shopware-Connector 3
Neu SW5 - Nach Connector Update - Bilder werden Artikel nicht zugewiesen Shopware-Connector 19
Neu JTL Shop 4 - Artikel mit Pfand kann nicht in EU verschickt werden Allgemeine Fragen zu JTL-Shop 1
Neu Alle Artikel werden übertragen bei Shopabgleich nach Datenbankumzug JTL-Wawi - Fehler und Bugs 1
Neu Set-Artikel - bei einer bestimmten, enthaltenen Zeichenfolge soll der TARIC-Code ein- bzw. ausgeblendet werden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Berichtscontainer, Artikel sollen vollständig abgebildet werden oder vorher einen Seitenumbruch machen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Reiter Artikel Ebay und Amazon Import Einrichtung und Installation von JTL-eazyAuction 0
Neu SQL/VS Storde Procedure - Artikel hinzufügen Schnittstellen Import / Export 3
Neu Artikel aus Unterkategorien in Artikelübersicht anzeigen wenn Überkategorie leer ist Allgemeine Fragen zu JTL-Shop 1
Neu Widersprüchliche Darstellung von Artikel Betrieb / Pflege von JTL-Shop 14
Neu Artikel mit Variation wird zu Freiposition User helfen Usern - Fragen zu JTL-Wawi 2
Neu Artikel Beschreibung Bilder responsive gestalten ? Allgemeine Fragen zu JTL-Shop 8
Neu Neuen Artikel auf altes ebay Angebot verknüpfen eBay-Anbindung - Ideen, Lob und Kritik 0
In Diskussion Zufälligen Artikel in Auftrag legen JTL-Workflows - Ideen, Lob und Kritik 7
Neu Anbindung Woocommerce und Amazon - alle Artikel sind doppelt vorhanden Schnittstellen Import / Export 0
Neu Newsletter Standardvorlage findet keine Artikel, Kategorien, Hersteller JTL-Shop - Fehler und Bugs 0
Neu Rechnung nur über gelieferte Artikel? Arbeitsabläufe in JTL-Wawi 1
Neu Artikel verschwunden ?? JTL-Wawi - Fehler und Bugs 2
Neu Artikel duplizieren erzeugt immer diesen Fehler User helfen Usern - Fragen zu JTL-Wawi 7
Neu In Kategorien Artikel Reihenfolge Auswählen Allgemeine Fragen zu JTL-Shop 4
In Diskussion doppelte Artikel im Auftrag JTL-Workflows - Ideen, Lob und Kritik 2
Neu Artikel im Shop, Stückzahl teilbar JTL-Wawi - Fehler und Bugs 2
Neu Var. Kombi Artikel einzeln im Shop Sichtbar Arbeitsabläufe in JTL-Wawi 2
Beantwortet Auftrag enthält Artikel aus Standard- und WMS Lager Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 2
Neu Fehler mit Sonderzeichen in den Metadaten der Artikel. JTL-Wawi - Fehler und Bugs 0
Artikel mit bestimmtem Funktionsattribut aus Suchergebnis löschen Einrichtung JTL-Shop5 1
Neu "Hitparade" der am besten verkauften Artikel erstellen User helfen Usern - Fragen zu JTL-Wawi 6
Neu Je nach Artikel(-Gruppe) automatisch Hinweis auf Pickliste hinzufügen Individuelle Listenansichten in der JTL-Wawi 0
Neu Preis von Vater Artikel anstatt das günstigste Kind anzeigen Templates für JTL-Shop 1
Neu Verkaufte Artikel Anzeigen User helfen Usern - Fragen zu JTL-Wawi 3
Neu Lieferschein mit Auflistung aller Artikel Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Beantwortet Workflow Artikel mit Verlust (VK-EK) JTL-Workflows - Ideen, Lob und Kritik 4
Neu Amazon Lister bestehendes Amazon Angebot mit Wawi-Artikel / selbsterstellte Produkseite über JTL zentral pflegen und aktualisieren User helfen Usern - Fragen zu JTL-Wawi 0
Neu Automatisch Artikel hinzufügen - abhängig von Kunden und Artikel User helfen Usern - Fragen zu JTL-Wawi 0
Neu Eigene Artikel-Sortierung in Artikelübersicht Allgemeine Fragen zu JTL-Shop 1
Neu Fehler beim Artikel duplizieren seit Wawi 1.5.48.1 JTL-Wawi - Fehler und Bugs 2
Neu Anzeige von Artikeln in Kategorien anhand hinterlegter Merkmale beim Artikel Betrieb / Pflege von JTL-Shop 0
Neu amazon export von artikel und übernahmen in wawi User helfen Usern - Fragen zu JTL-Wawi 0
Neu Falscher Lagerstand FBM Artikel Amazon-Anbindung - Fehler und Bugs 0
Neu Hinweis bei Wareneingang von Artikel Arbeitsabläufe in JTL-Wawi 0
Neu Kundentextfeld aus Artikel an WAWI übertegen ? WooCommerce-Connector 4

Ähnliche Themen