Neu Variantenbild wird nicht zum Hauptbild...

TingTong

Neues Mitglied
8. März 2021
12
0
Hallihallo lieben Wissenden...

Ehe mir die Nerven durchbrennen versuche ich es mal hier:

Ich habe überwiegend Ameisenfrei einen Shop aufgebaut. Etliche Artikel als Variantenartikel. Artikelbilder werden auf die Varianten vererbt und das in der Variante zugewiesene Bild soll zum Hauptbild gemacht werden. Bei über 1200 Artikeln so gemacht und funktioniert.
Nun wollte ich "mal eben" ein paar Artikel nachlegen und nach drei Stunden gelingt es immer noch nicht, dass das Variantenbild angezeigt wird. Geht man mit der Maus auf die Variante, wird das richtige Bild gehovert. Klicke ich die Variante dann an, ist es wieder weg. Artikel fünfmal hin und hergelöscht - nutzlos. Shop komplett übertragen. Geht auch nicht. Bild manuell eingetragen. Ohne Erfolg.
Nach drei Stunden nun haben ich einen funktionierenden Artikel in die Warengruppe kopiert, Varianten (jaja, mit Auswahl der Variante und zwei Häckchen) erstellt und plopp - geht dann da auch nicht mehr.
An der Stelle steig ich aus und weiß gar nicht mehr, wo ich anfangen sollte den Fehler (Bestimmt USerseitig) zu finden.
Jemand eine Idee?
Vielen herzlichen Dank schon mal.

Ach ja: Der shop ist neozed.de Wer da mal in die Gruppe Modul geht und zum Beispiel Rahmen anklickt sieht, dass alles funktioniert. In der Gruppe Fontana unter Schalter sind mal zwei Artikel bei denen es dann irgendwie nicht mehr geht. Das macht mich fertig :)

Gruß
Tom
 
Zuletzt bearbeitet:

wespread.online

Mitglied
29. September 2020
79
10
Hallo,

sehr interessantes Thema, ich habe auch Schwierigkeiten da. Hast du eigentlich Kinderartikel, oder sind das nur Variationen? Hast du irgendein Artikel mit mehr als 1 Variation? Mich interessiert wie dort die Bilder angezeigt werden.

Ich habe grad die zwei Artikel unter Schalter mir angeschaut, eigentlich werden die Bilder neugeladen.
 

TingTong

Neues Mitglied
8. März 2021
12
0
Hi there,

das sind so "Kleinigkeiten" die wirklich Zeit rauben. Immer wieder probieren und immer wieder im Internet suchen. Man wird ja kaum der Erste mit dem Problem sein. Ich habe dann einen alten Post gefunden. Ich glaube von 2016. Das Problem sei bekannt. Wilde Tips um an der Datenbank rumzufummeln oder Bilder mit Bildbearbeitung öffnen und wieder speichern damit der Datei-Hash verändert wird. Wenn ich da ewig rumprobieren wollte, müsste ich kein JTL benutzen. Da gibt es andere Lösungen wenn man Spaß am rumbasteln hat. Mir ist da mittlerweile die Zeit zu Schade für. Trotz Informatikstudium. Oder gerade deshalb... :)

Also richtig: die Bilder verändern sich mittlerweile. Die zeitärmste Änderung ist: Für den Hauptartikel ein allgemeines Bild verwenden und für die Variationen dann die tatsächlichen Bilder auswählen. Das umgeht irgendwie das Problem.

Alle Artikel wurden so angelegt, dass im Prinzip die Eckdaten und Variationen eingegeben wurden. Der Artikel besteht zum Beispiel aus 10 Variationen, also 10 produktspezifischen Bildern und zwei "Haupt"-Bildern mit Bemassung und Explosionszeichnung. Die Bilder wurden von mir alle unter "Bilder" im Artikel eingepflegt. Unter den Variationen habe ich dann für die jeweilige var das Bild nochmal separat ausgewählt. Danach Variablen-Artikel automatisch erzeugen und fertig. Klappte tadellos bei über 1200 Artikeln.

Hier nun begann es damit, dass Artikelbilder nicht mehr richtig durchnummeriert wurden. Das hat das System zwar korrigiert, aber nach einem Upload war wieder alles durcheinander. Dazu kam, dass, wenn man eine Artikelvariation aufgerufen hat, standen da 6 Bilder. Maske schließen, öffnen und schwupp, waren es 12 Bilder. Wieder nummerieren - upload - und danach waren sie wieder durcheinander. Überall Cache leeren, zweiten Browser testen, rumfummeln und schließlich den Weg suchen, der das Problem umgeht.

Das ist der Sachstand. Gelöst ist nix. Und das schafft bei mir zumindest Unsicherheit. Ehrlich gesagt, möchte ich nicht nach jedem Upload alle Artikel mal testweise aufrufen um nachzuschauen, ob es denn funktioniert.
Wir bauen unseren Shop gerade erst auf. Auf Design legen wir im Moment keinen Wert. "Laufen" muss es erstmal. Dann kann man sich über andere Templates Gedanken machen. Ich muss das auch unserem Geschäftspartner "verkaufen" können, dass wir in Deutschland eben dies System verwenden und uns nicht an die zentrale Navision dranhängen.

Wenn diese Standardfunktionen ohne Ticket-Support nicht umsetzbar sind, müssen wir überlegen ob wir damit glücklich werden. Wenn es wenigstens die "Beseitigung" des Problems wäre, die mich mehr als 6 Stunden gekostet hat wäre es ja schnuppe. Aber irgendwann interessiert mich nicht mehr wo das Problem genau wohnt, sondern wie ich am besten n Bogen darum fahren kann, nachdem ich feststellen konnte, wo das Problem "ungefähr" zu Hause ist :)

Aber gespannt bin ich natürlich schon, ob es jetzt das persönliche Unvermögen ist oder tatsächlich ein Bug, der 2016 schon im Forum war und schlicht die Grenze des Developments markiert :)
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Papier / Labelgröße wird nicht gespeichert Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Lagerbestand wird nicht übertragen WooCommerce-Connector 0
Neu Neu eingetragener Lizenzschlüssel wird nicht in der Wawi-Lizenzenliste angezeigt Einrichtung und Installation von JTL-eazyAuction 0
Neu elektronisch erbrachte Leistung wird nicht übertragen Gambio-Connector 2
Gelöst Eazyshipping - Button "Verpacken" wird nicht automatisch ausgelöst Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 3
Neu Erzeugung der Standard Rechnung unterdrücken da Rechnung über Workflow generiert wird (druckt aktuell 2 Rechnungen) Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Php.ini im Rootverzeichnis wird beim Wawi Abgleich überschrieben Upgrade JTL-Shop4 auf JTL-Shop5 1
Beantwortet custom.css im NovaChild wird nur in <noscript> geladen? Templates für JTL-Shop 1
Neu Versandlabel wird nicht mehr gedruckt, mit Zebra LP2844 User helfen Usern - Fragen zu JTL-Wawi 10
In Bearbeitung Artikel-Rabatt wird auf alle Stückzahlen angewendet JTL-POS - Fehler und Bugs 6
Neu Verfügbarkeitsbestätigung wird nicht gesendet, obwohl Artikel wieder verfügbar ist JTL-Shop - Fehler und Bugs 6
Neu Workflow Retouren - Umtauschauftrag erstellen Feld Adresse wird nicht gespeichert JTL-Wawi - Fehler und Bugs 3
Neu Amazon - "MWS wird im Laufe der Zeit deaktiviert" - Verkaufspartner-API Amazon-Anbindung - Ideen, Lob und Kritik 2
Neu Menge bei Zusammenführung wird zusammengefasst Arbeitsabläufe in JTL-Wawi 4
Neu Beschreibungstext bei Merkmal wird nicht übernommen, Bug 1.5.30.0 JTL-Wawi - Fehler und Bugs 3
Neu Update auf JTL-Wawi 1.5.46.4 - Externe Bestellnummer wird in Umtauschauftrag nicht mehr übernommen, wieso? JTL-Wawi - Fehler und Bugs 0
Neu Negativer Rabattwert wird bei Auftragserstellung zu Nullpreis User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung E-Mail Adresse wird nicht angezeigt JTL-POS - Fehler und Bugs 5
Neu Der Auftrag wird nicht ausgeliefert: Bereits auf einer anderen Pickliste. Arbeitsabläufe in JTL-Wawi 0
Neu Bezeichnung wird als Artikelnummer angezeigt auf Rechnungen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu 1.5.46.1: Versandstatus bei Amazon wird nicht gesetzt User helfen Usern - Fragen zu JTL-Wawi 16
Beantwortet Abnahmeintervall von Wawi wird auf WMS missachtet? Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 4
Gelöst Swissbit TSE microSD wird nicht erkannt - Samsung Tab A7 & Lenovo P11 JTL-POS - Fehler und Bugs 7
In Bearbeitung JTL POS Bon mit Retoure - Lagerbestand wird nicht erhöht Allgemeine Fragen zu JTL-POS 3
In Diskussion Mindestabnahme Abnahmeintervall wird nicht berücksichtigt JTL-POS - Fehler und Bugs 2
Neu Taric Code wird auch bei Versandkosten angezeigt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Beantwortet Von Amazon gesplittete Aufträge - Zahlung wird nicht gesetzt Amazon-Anbindung - Fehler und Bugs 5
Neu [OPC] OnPage Composer wird nicht geladen Allgemeine Fragen zu JTL-Shop 5
Warenkorb wird nicht angezeigt Einrichtung JTL-Shop5 2
Neu Wo wird Searchloud verwendet? Templates für JTL-Shop 3
Neu Lieferdatum wird nicht angezeigt Technische Fragen zu Plugins und Templates 1
Neu Es wird 0 Bestand bei Ebay angezeigt trotz laufender Ebay-Auktion eBay-Anbindung - Fehler und Bugs 0
Neu Konfigurator wird im Shop nicht angezeigt Einrichtung JTL-Shop5 4
JTL Shop 5.0.1 - Eigene Seite wird im Backend nicht mehr angezeigt nach dem Verschieben in andere Linkgruppe Einrichtung JTL-Shop5 5
Neu Artikel wird nicht aus Kategorie gelöscht im Shop JTL-Wawi - Fehler und Bugs 1
Paypal Plus wird nicht angezeigt Einrichtung JTL-Shop5 4
Neu Box im Footer wird beim Paypal-Plugin-Update gelöscht JTL-Shop - Fehler und Bugs 5
Neu Auf Auftragsformularen wird keine Paketangabe gemacht Arbeitsabläufe in JTL-Wawi 0
Neu Grundpreisangabe in Artikelüberschrift Ebay wird nicht aktualisiert eBay-Anbindung - Fehler und Bugs 0
Neu Amazon Zahlungseingang wird falsch verbucht User helfen Usern - Fragen zu JTL-Wawi 0
Neu Rabatt an die JTL-WaWi wird nicht übertragen Shopify-Connector 0
Neu Grid-Loyout einfügen, es wird nicht angezeigt. Allgemeine Fragen zu JTL-Shop 3
Neu Kunden-Guthaben wird im Shop nicht übertragen JTL-Shop - Fehler und Bugs 2
Neu Registrierung in diesem Forum nicht möglich mit aktuellen Browsern (Captcha wird nicht angezeigt) Smalltalk 1
Neu Lieferdauer wird doppelt angezeigt Technische Fragen zu Plugins und Templates 0
Neu FBA Bestand wird auf FBM Angebote aufgerechnet Amazon-Anbindung - Fehler und Bugs 1
Neu Stornomitteilung wird nicht mitgeteilt eBay-Anbindung - Ideen, Lob und Kritik 1
Neu Lieferantenrückstandserinnerung wird nicht versendet Arbeitsabläufe in JTL-Wawi 0
Neu Rabatt wird nicht mehr angezeigt bzw. mit gedruckt (X% fehlt auf der Rechnung) User helfen Usern - Fragen zu JTL-Wawi 4
Offen Druck wird teilweise nicht angeschoben - benötige Alternative JTL-Workflows - Ideen, Lob und Kritik 0

Ähnliche Themen