Gelöst Synchronisation nach Shop (2.0.3.0) und Connector(1.8) update nicht mehr möglich

Zschopautaler Imker

Sehr aktives Mitglied
25. April 2017
190
31
Frankenberg
Hallo, habe mein Shop von Version 2.0.2.2 auf 2.0.3.0 geupdatet und dazu gleich den Connector auf Version 1.8 gebracht da ja gewisse Fehler in der 1.6 waren (Versandkosten).
So nun erhalte ich leider den Fehler:
Synchronistaion mit Webshop nicht möglich!

Exception bei core.connector.auth: Duplicate entry '1' for key 'PRIMARY'

Duplicate entry '1' for key 'PRIMARY'
Response:{"result":null,"error":{"code":1062,"message"😀uplicate entry '1' for key 'PRIMARY'"."data":Exception
'jtl\\Connector\\Core\\Exception\\DatabaseException' (Code: 1062) with meassage 'Duplicate entry '1' for key 'PRIMARY" in phar:\/\/\/var\/clients\/.....\/....\/....\/jtlconnector\/index.php\/vendor\/jtl\/connector\/core\/Database\/Mysql.php:3

Ich hätte jetzt auf einen Datenbank doppeleintrag getipt aber so ähnliche fehler gabe es auch schon beim Gambio Connector ????

Ein Tip woher der fehler kommt oder wo ich schauen kann.

danke
 

daniel.jtl

Moderator
12. März 2014
1.277
28
Hast du auch geprüft ob die Migrierung der Link-Tabellen erfolgreich durchgelaufen ist? Beim Sprung von 1.6 auf 1.7 ist ja das gesamte Mapping überarbeitet worden.
 

Zschopautaler Imker

Sehr aktives Mitglied
25. April 2017
190
31
Frankenberg
Wie führe ich das durch???? Habe schon im Forum geschaut ob ich beim Connector Update was beachten muss aber leider null gefunden nur das ich die neuen Datein nur hochladen muss.
Beim Shop selber hat er alle Datenbank Updates ohne Fehler durchgeführt.

Hab auch den Connector im Verzeichnis selber gelöscht und neu hochgeladen ob es eventuell an einem Übertragungsfehler liegen könnte brachte aber null....
Und vom Connector Einträge in der Datenbank löschen ist denke ich mal eine Schlechte idee.

Der Shop selber ist mit der Version 2.0.2.1 Installiert und nun auf 2.0.3.0, so das da wenig fehler vorhanden sein könnten ....
 

Zschopautaler Imker

Sehr aktives Mitglied
25. April 2017
190
31
Frankenberg
Hallo,
nach wie vor geht nix. Die 1.6 Geht nicht mehr bringt diese Fehlermeldung beim Abrufen:

Abgleich-Protokoll:
Prüfe Endpointkonfiguration.
Abgleich gestartet für 'Zschopautaler-Imker.de'.
Onlineshop-Abgleich beendet für 'Zschopautaler-Imker.de'.
Fehler:
Exception: customer.pull hat keine Daten zurückgegeben.
Kunden-Empfangen-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
customer.pull hat keine Daten zurückgegeben.
Exception bei customer.pull:
customer.pull hat keine Daten zurückgegeben.
Response: <Empty>
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.vikS4xp0B25(String , Object , Boolean , NetworkCredential )
Warnungen:
Abgleich darf nicht weiterlaufen.Abgleich darf nicht weiterlaufen.

Und bei der 1.8 Version kommt der Fehler wie ganz oben beschrieben.
Wer kann helfen .... finde keine Lösung....
Stehe nun vor dem Problem das ich im Shop Bestellungen habe die ich nicht mehr ins JTL bekomme
 

Zschopautaler Imker

Sehr aktives Mitglied
25. April 2017
190
31
Frankenberg
Ich habe den Fehler nun gefunden. Dieser Tritt auf solang das Installationsverzeichnis mit Daten noch vorhanden ist. Habe das Verzeichnis gelöscht und Siehe da es geht alles in neuster Version .... gestern nochmals 5h gesucht und gemacht .....
Habe leider übersehen/nicht dran gedacht das man es "löschen" soll ......
 

Zschopautaler Imker

Sehr aktives Mitglied
25. April 2017
190
31
Frankenberg
Hallo,
der Fehler liegt an der der Datenbank Tapelle "jtl_connector_link_category" diese hat irgendwo einen Fehler in der Codierung (Primery ,....) ... habe diese gelöscht (was natürlich nicht die richtige Lösung ist) und ab da hat das 1.8 JTL Connector ohne Fehler gearbeitet es hat nix mit dem Install Verzeichnis zu tun.
Da ich von Programmierung und MYSQL und so null Ahnung habe sollten aber die davon Ahnung haben jetzt was damit anfangen können.
 

Ähnliche Themen