Gelöst Seriennummer wird nicht in die Dokumente Auftrag/Lieferschein/Rechnung übernommen

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Eduard Anhänger

Neues Mitglied
30. Juli 2020
2
1
Hallo liebe JTL Wawi User,

wir benutzen das Programm jetzt seit ca. einer Woche und sind gerade dabei die Vorlagen anzupassen, sowie erste Artikel einzupflegen.

Jetzt haben wir das Problem, das wir die Seriennummern der Artikel nicht in die Dokumente bekommen.
Die Artikel werden mit aktiver Bestandsführung angelegt; Option Artikel mit Seriennummer + Seriennummer verfolgen ist aktiviert.
Beim Wareneingang geben wir die Seriennummer in der Maske ein und können diese auch in der Bestandsübersicht sehen.

Wenn wir jetzt einen Auftrag mit dem Artikel anlegen und anschließend ausliefern, können wir im Versand die entsprechende Seriennummer auswählen.
Allerdings wird uns diese weder im Auftrag, noch auf dem Lieferschein oder der Rechnung angezeigt.

Bei Artikeln mit Charge funktioniert alles, dort wird nach dem Versand die Chargen-Nr. auf den Belegen angezeigt.


In der Rechnungsvorlage ist bei dem Objekt "Batch number / BBD / Serial number" die Darstellungsbedingung auf "immer anzeigen" gesetzt.

Der Inhalt lautet:
LocNumber$(InvoicePositionDeliveryDetails.Quantity, JTL_GetCulture(Report.CountryISO, Report.LanguageISO, Report.CurrencyISO), @DecimalQuantity) +
cond(IsNullOrEmpty(InvoicePosition.Unit), "", " " +InvoicePosition.Unit) +
cond(IsNullOrEmpty(InvoicePositionDeliveryDetails.BatchNumber), "", " Charge: " + InvoicePositionDeliveryDetails.BatchNumber) +
cond(IsNull(InvoicePositionDeliveryDetails.BestBeforeDate), "", " MHD: " + LocDate$(InvoicePositionDeliveryDetails.BestBeforeDate, JTL_GetCulture(Report.CountryISO, Report.LanguageISO, Report.CurrencyISO))) +
cond(IsNullOrEmpty(InvoicePositionDeliveryDetails.SerialNumber), "", " s/n: " + InvoicePositionDeliveryDetails.SerialNumber)


Wo liegt hier der Fehler? Kann mir jemand helfen?
 

area57

Neues Mitglied
26. August 2020
3
1
Gibt es hierzu mittlerweile eine Idee oder Abhilfe?
weil so wie es aktuell ist, ist der Einsatz für mich nicht praktikabel bzw. brauchbar
 

kss_admin

Neues Mitglied
24. August 2020
9
1
Bei uns leider auch diesselbe Situation. Auf irgendeinem Dokument müssen wir die Seriennummer aufführen. Lieferschein oder Rechnung, spielt keine Rolle. Wann wird es hierzu einen BugFix geben?
 
  • Gefällt mir
Reaktionen: area57

EMO

Mitglied
18. Juli 2019
18
3
Wir haben das gleiche Problem bei uns! Die Seriennummer muss zwingend auf dem Lieferschein stehen. Wir bekommen es nicht hin, trotz der Im Video genannten Einstellungen! Ist hier evtl. schon die Ursache bekannt?
 

exuled

Offizieller Servicepartner
SPBanner
8. August 2019
64
12
Hallo,

ich konnte das Problem nicht nachstellen, sowohl mit den alten und neuen Vorlagensets.

Habt ihr schonmal ein neues Vorlagenset erstellt und geschaut, ob es dort auch auftaucht
Evtl. ist auch die Breite vom Objekt "Batch number / BBD / Serial number" zu gering, dann wird es nicht dargestellt.

Gruß
Chris
 

naltec_de

Mitglied
25. Mai 2020
10
2
Hab alles probiert. Neues Vorlagenset, Unterelemente angehängt usw. bringt alles nichts.
Geht dass eigentlich mit JTL_DirectQuery?
Wie wäre der Code dafür?
Vielleicht ist einfach die eingetragene Variable falsch?

Das steht bei mir in "Batch number / BBD / Serial number" drin:

LocNumber$(InvoicePositionDeliveryDetails.Quantity, JTL_GetCulture(Report.CountryISO, Report.LanguageISO, Report.CurrencyISO), @DecimalQuantity) +
cond(IsNullOrEmpty(InvoicePosition.Unit), "", " " +InvoicePosition.Unit) +
cond(IsNullOrEmpty(InvoicePositionDeliveryDetails.BatchNumber), "", " Charge: " + InvoicePositionDeliveryDetails.BatchNumber) +
cond(IsNull(InvoicePositionDeliveryDetails.BestBeforeDate), "", " MHD: " + LocDate$(InvoicePositionDeliveryDetails.BestBeforeDate, JTL_GetCulture(Report.CountryISO, Report.LanguageISO, Report.CurrencyISO))) +
cond(IsNullOrEmpty(InvoicePositionDeliveryDetails.SerialNumber), "", " s/n: " + InvoicePositionDeliveryDetails.SerialNumber)
 
Zuletzt bearbeitet:

exuled

Offizieller Servicepartner
SPBanner
8. August 2019
64
12
Hallo,

genau damit funktioniert es. Dann liegt das Problem an anderer Stelle.

Links unter Eigenschaften --> Layout --> Darstellungsbedingung aktiviert?

Gruß
Chris
 

Dalibor Josic

Sehr aktives Mitglied
22. Dezember 2014
993
85
Gaildorf
Hab alles probiert. Neues Vorlagenset, Unterelemente angehängt usw. bringt alles nichts.
Geht dass eigentlich mit JTL_DirectQuery?
Wie wäre der Code dafür?
Vielleicht ist einfach die eingetragene Variable falsch?

Das steht bei mir in "Batch number / BBD / Serial number" drin:

LocNumber$(InvoicePositionDeliveryDetails.Quantity, JTL_GetCulture(Report.CountryISO, Report.LanguageISO, Report.CurrencyISO), @DecimalQuantity) +
cond(IsNullOrEmpty(InvoicePosition.Unit), "", " " +InvoicePosition.Unit) +
cond(IsNullOrEmpty(InvoicePositionDeliveryDetails.BatchNumber), "", " Charge: " + InvoicePositionDeliveryDetails.BatchNumber) +
cond(IsNull(InvoicePositionDeliveryDetails.BestBeforeDate), "", " MHD: " + LocDate$(InvoicePositionDeliveryDetails.BestBeforeDate, JTL_GetCulture(Report.CountryISO, Report.LanguageISO, Report.CurrencyISO))) +
cond(IsNullOrEmpty(InvoicePositionDeliveryDetails.SerialNumber), "", " s/n: " + InvoicePositionDeliveryDetails.SerialNumber)
Nimm mal die Variablen mit 'Unit' raus und teste es erneut.
 

EMO

Mitglied
18. Juli 2019
18
3
Ich habe ebenfalls schon sehr viel getestet. Das kuriose ist, dass es in einem anderen Mandanten einwandfrei funktioniert! Ich habe sogar das funktionierende Vorlagenset aus dem Mandanten exportiert. Dieses habe ich dann im entsprechenden Mandanten wieder importiert. Die Seriennummer wurde auch dann nicht angezeigt! Ein komplett neues Vorlagenset bringt ebenfalls keine Änderung. Das ärgerliche daran ist, dass das Modul 99,00€/Monat kostet und aktuell für diesen Mandanten nicht nutzbar ist!
 

Dalibor Josic

Sehr aktives Mitglied
22. Dezember 2014
993
85
Gaildorf
Ich habe bei einem Kunden von mir festgestellt, dass die Variable für die Seriennummer in den neuen Vorlagen nicht funktioniert. Ich habe das per Script gelöst.
 

exuled

Offizieller Servicepartner
SPBanner
8. August 2019
64
12
Hallo,

ich habe gerade nochmal ein neues globales Vorlageset mit der 1.5.31.0 erstellt und es funktioniert.
Mit der 1.5.30.3 wurde ein Service Pack für List & Label bereitgestellt. Evtl. wurde hier ein "Bug" dieszbgl. behoben.

Welche Wawi Versionen habt ihr im Einsatz?

Gruß
Chris
 

EMO

Mitglied
18. Juli 2019
18
3
Hello,

ein neues globales Vorlagenset habe ich ebenfalls erstellt. Leider ohne Erfolg.
Wir benutzen die aktuelle Version 1.5.31.0
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Automatisierte Auslieferung von Seriennummer Artikeln Dienstleistung, Jobs und Ähnliches 0
Neu Charge, MHD und Seriennummer bei Stücklistenartikeln auf Lieferschein Arbeitsabläufe in JTL-Wawi 3
Neu Seriennummer oder Charge im Auftrag für Position erzwingen? User helfen Usern - Fragen zu JTL-Wawi 6
Neu Inventur Probleme bei Artikel mit Seriennummer. JTL-Wawi - Fehler und Bugs 1
Neu Falsche Zahlungsart wird übertragen seit Update WooCommerce-Connector 0
Neu Rechnungen wird bei einem Artikel auf zwei Seiten gedruckt statt auf einer JTL-Wawi - Fehler und Bugs 0
Neu Versandbenachrichtigung wird doppelt versandt JTL-Wawi - Fehler und Bugs 0
Neu SHOP5: Composer / Produktseite / Inhalt zwischen Preis und langer Beschreibung wird am Handy nicht angezeigt JTL-Shop - Fehler und Bugs 2
Neu [Error][Code:21916274] Erfordert Bestandseinheit-Unterstützung, wenn ein Artikel, der bereits über eine Bestandseinheit verwaltet wird, bearbeitet ode eBay-Anbindung - Fehler und Bugs 0
Neu Datenbank kann nicht geöffnet werden. Sie wird zurzeit wiederhergestellt. Installation von JTL-Wawi 0
Bild/Link wird unter eigene Seiten nicht angezeigt Einrichtung JTL-Shop5 1
Neu Abschaltung easylog wo wird der Ausdruck konfiguriert User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst Druckvorlage Html-code wird angezeigt User helfen Usern - Fragen zu JTL-Wawi 3
In Bearbeitung Es wird mal wieder Zeit "Danke" zu sagen ;) JTL-POS - Ideen, Lob und Kritik 1
Neu Bestellung wird automatisch auf mehrere Pakete aufgeteilt -> wie bekomme ich eine gesamte Rechnung Arbeitsabläufe in JTL-Wawi 2
Neu MwSt. für UK wird von ebay einbehalten User helfen Usern - Fragen zu JTL-Wawi 0
Neu Aus Nettopreis in Gambio wird Brutto in WaWi Gambio-Connector 6
Neu Auftrag import: Die Versandposition wird nicht im gesamten bezahlten Preis berechnet JTL-Ameise - Fehler und Bugs 1
Gelöst Retoure wird nicht auf Quelllager gebucht JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 3
Neu Bildname wird falsch gesetzt -> x-jpg.jpg Shopware-Connector 15
Gelöst Lieferantenartikelnummer wird im Wareneingang nicht erkannt Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 3
Neu Attribut mit Checkbox wird nicht mehr übertragen Shopware-Connector 0
Neu EAN Barcode wird nicht gedruckt Betrieb / Pflege von JTL-Shop 0
Neu mailchimp newsletter wird nicht zugestellt - ich krieg nen Aff´ User helfen Usern 2
Neu Consent Manager wird falsch dargestellt Einrichtung JTL-Shop5 6
Neu Bestellung Versand Status wird nicht übertragen Technische Fragen zu den JTL-Connectoren 0
Neu Wann wird das es das nächste/erste (?) Bugfix/Update für Shop 5.0.0 geben? Installation / Updates von JTL-Shop 2
Neu Für teilgelieferte Bestellungen wird "komplett geliefert" gesendet Shopify-Connector 0
Verwiesen an Support Lagerbestand bei FBA wird nicht mehr in der WAWI angezeigt User helfen Usern - Fragen zu JTL-Wawi 3
Abgelehnt Arbeitsplatzkonfiguration wird gelöscht bei Absturz JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 4
Neu URL zur Sendungsverfolgung wird nicht hinterlegt Gambio-Connector 4
In Bearbeitung Produkte mit Konfiguration - Konfiguration wird nicht berechnet JTL-POS - Fehler und Bugs 2
Neu NOVA: UVP Ersparnis wird nicht angezeigt Templates für JTL-Shop 1
Neu Nach Auftrags Import wird die Artikelnummer nicht übernehmen JTL-Ameise - Fehler und Bugs 5
Neu SHOP5: Variable cLocalizedWert in Guthaben Mail wird nicht angezeigt. JTL-Shop - Fehler und Bugs 11
Neu Paypal Express und Paypal Plus wird im Shop 5 nicht angezeigt Plugins für JTL-Shop 14
Neu [Shop4|Evo]Änderung im Template wird ignoriert Templates für JTL-Shop 0
Neu Artikeldetailseite Slick "gallery" wird erst bei "img" hover initialisiert JTL-Shop - Fehler und Bugs 2
Abgelehnt RMA Rechnungskorrektur wird nicht erstellt JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 1
Neu E-Mailvorlagen / Kundengruppenzuweisung durch Onlineshop-Betreiber / Betreffzeile DE und EN #kundengruppe.name# wird nicht gefüllt JTL-Shop - Fehler und Bugs 1
In Bearbeitung Kunden USt-IdNr wird nicht von Amazon ins Wawi übertragen Amazon-Anbindung - Fehler und Bugs 2
Gelöst Bei Kauf von ebay Italien wird falsche Produktbezeichnung im Auftrag angezeigt Gelöste Themen in diesem Bereich 2
In Bearbeitung Marke wird bei der eBay Suche nicht gefunden eBay-Anbindung - Fehler und Bugs 3
Neu Kurzbezeichnung wird vor Artikelbezeichnung gedruckt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Zahlungsart wird nicht angezeigt , ist leer Arbeitsabläufe in JTL-Wawi 0
Neu Nummernkreis Artikel geändert, jetzt wird nicht hochgezählt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Änderungen an Child Template SCSS Variablen wird nicht übernommen Technische Fragen zu Plugins und Templates 1
Neu UstID Prüfung - wie wird geloggt? amtliche Bestätigung ab 01.01.2021 weggefallen - keine Briefe mehr. User helfen Usern - Fragen zu JTL-Wawi 4
Gelöst NOVA Template - Slick Slider macht Probleme - Geladen wird nach 'mouseenter' & 'touchstart' Templates für JTL-Shop 7
Consent-Manager wird nicht angezeigt Upgrade JTL-Shop4 auf JTL-Shop5 15
Ähnliche Themen