Neu Riesen Problem mit neuem Connector

  • Ersteller des Themas Ersteller des Themas wolfi
  • Erstellungsdatum Erstellungsdatum

wolfi

Aktives Mitglied
13. März 2013
34
0
Hallo,
Wawi-Version : 1.5.21.3
Gambio-Version : 4,0,0,1
Connector-Version : 2.10.7
PHP Version 7.1

Ich habe heute das Gambio Update auf 4.0.0.1 und das Connectorupdate auf 2.10.7 gemacht.
Connector Dateien wurde Binär übertragen.
Connector konnte mit Install aufgerufen werden.
Parameter wurden übernommen und abgespeichert.
"integrity-check" wurde ausgeführt und ist alles auf grün
Allerding bekomme ich jetzt eine Fehlermeldung:
connector.png
Erst mit der alten Online Shop Anbindung und dann mit einer neuen.
Immer die selbe Fehlermeldung

Kann mir da jemand weiterhelfen.
Ist wirklich dringend, da ich täglich an die 100 Aufträge übernehmen muss.
 

wolfi

Aktives Mitglied
13. März 2013
34
0
Guten Morgen,
Hat den wirklich niemand eine Lösung für mich.
Hallo JTL: Ich würde auch gerne für die Lösung etwas bezahlen.
Es ist wirklich dringend!!!!!
 

bork

Sehr aktives Mitglied
26. Januar 2007
852
104
Hast du die PHP-Version auf dem Server auch geändert?
Server mal neu gestartet?
Die alte config.json mal testweise hochgeladen? Ich kenne das eigentlich nicht so, dass man beim Connector-Update den Installer nochmal ausführt. Duplicate Entry hört sich so an wie Primärschlüsselverletzung: Der Wert 1 darf nur 1x vorkommen, ist aber öfter da.
Von welcher Connector-Version hast du denn upgegraded? Es gab ja zwischendurch auch eine massive Datenbank-Änderung....
 

bork

Sehr aktives Mitglied
26. Januar 2007
852
104
Du könntest mal schauen, ob eine der JTL2Gambio Mapping Tabellen doppelte Primärschlüssel-Werte enthält:

Select endpoint_id from jtl_connector_link_category where endpoint_id = 1;

Und das selbe nicht nur für jtl_connector_link_category sondern für alle Mapping-Tabellen:

jtl_connector_link_crossselling
jtl_connector_link_crossselling_group
jtl_connector_link_customer
jtl_connector_link_customer_order
jtl_connector_link_delivery_note
jtl_connector_link_image
jtl_connector_link_manufacturer
jtl_connector_link_payment
jtl_connector_link_product
jtl_connector_link_specific
jtl_connector_link_specific_value
jtl_connector_payment
jtl_connector_product_checksum

Wenn du in einer der Tabellen mehr als einen Datensatz angezeigt bekommst, hast du dein Problem gefunden (und dann kann man über eine Lösung nachdenken).

Wenn du bezahlten Support möchtest, musst du bei JTL ein Support-Paket buchen oder dir hier einen Servicepartner heraussuchen: https://www.jtl-software.de/servicepartner
 
  • Gefällt mir
Reaktionen: wolfi

bork

Sehr aktives Mitglied
26. Januar 2007
852
104
Nebenbei: Hast du beim Wechsel von GX3 auf GX4 auch eine neue Connector-Lizenz im JTL Kundencenter geholt?
 

wolfi

Aktives Mitglied
13. März 2013
34
0
Hallo Bork,
erstmals vielen Dank für deine Unterstützung.
Folgende Werte wurden ausgegeben:

jtl_connector_link_category = 1;
jtl_connector_link_crossselling = nichts
jtl_connector_link_crossselling_group = nichts
jtl_connector_link_customer = nichts
jtl_connector_link_customer_order = nichts
jtl_connector_link_delivery_note = nichts
jtl_connector_link_image = nichts
jtl_connector_link_manufacturer = 1
jtl_connector_link_payment = nichts
jtl_connector_link_product = nichts
jtl_connector_link_specific = nichts
jtl_connector_link_specific_value = nichts
jtl_connector_payment Fehlermeldung: Unknown column endpoint_id in field list
jtl_connector_product_checksum = nichts
 

wolfi

Aktives Mitglied
13. März 2013
34
0
Also liebes Team von JTL!!!!!
Laut Gambio fehlt die Spalte endpoint_id scheinbar in einer Tabelle von JTL

Seid ihr deshalb so still, da ihr diesen Fehler kennt?
 

B M S

Gut bekanntes Mitglied
19. Juli 2016
100
2
Select endpoint_id from jtl_connector_link_category where endpoint_id = 1; ??? Was soll das bringen, außer dem Datensatz mit der endpoint_id 1 wird gar nichts ausgegeben 🙂

Nee mach ma folgendes um Doppelten Content zu finden:

SELECT * FROM `jtl_connector_link_category` GROUP BY `endpoint_id` HAVING COUNT(`endpoint_id`) >1
SELECT * FROM `jtl_connector_link_manufacturer` GROUP BY `endpoint_id` HAVING COUNT(`endpoint_id`) >1
usw...

dann sollteste den/die Übeltäter find
Daten vergleichen, wenn gleich, dann einen Löschen.

P.S.: die jtl_connector_payment Tabelle hatte noch nie eine endpoint_id
 

bork

Sehr aktives Mitglied
26. Januar 2007
852
104
Select endpoint_id from jtl_connector_link_category where endpoint_id = 1; ??? Was soll das bringen, außer dem Datensatz mit der endpoint_id 1 wird gar nichts ausgegeben 🙂
Außer DEN DatensätzEN mit endpoint id 1. Steht doch in der Fehlermeldung dass Wert 1 doppelt ist. Wenn es 2 Ergebnisse gibt, ist das der duplicate entry. Was gibt's dagegen einzuwenden (außer dass das nicht die Ursache war)?
 

B M S

Gut bekanntes Mitglied
19. Juli 2016
100
2
@bork stimmt auch wieder 🙂 man sollte halt auch immer alles lesen bevor man sein Senf dazu gibt 🙂
 

wolfi

Aktives Mitglied
13. März 2013
34
0
Also mit der Methode von BMS ist folgender <Fehler aufgetraten:
Records: in 0.0009 sec
Error: Unknown column 'endpoint_id' in 'group statement'
 

bork

Sehr aktives Mitglied
26. Januar 2007
852
104
Also irgendwo gibt es einen doppelten Eintrag der nur 1x vorkommen darf. Woher das jetzt genau kommt, kann man aus der Ferne nicht nachvollziehen.

Wie ist der Connector denn eingestellt? Import und Export? Welche Daten werden in welche Richtung transportiert? Wenn du da mal alles ausstellst und dann immer eins zusätzlich an und anschließend direkt probierst den Abgleich durchzuführen, kann man zumindest schonmal sagen welche Tabelle betroffen ist und dann das Problem eingrenzen.
 

bork

Sehr aktives Mitglied
26. Januar 2007
852
104
wobei der Fehler bei core.connector.auth auftritt - hört sich fast an als gäbe es die Connector-Benutzerdaten 2x. Soweit ich weiß stehen die aber gar nicht mehr in der Datenbank, sondern in der config.json Datei auf dem FTP Server. Vielleicht hat Immanuel von JTL noch eine Idee.
 

wolfi

Aktives Mitglied
13. März 2013
34
0
wobei der Fehler bei core.connector.auth auftritt - hört sich fast an als gäbe es die Connector-Benutzerdaten 2x. Soweit ich weiß stehen die aber gar nicht mehr in der Datenbank, sondern in der config.json Datei auf dem FTP Server. Vielleicht hat Immanuel von JTL noch eine Idee.
Danke bork für deine Hilfe.
Ich werde das mal durchtesten.
Von JTL meldet sich leider niemand.

Danke!!!!
 

wolfi

Aktives Mitglied
13. März 2013
34
0
Also irgendwo gibt es einen doppelten Eintrag der nur 1x vorkommen darf. Woher das jetzt genau kommt, kann man aus der Ferne nicht nachvollziehen.

Wie ist der Connector denn eingestellt? Import und Export? Welche Daten werden in welche Richtung transportiert? Wenn du da mal alles ausstellst und dann immer eins zusätzlich an und anschließend direkt probierst den Abgleich durchzuführen, kann man zumindest schonmal sagen welche Tabelle betroffen ist und dann das Problem eingrenzen.
Ich kann leider keinen Abgleich durchführen, da ich ja nicht mal eine Verbindung aufbauen kann.
 

Ähnliche Themen