Neu Riesen Problem mit neuem Connector

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

wolfi

Aktives Mitglied
13. März 2013
34
0
Hallo,
Wawi-Version : 1.5.21.3
Gambio-Version : 4,0,0,1
Connector-Version : 2.10.7
PHP Version 7.1

Ich habe heute das Gambio Update auf 4.0.0.1 und das Connectorupdate auf 2.10.7 gemacht.
Connector Dateien wurde Binär übertragen.
Connector konnte mit Install aufgerufen werden.
Parameter wurden übernommen und abgespeichert.
"integrity-check" wurde ausgeführt und ist alles auf grün
Allerding bekomme ich jetzt eine Fehlermeldung:
connector.png
Erst mit der alten Online Shop Anbindung und dann mit einer neuen.
Immer die selbe Fehlermeldung

Kann mir da jemand weiterhelfen.
Ist wirklich dringend, da ich täglich an die 100 Aufträge übernehmen muss.
 

wolfi

Aktives Mitglied
13. März 2013
34
0
Guten Morgen,
Hat den wirklich niemand eine Lösung für mich.
Hallo JTL: Ich würde auch gerne für die Lösung etwas bezahlen.
Es ist wirklich dringend!!!!!
 

bork

Gut bekanntes Mitglied
26. Januar 2007
531
14
Hast du die PHP-Version auf dem Server auch geändert?
Server mal neu gestartet?
Die alte config.json mal testweise hochgeladen? Ich kenne das eigentlich nicht so, dass man beim Connector-Update den Installer nochmal ausführt. Duplicate Entry hört sich so an wie Primärschlüsselverletzung: Der Wert 1 darf nur 1x vorkommen, ist aber öfter da.
Von welcher Connector-Version hast du denn upgegraded? Es gab ja zwischendurch auch eine massive Datenbank-Änderung....
 

bork

Gut bekanntes Mitglied
26. Januar 2007
531
14
Du könntest mal schauen, ob eine der JTL2Gambio Mapping Tabellen doppelte Primärschlüssel-Werte enthält:

Select endpoint_id from jtl_connector_link_category where endpoint_id = 1;

Und das selbe nicht nur für jtl_connector_link_category sondern für alle Mapping-Tabellen:

jtl_connector_link_crossselling
jtl_connector_link_crossselling_group
jtl_connector_link_customer
jtl_connector_link_customer_order
jtl_connector_link_delivery_note
jtl_connector_link_image
jtl_connector_link_manufacturer
jtl_connector_link_payment
jtl_connector_link_product
jtl_connector_link_specific
jtl_connector_link_specific_value
jtl_connector_payment
jtl_connector_product_checksum

Wenn du in einer der Tabellen mehr als einen Datensatz angezeigt bekommst, hast du dein Problem gefunden (und dann kann man über eine Lösung nachdenken).

Wenn du bezahlten Support möchtest, musst du bei JTL ein Support-Paket buchen oder dir hier einen Servicepartner heraussuchen: https://www.jtl-software.de/servicepartner
 
  • Gefällt mir
Reaktionen: wolfi

bork

Gut bekanntes Mitglied
26. Januar 2007
531
14
Nebenbei: Hast du beim Wechsel von GX3 auf GX4 auch eine neue Connector-Lizenz im JTL Kundencenter geholt?
 

wolfi

Aktives Mitglied
13. März 2013
34
0
Hallo Bork,
erstmals vielen Dank für deine Unterstützung.
Folgende Werte wurden ausgegeben:

jtl_connector_link_category = 1;
jtl_connector_link_crossselling = nichts
jtl_connector_link_crossselling_group = nichts
jtl_connector_link_customer = nichts
jtl_connector_link_customer_order = nichts
jtl_connector_link_delivery_note = nichts
jtl_connector_link_image = nichts
jtl_connector_link_manufacturer = 1
jtl_connector_link_payment = nichts
jtl_connector_link_product = nichts
jtl_connector_link_specific = nichts
jtl_connector_link_specific_value = nichts
jtl_connector_payment Fehlermeldung: Unknown column endpoint_id in field list
jtl_connector_product_checksum = nichts
 

wolfi

Aktives Mitglied
13. März 2013
34
0
Also liebes Team von JTL!!!!!
Laut Gambio fehlt die Spalte endpoint_id scheinbar in einer Tabelle von JTL

Seid ihr deshalb so still, da ihr diesen Fehler kennt?
 

B M S

Aktives Mitglied
19. Juli 2016
84
2
Select endpoint_id from jtl_connector_link_category where endpoint_id = 1; ??? Was soll das bringen, außer dem Datensatz mit der endpoint_id 1 wird gar nichts ausgegeben :)

Nee mach ma folgendes um Doppelten Content zu finden:

SELECT * FROM `jtl_connector_link_category` GROUP BY `endpoint_id` HAVING COUNT(`endpoint_id`) >1
SELECT * FROM `jtl_connector_link_manufacturer` GROUP BY `endpoint_id` HAVING COUNT(`endpoint_id`) >1
usw...

dann sollteste den/die Übeltäter find
Daten vergleichen, wenn gleich, dann einen Löschen.

P.S.: die jtl_connector_payment Tabelle hatte noch nie eine endpoint_id
 

bork

Gut bekanntes Mitglied
26. Januar 2007
531
14
Select endpoint_id from jtl_connector_link_category where endpoint_id = 1; ??? Was soll das bringen, außer dem Datensatz mit der endpoint_id 1 wird gar nichts ausgegeben :)
Außer DEN DatensätzEN mit endpoint id 1. Steht doch in der Fehlermeldung dass Wert 1 doppelt ist. Wenn es 2 Ergebnisse gibt, ist das der duplicate entry. Was gibt's dagegen einzuwenden (außer dass das nicht die Ursache war)?
 

wolfi

Aktives Mitglied
13. März 2013
34
0
Also mit der Methode von BMS ist folgender <Fehler aufgetraten:
Records: in 0.0009 sec
Error: Unknown column 'endpoint_id' in 'group statement'
 

bork

Gut bekanntes Mitglied
26. Januar 2007
531
14
Also irgendwo gibt es einen doppelten Eintrag der nur 1x vorkommen darf. Woher das jetzt genau kommt, kann man aus der Ferne nicht nachvollziehen.

Wie ist der Connector denn eingestellt? Import und Export? Welche Daten werden in welche Richtung transportiert? Wenn du da mal alles ausstellst und dann immer eins zusätzlich an und anschließend direkt probierst den Abgleich durchzuführen, kann man zumindest schonmal sagen welche Tabelle betroffen ist und dann das Problem eingrenzen.
 

bork

Gut bekanntes Mitglied
26. Januar 2007
531
14
wobei der Fehler bei core. connector.auth auftritt - hört sich fast an als gäbe es die Connector-Benutzerdaten 2x. Soweit ich weiß stehen die aber gar nicht mehr in der Datenbank, sondern in der config.json Datei auf dem FTP Server. Vielleicht hat Immanuel von JTL noch eine Idee.
 

wolfi

Aktives Mitglied
13. März 2013
34
0
wobei der Fehler bei core.connector.auth auftritt - hört sich fast an als gäbe es die Connector-Benutzerdaten 2x. Soweit ich weiß stehen die aber gar nicht mehr in der Datenbank, sondern in der config.json Datei auf dem FTP Server. Vielleicht hat Immanuel von JTL noch eine Idee.
Danke bork für deine Hilfe.
Ich werde das mal durchtesten.
Von JTL meldet sich leider niemand.

Danke!!!!
 

wolfi

Aktives Mitglied
13. März 2013
34
0
Also irgendwo gibt es einen doppelten Eintrag der nur 1x vorkommen darf. Woher das jetzt genau kommt, kann man aus der Ferne nicht nachvollziehen.

Wie ist der Connector denn eingestellt? Import und Export? Welche Daten werden in welche Richtung transportiert? Wenn du da mal alles ausstellst und dann immer eins zusätzlich an und anschließend direkt probierst den Abgleich durchzuführen, kann man zumindest schonmal sagen welche Tabelle betroffen ist und dann das Problem eingrenzen.
Ich kann leider keinen Abgleich durchführen, da ich ja nicht mal eine Verbindung aufbauen kann.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Problem Bildimport - Mehrfachupload von ein und dem selben Bild JTL-Ameise - Fehler und Bugs 0
Neu PROBLEM: Import durch Ameise Indiv. VK-Brutto User helfen Usern - Fragen zu JTL-Wawi 1
Neu Problem beim Update der Vorlagen für eBay eBay-Designvorlagen - Fehler und Bugs 8
Neu Umlaute Problem - UTF-8 Modified eCommerce-Connector 6
Offen Problem mit Grundpreis Gambio-Connector 1
Neu Bonuspunkte Position ( Versendet aber nicht gepickt Problem) User helfen Usern - Fragen zu JTL-Wawi 0
Neu Problem mit Bildern Ebay Variationsartikel Arbeitsabläufe in JTL-Wawi 8
Offen WMS Mobil auf Apple Ipad mit kleinem Problem JTL-WMS - Fehler und Bugs 3
Neu JTL Shopify Connector - Steuer Problem Shopify-Connector 6
Neu Editor-Problem und Darstellungsproblem in der Artikelübersicht JTL-Wawi - Fehler und Bugs 0
Neu Problem mit Plugin, kann mir jemand sagen was der Fehler bedeutet? Plugins für JTL-Shop 4
Neu LS-POS - RAW Druckvorlage problem mit @Logo1 Fragen rund um LS-POS 3
Neu Problem mit Lizenzierung JTL-Wawi User helfen Usern - Fragen zu JTL-Wawi 2
Neu (gelöst) Problem mit Variationsbox/Variationsauswahl Gelöste Themen in diesem Bereich 0
Neu Mwst Problem im Warenkorb WooCommerce-Connector 3
Gelöst Problem Anbindung WooCommerce 4 Gelöste Themen in diesem Bereich 1
Neu Reservierte Produkte in Aufträgen Problem! User helfen Usern - Fragen zu JTL-Wawi 1
Neu Problem mit Lieferzeit als Werktage - System-Lieferzeit ist falsch Betrieb / Pflege von JTL-Shop 1
Neu Rechnungsstellung mit falscher Artikelbeschreibung Arbeitsabläufe in JTL-Wawi 2
Neu Meine Artikel samt eigener Attribute mit Ameise importieren Starten mit JTL: Projektabwicklung & Migration 0
Neu Anzeige der Angebote ohne Mwst. und mit eBay-Anbindung - Ideen, Lob und Kritik 0
Neu Absenderreferenz für DHL-Labelerzeugung (Versenden 3.0) als Variable um Kundenspezifische Absender (mit Logo) nutzen zu können JTL-Wawi - Ideen, Lob und Kritik 0
Neu Versandart mit Preisstaffel Einrichtung von JTL-Shop 1
Neu Aktivieren/deaktivieren von Sonderpreisen mit der Ameise User helfen Usern - Fragen zu JTL-Wawi 0
Neu Preisliste mit CrossSelling-Artikeln User helfen Usern - Fragen zu JTL-Wawi 0
Neu Leistungsdatum in Rechnungsvorlagen als Variable (mit automatischer Ermittlung) JTL-Wawi - Ideen, Lob und Kritik 0
Neu JTL Wawi Datenabgleich mit Shopify Onlineshop-Anbindung 0
Neu 1.5.24.1 - gesperrtes Lager mit Zulauf? JTL-Wawi - Fehler und Bugs 0
Neu Angebot mit Lieferadresse versehen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Offen "Ebay Kategorien" werden zu Woocommerce product_attributes Shop Synchronisation mit JTL WooCommerce-Connector 1
Neu Probleme beim Shopabgleich / Bilderübertragung findet nicht statt / bricht mit 404er ab... Shopify-Connector 3
Gelöst Freipositionen mit 19% - Dringend Gelöste Themen in diesem Bereich 4
Offen Kassierer mit Namen auf dem Kassenbon ausweisen Allgemeine Fragen zu JTL-POS 2
In Bearbeitung Rechnungen mit 19% ausgewiesen, da Aufträge schon am 30.06. erstellt JTL-Wawi - Fehler und Bugs 4
Gelöst Gelöst: Kundenansprache im Shop nur mit Vorname Gelöste Themen in diesem Bereich 0
Offen Import/Export (CSV) - Artikelimport mit PLU Einrichtung / Updates von JTL-POS 2
Neu Neue Kinderartikel mit Problemen User helfen Usern - Fragen zu JTL-Wawi 2
Offen Workflow für Email versenden mit definierter Absender-Emailadresse ermöglichen JTL-Workflows - Ideen, Lob und Kritik 1
Neu Amazon unterschiedliche Stückzahlen mit einem Artikelstamm verknüpfen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Übersicht Versand - lieferbare Aufträge - mit Artikelkurzbezeichnung Individuelle Listenansichten in der JTL-Wawi 0
Neu Versandliste mit Artikel in Kurzfassung Individuelle Listenansichten in der JTL-Wawi 0
In Bearbeitung Formular in JTL-Warenwirtschaft mit Datenbankzugriff, Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Gelöst VCS mit eigenen Rechnungen Amazon-Anbindung - Ideen, Lob und Kritik 1
Offen Template für neue Artikel/Kategorien mit Gambio-Attributen Gambio-Connector 2
Gelöst Probleme mit Rechnung versenden/Speichern Workflow Gelöste Themen in diesem Bereich 3
Neu Artikeletikett mit Sonderpreis, wenn vorhanden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu Exportvorlagen Angebot Netto-Positionspreis mit 4 Nachkommastellen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
Neu JTL Barcodes mit Scanner und externer Liste User helfen Usern - Fragen zu JTL-Wawi 1
Neu E-Mail Vorlage Auftragsbestätigung mit Produktbildern, die proportional sind und nicht verzerrt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
In Diskussion Wawi mit POS auf Einzelrechner Einrichtung / Updates von JTL-POS 3
Ähnliche Themen