Neu Probleme beim Verbinden mit SQL Server von Arbeitsplatzrechner

Pucci

Mitglied
17. August 2021
41
10
Hallo,
ich wollte die Wawi auf einem Haupt-Pc installieren und anschließend dann auf einem anderen Arbeitsplatz, welcher auf die Datenbank des Haupt-PCs zugreift.
Auf dem Haupt PC kann ich nach Installation die Datenbank ohne Probleme öffnen, aber auf dem anderen Arbeitsplatz komischerweise nicht. Die PCs sind beide im gleichen Netzwerk.
Ich habe dann selbstverständlich mich durchs Forum gewühlt, wurde aber einfach nicht schlau. Als Servername habe ich den namen des pc (so wie es auch in den tutorials erklärt wird) angegeben. Dann \JTLWAWI (die instanz heißt auch zu 100% so) und das hat nicht funktioniert. Anschließend dann mit dem Port. Also PCName,Port\JTLWAWI
das hat auch nicht funktioniert. Letzten Endes habe ich es auch mit der IP-Adresse probiert und das ging auch nicht.
TCP/IP ist aktiviert. Und die Dienste sehen folgendermaßen aus:

Screenshot 2022-04-26 203743.png

Hat der SQL Server-Agent was damit zu tun?


Im SQL Server Configuration Manager sieht es bei den Server-Diensten so aus:
1650998916741.png


Die Fehler Meldung bei dem anderen Arbeitsplatz sieht so aus:
Screenshot 2022-04-26 202855.png

Und leider weiß ich mittlerweile auch nicht mehr so richtig weiter, was ich noch ausprobieren kann. Damit das funktioniert.
Ach ja, die Antivirus-Software habe ich auch abgeschaltet.
Die JTL-Wawi Datenbankverwaltung habe ich auch als Adminstrator gestartet.

Hoffe, mir kann hier eventuell jemand weiterhelfen :D
 

Christian_Röhl

Aktives Mitglied
7. Mai 2015
20
7
Berlin
Moin, hast du den Port der DB in der Firewall freigegeben? Der Server-Agent spielt hier keine Rolle, der ist wichtig bei den zu definierenden Wartungspänen, das macht aber nur bei der Standardversion Sinn.

Bitte FW prüfen und dort den Port der DB freigeben. Vom PC aus kann man das testen telnet IP port, telnet muß aber als feature nachinstalliert werden. Gern auch PN, dann machen wir das morgen kurz per TeamViewer. Dauert 5 Min.
 
  • Gefällt mir
Reaktionen: SebiW

FitBike

Neues Mitglied
13. Mai 2022
3
0
Moin, hast du den Port der DB in der Firewall freigegeben? Der Server-Agent spielt hier keine Rolle, der ist wichtig bei den zu definierenden Wartungspänen, das macht aber nur bei der Standardversion Sinn.

Bitte FW prüfen und dort den Port der DB freigeben. Vom PC aus kann man das testen telnet IP port, telnet muß aber als feature nachinstalliert werden. Gern auch PN, dann machen wir das morgen kurz per TeamViewer. Dauert 5 Min.
Hallo ich habe das gleiche Problem denke ich. Aber ich verstehe leider nur Bahnhof. würdest du mir per teamViewer helfen?
 

Pucci

Mitglied
17. August 2021
41
10

ergowebshop

Neues Mitglied
14. Januar 2022
15
4
Anschließend dann mit dem Port. Also PCName,Port\JTLWAWI
Vielleicht nur ein Tippfehler, aber es müsste heißen: PCName\JTLWAWI,Port
falls noch jemand das Problem hat.


Der sql server wird mir dort nicht angezeigt
Du meinst der SQL Server taucht nicht bei Firewall Regeln auf?
Na dann wie im Artikel erwähnt einen neuen Eintrag hinzufügen:

In der Liste schauen wir, ob wir einen Eintrag für den SQL-Serverzugriff entdecken. Wenn nicht, legen wir diesen Eintrag neu an. Dazu klicken wir mit der Rechten Maustaste auf den Punkt Eingehende Regeln und danach auf Neue Regel … Es öffnet sich der Assistent für neue eingehende Regel.
 

Kaffeeautomatenersatzteil

Neues Mitglied
17. Februar 2022
15
5
Hallo, ich habe ein ähnliches Problem seit gestern.

Der DB-Server ist ein eigener Server, der über IP in der Domäne erreichbar ist, etwa so wie hier:

SRV-DBxxxxx\JTL WAWI.

Das hat Monate funktioniert, seit gestern nicht mehr.

Nach langer Suche habe ich auf dem Terminalserver und dem DB-Server die Firewalls deaktiviert
und in der Wawi ein neues DB-Profil mit der IP statt dem Namen erstellt:

192.xxx.xxx.xxx\JTLWAWI

Das funktioniert jetzt, jedoch nur bei ausgeschalteten Firewalls.

Das man die IP statt des Namens nimmt ist ja nicht weiter tragisch.
Hat evtl. noch den Vorteil, wenn der DNS mal ein Problem hat, bekommt man immer noch die Verbindung.

Gibt es irgendwo eine aktuelle Schritt für Schritt Anleitung, wie die Firewalls zu konfigurieren sind und welche Ports ggf.
auch im SQL Configurationsmanager unter TCP/IP Protokolle einzustellen sind?

Dort steht bei mir:
  • unter IPAll Dynamische Ports 49720
  • unter IP2 ( wo die IP 192.xxx.xxx.xxx steht ) Dymamische TCP-Ports = 0
  • TCP Port = Kein Eintrag
Alle Anleitungen die ich bisher gefunden habe, sind entweder veraltet ( Windows 7 )
Oder beschreiben nur, das die Regeln entsprechend zu konfigurieren sind.

Aber die Aussage. " das dies entsprechend zu konfigurieren ist" , ist ja keine Anleitung.
Hat jemand eine Lösung ?
 

Shopworker.de

Offizieller Servicepartner
SPBanner
4. Januar 2011
3.993
500
Arnsberg, Sauerland

Kaffeeautomatenersatzteil

Neues Mitglied
17. Februar 2022
15
5
Hallo,
vielen Dank für Eure Hilfe, das ist wirklich sehr nett das es jemand liest und auch antwortet.

Die genannte JTL Anleitung hatte ich schon gefunden, jedoch kann ich damit leider gar nichts anfangen, weil das veraltet ist.

Ich gehe davon aus, das grundsätzlich nur " Eingehende " Regeln auf dem DB Server gemeint sind.
Muss es auch eingehende/ausgehende Regeln auf dem Terminalserver geben ?

Aktuell sieht die Firewall jedenfalls ganz anders aus als in der Anleitung.
Viele Dinge können dort eingestellt werden und Häkchen gesetzt.

Für jemanden der das Tag ein / Tag aus macht ist es vermutlich schnell gelöst.

Für alle anderen stellt sich das so dar, das man das ja nicht jeden Tag sieht und sich bei manchem Haken
nicht vorstellen kann ob es richtig oder zwingend erforderlich ist.

Ich füge hier mal ein Bild an.
Das sind die eigehenden Regeln auf dem DB-Server.
Es gibt noch eine "ausgehende" für UDP-Ports auf dem DB Server.

Der Terminalserver hat gar keine SQL-Regeln.

Wer jetzt leicht verwirrt ist, dem geht es wie mir....
Den festen Port 50888 habe ich selbst hinzugefügt, auch im SQL Configuration Manager unter IPAll

Das hat aber nicht geholfen.

Ich vermute, ein Windows Security Update für Defender hat mir am Mittwoch Abend etwas verändert, was dazu führte,
das dann keine Datenbankverbindung mehr ausgebaut werden konnte.

1653655755757.png
 

zeroalex

Aktives Mitglied
19. September 2015
40
0
Hallo,

schau bitte mal nach dem Firewall Profil, nicht das dies auf Öffentlich steht. Das passiert hier und da mal nach einem Update.
 

Kaffeeautomatenersatzteil

Neues Mitglied
17. Februar 2022
15
5
Hallo an Alle, die dieses Thema verfolgen.

Ich habe mittlerweile eine Lösung für die Firewall auf dem externen DB-Server gefunden, die zumindest funktioniert.
Den Port 50888 habe ich im SQL-Konfugurationsmanager unter

-> SQL Server Netzwerkkofiguration -> Protokolle für JTLWAWI -> TCP/IP -> -IP-Adressen -> IPAll eingetragen.
bei Dynamische TCP-Ports eine 0 ( Null ) um die Verwendung dynamischer Ports zu erlauben.

Ob dies die beste und vor allem eine sichere Lösung ist, kann ich nicht beurteilen.
Ich glaube das geht noch besser, vor allem Dynamische Ports unter IPAll könnten mit den Reglen möglicherweise unsinnig sein.

Für eingehende Reglen habe ich lokale Ports verwendet, für ausgehende die Remoteports.

In Anleitungen steht oft nur das Ports freigegeben werden müssen, aber Angaben ob ein.- oder ausgehende Regeln gemeint sind,
welche davon erforderlich und in welcher Regel lokale ports oder remote-ports eingestellt werden müssen habe ich leider nicht gefunden.

Sobald ich in den Reglen zusätzlich die sqlserv.exe als zugelassenes Programm eintrage, geht in der WaWi auf dem Terminalserver nichts mehr:
Wenn jemand sieht was hier grundsätzlich falsch ist oder besser gemacht werden kann, bitte hier posten, dann haben alle Leser etwas davon.

Ich wünsche Allen eine schöne Woche...

1653809400390.png


1653809778444.png
 

ergowebshop

Neues Mitglied
14. Januar 2022
15
4
Hallo.
Bei dynamische Ports eine 0 einzutragen führt zu genau dem was das Wort und die Beschreibung darunter sagt, dynamisch, also einen immer wechselnden Port. Deswegen ging es bei dir womöglich Monate lang und jetzt nicht mehr.

Wir haben den sog. dynamischen Port fest eingetragen unter IPAll und in der Firewall und so funktioniert das seit Monaten. Es reicht auch eine Regel mit lokalem Port und nur TCP. In unserem Fall auf einem Windows Server 2016 mit SQL Server 2017 ist das übrigens.

Bei dir dann halt entsprechend mit Port 50888.

Vielleicht nur ein Tippfehler, aber der SQL Server heißt sqlservr.exe, nicht sqlserv.exe


1653993301466.png
 

Kaffeeautomatenersatzteil

Neues Mitglied
17. Februar 2022
15
5
Hallo Ergowebshop,

danke für die " Inspiration "... Das funktioniert.

Ich kann bei " Eingehende Regeln " für die TCP Ports 1433, 50xxx jetzt auch den Pfad zur sqlsevr.exe ( war ein Tippfehler von mir )
als zugelassenes Programm eintragen. Die Wawi meckert hier nicht...

Die Eingehende Regel UDP Port 1434 habe ich erstmal aktiv gelassen, funktioniert aber nicht mit den Pfad zur sqlsevr.exe.
wenn ich dort den Pfad zur sqlsevr.exe eintrage, findet die Wawi die Datenbank nicht. Den UDP Port 1434 ( Eingehende Regel )
braucht also nach meiner Einschätzung eine oder eine weitere Anwendung.

Die 2 ausgehenden Regeln ( die für TCP Port und die Regel für UDP Port ) habe ich auch zunächst drin gelassen,
aber auch die Ports wie oben geändert und lokale Ports statt Remote Ports gewählt. Auch das funktioniert.

Bei den 2 "ausgehenden Regeln" habe ich beliebige Programme zugelassen.
Eine Beschränkung auf die sqlsevr.exe habe ich nicht getestet.

Schöne Grüße an alle Leser, hoffentlich können hier weitere User profitieren
und Ihre Verbindung zur Datenbank wiederherstellen, falls Diese mal nicht geht.
 
  • Gefällt mir
Reaktionen: ergowebshop

ergowebshop

Neues Mitglied
14. Januar 2022
15
4
Auf 1434 horcht für gewöhnlich der sog. SQL Server Browser für benannte Instanzen.

Die Idee ist das alle Clients sagen "ich will auf Server XYZ, Instanz JTLWAWI", dann fragen die bei XYZ auf Port 1434 und der Server sucht die Instanz raus, man muss dann nicht mit dynamischen Ports hantieren. Also wenn du nur auf "192.xxx.xxx.xxx\JTLWAWI" gehst ohne Portangabe, ja dann kann es sein, dass er die 1434 braucht, dann muss aber afaik auch im SQL Server Configuration Manager der Dienst dazu aktiviert sein.

Gib einfach den Port mit an und gut. 😅 Wir haben auch "beliebiges Programm" in der Regel und nicht nur auf die Exe beschränkt.
 

Kaffeeautomatenersatzteil

Neues Mitglied
17. Februar 2022
15
5
Vielen Dank.

Ich habe zum besseren Verständnis aktuell noch diese weiterführenden Erklärungen von Microsoft gelesen:
https://docs.microsoft.com/de-de/sq...atabase-engine-and-ssas?view=sql-server-ver16

Das Thema ist schon sehr viel umfangreicher, als man es sich vorher denkt.
Jetzt verstehe ich auch , das es nicht mal eben so gemacht ist und das es hier viele Abhängigkeiten und Möglichkeiten gibt.

Grüße
 
  • Gefällt mir
Reaktionen: ergowebshop
Ähnliche Themen
Titel Forum Antworten Datum
Neu Probleme beim Uk-Export - Zollinhaltserklärung CN23 veraltet? Arbeitsabläufe in JTL-Wawi 2
Neu Probleme beim Update auf 1.6 - Datenbank Fehler? Ideen zur Lösung? JTL-Wawi 1.6 1
Neu Probleme mit Ameise beim Artikelimport / Artikelaktualisierung und Lieferantenartikeln (insbes. mit Dropshipping + VPE) JTL-Ameise - Fehler und Bugs 22
Neu Probleme mit Yahoo und Internet Provider Allgemeine Fragen zu JTL-Shop 2
Neu Gibts gerade Probleme mit JTL Shipping? JTL-ShippingLabels - Fehler und Bugs 32
Neu Probleme mit PayPal Express JTL-Shop - Fehler und Bugs 2
Hilfe! Habe Probleme, "Rechnungskorrekturen" FINAL zu verstehen - traue mich nicht mehr, irgendwas zu machen! JTL-Wawi 1.6 18
Neu Probleme mit Duplicate Content Blogbeiträge Betrieb / Pflege von JTL-Shop 0
Verwiesen an Support Probleme mit GS1-128 und Packtisch+ JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 4
In Bearbeitung Rechnungserstellung via POS und Probleme mit dem Steuerberater Allgemeine Fragen zu JTL-POS 1
Neu Probleme bei Shop4 PayPal Express Zahlungen gehäuft JTL-Shop - Fehler und Bugs 45
Neu Achtung: Probleme mit Englischer WaWi JTL-Wawi 1.6 0
Neu Probleme mit Upload (Artikel, Hersteller, Kategorien) Shopware-Connector 4
Neu Probleme bei instalation User helfen Usern - Fragen zu JTL-Wawi 1
Händlerbund Rechtsprüfung Probleme Einrichtung JTL-Shop5 4
In Bearbeitung Gastro Probleme Allgemeine Fragen zu JTL-POS 3
Neu JTL-Vouchers UI: Probleme bei der Anzeige von Gutscheinen mit PIN JTL-Wawi - Fehler und Bugs 0
Neu Probleme mit Paypal Checkout: Plugin stürzt ab Plugins für JTL-Shop 3
Neu Shopware Abgleich - JTL 1.6 Probleme Shopware-Connector 3
Neu Probleme mit der Amazon-Schnittstelle --> Selbsterstellte Produktseite bleibt dauerhaft im Status gesendet Amazon-Anbindung - Fehler und Bugs 9
Neu Probleme mit aufzustellende Vorlagen auf Ebay eBay-Anbindung - Fehler und Bugs 4
Neu Exportformat Googleshopping - Probleme Schreibrechte Plugins für JTL-Shop 5
Neu Probleme mit der InvoicePosition.ProductInternalId Individuelle Listenansichten in der JTL-Wawi 1
Neu Neu angelegte Sprache und Probleme in der Länderverwaltung Allgemeine Fragen zu JTL-Shop 0
Neu Naues PayPal Checkout Plugin macht Probleme bei der Installation Plugins für JTL-Shop 9
Beantwortet JTLWawiExtern - Mail-Versand macht Probleme [erledigt] Schnittstellen Import / Export 3
Neu Neues ebay Template - Probleme mit Schriftdarstellung User helfen Usern - Fragen zu JTL-Wawi 0
Neu Beta 1.6.35.2 Probleme mit Steuerschlüsselname JTL-Wawi - Fehler und Bugs 2
Neu Probleme mit dem Child Template nach Shop 5 Update Installation / Updates von JTL-Shop 2
Neu Probleme mit Bildeinbindung und Links in den News Allgemeine Fragen zu JTL-Shop 0
Neu Fehler beim Export: Deprecated: JTL\Catalog\Currency: getter should be used to get cISO in /var/www/vhosts/ JTL-Shop - Fehler und Bugs 0
Fehler beim Update JTL-Wawi 1.6 0
Neu Gratisbeigabe beim Kauf bestimmter Artikel Allgemeine Fragen zu JTL-Shop 0
Neu Beim Hochladen wird die Steuerklasse auf 0 gesetzt! Gambio-Connector 4
Neu Problem / Fehler beim Update von JTL Connector 2.2.5.3 auf 2.13.0 (Shopware 5.5.10) Shopware-Connector 1
Neu WAWI 1.6.38.2: Skontosatz geht beim Erstellen der Rechnung verloren JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Shopify Abgleich Shopify-Connector 0
Neu Fehler beim senden von Rechnungen per Mail JTL-Wawi - Fehler und Bugs 1
Kopf & Fußzeile sind verschwunden bei der Rechnungsvorlage beim Drucken JTL-Wawi 1.6 0
Neu Fehler beim Bearbeiten von Vorlagen Bausteinen JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Abgleich mit Shopware 6.4.11.1 Onlineshop-Anbindung 3
Neu Wawi 1.6 / Kommunikation aus Wawi wird beim Lieferanten (in JTL wawi) nicht abgelegt JTL-Wawi - Fehler und Bugs 2
MwSt. beim Versand JTL-Wawi 1.6 6
Neu (WooCommerce) JTL Connector Aufträge lassen sich nicht bearbeiten "Fehler beim MARS-Batch" User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim heutigen Update von 1.6.38.1 auf 1.6.38.2 Installation von JTL-Wawi 1
Beantwortet JTL Wawi reagiert nicht mehr beim Klick auf "VCS Rechnungsduplikate" JTL-Wawi - Fehler und Bugs 2
In Bearbeitung Wawi stürzt ab beim markieren in Listen JTL-Wawi 1.6 3
Problem beim Importieren neuer Kategorien über Ameise - Kategorien Level und Interner Schlüssel gesetzt JTL-Wawi 1.6 4
Neu Individuelle Kundennachricht beim Angebot mitschicken User helfen Usern - Fragen zu JTL-Wawi 2
Neu Nichtgelieferte/Defekte Waren beim Wareneingang vermerken Arbeitsabläufe in JTL-Wawi 3

Ähnliche Themen