Neu PayPal leitet nicht korrekt zum Shop zurück

Pluto

Aktives Mitglied
3. Juli 2014
96
1
Hannover
Moin,

ich bin mit meiner Recherche aktuell auf unser Kundenfeedback angewiesen, da ich es selbst nicht testen kann (Sandbox Modus scheint irgendwie nie so recht zu klappen). Anhand der Informationen sieht die Sache so aus:

Wenn ein Kunde über PayPal PLUS einen Artikel kaufen möchte, so wird er zu PayPal weitergeleitet, gibt dort seine Daten ein, bestätigt und sollte dann - im Normalfall - wieder zurück zum Shop gelangen. Dies scheint nicht zu funktionieren. Ist ein wenig "Stille Post" da die Kunden das Problem unseren Vertrieblern schildern und diese dann wiederrum mir. Die Aussage der Kunden: Die Seite scheint nicht zu laden bzw. es gibt einen Timeout und die Bestellung kann nicht abgeschlossen werden.

Einige Kunden haben dann, nachdem Sie 2-3x die Bestellung erneut ausgeführt haben PayPal Express genutzt - dies scheint also problemlos zu funktionieren. Ob es beim normalen PayPal auch auftritt kann ich leider derzeit nicht sagen.

Die Validation ist bei PayPal Basic, Express und PLUS jeweils erfolgreich. Einstellungen sollten auch alle passen. Im Systemlog werden keine Fehler angezeigt, was die Fehlerursache natürlich erschwert. In anderen Shops die noch auf der 4.0.1 laufen habe ich den Fehler nicht bei gleichen Einstellungen.

Hat jemand vielleicht einen Ratschlag, wie und wo man hier ansetzen kann um den Fehler ausfindig zu machen? Das Problem tritt vermutlich erst seit der Umstellung auf den neuen Shop 4.0.5 auf, vorher war Version 3.2 im Einsatz.

Vorab besten Dank 🙂

---
WAWI: 1.1.4.14
JTL-Shop: 4.0.5
Templateversion 4.05
Datenbankversion 4.05
PHP-Version 7.0.15
MySQL-Version: 5.6.35
 
Zuletzt bearbeitet:

Frank Hoffmeister

Sehr aktives Mitglied
11. Mai 2014
145
28
Kenn ich, was letztendlich wirklich hilft, php speicherlimit 512 und timeout 240 dann geht es, noch zusätzlich hotfix für Paypal Plugin 106 einspielen.
Mfg
Frank Hoffmeister
 

Pluto

Aktives Mitglied
3. Juli 2014
96
1
Hannover
Guten Morgen und vielen Dank für Ihre Antwort - damit versuche ich es.
Das memory_limit hatte ich bereits auf 512, aber die execution_time habe ich jetzt entsprechend erhöht.
Wenn das Hotfix die .class Datei ist, war das auch schon eingespielt 🙂
 

Pluto

Aktives Mitglied
3. Juli 2014
96
1
Hannover
Hallo Paddelparadies,
eine Return URL habe ich nicht angegeben, allerdings mit dem Gedanken gespielt, nachdem ich die Möglichkeit dazu gefunden hatte.
Da nirgends etwas dazu stand - also sprich in einer Anleitung oder HowTo (es sei denn ich habe es mehrfach überlesen) - wollte ich keine Experimente im Livebetrieb machen.
Ich muss aber sagen, dass ich seit der Umstellung der execution time kein negatives Feedback mehr aus unserem Vertrieb gehört habe. Entweder es scheint daran gelegen zu haben... oder ich bekomme allgemein kein Feedback mehr 🙂
 

Ähnliche Themen