Gelöst ich kann nicht auf meinen Shop zugreifen

pagger

Mitglied
13. Februar 2018
10
0
Ich habe alles wie in der Beschreibung durch geführt. (Entfernen Sie nach erfolgreicher Installation das install/-Verzeichnis aus Ihrem Shop. Der Datei includes/config.JTL-Shop.ini.php sollten Schreibrechte entzogen werden. 644 ist ab jetzt ausreichend für diese Datei.)
Wenn ich nun auf meine Seite gehe kommt folgender Text. Die Konfigurationsdatei des Shops konnte nicht geladen werden! Bei einer Neuinstallation bitte hier klicken.
Wenn ich dann darauf klicke ändert sich nur die Adresszeile und sonst nix: meinehp/install/index.php. Klicke ich nochmal drauf dann fügt sich nur ein install vor das andere hinzu. Bitte was habe ich falsch gemacht oder was kann ich ändern. Bin völlig am Verzweifeln.
lg
 

ag-websolutions.de

Sehr aktives Mitglied
29. Dezember 2009
14.548
233
Hast du noch mal die Dateirechte der includes/config.JTL-Shop.ini.php geprüft?

Hast du diese wirklich auf 644 stehen?
Bei welchem Webhoster bist du?
 

pagger

Mitglied
13. Februar 2018
10
0
Ich bin bei all-inkl.com und ich habe 644 stehen bei includes/config.JTL-Shop.ini.initial.php
die andere ist nicht mehr da. Die ist seit dem Löschen vom Installordner weg.
 
Zuletzt bearbeitet:

ag-websolutions.de

Sehr aktives Mitglied
29. Dezember 2009
14.548
233
all-inkl ist eigentlich ein sehr passabler hoster für kleinere JTL-Shops.

Was passiert denn, wenn du die Rechte wieder auf 777 zurück setzt?
Welchen Inhalt hat denn deine includes/config.JTL-Shop.ini.php?
 

pagger

Mitglied
13. Februar 2018
10
0
wenn ich es auf 777 setze ändert das nichts.
die habe ich nicht, die includes/config.JTL-Shop.ini.php
 

pagger

Mitglied
13. Februar 2018
10
0
Ich habe nur diese: includes/config.JTL-Shop.ini.initial.php und die ist auch auf 644 gestellt.
 

ag-websolutions.de

Sehr aktives Mitglied
29. Dezember 2009
14.548
233
Ich habe nur diese: includes/config.JTL-Shop.ini.initial.php

Dann ist die Installation nicht / fehlerheaft gelaufen.

Du mmusst diese Datei VOR start der Installation umbenennen in config.JTL-Shop.ini.php

also das ".initial" raus nehmen ... Dann installieren

Zitat aus dem Guide

Bei einer Neuinstallation des JTL-Shop ist standardmäßig die Datei includes/config.JTL-Shop.ini.php nicht angelegt. In dieser Datei werden während der Installation wichtige Datenbankverbindungs-Einstellungen geschrieben sowie das Verschlüsselungspasswort für sensible Kundendaten gespeichert. Die Datei config.JTL-Shop.ini.php ist im Ordner includes nicht vorhanden, benennen Sie die Datei config.JTL-Shop.ini.initial.php um in config.JTL-Shop.ini.php. Für die Installation geben Sie dieser Datei bitte auch Schreibrechte (Im Zweifel 777).

https://guide.jtl-software.de/JTL-Shop_neu_installieren
 
  • Gefällt mir
Reaktionen: sah

pagger

Mitglied
13. Februar 2018
10
0
So nun kommt folgende Fehlermeldung wenn ich auf meinen Shop gehe nach der Installation: Warning: require_once(/www/htdocs/w017a013/topstein-petfood.com/includes/config.JTL-Shop.ini.php): failed to open stream: Permission denied in /www/htdocs/w017a013/topstein-petfood.com/includes/globalinclude.php on line 9

Fatal error: require_once(): Failed opening required '/www/htdocs/w017a013/topstein-petfood.com/includes/config.JTL-Shop.ini.php' (include_path='.:/usr/share/php:..') in /www/htdocs/w017a013/topstein-petfood.com/includes/globalinclude.php on line 9


das steht in line 9: require_once dirname(__FILE__) . '/config.JTL-Shop.ini.php';

 

pagger

Mitglied
13. Februar 2018
10
0
und das kommt wenn ich auf shop-backend gehe:
Warning: require(/www/htdocs/w017a013/topstein-petfood.com/includes/config.JTL-Shop.ini.php): failed to open stream: Permission denied in /www/htdocs/w017a013/topstein-petfood.com/admin/includes/admininclude.php on line 10

Warning: require(/www/htdocs/w017a013/topstein-petfood.com/includes/config.JTL-Shop.ini.php): failed to open stream: Permission denied in /www/htdocs/w017a013/topstein-petfood.com/admin/includes/admininclude.php on line 10

Fatal error: require(): Failed opening required '/www/htdocs/w017a013/topstein-petfood.com/admin/includes/../../includes/config.JTL-Shop.ini.php' (include_path='.:/usr/share/php:..') in /www/htdocs/w017a013/topstein-petfood.com/admin/includes/admininclude.php on line 10

in der line 10: }




 

pagger

Mitglied
13. Februar 2018
10
0
ich habe der includes/config.JTL-Shop.ini.php nicht auf 644 sondern auf 444 die Berechtigung gesetzt und dann klappte alles.
 

Ähnliche Themen