Beantwortet GELÖST - Verbindungstest JTL-Wawi 1.6 -> JTL-Shop 5.1 scheitert

tg@becarema

Neues Mitglied
10. August 2022
4
0
Hallo zusammen,
ich habe zum Testen einen neuen JTL-Shop in der aktuellen Version 5.1.4 und die aktuelle JTL-Wawi Version 1.6.41.2 installiert.
Leider lässt sich die Wawi nicht mit dem Shop verbinden, da beim Verbindungstest der Fehler "Beim Testen der Verbindung ist ein Fehler aufgetreten: Es wurden keine Daten vom Shop gesendet. Bitte prüfen Sie, ob die Schnittstelle auf der Shopseite einwandfrei funktioniert." auftritt.
Der Shop ist im Browser problemlos erreichbar, kann mich auch im Backend einloggen usw.
Habe bereits den Shop neu heruntergeladen und auf dem Webserver installiert, alles mit HTTPS und ohne versucht, kam jedoch bisher nie weiter als diese Fehlermeldung...

Beim Testen ohne Verschlüsselung habe ich die Verbindung mit Wireshark aufgezeichnet, die Wawi sendet einen POST an <shop-domain>/dbeS/mytest.php und bekommt vom Server auch eine Antwort 200 OK, die jedoch eine Content-Length von 0 hat.
Daraufhin habe ich mir die entsprechende Datei auf dem Server angeschaut, diese beinhaltet nur folgendes:
<?php // removed in 5.0.0
Daraus würde ich schließen, dass das nie funktionieren kann, wenn die Wawi eine Antwort von dieser Datei erwartet, da deren Funktionalität wohl in Shop Version 5 nicht mehr existiert?

Hat dieses Problem sonst noch jemand? Müsste ja bei allen Neuinstallationen auftreten?

Bin für jede Hilfe dankbar!
 

tg@becarema

Neues Mitglied
10. August 2022
4
0
In der Wawi habe ich bei Webserver -> Sync-Benutzername und Sync-Kennwort die Daten eingetragen, die im Shop unter /admin/wawisync.php hinterlegt sind.
 

Georg964

Sehr aktives Mitglied
25. März 2022
249
85
Dann würde ich mal den Hoster kontaktieren ob da was nicht durch die Firewall darf oder sonst irgendwas schief läuft auf dem Server.
 

tg@becarema

Neues Mitglied
10. August 2022
4
0
Dann würde ich mal den Hoster kontaktieren ob da was nicht durch die Firewall darf oder sonst irgendwas schief läuft auf dem Server.
Der Shop läuft auf einem eigenen Testserver (Ubuntu 20.04), als Firewall ist nur die ufw aktiv (Port 80 und 443 sind eingehend natürlich offen). Der Server hängt mit seiner Netzwerkkarte direkt im Internet, ohne zwischengeschaltete Firewalls.
 

tg@becarema

Neues Mitglied
10. August 2022
4
0
Habe das Problem gefunden. 🎉
In der Apache Konfiguration für den Shop war AllowOverride All noch nicht gesetzt, was ein peinlicher Fehler...

@Georg964 Danke für deine Mithilfe, der Post #5 hat mich letztendlich auf die richtige Idee gebracht.
 

forumjtlolshopag

Sehr aktives Mitglied
6. Juni 2018
843
245
Hatte gerade das gleiche Problem beim Plesk System mit dem JTL Shop 5. Musste den PHP Handler von FPM-nginx auf FPM-apache umstellen und schon hat es wieder funktioniert. Wahrscheinlich eine fehlende direktive für NGINX...
 

Ähnliche Themen