Neu Gambio Bestellungen: Import der Positionen als Freiposition?

bork

Gut bekanntes Mitglied
26. Januar 2007
467
7
Hallo,

unsere Amazon-Bestellungen werden in Gambio mit products_id 0 angelegt. Die Positionen wurden dann beim Import in die JTL Wawi trotzdem passend gemappt, vermutlich über die übereinstimmende Artikelnummer. Seit Update auf JTL Wawi 3. und Connector 3.10.2 werden die Bestellpositionen aber offenbar als Freipositionen importiert und der Bestand nicht mehr ausgebucht? Woran kann das liegen?
 

bork

Gut bekanntes Mitglied
26. Januar 2007
467
7
Nochmal weiter getestet: Bis einschließlich Connector-Version 2.9.x werden Bestellpositionen unabhängig von Gambio- und JTL Wawi-Version in JTL Wawi auch ohne products_id passend über die Artikelnummer gemappt und reduzieren in JTL Wawi den verfügbaren Warenbestand, ab 2.10.x geht das nicht mehr sondern die Positionen werden Freitextpositionen und werden nicht mehr reserviert. Kann man das wieder mit einbauen in den aktuellen Connector? Das wäre echt hilfreich.
 

bork

Gut bekanntes Mitglied
26. Januar 2007
467
7
Kann ich vielleicht mit GX 3.14.2.0 nochmal zurück auf den JTL Connector 2.9.x bis dies hier geklärt ist? Uns fliegen hier die Lagerbestände um die Ohren...
 

Niklas Kokoschka

Moderator
Mitarbeiter
31. Juli 2018
68
18
Hallo bork,

ich habe das Ganze gerade bei mir mit den folgenden Konfigurationen nachgestellt:
WAWI - 1.15.10.0
Connector - 2.10.3
Gambio Shop - 3.13
Es wurden die Artikel in den Bestellpositionen ordentlich gemapped und nicht als Freitextpositionen markiert.

Gruß,
Niklas Kokoschka
 

bork

Gut bekanntes Mitglied
26. Januar 2007
467
7
Hallo Niklas,

danke. Hast du gelesen dass es um Bestellpositionen geht die keine products_id hinterlegt haben?

VG
bork
 

bork

Gut bekanntes Mitglied
26. Januar 2007
467
7
Also Connector 2.9.x hat Artikel die auf anderen Wegen in den Gambio Shop kommen als über das Frontende (ohne Zuordnung von products_id und products_properties_combis_id) passend in der JTL Wawi gemappt, wenn die Artikelnummer identisch war. Connector 2.10.x macht das nicht mehr.

Frage 1 daher:
Ist das Verhalten unter 2.10.x ein Bug oder war das Verhalten unter 2.9.x ein Bug oder ist das Verhalten einfach nicht mehr gewünscht und daher deaktiviert?

Frage 2:
Für uns ist es total wichtig DASS es gemappt wird. Im Notfall müssen wir zusehen, dass die Daten per Cronjob passend in den Tabellen nachgetragen werden. Wie ich das sehe, wird gemappt über die endpoint_id Spalte in jtl_connector_link_products und die Syntax ist: <gambio products_id>_<gambio products_properties_combis_id> . Aus welchen Tabellen werden diese Teile denn zusammengesetzt? Ich habe schon versucht, die products_id und die properties_combi_model in die orders_products Tabelle einzutragen und eine neue Zeile in der orders_products_properties einzufügen. Das hilft aber nichts, das Produkt wird immer noch nicht in der JTL Wawi im Auftrag gemappt. Wenn ich wüsste, aus welchen Tabellen und Spalten sich der Connector die products_id und die products_properties_combis_id zur Bestellung zieht, komme ich auch so weiter...
 

Niklas Kokoschka

Moderator
Mitarbeiter
31. Juli 2018
68
18
Hallo bork,
Ich rate dir die Artikelnummern (SKUs), also die Spalten "combi_model " in "products_properties_combis" und "products_model" in 'products' entsprechend der Artikelnummern in der WAWI zu pflegen, damit diese beim Import von Bestellungen zum mapper der Produkte genutzt werden können.

Von der Logik her wie Bestellpositionen importiert werden, hat sich schon sehr lange nichts geändert.

Zu Frage 1:
Es handelt sich hier nicht um gewünschtes Verhalten. Alle Artikel sollten über die SKU gemapped werden, wenn keine Verknüpfung über die product_id (kein Eintrag in der Linking Tabelle) existiert.

Zu Frage 2;
Dadurch, dass du Artikel über Artikelnummern (SKUs) mappen möchtest, sollte die product_id an dieser Stelle für dich nicht relevant sein.
 

Niklas Kokoschka

Moderator
Mitarbeiter
31. Juli 2018
68
18
Hallo,
Am einfachsten wäre es wenn du im Shopbackend die Produkte durchgehst und dort das Feld "Artikel-Nr." mit dem Wert des Feldes "Artikelnummer" in der Wawi befüllst.Unbenannt.PNGUnbenannt2.PNG
 

bork

Gut bekanntes Mitglied
26. Januar 2007
467
7
Hallo,

das passt 1:1. Ich habe die Artikel ja alle vor etwa 10 Jahren in der Wawi erstellt und zu Gambio hochgeladen. Also alle Hauptartikel in der Wawi haben in Gambio die selbe products_model, und alle Kindartikel in der Wawi haben in der products_properties_combis die selbe combi_model. Aber seitdem ich den Connector 2.10.x benutze findet das Mapping nicht mehr statt.

VG
bork
 
Zuletzt bearbeitet:

Immanuel

Moderator
Mitarbeiter
24. August 2016
482
80
Hallo @bork,

in Connector Version 2.10.x wurde nichts bezüglich der sku an einer Bestellposition verändert. Bitte sende mir einen entsprechenden Abgleich Log per PM zu, in welchem sich eine Bestellung mit Bestellpositionenen, die nicht ordentlich gemapped wurden, befindet.
 

bork

Gut bekanntes Mitglied
26. Januar 2007
467
7
Danke, habe Log und Screenshot gemailt per PM. Ich habe noch eins wenn du ein zweites brauchst....
 

bork

Gut bekanntes Mitglied
26. Januar 2007
467
7
Danke JTL, danke Immanuel und Niklas!

Zur Info falls jemand auch mal dieses Problem hat: In die Tabelle jtl_connector_link_products hatte sich ein Eintrag mit endpoint_id 0 eingeschlichen, der nicht rein darf.
 
  • Gefällt mir
Reaktionen: Niklas Kokoschka

Über uns

  • In unserem moderierten JTL-Forum könnt Ihr Euch themenbezogen mit der JTL-Community rund um die Produkte von JTL, passende Erweiterungen und den E-Commerce im Allgemeinen austauschen, Tipps und Tricks teilen sowie Verbesserungswünsche und Fehler diskutieren.

    Unsere Forumsnutzer helfen sich untereinander auch gerne weiter, wenn Sie mal nicht weiterkommen oder einen Ratschlag benötigen.

Schnell-Navigation

Benutzer Menü