In Bearbeitung Fehlermeldung beim XML Auftragsimport

florando

Aktives Mitglied
16. Juni 2011
2
1
Hallo, wir sind in den letzten Tagen auf Wawi 1.1.4.7 umgestiegen und haben folgendes Problem: Wir möchten per XML-Export Aufträge von einem Mandanten zu einem anderen Mandanten importieren, was in der Vergangenheit mit WAWI<1 auch immer bestens geklappt hat.

Wir haben wie im Guide https://guide.jtl-software.de/jtl/K...ng#Auftr.C3.A4ge_per_CSV_oder_XML_exportieren
beschrieben eine Exportauftragsvorlage erstellt. Wenn wir die so generierte Auftrags-XML-Datei beim anderen Mandanten über Verkauf->Importieren->Aufträge(*.xml) importieren möchten, erhalten wir als Fehlermeldung:

"Der Wert NULL kann in die cVErsandlandWaehrung-Spalte, Mandant_8.dbo.tBestellung-Tabelle nicht eingefügt werden. Die spalte lässt NULL-Werte nicht zu. Fehler bei INSERT."

Wenn wir hingegen den Auftrag bei dem Mandanten, der die XML-Exportdatei erstellt hat, wiederum importieren, erhalten wir keinen Fehler.

Wir freuen uns über jede Hilfe, da wir den Austausch von Aufträgen zwischen Mandanten unbedingt benötigen.

Lieben Dank im Voraus.

Angehängt das Fehlerprotokoll
 

Anhänge

  • errorlog_20161026103955.txt
    11,9 KB · Aufrufe: 15

kowo

Aktives Mitglied
11. Dezember 2013
11
3
Hallo,

hast du die Firmennummer kontrolliert und im XML-File angepasst? Bei mir z.b. Firma 2:

--> <tBestellung kFirma="2">

Lg, Wolfgang
 

xferryx

Aktives Mitglied
1. März 2017
46
1
Hallo,

hat jemand mittlerweile eine Lösung gefunden? Wir haben das gleiche Problem. An der Firma kann es nicht liegen. Wir haben den Wert aus der Datenbank ausgelesen und eingetragen. Dennoch bekommen wir o. g. Fehlermeldung.
Gruß xferryx
 

Rico Giesler

Offizieller Servicepartner
SPBanner
10. Mai 2017
13.231
1.452
Bitte mal bei Mandant 2 prüfen wie der Export hier ausschaut:
<tBestellungen><tBestellung cRechnungsNr="" kFirma="5" cFirma="MeineFirma" cMandant="meinMandant">
Wenn man das bei dem Export von Mandant 1 anpasst sollte der Import in Mandant 2 möglich sein.

PS: Bitte auch prüfen ob die Währungen alle korrekt angelegt wurden (ISO-Codes auch prüfen)
 

xferryx

Aktives Mitglied
1. März 2017
46
1
ok, mein Fehler. Ich hab das mit den Mandanten oben überlesen. Wir haben nur einen Mandant.

Nach erneutem Versuch, jetzt mit Version 1.2.3.8, funktionierts. Danke
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Fehlermeldung beim Ausliefern User helfen Usern - Fragen zu JTL-Wawi 2
Neu Fehlermeldung beim aktualisiseren des Angebotes eBay-Anbindung - Fehler und Bugs 0
Neu Beim Shop abgleich kommt seit gestern immer eine Fehlermeldung mmit Interneterweiterung interner Fehler Onlineshop-Anbindung 10
Neu JTL Ameise Ebay CSV import | Fehlermeldung JTL-Wawi - Fehler und Bugs 1
Neu Fehlermeldung "Freiposition", obwohl Artikel angelegt wurde JTL-Wawi - Fehler und Bugs 1
Neu Fehlermeldung bei Artikel duplizieren JTL-Wawi - Fehler und Bugs 4
Neu Retoure Fehlermeldung User helfen Usern - Fragen zu JTL-Wawi 0
Neu Erster Datenabgleich modified zu JTLWAWI scheitert ohne ersichtliche Fehlermeldung Modified eCommerce-Connector 0
Neu Fehlermeldung: Ameise - Die Sequenz enthält keine Elemente JTL-Ameise - Fehler und Bugs 3
Neu Auftrag mit Fehlermeldung bearbeitet jetzt bleibt der offen. User helfen Usern - Fragen zu JTL-Wawi 0
Neu JTL-Wawi Fehlermeldung JTL-Wawi - Fehler und Bugs 7
Neu Fehlermeldung "Prime vom Verkäufer" User helfen Usern - Fragen zu JTL-Wawi 1
Neu InvalidShippingServieOfferId Fehlermeldung bei zwei Österreich Aufträgen (Amazon) JTL-ShippingLabels - Fehler und Bugs 12
Neu SQL Datenbank nicht gefunden - Fehlermeldung Individuelle Listenansichten in der JTL-Wawi 7
Gelöst Wareneingang lässt sich nicht buchen Fehlermeldung: Von den Bilddaten wurde bei der Verarbeitung ein Überlauf generiert User helfen Usern - Fragen zu JTL-Wawi 1
Neu Anbindung mit der neuen Ansicht verursacht eine Fehlermeldung Amazon-Anbindung - Fehler und Bugs 2
Neu JTL Search aus einem URL Verzeichnis führt zur 404 Fehlermeldung Allgemeine Fragen zu JTL-Shop 5
Neu Fehlermeldung dbo.tKunde Installation von JTL-Wawi 0
Neu Lieferantenauswahl beim Import JTL-Ameise - Fehler und Bugs 4
Neu Shopware 6 Connector Probleme beim Abgleich der Bestellungen mit Klarna Shopware-Connector 0
Neu DB-Fehler beim Update von 1.5 auf 1.6: Foreign Key in tBestellung JTL-Wawi - Fehler und Bugs 0
Neu Exportformat für AdCell - Problem beim Grundpreis Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Problem mit Fstr() beim Formatieren des Einzelstückpreises User helfen Usern - Fragen zu JTL-Wawi 1
Neu Pause beim Druck von Lieferscheinen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu Fehler beim Verpacken JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 1
Neu Lagerplatzempfehlung beim Einlagern Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 2
Neu Plugin Migrations werden beim deinstallieren nicht zurück gesetzt JTL-Shop - Fehler und Bugs 0
Neu Fehler beim Anlegen von Verkaufskanal Shop5 im Testsystem Onlineshop-Anbindung 0
Neu Problem beim Connect Shopify-Connector 1
Neu Rabatt beim Einkauf, nachträglich ändern User helfen Usern - Fragen zu JTL-Wawi 2
Neu Plugin: "JTL Theme Editor" in Shop 5 - Fehler beim Speichern der Datei. Allgemeine Fragen zu JTL-Shop 5
Neu Seitenränder/Shop Container auf eigene Seiten beim Composer Allgemeine Fragen zu JTL-Shop 1
Neu Fehler beim Anlegen von Verkaufskanal Shop5 im Testsystem Installation / Updates von JTL-Shop 3
Neu Produktion ohne zu wissen welche Stückzahl beim Endprodukt hergestellt wird. JTL-Plan&Produce - Ideen, Lob und Kritik 14
Neu Falscher Mailclient beim Export von Aufträgen und Co als PDF User helfen Usern 0
Neu Fehler beim Shopware Shopabgleich JTL-Wawi - Fehler und Bugs 0
Neu JTL SHOP 5 unter Mobile IOS Safari verschwindet das Menü beim Scrollen JTL-Shop - Fehler und Bugs 6
Neu Wawi mails landen beim Kunden im Spam Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Merkmale - Eingaben beim HTML-Editor werden nicht gespeichert - übernommen JTL-Wawi - Fehler und Bugs 2
Neu Fehler beim Abgleich WooCommerce-Connector 0
Neu Probleme beim importieren von Aufträgen JTL-Ameise - Fehler und Bugs 2
Issue angelegt UstID Fehler beim Import über Ameise - Wawi V1.5.49.1 User helfen Usern - Fragen zu JTL-Wawi 2
Neu Hilfe beim Workflow User helfen Usern - Fragen zu JTL-Wawi 2
Neu Konfigurator verursacht HTTP Error 500 beim Abgleich JTL-Shop - Fehler und Bugs 1
Neu Fehler beim Anlegen einer Umlagerung / Amazon-SKU Fehler Amazon-Lister - Fehler und Bugs 0
Neu Verzögerung beim Drucken von DHL Labels JTL-ShippingLabels - Fehler und Bugs 0
Neu INSERT Fehler beim Duplizieren von Artikeln JTL-Wawi - Fehler und Bugs 1
Neu Amazon Anbindung fehler beim Authorsieren ein neues Konto Amazon-Anbindung - Fehler und Bugs 0
Neu Fehler beim Abgleich WooCommerce-Connector 2
Neu Tag beim Kunden zu Shopify übertragen Shopify-Connector 7

Ähnliche Themen