Neu Fehler seit Upgrade von JTL Shop 4 (CFE) auf 5.0

PatrickSchaefer

Mitglied
20. Februar 2020
7
2
Moin,

habe soeben das Update durchgeführt und es funktioniert auch fast alles.
Jedoch werden keine Mails versendet, die Testmails jedoch schon.
Bei den E-Mail Vorlagen zeigt er mir als Status Inaktiv.
Nach dem zurücksetzen, welches funktioniert, zeigt er mir dann beim Speichern der Einstellungen folgenden Fehler an:

Die E-Mail-Vorlage ist fehlerhaft.
Smarty Syntax-Fehler:
on line: ...ad751cc34` resulted in a `403 Forbidden` response: (truncated...)

Hat einer eine Idee wodran das liegen kann?
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.881
529
Halle
Hm, die Meldung "...resulted in a `403 Forbidden..." deutet darauf hin, dass der Prozess, der die Syntaxprüfung für das Mailtemplate durchführt, nicht ausgeführt werden kann, weil der Server den Zugriff (wg. fehlender Rechte o.ä.) verweigert. Wenn dein Backend also ganz normal erreichbar ist und nicht zusätzlich per .htaccess ein Passwortschutz gesetzt ist, dann würde ich dich bitten morgen bei unserem Support ein Ticket mit Verweis auf diesen Thread zu eröffnen.
 

PatrickSchaefer

Mitglied
20. Februar 2020
7
2
Moin, der Support ist hier leider nicht behilflich, wegen fehlende m Bronze Support. Hat sonst vielleicht noch einer ne Idee? Neuinstallation half ebenfalls nichts.
 

Nicson

Sehr aktives Mitglied
29. August 2012
516
94
Bayern
Hi, ich hatte den selben Fehler, ein wenig Suche auf dem Server...
Code:
ModSecurity: Warning. Pattern match "(?i:(?:union\\\\s*?(?:all|distinct|[(!@]*?)?\\\\s*?[([]*?\\\\s*?select\\\\s+)|(?:\\\\w+\\\\s+like\\\\s+[\\"'`])|(?:like\\\\s*?[\\"'`]\\\\%)|(?:[\\"'`]\\\\s*?like\\\\W*?[\\"'`\\\\d])|(?:[\\"'`]\\\\s*?(?:n?and|x?x?or|div|like|between|and|not|\\\\|\\\\||\\\\&\\\\&)\\\\s+[\\\\s\\\\w]+=\\\\s*?\\\\w+\\\\s*?h ..." at ARGS:io. [file "/etc/apache2/modsecurity.d/rules/owasp_modsecurity_crs_3-plesk/REQUEST-942-APPLICATION-ATTACK-SQLI.conf"] [line "705"] [id "942260"] [rev "2"] [msg "Detects basic SQL authentication bypass attempts 2/3"] [data "Matched Data: \\x22:\\x22mailvorlageSyntaxCheck\

Da dieser Server auf Plesk lief > OWASP_CRS/WEB_ATTACK/SQL_INJECTION nun temporär deaktiviert, natürlich nicht die gewünschte Lösung, aber zumindest kann man die Vorlagen anpassen.
 

PatrickSchaefer

Mitglied
20. Februar 2020
7
2
Moin, danke für den Hinweis, das hat jedoch ebenfalls nichts geholfen. Die Ideen vom Support leider auch nicht. Letztendlich hat eine Komplette Neuinstallation der Neuen Shopversion (Blanko) geholfen. Ich musste nur umständlich sämtliche Daten, Inhalte selbst in den neuen Shop übernehmen. Hier ging definitiv beim Update etwas schief. Thread kann geschlossen werden. Danke!
 

Ähnliche Themen