Gelöst Datenbank Updatefehler von 52 auf 53

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.648
2.700
Berlin
Firma
css-umsetzung
Leider lässt sich das Updaten der Datenbank nicht durchführen, ich habe auch den Prozess der Datenbank reparatur durchlaufen.

Datenbank ist eine 2012er DEVELOPER Version

Code:
Unbehandelte Ausnahme #48C31DE22B948975 vom Typ jtlDatabase.Maintenance.Exceptions.DBIntegrityCheckFailedException in Void Run()
jtlDatabase.Maintenance.Exceptions.DBIntegrityCheckFailedException: Die Prüfung der Datenbank ist fehlgeschlagen
   bei jtlDatabase.Maintenance.DBBackupWorker.Run()
   bei jtlCore.Forms.DBTools.BackupDB.Fe5YLzh5X4f(Object , DoWorkEventArgs )
   bei System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
   bei System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
Hilfe unter: http://wiki.jtl-software.de/index.php?title=Kategorie:JTL-Wawi:Hinweise_FAQ#Datenbank_reparieren_SQL_2005_Express
SQL-Fehler #1823, Klasse 16 (Eine Datenbank-Momentaufnahme kann aufgrund eines Fehlers beim Starten nicht erstellt werden.) bei :1@(local)\JTLDEV
SQL-Fehler #1823, Klasse 16 (Eine Datenbank-Momentaufnahme kann aufgrund eines Fehlers beim Starten nicht erstellt werden.) bei :1@(local)\JTLDEV
SQL-Fehler #5149, Klasse 16 (Bei MODIFY FILE wurde beim Versuch, die physische Datei 'D:\MS-SQL-JTL-DEV\MSSQL11.JTLDEV\MSSQL\DATA\eazybusiness.mdf:MSSQL_DBCC10' zu erweitern, der Betriebssystemfehler 665(Der angeforderte Vorgang konnte aufgrund einer Dateisystemeinschränkung nicht abgeschlossen werden.) festgestellt.) bei :1@(local)\JTLDEV
SQL-Fehler #7928, Klasse 16 (Die Datenbank-Momentaufnahme für Onlineüberprüfungen konnte nicht erstellt werden. Die Ursache wird in einem vorherigen Fehler beschrieben, oder eines der zugrunde liegenden Volumes unterstützt Dateien mit geringer Dichte oder alternative Datenströme nicht. Es wird versucht, exklusiven Zugriff zu erhalten, um die Überprüfung offline auszuführen.) bei :1@(local)\JTLDEV
SQL-Fehler #5030, Klasse 16 (Die Datenbank konnte nicht exklusiv gesperrt werden, um den Vorgang auszuführen.) bei :1@(local)\JTLDEV
SQL-Fehler #7926, Klasse 16 (Die CHECK-Anweisung wurde abgebrochen. Die Datenbank konnte nicht überprüft werden, da eine Datenbank-Momentaufnahme nicht erstellt werden konnte und die Datenbank oder Tabelle nicht gesperrt werden konnte. Weitere Informationen zu Situationen, in denen dieses Verhalten erwartet ist, und zu Problemumgehungen finden Sie in der Onlinedokumentation. Weitere Informationen finden Sie außerdem in vorherigen Fehlern.) bei :1@(local)\JTLDEV
Title = Die Prüfung der Datenbank ist fehlgeschlagen
Description = Die Prüfung der Datenbank hat Fehler ergeben. Um die Sicherheit Ihrer Daten nicht zu gefährden sollten Sie nicht mit dieser Datenbank weiterarbeiten.
Im Fehlerlog finden Sie die Meldungen des SQL-Servers und Hinweise auf die Behebung des Fehlers.

Zeitstempel: 2015-05-14T10:32:26
Locale: German (Germany)
Locale: German (Germany)
Version: 099953
Plattform: Wawi
Versionshash: D7F5A9EC
Prozessname: System.Diagnostics.Process (JTL-wawi)
Physikalischer Speicher: 214810624 / Peak: 380063744
Basispriorität: 8
Prioritätsklasse: Normal
CPU-Zeit (User): 0:00:12,546875
CPU-Zeit (System): 0:00:02,046875
Page-Size (Sytem): 952360 / Peak: 325005312
Page-Size: 158875648 / Peak: 325005312
Offene Handles: 812
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.921
264
AW: Datenbank Updatefehler von 52 auf 53

War dies der gleiche SQL-Benutzer?

(Bei MODIFY FILE wurde beim Versuch, die physische Datei 'D:\MS-SQL-JTL-DEV\MSSQL11.JTLDEV\MSSQL\DATA\eazybusiness.mdf:MSSQL_DBCC10' zu erweitern, der Betriebssystemfehler 665(Der angeforderte Vorgang konnte aufgrund einer Dateisystemeinschränkung nicht abgeschlossen werden.)

Evtl. hat der Benutzer keine Rechte.
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.648
2.700
Berlin
Firma
css-umsetzung
AW: Datenbank Updatefehler von 52 auf 53

ja, ich hatte auch extra versucht ein anderes Verzeichnis für die Sicherung zu nehmen Aber auch da hatte ich diesen Fehler
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.921
264
AW: Datenbank Updatefehler von 52 auf 53

Es geht nicht um Sicherung, sondern um den Zugriff auf die Datenbank-Datei eazybusiness.
Dafür fehlen schon die Rechte.

Wird mit dem "sa" - SQL Benutzer gearbeitet?
Wir der Ordner "D:\MS-SQL-JTL-DEV\MSSQL11.JTLDEV\MSSQL\DATA\" irgendwie geschützt oder die Datei komprimiert?


Sieht danach aus:
https://support.microsoft.com/en-us/kb/231347/de
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.648
2.700
Berlin
Firma
css-umsetzung
AW: Datenbank Updatefehler von 52 auf 53

Hmmm ja das laeuft über den Benutzer sa die Platte ist im ReFS Format formatiert.
ich lasse ja automatische Backups laufen, die funktionieren.

ich ändere mal gleich mein DateiFormat auf "normal" und schau ob da weitere komprimierungen eingeschaltet sind.

vielen Dank für die Info
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.648
2.700
Berlin
Firma
css-umsetzung
AW: Datenbank Updatefehler von 52 auf 53

OK,
das muss dann wirklich etwas mit dem Format zu tun gehabt haben 🙁 , jetzt geht es
Da wäre ich ja nie drauf gekommen.

vielen Dank.
 

Ähnliche Themen