Wichtig Beta Connector für Presta 8 mit PHP 8+

  • Wichtiger Hinweis Liebe Kunden, solltet Ihr den DATEV Rechnungsdatenservice 2.0 nutzen, dann müsst Ihr bis zum 30.06.2024 JTL-Wawi 1.9 installieren. Danach wird die Schnittstelle für ältere Versionen nicht mehr unterstützt.

Tim Platzke

Moderator
Mitarbeiter
9. Juni 2022
128
66
Hallo zusammen,
ich möchte mich direkt erst einmal entschuldigen, dass es so lange gedauert hat.
Das update auf den neuen Core mit Support von PHP8.1+ war deutlich komplexer als gedacht und es gab auch noch eine Engstellen in der QA

Wir haben jetzt eine Beta Version für Presta Connector.
In diesem Update sind folgenden Verbesserungen enthalten:
  • Unterstützung von PHP 8.1+
  • Connector Core 5.2 (Alte Connector Plugins funktionieren NICHT mehr)
  • Support für Presta 8.1
  • Viele Fehlerbehebungen
  • Verbessertes Logging
Ihr könnt hier den Connector vorab testen, falls euch größere Probleme auffallen, geb bitte Bescheid. Falls es keine Probleme gibt wird der Connector am 9.4.24 14.05.24 demnächst released.

Hier könnt ihr die Beta herunterladen:
https://downloads.jtl-software.de/jtlconnector/Presta/jtl_connector_prestashop_2.0.0-beta13.zip

Änderungen Beta2:
- chmod Fehler bei Install behoben
Änderungen Beta 3:
- fix CustoemrOrder Pull with Order Delete Module
- fix Payment status on initial orderPull
- fix stock and custom prices update on product push
Änderungen Beta 4:
- fix Payment Name
- fix Shipping Line Item missing
- better error if presta is rejecting the tracking number
Änderungen Beta 5:
- fix Order Carrier loading by DliveryNotePush
- fix payment mapping in payment pull
Änderungen Beta 6:
- Fix bei Specific Push wenn Feature in Presta nur teilweise vorhanden ist (DB leichen)
- fix variaten delete
- fix variant mapping for order
Änderungen Beta 7
- fix falsche steuer für bestellungen aus nicht standard land
Änderungen Beta 8
- fix Var Name in Order Pull
Änderungen Beta 9
- fix order not found in status Change Push
Änderungen Beta 10
- fix varianten wholesale price und price können negativ werden.
Änderungen Beta 11
- Bestellungen verwenden als externe Auftragsnummer wieder die Referenz aus Presta
- fix Rabattpositionen fehlen
- fix Notitz in Bestellung fehlt
- Artikel die im Shop nicht mehr existieren aber noch linkings haben füren nichtmer zu fehlern
- varianten logik überarbeitet
Änderungen Beta 12
- fix Umlaute in kategorie name werden entfernt
- fix kaputte kattegorie nach upload fehler
- fix html wird bei beschreibung entfernt
- limitiere beschreibung, kurzbeschreibung und meta beschreibung auf maximale zeichenlänge von presta
- fix reset von url path
- fix attribute group color reset
- fix var image remove
Änderungen Beta 13
- url erstellung für Kategorien und Artikel vereinheitlicht
- beschreibungen werden nun nur abgeschnitten wenn die option in den modul einstellungen aktiviert ist
 
Zuletzt bearbeitet:
  • Ich liebe es
Reaktionen: recent.digital

KristinaS

Aktives Mitglied
8. Mai 2017
82
8
Hallo zusammen,
ich möchte mit direkt erst einmal entschuldigen, dass es so lange gedauert hat.
Das update auf den neuen Core mit Support von PHP8.1+ war deutlich komplexer als gedacht und es gab auch noch eine Engstellen in der QA

Wir haben jetzt eine Beta Version für Presta Connector.
In diesem Update sind folgenden Verbesserungen enthalten:
  • Unterstützung von PHP 8.1+
  • Connector Core 5.2 (Alte Connector Plugins funktionieren NICHT mehr)
  • Support für Presta 8.1
  • Viele Fehlerbehebungen
  • Verbessertes Logging
Ihr könnt hier den Connector vorab testen, falls euch größere Probleme auffallen, geb bitte Bescheid. Falls es keine Probleme gibt wird der Connector am 9.4.24 released.

Hier könnt ihr die Beta herunterladen:
https://downloads.jtl-software.de/jtlconnector/Presta/jtl_connector_prestashop_2.0.0-beta.zip
https://downloads.jtl-software.de/jtlconnector/Presta/jtl_connector_prestashop_2.0.0-beta2.zip

https://downloads.jtl-software.de/jtlconnector/Presta/jtl_connector_prestashop_2.0.0-beta3.zip

Änderungen Beta2:
- chmod Fehler bei Install behoben
Änderungen Beta 3:
- fix CustoemrOrder Pull with Order Delete Module
- fix Payment status on initial orderPull
- fix stock and custom prices update on product push
Vielen Dank, wir hatten im Januar festgestellt, dass beim alten Connector der Bestandsabgleich nicht mehr funktionierte und dann nach entsprechender Aufforderung durch JTL unseren Prestashop auf Version 8.1.3 hochgezogen und mit Pre-Versionen des Connectors, die wir vom Support bekommen haben, verknüpft. Danach funktionierte zwar der Bestandsabgleich, aber es tauchten diverse andere Probleme auf, siehe auch Thread "Der Shop hat nicht alle Zahlungen gesendet". Nun habe ich gestern noch den neuen Connector installiert, aber weiterhin werden die Varkombi-Artikel im Shop nicht erkannt und beim Versuch, neue Varkombis online zu schalten, neue Variationen statt neuer Variationswerte angelegt, mit der Folge, dass der Shop das dann die Atikel nicht mehr darstellen kann. Auch erhalten neu in den Shop exportierte Varkombis keinen Bestand.

Aktuell habe ich einen Versuch unternommen, den Connector zurückzusetzen und die Artikel aus dem Shop neu zu verknüpfen, aber auch das funktioniert hier offenbar nur für die normalen Artikel, Variationskombinatioenen erkennt die Wawi wieder nicht und legt hierfür neue Artikel an, anstatt die Varkombis zu verknüpfen. Noch läuft der Abgleich, aber es ist schon klar, dass ich danach alles wieder zurücksichern und auf den vorherigen Stand zurücksetzen muss.

Bei Bestellungen wird für Varkombis zwar die richtige Artikelnummer eingelesen, aber statt dem Artikel eine Freiposition in den Auftrag genommen.

Im normalen Artikelabgelich erhalten wir einen Fehler bei der Übertragung von Lieferscheinen, weil die Versandarten nicht gefunden werden. Wir brauchen die Übertragung der Lieferscheine nicht und würden die gerne abschalten. Offenbar stört sich der Connector daran, dass vom Packtisch andere Versandarten kommen als aus dem Shopsystem. Das kommt daher, dass die Versandarten im Shopsystem allgemeiner sind als am Packtisch, der Kunde bestellt z.B. mit Briefversand, am Packtisch muss dann für die richtige Frankierung gewählt werden, ob es ein Versand per Kompaktbrief, Großbrief, Maxibrief, Büwa oder Warenpost DE oder EU oder NON-EU ist. Nur mal so als Beispiel. Ich werde doch nicht alle Tarife auch noch einmal im Shop anlegen müssen? Wozu?

Logs vom Server kann ich leider nicht zur Verfügung stellen, es werden weiterhin trotz entsprechender Einstellungen keine auf dem Server abgelegt, auch nicht durch die neue Connectorversion. Ich hatte bereits einige Supporttickets, allerdings wurden diese immer schneller geschlossen als eine Problemlösung in Sicht kam.

Ich gehe davon aus, dass der Connector in der JTL Entwicklung besser funktioniert hat, sonst würde er ja nicht kurz vor dem Release stehen und forder auf diesem Weg nun Support für mein System an.

Abgleich nach Connector-Reset ist gleich fertig, ich schaue mir dsas gleich noch genauer an.
 
  • Gefällt mir
Reaktionen: Matti_Fla

KristinaS

Aktives Mitglied
8. Mai 2017
82
8
Vielen Dank, wir hatten im Januar festgestellt, dass beim alten Connector der Bestandsabgleich nicht mehr funktionierte und dann nach entsprechender Aufforderung durch JTL unseren Prestashop auf Version 8.1.3 hochgezogen und mit Pre-Versionen des Connectors, die wir vom Support bekommen haben, verknüpft. Danach funktionierte zwar der Bestandsabgleich, aber es tauchten diverse andere Probleme auf, siehe auch Thread "Der Shop hat nicht alle Zahlungen gesendet". Nun habe ich gestern noch den neuen Connector installiert, aber weiterhin werden die Varkombi-Artikel im Shop nicht erkannt und beim Versuch, neue Varkombis online zu schalten, neue Variationen statt neuer Variationswerte angelegt, mit der Folge, dass der Shop das dann die Atikel nicht mehr darstellen kann. Auch erhalten neu in den Shop exportierte Varkombis keinen Bestand.

Aktuell habe ich einen Versuch unternommen, den Connector zurückzusetzen und die Artikel aus dem Shop neu zu verknüpfen, aber auch das funktioniert hier offenbar nur für die normalen Artikel, Variationskombinatioenen erkennt die Wawi wieder nicht und legt hierfür neue Artikel an, anstatt die Varkombis zu verknüpfen. Noch läuft der Abgleich, aber es ist schon klar, dass ich danach alles wieder zurücksichern und auf den vorherigen Stand zurücksetzen muss.

Bei Bestellungen wird für Varkombis zwar die richtige Artikelnummer eingelesen, aber statt dem Artikel eine Freiposition in den Auftrag genommen.

Im normalen Artikelabgelich erhalten wir einen Fehler bei der Übertragung von Lieferscheinen, weil die Versandarten nicht gefunden werden. Wir brauchen die Übertragung der Lieferscheine nicht und würden die gerne abschalten. Offenbar stört sich der Connector daran, dass vom Packtisch andere Versandarten kommen als aus dem Shopsystem. Das kommt daher, dass die Versandarten im Shopsystem allgemeiner sind als am Packtisch, der Kunde bestellt z.B. mit Briefversand, am Packtisch muss dann für die richtige Frankierung gewählt werden, ob es ein Versand per Kompaktbrief, Großbrief, Maxibrief, Büwa oder Warenpost DE oder EU oder NON-EU ist. Nur mal so als Beispiel. Ich werde doch nicht alle Tarife auch noch einmal im Shop anlegen müssen? Wozu?

Logs vom Server kann ich leider nicht zur Verfügung stellen, es werden weiterhin trotz entsprechender Einstellungen keine auf dem Server abgelegt, auch nicht durch die neue Connectorversion. Ich hatte bereits einige Supporttickets, allerdings wurden diese immer schneller geschlossen als eine Problemlösung in Sicht kam.

Ich gehe davon aus, dass der Connector in der JTL Entwicklung besser funktioniert hat, sonst würde er ja nicht kurz vor dem Release stehen und forder auf diesem Weg nun Support für mein System an.

Abgleich nach Connector-Reset ist gleich fertig, ich schaue mir dsas gleich noch genauer an.
Anbei ein beispielhafter Screenshot, indem man sieht, dass die Verknüpfung der vorhandenen Varkombiartikel fehlgeschlagen ist und statt dessen neue Artikel für die Varkombiartikel angelegt worden sind. Z.B. für Artikel EN704500-75-09 gibt es jetzt ein Duplikat namens EN704500_1991 aus dem Presta-Import mit identischer EAN und identischem Lagerbestand. In der Datenbank erscheint im der link_product-Tabelle nun auch eine neue, viel zu hohe Host-ID für diesen Artikel (11479) anstelle der alten (2980), weil der Artikel eben nicht verknüpft sondern neu angelegt worden ist.

Log-Files auf dem Server wurden leider weiterhin NICHT angelegt, obwohl Developer-Logs aktiviert sind.
Ich beginne nun mit der Rücksicherung, um jetzt erst einmal wieder die aktuellen Bestellungen versenden zu können...
Achja, unser System: JTL Wawi 1.18.12.2 (nachUpdate aus Versionen 1.17.X und früheren), Prestashop 8.1.3 (nach Upgrade aus Presta 1.7), Connector obiger 2.0.0.Beta3
Herzliche Grüße,
Kristina
 

Anhänge

  • Screenshot20240405_1.jpg
    Screenshot20240405_1.jpg
    1,2 MB · Aufrufe: 4
Zuletzt bearbeitet:

Tim Platzke

Moderator
Mitarbeiter
9. Juni 2022
128
66
Hi Kristina,
danke für deine Rückmeldung.
Das ist natürlich nicht so gewollt.
So wie ich deinen Text verstehe gibt es hier aktuell noch diese Probleme:
  • Product push/pull: Varkombis werden nicht korrekt erkannt/gemappt | eventuell mit beta 6 gefixt
  • StockUpdate push: Varkombis werden gar nicht erkannt | eventuell mit beta 6 gefixt
  • Bestellungs pull: Varkombis werden als Freiposition übertragen gefixt mit Beta 6
  • DeliveryNote push: Abbruch bei unbekannter Versandart im Shop Gefixt mit Beta 5
  • CustomerOrder pull: Versandart an positionen nicht korrekt Gefixt in Beta4
  • Payment pull: Falsche Zahlungsart Gefixt in Beta4
Zu den logs:
Ich habe das eigentlich gefixt, die logs sind aber jetzt in var/ log und nicht mehr direkt im logs ordner. Die entsprechenden button auf der Modulseite habe ich angepasst.
Falls du via FTP nachgeschaut hast, schau bitte nochmal im jtlconnector/var/log ordner. Falls du versucht hast die logs über den button herunter zu laden, geb mir bitte nochmal Rückmeldung, dann muss ich da nochmal nachsehen.

Ich werde mir das gleich anschauen und im laufe des Tages eine neue Version erstellen.
Das release für morgen ist wahrscheinlich erstmal gecancelt, bis die Fehler behoben sind.
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: Matti_Fla

KristinaS

Aktives Mitglied
8. Mai 2017
82
8
Hi Kristina,
danke für deine Rückmeldung.
Das ist natürlich nicht so gewollt.
So wie ich deinen Text verstehe gibt es hier aktuell noch diese Probleme:
  • Product push/pull: Varkombis werden nicht korrekt erkannt/gemappt
  • StockUpdate push: Varkombis werden gar nicht erkannt
  • Bestellungs pull: Varkombis werden als Freiposition übertragen
  • DeliveryNote push: Abbruch bei unbekannter Versandart im Shop
Zu den logs:
Ich habe das eigentlich gefixt, die logs sind aber jetzt in var/ log und nicht mehr direkt im logs ordner. Die entsprechenden button auf der Modulseite habe ich angepasst.
Falls du via FTP nachgeschaut hast, schau bitte nochmal im jtlconnector/var/log ordner. Falls du versucht hast die logs über den button herunter zu laden, geb mir bitte nochmal Rückmeldung, dann muss ich da nochmal nachsehen.

Ich werde mir das gleich anschauen und im laufe des Tages eine neue Version erstellen.
Das release für morgen ist wahrscheinlich erstmal gecancelt, bis die Fehler behoben sind.
Hallo Tim,
vielen Dank für die Rückmeldung.

Ja, die genannten Probleme bestehen wie dargestellt.

Wir haben noch zwei weitere Themen aus dem Bestellimport:
Die Versandarten werden zwar korrekt erkannt und als Auftragsversandart korrekt vermerkt, aber nicht in die Auftragspositionen übernommen. Die müssen wir derzeit immer manuell nachtragen, indem wir die Versandart ändern (dann wird endlich eine Versandposition im Auftrag angelegt) und dann wieder auf die eigentliche, korrekte Versandart zurückändern (dann wird die nachträglich angelegte Versandposition aktualisiert).
Bei den Zahlungen wird die Zahlungsart nicht in den Auftrag übernommen, Zahlbeträge und Zahldatum werden zwar nun korrekt übertragen, aber es wird keine Auftragszahlungsart gesetzt und der übermittelten Zahlung wird immer die Zahlungsart Amazon Pay zugeordnet, obwohl bei uns fast alle Zahlungen per Paypal oder Mollie erfolgen.

Logs: Ich habe nachgesehen und die Logs nun im neuen Ordner gefunden :) Gerne übersende ich sie Euch, bzw. lösche noch einmal alle und lasse neue für Euch erstellen. Schreibt mir einfach, was Ihr benötigt, und wo ich es hinsenden soll, falls Euch das helfen würde.

Ich freue mich, dass es weiter vorangeht. Gern spiele ich die nächste Connectorversion umgehend ein, gebe Rückmeldung und stelle neue Logfiles zur Verfügung. Meldet Euch einfach, was Ihr für sinnvoll haltet/benötigt.

Mit herzlichen Grüßen, Kristina
 

Tim Platzke

Moderator
Mitarbeiter
9. Juni 2022
128
66
Hi Kristina,
entschuldige das es etwas gedauert hat, die Varkombis sind sehr komplex.
Dementsprechend hab ich bis jetzt auch nur die andere Fehler fixen können.

Kannst du mir zu dem Abbruch bei unbekannter Versandart im Shop genau beschreiben, wie euer Workflow ist oder mit einen ( Wawi) Abgleich log zukommen lassen? Ich habe alles versucht, was mir einfällt und konnte keinen Fehler provozieren.

Wenn du Zeit hast, wäre es toll, wenn du die aktuelle beta 4 einmal testen kannst. Vor allem die fehlende Versandposition und die falsche Zahlungsart.
 

KristinaS

Aktives Mitglied
8. Mai 2017
82
8
Hallo Tim,
prima, DANKE, es geht voran :)

Ich spiele spätestens morgen vormittag die neue Connectorversion ein und gebe dann mein Feedback. Wohin soll ich die Logs senden - als PN aus dem Forum an Dich wäre ok?

2 Gedanken schon vorab:
1) Der Abbruch bei der Übertragung der Lieferscheine fällt nur auf, wenn der Abgleich manuell angestoßen wird, der Worker scheint sich nicht daran zu stören und überträgt zumindest die Bestelldaten, Preise und Bestände dennoch.
2) Ein interessanter Effekt bei den Varkombis ist, dass die Bestände und Preise für die Varkombis korrekt durch den Abgleich aktualisiert werden doch das Hinzufügen anderer Variantenbeim Abgleich und auch das Anlegen der Bestellpositionen beim Einlesen der Aufträge nicht funktioniert.

Bis morgen,
mit herzlichen Grüßen,
Kristina
 

Matti_Fla

Aktives Mitglied
16. September 2019
38
2
Wir haben den neuesten Connector getestet mit Multishop PrestaVersion.
Bei einem von drei Shops werden ohne Probleme Artikel mit Var-Kombis angelegt.
Die anderen beiden Shops legen nur den Vaterartikel an und dann kommt Fehler: "Kein Eintrag in Combination-> minimal_quantity"
 

steffenwerner

Aktives Mitglied
14. Oktober 2015
16
0
Wir haben einen Prestashop 8.1.3 am Laufen mit dem Connector 1.13.4
Seit ein paar Tagen hatte ich Probleme mit dem Abgleich und daher habe ich gerade eben auf PHP 8.2 und der beta4 upgedated. Danach brach der Abgleich bei Unterkategorien ab. Nachdem ich diese gelöscht habe, wurden diese übertragen, allerdings ohne Artikel. Dann bleibt die Verbindung hängen und friert für einige Minuten ein. Danach kann ich wenigstens ein Errorlog abspeichern.

Was muss/kann ich tun? Liegt der Fehler bei mir?
 

Anhänge

  • errorlog_20240415200843.txt
    137,8 KB · Aufrufe: 2
  • logs.zip
    9,1 KB · Aufrufe: 1

KristinaS

Aktives Mitglied
8. Mai 2017
82
8
Wir haben einen Prestashop 8.1.3 am Laufen mit dem Connector 1.13.4
Seit ein paar Tagen hatte ich Probleme mit dem Abgleich und daher habe ich gerade eben auf PHP 8.2 und der beta4 upgedated. Danach brach der Abgleich bei Unterkategorien ab. Nachdem ich diese gelöscht habe, wurden diese übertragen, allerdings ohne Artikel. Dann bleibt die Verbindung hängen und friert für einige Minuten ein. Danach kann ich wenigstens ein Errorlog abspeichern.

Was muss/kann ich tun? Liegt der Fehler bei mir?
Hallo Steffen,

wir hatten im Januar auf Presta 8.1.3 umgestellt (mit PHP-Version 8.1.27) und zumindest bei bestehenden Unterkategorien noch keinen Fehler festgestellt. Allerdings kann ich mich nicht erinnern, seitdem neue Unterkategorien angelegt und übertragen zu haben. Da wir hier aber seitdem erhebliche Probleme mit der Erkennung von bereits vorhandenen Varkombi-Artikeln haben, lassen wir den Connector seitdem eigentlich nur noch für Preis- und Bestandsabgleich und den Auftragsimport laufen. Sobald aber die Varkombierkennung wieder funktioniert, habe ich hier auch noch einen ganzen Stapel an Artikeln einzustellen/zu aktualisieren und werde auch noch einmal neue Unterkategorien anlegen. Ich behalte das Thema dann mit im Blick, warte aber erst einmal auf eine Beta, die unsere Probleme mit der Varkombierkennung fixt.

GLG Kristina
 

Tim Platzke

Moderator
Mitarbeiter
9. Juni 2022
128
66
Beta 5 ist released, fixes siehe erster post. Varkombis sind leider noch nicht dabei.
Ich muss mich leider heute erstmal um ein problem beim Shopify Connector kümmmern, werde aber danach direkt mit den Varkombis weitermachen.
 

KristinaS

Aktives Mitglied
8. Mai 2017
82
8
Beta 5 ist released, fixes siehe erster post. Varkombis sind leider noch nicht dabei.
Ich muss mich leider heute erstmal um ein problem beim Shopify Connector kümmmern, werde aber danach direkt mit den Varkombis weitermachen.
Schön, dass die bereitgestellten Logs so hilfreich waren und es nun mit großen Schritten vorwärts geht:love:

Ich habe nun den Beta5 Connector eingespielt und kann nun auch für unser System bestätigen: Lieferscheinübertragung führt nicht mehr zum Abbruch des Abgleichs, Versandpositionen werden seit Beta4 wieder korrekt in den Aufträgen angelegt und Zahlungsarten zu den Aufträgen nun auch bei unseren Paypalzahlungen korrekt als Zahlung und als Auftragszahlungsart angelegt (seit Beta5). Für mollie habe ich das leider noch nicht testen können, beim Einlesen der nächsten Bestellung mit mollie-Zahlung schaue ich aber definitiv drauf.

Also Bestätigung ✅ von hier für:
  • DeliveryNote push: Abbruch bei unbekannter Versandart im Shop Gefixt mit Beta 5
  • CustomerOrder pull: Versandart an positionen nicht korrekt Gefixt in Beta4
  • Payment pull: Falsche Zahlungsart Gefixt in Beta4

Bleiben noch die vielfältigen Varkombiprobleme...

Ach ja, bitte vielleicht auch noch einmal auf die Steuersätze bei EU-Auslandsbestellungen schauen, hatte ich ganz vergessen, war zumindest in früheren Versionen des Connectors bei uns fehlerhaft - es wurden die korrekten Bruttobeträge aber der falsche - immer deutsche 19% - Steuersatz in die Aufträge übernommen. Nach Kopieren der Artikelnummer und manuellem Neuanlegen der Artikelposition im Auftrag stimmte es dann. Ist das in der aktuellen Version jetzt ok? Ich konnte es mangels passender EU-Bestellung leider aktuell noch nicht testen.

Mit herzlichen Grüßen,
Kristina
 

Tim Platzke

Moderator
Mitarbeiter
9. Juni 2022
128
66
Also bei den Varkombis hab ich (glaube ich) fortschritte gemacht. Neuanlegen von artikel mit varkombis funktioniert, probleme gibt es nur wenn varianten dazukommen/entfernt werden oder geupdated werden.
Falsche Steuersätze schaue ich mir an.
 
  • Gefällt mir
Reaktionen: KristinaS

Tim Platzke

Moderator
Mitarbeiter
9. Juni 2022
128
66
Beta 6
habe einige der varianten Sachen fixen können 🎉, siehe erster post.

Zu den Steuersätzen, laut code wird die von Presta berechnete Steuer genommen, falls das dennoch nicht passen sollte, muss ich die nachberechnen, was nicht schön ist aber möglich.
 

Tim Platzke

Moderator
Mitarbeiter
9. Juni 2022
128
66
Wir haben den neuesten Connector getestet mit Multishop PrestaVersion.
Bei einem von drei Shops werden ohne Probleme Artikel mit Var-Kombis angelegt.
Die anderen beiden Shops legen nur den Vaterartikel an und dann kommt Fehler: "Kein Eintrag in Combination-> minimal_quantity"
Die minimal_quantity wird vom Mindestabnahme Feld aus der wawi befüllt. Der Connector limitiert den wert dann noch auf positive Ganzzahlen. Mir ist nicht ganz klar wie das passieren kann.
Kannst du bitte nochmal einen Abgleich machen und mir den Abgleich log zukommen lassen? Der Wawi Errorlog bringt mir leider nichts, es muss ein Abgleich log sein, dann kann ich prüfen was für daten von der wawi kommen.

Hier steht wie man den Abgleich log in der Wawi aktiviert: https://jtl-url.de/-kdiq

Wir haben einen Prestashop 8.1.3 am Laufen mit dem Connector 1.13.4
Seit ein paar Tagen hatte ich Probleme mit dem Abgleich und daher habe ich gerade eben auf PHP 8.2 und der beta4 upgedated. Danach brach der Abgleich bei Unterkategorien ab. Nachdem ich diese gelöscht habe, wurden diese übertragen, allerdings ohne Artikel. Dann bleibt die Verbindung hängen und friert für einige Minuten ein. Danach kann ich wenigstens ein Errorlog abspeichern.

Was muss/kann ich tun? Liegt der Fehler bei mir?
Leider kann ich dir das nicht sagen, der errorlog zeigt das dein Shop (aus welchen Gründen auch immer) mit der Shop Startseite anstelle des connectors geantwortet hat.
Die Connector Logs sind aber unauffällig.
Auch hier wäre ein Abgleich log hilfreich, Anleitung zum aktivieren: https://jtl-url.de/-kdiq
 

steffenwerner

Aktives Mitglied
14. Oktober 2015
16
0
Die minimal_quantity wird vom Mindestabnahme Feld aus der wawi befüllt. Der Connector limitiert den wert dann noch auf positive Ganzzahlen. Mir ist nicht ganz klar wie das passieren kann.
Kannst du bitte nochmal einen Abgleich machen und mir den Abgleich log zukommen lassen? Der Wawi Errorlog bringt mir leider nichts, es muss ein Abgleich log sein, dann kann ich prüfen was für daten von der wawi kommen.

Hier steht wie man den Abgleich log in der Wawi aktiviert: https://jtl-url.de/-kdiq


Leider kann ich dir das nicht sagen, der errorlog zeigt das dein Shop (aus welchen Gründen auch immer) mit der Shop Startseite anstelle des connectors geantwortet hat.
Die Connector Logs sind aber unauffällig.
Auch hier wäre ein Abgleich log hilfreich, Anleitung zum aktivieren: https://jtl-url.de/-kdiq
ok, das Log habe ich aktiviert.....
die letzte Meldung unter Aktueller Schritt lautet übrigens; Abschlussinfo senden. dann friert der Connector ein. Und es braucht ca. 2 Minuten, bis das Hinweisfenster mit den Logs erscheint.

Was kann ich tun, damit der Connector nicht auf die Startseite referiert?
 

Anhänge

  • Connector-Abgleich-Debug 20240416 21-21-05.zip
    46,7 KB · Aufrufe: 2
Zuletzt bearbeitet:

Tim Platzke

Moderator
Mitarbeiter
9. Juni 2022
128
66
ok, das Log habe ich aktiviert.....
die letzte Meldung unter Aktueller Schritt lautet übrigens; Abschlussinfo senden. dann friert der Connector ein. Und es braucht ca. 2 Minuten, bis das Hinweisfenster mit den Logs erscheint.

Was kann ich tun, damit der Connector nicht auf die Startseite referiert?
ok, also der fehler kommt beim status change push.
Im log steht das du noch beta 4 verwendest, kannst du es mit beta 6 versuchen?
Ich vermute das du auf den Fehler mit dem OrderCarrier kommst, der ist seit beta5 gefixt.
 

Tim Platzke

Moderator
Mitarbeiter
9. Juni 2022
128
66
Ach ja, bitte vielleicht auch noch einmal auf die Steuersätze bei EU-Auslandsbestellungen schauen, hatte ich ganz vergessen, war zumindest in früheren Versionen des Connectors bei uns fehlerhaft - es wurden die korrekten Bruttobeträge aber der falsche - immer deutsche 19% - Steuersatz in die Aufträge übernommen. Nach Kopieren der Artikelnummer und manuellem Neuanlegen der Artikelposition im Auftrag stimmte es dann. Ist das in der aktuellen Version jetzt ok? Ich konnte es mangels passender EU-Bestellung leider aktuell noch nicht testen.
Ich hab den Fehler jetzt finden können, in Beta7 sollte die Steuer korrekt ausgewiesen werden.
 
  • Gefällt mir
Reaktionen: KristinaS

KristinaS

Aktives Mitglied
8. Mai 2017
82
8
Also bei den Varkombis hab ich (glaube ich) fortschritte gemacht. Neuanlegen von artikel mit varkombis funktioniert, probleme gibt es nur wenn varianten dazukommen/entfernt werden oder geupdated werden.
Falsche Steuersätze schaue ich mir an.
Guten Morgen Tim,
wow, das gab jetzt wirklich einen Satz nach vorn 🎉 Die Varkombiartikel werden jetzt beim Bestellimport wieder erkannt und als Artikel angelegt.
Bestellungs pull: Varkombis werden als Freiposition übertragen


So muss ich endlich nicht mehr jede Shop-Bestellung manuell berichtigen, DANKE 😀 Eine Kleinigkeit fehlt aber noch: Die Artikelpositionen werden nun in den Aufträgen als solche angelegt, aber als Artikelname wird offenbar der allgemeine Name aus dem Shopsystem eingetragen und zwar ohne Angaben zu den Varianten (also. z.B. Größe, Farbe). Das bedeutet, dass man anhand der Rechnung, die bei uns auch Grundlage für den Packtisch-Mitarbeiter ist, nur an der Artikelnummer erkennen kann, welche Variante da nun gemeint ist. Für manchen Packtischmitarbeiter aber auch manchen Kunden eine Herausforderung... Früher wurde da die (komplette) Artikelbezeichnung aus der Wawi angedruckt, vielleicht kriegen wir das auch noch hin? Oder zumindest die Variantenangabe aus dem Shop?

GLG Kristina
 
  • Gefällt mir
Reaktionen: Matti_Fla
Ähnliche Themen
Titel Forum Antworten Datum
BETA aktuelle Connector Version mit WPML Unterstützung WooCommerce-Connector 7
Neu Wawi Beta 1.9.4.1 Instalationsdatei lässt sich nicht öffnen Installation von JTL-Wawi 16
Neu 👉 JTL-Wawi 1.9 Open Beta Release - Aktuell 1.9.4.1 Releaseforum 2
Neu JTL-Wawi 1.9 Open Beta User helfen Usern - Fragen zu JTL-Wawi 6
Neu Neue Oberfläche Wawi 1.8.12.2 (Beta) JTL-Wawi - Ideen, Lob und Kritik 0
Neu Shopware 5: Nach Backup-Einspielung führt der Connector keinen Abgleich mehr durch Shopware-Connector 3
Neu JTL WooCommerce-Connector bis oder bis einschließlich? WooCommerce-Connector 5
JTL WAWI 1.8.12.2 Shopware 6 / Connector Abgleich Fehler Gelöste Themen in diesem Bereich 3
Fehlermeldung bei JTL-Connector/JTL-Wawi WooCommerce-Connector 1
Neu JTL-Connector Token Shopware-Connector 1
Abkündigung Shopware 5 Connector Shopware-Connector 1
Neu PrestaShop Connector für Prestashop 8 mit PHP 8.2 wird nicht unterstützt PrestaShop-Connector 3
Neu Passenden WooCommerce Connector zu meinem WordPress WooCommerce-Connector 8
Neu JTL Shopify Connector und Billbee frage Shopify-Connector 0
Neu JTL Connector zu SW6 auch als Testumgebung möglich ? Onlineshop-Anbindung 4
Neu Shopify Erhöhung der Varianten von 100 auf 2000 - Connector App Problem Shopify-Connector 4
Neu Greyhound JTL-Connector funktioniert nach Update auf 1.8.12 nicht mehr richtig Technische Fragen zu den JTL-Connectoren 6
Neu Connector anlegen in Verkaufskanälen nicht möglich, Verbindungstest schlägt fehl Shopware-Connector 2
Neu JTL Connector Woocomerce für PHP Version 7.4 WooCommerce-Connector 2
Fehler beim Datenbank - JTL WAWI Connector WooCommerce-Connector 1
Neu Woocommerce mit JTL Connector "Die Shop-URL verweist nicht auf einen gültigen Shop" WooCommerce-Connector 4
JTL WAWI 1.8.11.1 / JTL CONNECTOR / Shopware 6 JTL-Wawi 1.8 4
Neu Connector für php 8.3 / Prestashop 8.1.3 PrestaShop-Connector 6
Neu Migration von eCommerce-Integrator auf JTL Connector - Software 5 Shop Onlineshop-Anbindung 2
Neu JTL Connector WooCommerce überträgt keine Bestellungen mehr WooCommerce-Connector 3
Neu JTL Connector Woocommerce nicht möglich WooCommerce-Connector 9
Neu Anordnung des Elementes für Anzahl der Ergebnisse für Kategorieseiten User helfen Usern - Fragen zu JTL-Wawi 0
Neu Anfrage: Plugins für Bestellfortschritt und Versandkostengrenze gesucht... Plugins für JTL-Shop 1
Auftrag erfassen, nur eine Zeile für Positionsname? JTL-Wawi 1.9 4
Neu Sammelauftrag zusammenfassen für Rechnung User helfen Usern - Fragen zu JTL-Wawi 1
Neu FBA Umlagerung + Vorschlagsmengenberechnung: Spalte für Artikel- /Gesamtgewicht JTL-Wawi - Ideen, Lob und Kritik 0
Neu 1.9.4.1 Ausgabe Dropdown-Menü für Angebote und Aufträge funktioniert nach Update nicht mehr Installation von JTL-Wawi 2
Neu Einkaufspreise für Produktionsartikel JTL-Plan&Produce - Ideen, Lob und Kritik 2
Workflow für Rechnung automatisch als PDF in Verzeichnis abspeichern JTL-Wawi 1.8 9
Versanddaten-Exportvorlage (nicht EU) für DPD Cloud JTL-Wawi 1.8 0
Neu Variable für Steuernummer in Dokumenten Gelöste Themen in diesem Bereich 7
Neu Angebotslink für Klarna JTL-Wawi - Ideen, Lob und Kritik 2
Neu Versandstaffel für ebay einstellen eBay-Anbindung - Ideen, Lob und Kritik 0
Neu Rabatt für Kinder mit Rabattangabe User helfen Usern - Fragen zu JTL-Wawi 2
In Bearbeitung POS Kassenbuch Eintrag für Konto ist leer / Buchungskonto fehlt Allgemeine Fragen zu JTL-POS 1
Neu Anfrage: Sendy Plugin für JTL Shop 5 Plugins für JTL-Shop 0
Neu Anderer Steuerschlüssel für bestimmte Aufträge / Kunden User helfen Usern - Fragen zu JTL-Wawi 1
Neu URLs für Sprache Englisch nicht generieren Allgemeine Fragen zu JTL-Shop 8
Neu Kundendaten extern verschlüsseln (Für den eigenen Shop) und per Import importieren Technische Fragen zu Plugins und Templates 2
Neu Adressabgleich für Shop5 Plugins für JTL-Shop 5
Welche Tabelle für Trennzeichen? JTL-Wawi 1.8 1
In Bearbeitung Feature Request: Epson USB Stick an Epson TM-M30iii für mehrere Kassen Allgemeine Fragen zu JTL-POS 1
Neu Wie stelle ich ohne viel Aufwand fest, ob meine Plugins nach einem Update für JTL Shop 5.3.1 geeignet ist ? JTL-Shop - Ideen, Lob und Kritik 4
Neu Wokflow für Auftrag im Fehlbestand incl Artikelnummer User helfen Usern - Fragen zu JTL-Wawi 6
Neu Link für Newsletter um ihn im Browser zu öffnen Allgemeine Fragen zu JTL-Shop 0

Ähnliche Themen