Neu 1.4.32.0 - "Drucker aus Vorlage verwenden" - immernoch nicht funktionsfähig (in "Legacy"-Vorlagen ?)

  • Wartungsarbeiten - Deutsche Post / Internetmarke - 22.10.19 - 6Uhr bis 7Uhr
    Der Kauf / Bezug von INTERNETMARKEN (über alle Kanäle) und die Bezahlung mit der PORTOKASSE ist während der Anpassung nicht möglich.
    Weiterführende Infos gibt es hier: Infos zur Wartung

SLiPCoR

Aktives Mitglied
14. März 2016
20
0
#1
Hallo zusammen!

Es wurde im Changelog ja erwähnt, dass an den Druckern bzgl. der Druckvorlage gearbeitet wurde. In der vorherigen Version kamen Druckauftrage "Drucker aus Vorlage" gar nicht an.
Wir sind nun einen kleinen Schritt weiter. Ich werde nochmal kurz zusammenfassen wie unsere Definition ist.

TL;DR: Ich habe das Gefühl, dass im Formular-Editor im Layout die Drucker-Einstellung (der Drucker, Magazineinstellungen werden gespeichert) nicht gesichert wird. Beim wieder Öffnen ist der Drucker wieder auf Client-Standard gesetzt. Dies führt meines Erachtens zu Druckproblemen und zum Aushebeln der "Drucker aus Vorlage"-Funktion. Es scheint an der Vorlage oder Vorlagen-Art zu liegen. Die Vorlage benutzen wir schon seit Jahren und wir würden diese Funktion gerne mit der Vorlage nutzen!

Ausführliche Informationen/Meine Versuche dem Problem auf den Grund zu gehen:
---------------------------

Wir gehen mit einer Remoteverbindung auf den Server. Dieser hat eigene Drucker lokal installiert und diese werden auch überall verwendet.

Gewünschte Einstellungen z.B. für Rechnungsdruck:

Drucker 1: "Drucker aus Vorlage"
Drucker 2: "Ablage 2"

Es gibt folgende Drucker:

Ablage 2 - Automatische Magazinwahl, Druck in SW, Standardpapier, Ausgabe in spezial-Ablage [für die Kopien]
Schwarzweiss (Standard) - Automatische Magazinwahl, Druck in SW, Standardpapier - [nicht in Benutzung]
Briefbogen (Für "Erste Seite") - Kassette 3, Medium Papier, Schwarzweiss [Benutzt für die erste Seite, für die Anschrift und Fußzeile, nicht für die folgenden Seiten gedacht]
Schwarzweiss Kassette 2 - Kassette 2, Medium Papier, Schwarzweiss [Gedacht für die Folgeseiten]

-------------------------------------------


Den Drucker in der Vorlage (Projekt->Layoutbereiche) habe ich eingestellt auf
* Erste Seite: Drucker "Briefbogen", Kassette 3
* Zweite Seite: Drucker "Schwarzweiss Kassette 2", Kassette 2

Es gibt keine manuellen Einstellungen für Papierdicke.

Wenn ich den Formular-Editor zumache und wieder aufmache, sehe ich, dass der Drucker immer wieder zurückgesetzt wird auf:

Schwarzweiss (Standard) (umgeleitet) - Dies ist der auf dem Client-PC installierte SW-Treiber was ja funktionieren könnte, aber es ist nicht der Drucker, den ich haben wollte, insbesondere sieht man wie folgt dass dies nicht funktionieren kann:

Die Kassetten-Einstellungen bleiben korrekt eingestellt, aber leider passiert folgendes:

Der Drucker bekommt beide Aufträge, führt zuerst Drucker 2 aus, dies klappt zuerst genau wie es sein sollte (ich denke, da der Drucker manuell in den Druckeinstellungen fest eingestellt ist)

Dann kommt der zweite Druckauftrag, der Drucker meldet einen Fehler "Falsches Papier in Kassette 3" - D.h. es wird die korrekte (im Layout eingestellte) Kassette angesprochen, aber, wahrscheinlich weil der Drucker nicht gespeichert wird, es wird der Standarddrucker mit Standardpapier ausgewählt, was aufgrund der Kassetten-Papier-Einstellung nicht klappt. Die Kassetten einzustellen auf "du hast Normalpapier" ist keine Lösung, da dickeres Papier (für die Brief-Rechnungen) höhere Temperaturen zum Fixieren braucht und daher definitiv eine Drucker-Einstellung benötigt die das Papier berücksichtigt.

Wir können uns erst einmal wie vorher damit behelfen, dass wir unseren Drucker manuell einrichten. [Drucker 1: MPC Briefbogen] Wir haben in unserem Druckertreiber sogar hinterlegt, dass die erste Seite von hier kommt und der Rest von da.

Aber ich würde gerne an einer Lösung dieser Formular-Einstellung arbeiten, um z.B. E-Mail-Kunden gar keine Rechnung mehr auszudrucken, dafür muss diese Drucker Einstellung im Layout aber funktionieren.
(Eine Formel hab ich schon. Falls Email Kunde, drucke die Rechnung nicht aus, ansonsten drucke die Rechnung. Diese Formel wird ebenfalls nicht gespeichert, sondern der Drucker springt auf Schwarzweiss zurück)

Ist es möglich, dass "nur" das Speichern des Druckers im Formular-Editor behoben werden muss und dann geht alles?

Bei Rückfragen bin ich noch bis Donnerstag und dann ab Dienstag wieder da.

Vielen Dank für eventuelle Mühen!

Edit1: Es scheint damit zu tun zu haben, dass ich eine alte Vorlage (seit Jahren) benutze. Wenn ich eine neue Vorlage erstelle, so behält diese die Drucker-Einstellungen.

MfG

SLiPCoR
 
Zuletzt bearbeitet:
14. Juni 2018
6
0
#2
Wir haben genau das selbe Problem:
Wenn wir den Formular-Editor zumachen und wieder aufmachen, ist der Drucker im Formular immer wieder auf den Standarddrucker zurückgesetzt.
 

Rico Giesler

Administrator
Mitarbeiter
10. Mai 2017
11.552
1.115
#3
Kannst du genauer beschreiben was du wo eingestellt hast?
Würde es gern nachstellen.
Welche Wawi-Version nutzt du und nutzt du auch die neuen Vorlagen?
 

Happy

Moderator
Mitarbeiter
29. Juli 2011
261
21
Hückelhoven
#4
Hallo Leute,
der Drucker welcher in den Projekteinstellungen hinterlegt werden kann, speichert List&Label auch korrekt weg.
Die JTL- Wawi bzw. viel mehr List&Label spricht diesen hinterlegten Drucker anschließend auch korrekt an.

Das Problem jedoch ist, das bei jedem Aufruf von L&L der jeweilige Client Drucker gezogen und hinterlegt wird.
Heißt bei jedem bearbeiten der Vorlage muss der Drucker in den Projekteinstellungen neu hinterlegt werden.

Das Papierkasettenproblem kenne ich schon länger und ich habe bis Heute keine Lösung dafür.
Bei einigen funktioniert das, bei anderen nicht.
Damals habe ich es auf den Drucker selbst oder Treiber geschoben.

Heute jedoch weiß ich das es ein Zusammenspiel aus diesem und der L&L Version ist.

Damals haben wir (Meine damalige Chefin und ich) uns dazu entschlossen beim Kunden einen zweiten Drucker hinzustellen, weil das einfach billiger war als weiter nach einer Lösung zu suchen ;)

Ich besorge mir nochmals die Changelogs von L&L und prüfe ob hier ein solcher Fehler behoben wurde und lasse die Entwicklung ein internes Update der Software prüfen, zuletzt bedeutete das einen enorm großen Entwicklungsaufwand.
 

Bullit26

Aktives Mitglied
24. April 2013
64
0
Blankenfelde-Mahlow
#5
Also, ich habe ein ähnliches Problem trotz der oben aufgeführten Varianten.
Ich habe eine Auftragsvorlage, diese soll auf einem Labelprinter gedruckt werden, der Lieferschein und Auftragsbestätigung soll aber auf einem anderen Drucker gedruckt werden.
Sobald ich die List&Label schließe ändert die WAWI 1.5.8.1, den im Projekt geänderten Labeldrucker, auf den in Win7 eingestellten Standarddrucker. Somit kommt alles aus einem Drucker. Gewollt ist aber das es druckt wie eingestellt...
Ich habe mich mit MS Remote Desktop angemeldet, auch mit teamviwer 14, bei allen das gleich Verhalten.

Alle Einstellungen für den Drucker sind auf den Labelprinter eingestellt.

Die Wawi läuft auf einem virtuellen Win 7 Rechner. Die Drucker stehen im Netzwerk

Es funktioniert wenn ich List&Label offen halte und das nicht schließe.

Woran kann das liegen? Kann ich win7 auch sagen, du sollst gar keinen Standarddrucker haben? Wenn ja wo kann man das einstellen?

Vielen Dank!