Neu Versandart englisch wird nicht automatisch zugeordet

SB-Admin

Mitglied
9. September 2020
22
5
Hallo,

wir haben ein Problem bei der automatischen Zuordnung einer Versandart. Der Konnektor wurde von unserem Shopanbieter (Xonic) erstellt und funktioniert soweit gut. Wenn wir Aufträge importieren, wird die Versandart (gleiche Schreibweise wie in JTL) automatisch zugeordnet. Ist es allerdings ein englischer Auftrag mit der Versandartbezeichnung "USP ( Shipping to DE)" wird die Versandart nicht zugeordnet, obwohl wir in der englischen Bezeichnung der Versandart "UPS (Versand nach DE)" diese englische Schreibweise korrekt eingerichtet haben. Werden beim automatischen Zuordnen nur die deutschen Bezeichnungen gematcht? Wir verwenden die neueste Version von JTL (1.5.41)

Vielen Dank für eine Hilfestellung
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.434
299
Hallo @SB-Admin,

ich habe es noch nicht getestet, würde aber vermuten, dass das Matching mit der Übersetzung der Versandart nicht funktioniert. An der CustomerOrder kann ein "shippingMethodName" gesetzt werden. Dieser sollte ausschlaggebend für die gewählte Versandart in JTL-Wawi sein. Je nach Möglichkeit sollte also dort die deutsche Bezeichnung hinterlegt sein. Zusätzlich kann ein CustomerOrderItem vom Typ " shipping" angelegt werden, welches eine beliebige Bezeichnung der Versandart als Namen enthalten kann. Diese wird dann entsprechend in der Bestellung in JTL-Wawi als Versandposition angezeigt.
 

SB-Admin

Mitglied
9. September 2020
22
5
Hallo Immanuel,

vielen Dank für die Rückmeldung. Wir verwenden nun einfach nur "UPS" und das klappt dann natürlich in DE/EN. Die Bestellposition ( CustomerOrderItem vom Typ " shipping" ) hatten wir vorher schon korrekt im Auftrag / Rechnung stehen. Nur die Versandart wurde nicht automatisch gesetzt. Jetzt klappt es.
 
  • Gefällt mir
Reaktionen: Immanuel

mona

Gut bekanntes Mitglied
26. April 2016
149
11
Lieber Immanuel

Möchte mich gleich einhaken... das Mapping funktioniert bei mir auch nicht, habe schon versucht, bei Englisch die deutsche Bezeichnung reinzunehmen.... einzige Versandart die funktionert ist Abholung und Barzahlung...

Habe im Wawi die Englische Sprache als Standard eingestellt (dies geht nicht anders wegen eines Plug-Ins). Versandart und Zahlungsart Englisch bei Englisch und Deutsch bei Deutsch
1616087726591.png

****************************************************************
im Admin-Panel des Shops genau dieselben Bezeichnungen
1616087570529.png

**********************************************************************
Zahlungsart im Wawi Englisch bei Englisch, Deutsch bei Deutsch

1616087310248.png

Die Versandart kann ich ja mit eigenen verbinden, bei Zahlungsart kann man das nicht.
WELCHE BEZEICHNUNG WIRD IM WAWI GENAU BENÖTIGT FÜR DAS MAPPING. DER NAME, DER BEI MIR ENGLISCH UNTER ZAHLUNGSART NAME STEHT?

Wäre sehr dankbar für einen Tipp, habe schon stundenlang alle Varianten durchprobiert mit Bestellungen erzeugen für den Versandart/Zahlungsart-Import. Im Wawi schon Versand- und Zahlungsart bei Auftrag
geändert und im Webshop aktualisiert. Irgendwie komme ich nicht weiter. Update auf Wawi 1.5.41 auch probiert.

Vielen Dank im voraus
gruss
mona
 

mona

Gut bekanntes Mitglied
26. April 2016
149
11
Habe in der Datenbank nachgeschaut - dort ist bei dbo.tversandart "cName" definiert für den Begriff, ohne Sprachrelation. Die Sprachalternative, in meinem Fall Deutsch, ist dann korrekt in VersandartSprache drin.

gruss
mona
 

Patrick Gugelsberger

Moderator
Mitarbeiter
1. Februar 2019
399
60
Hallo @mona,

eigentlich müsste nach dem ersten Import einer Bestellung welche in Englisch getätigt wurde in der Wawi unter "Versand->Versandarten" ein Vorschlag generiert werden.

Ich habe in meinem Beispiel einmal als englischen Versandartnamen für DHL "DoeHaEl" angegeben (Unter "Angezeigter Name Englisch"). Nachdem ich hier eine Bestellung in Englisch durchgeführt habe wurde mir der Vorschlag welcher im Screenshot zu sehen ist generiert, hier einfach noch die in der Wawi eingepflegte Versandart auswählen und das Matching sollte für zukünftige Bestellungen automatisch stattfinden.

Sollten diese Vorschläge bei dir nicht generiert werden müssten wir uns das genauer anschauen.
 

Anhänge

  • DHL englisch.png
    DHL englisch.png
    93,5 KB · Aufrufe: 4
  • Gefällt mir
Reaktionen: mona

mona

Gut bekanntes Mitglied
26. April 2016
149
11
Hallo Patrick

Vielen Dank für Deine Hilfe!! Bin nicht auf die Idee gekommen, eine englische Bestellung zu machen. Dachte eine Bestellung nähme sowieso beide Sprachvarianten ins Wawi....

Anhand Deines Bildes.....dann hast Du unter automatischen Versandarten einmal DoeHael für Englisch und ein separates für DHL deutsch?

Habe mittlerweile rausgefunden, dass wenn Kunde bereits in Wawi mit Barzahlung und Abholung,
dann kann dieser Kunde im Shop nichts anderes mehr wählen als diese eine Variante. Eine Änderung der Zahl-/Versandart im Wawi mit Webshopaktualisierung hat nichts gebracht....

Kreiere ich aber einen Neukunden, dann kommt Bar und Rechnung so wie es sein soll. Müsste aber doch bei einem bestehenden Kunden auch möglich sein....

dank & gruss
mona
 

Patrick Gugelsberger

Moderator
Mitarbeiter
1. Februar 2019
399
60
dann hast Du unter automatischen Versandarten einmal DoeHael für Englisch und ein separates für DHL deutsch?
Exakt, DHL ist mit deutschem Namen ebenfalls hinterlegt.

Habe mittlerweile rausgefunden, dass wenn Kunde bereits in Wawi mit Barzahlung und Abholung,
dann kann dieser Kunde im Shop nichts anderes mehr wählen als diese eine Variante.
Das sollte so nicht sein, das müsste ich mir dann mal genauer anschauen, eröffne hierzu am besten mal ein Ticket damit wir das genauer untersuchen können, falls du keine Tickets erstellen kannst schreib mir mal Privat hier im Forum.
 
  • Gefällt mir
Reaktionen: Immanuel

mona

Gut bekanntes Mitglied
26. April 2016
149
11
Finally.....gelöst - Habe alle Versandarten im Shop nochmals neu erstellt, vorher die im Wawi gelöscht.
Bestellungen gemacht und übertragen.

Nun funktioniert es - yeappie !!!
 
  • Gefällt mir
Reaktionen: Immanuel
Ähnliche Themen
Titel Forum Antworten Datum
In Diskussion Versandart bei Check24 und Kaufland Aufträgen durch Worklow die richtige Versandart setzen lassen JTL-Workflows - Ideen, Lob und Kritik 8
Neu Gutschein an Versandart koppeln Plugins für JTL-Shop 2
Neu Versandart erst ab X Artikeln anzeigen Betrieb / Pflege von JTL-Shop 0
Issue angelegt Versandart an letzte Position schieben JTL-Workflows - Ideen, Lob und Kritik 2
Neu Versandart ab Warenwert xy nicht mehr anbieten Einrichtung von JTL-Shop3 0
Neu Workflow Versandart setzten User helfen Usern - Fragen zu JTL-Wawi 5
Gelöst Versandart änder auf "Fake-Versandart" Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 5
Neu Versandart nach dem Ausliefern ändern Arbeitsabläufe in JTL-Wawi 0
Neu Artikel Kurzbeschreibung in Rechnungstext, keine Versandart angezeigt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Versandart Checkbox Technische Fragen zu den JTL-Connectoren 7
Neu Zuordnung Versandklasse zur Versandart Arbeitsabläufe in JTL-Wawi 2
In Bearbeitung Falsche Umsatzsteuer beim setzten der Versandart über Workflow JTL-Workflows - Fehler und Bugs 1
Günstigste Versandart als Standard anbieten Einrichtung JTL-Shop5 0
Zahlungsart bzw. Versandart bei sofort lieferbaren Artikeln Einrichtung JTL-Shop5 0
Neu Ausgabe Seriennummer deutsch englisch Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Fehler - weiße seite bei sprach wechsel auf englisch JTL-Shop - Fehler und Bugs 3
Neu Artikel mit Variation wird zu Freiposition User helfen Usern - Fragen zu JTL-Wawi 2
Neu Zahlungsart wird als Bestellposition eingefügt Allgemeine Fragen zu JTL-Shop 0
Neu Kunden anlegen - Kundennummer wird nicht automatisch vergeben User helfen Usern - Fragen zu JTL-Wawi 2
Neu [5.0.2]/[1.5.48.2] Bestellung wird falschem Kunden zugeordnet? JTL-Shop - Fehler und Bugs 0
In Diskussion IstRechnungsadresseUngleichLieferadress - was wird verglichen JTL-Workflows - Fehler und Bugs 0
Neu Seriennummer wird überschrieben JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 3
Neu Warum Attribut "Zustand" im Shop wird nicht angezeigt? JTL-Wawi - Fehler und Bugs 1
Neu Variable "additionalCharges" wird nicht angezeigt Einrichtung von JTL-Shop4 0
amazon pay wird nicht in als Zahlungsart im Bestellvorgang angezeigt Einrichtung JTL-Shop5 5
Gelöst JTL WAWI Bild aktualisieren - wird nicht im Shop übernommen User helfen Usern - Fragen zu JTL-Wawi 2
Gelöst Warnhinweis wenn Paket schwerer als Xkg wird Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 3
Neu Checkbox Dropchipping möglich wird nicht bei ALLEN zugewiesenen Artikeln ausgefüllt ?!? JTL-Wawi - Fehler und Bugs 0
Neu WAWI Struktur wird nicht richtig als Menüpunkte angezeigt JTL-Wawi - Fehler und Bugs 4
Verwiesen an Support Pickliste wird nicht übertragen JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 1
Gelöst GELÖST: Sunmi D2 - Anbinung Zettle - Standort wird verlangt Gelöste Themen in diesem Bereich 5
Neu Variationsartikel haben andere Lieferzeiten und Beschreibung wird eingeblendet Onlineshop-Anbindung 0
Neu Zahlungsmodul - IBAN wird nicht automatisch importiert Allgemeine Fragen zu JTL-Shop 0
Gelöst Gutschein Barcode wird nicht gedruckt Gelöste Themen in diesem Bereich 2
Neu Auftrag ist angelegt mit Überweisung aber "SEPA" Kommentar wird ausgegeben. 1.6.29.3 JTL-Wawi - Fehler und Bugs 0
Neu Varkombi Aufpreis wird nicht aufgeschlagen Betrieb / Pflege von JTL-Shop 4
Neu Mediendatei: Bei selbstbenannten Tabs mit mehreren Dateien wird nur eine angezeigt JTL-Shop - Fehler und Bugs 0
Neu Ist es möglich, dass ein Auftrag, welcher in der Wawi erstellt wurde, über LS-Pos abgerechnet wird? Fragen rund um LS-POS 1
Neu Detailbeschreibung wird mehrfach angezeigt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
In Bearbeitung Bon wird nicht beendet Allgemeine Fragen zu JTL-POS 3
Neu Versand mit Parcel.One wird nicht von Amazon übernommen Amazon-Anbindung - Fehler und Bugs 0
Neu Kategoriebild wird nicht hochgeladen? Gambio-Connector 3
Neu DHL Wunschpaket - Postnummern-Feld wird nicht angezeigt Plugins für JTL-Shop 1
Neu Warenkorb immer wieder leer, sobald der Browser geschlossen wird JTL-Shop - Fehler und Bugs 9
Neu Bestandsübersicht/Lagerplatz wird nicht gedruckt bei LB 0 User helfen Usern - Fragen zu JTL-Wawi 2
Neu Manuelle Beschaffungszeit wird immer automatisch auf 0 gestellt. JTL-Wawi - Fehler und Bugs 4
Neu header.tpl wird nicht aus dem Child Template genommen JTL-Shop - Fehler und Bugs 5
Neu Countdown Portlet wird bei Apple nicht ausgegeben JTL-Shop - Fehler und Bugs 1
Neu Papier / Labelgröße wird nicht gespeichert Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Lagerbestand wird nicht übertragen WooCommerce-Connector 2

Ähnliche Themen