Neu Versand- und Freitextpositionen in Dokumenten ohne Text

Mike73

Aktives Mitglied
19. Dezember 2019
124
19
Tach zusammen,

ich hatte hier schon mal einen Thread gesehen, da stellte jemand eine ähnliche Frage - ich finde ihn aber nicht mehr. Also sorry, falls das schon beantwortet wurde, dann gerne einen Link zum Thread.

Problem: Bei Versand- und Freitextpositionen werden die Namens- und Beschreibungsfelder für Formulare wie Rechnung oder Auftrag nicht gefüllt. Die Stellen im Dokument bleiben einfach leer.
Die Datenfelder selbst werden in der Tabelle sichtbar angezeigt, das konnte ich prüfen. Es scheint tatsächlich so zu sein, dass die Variablen in diesen Positionen einfach leer sind. Anzahl und Preis beispielsweise werden aber korrekt angezeigt.

Nachtrag: Beim Lieferschein ist zumindest die Freitextpositionn vorhanden, die Versandposition fehlt dafür vollständig.

Ist das ein Bug oder ein Feature ?

Gruß

Mike
 

Anhänge

  • capture_001_07052021_085458.jpg
    capture_001_07052021_085458.jpg
    3 KB · Aufrufe: 8
Zuletzt bearbeitet:

Underbär

Gut bekanntes Mitglied
19. Mai 2015
260
24
Das sieht mir nach einem Fehler in deiner Vorlage aus. Nutzt ihr alte Vorlagen mir deutschen Variablen oder die neuen Vorlagen mit englischen Variablen?
 

Mike73

Aktives Mitglied
19. Dezember 2019
124
19
Ich habe nichts an den Vorlagen geändert . Und ich kann dir nicht sagen, ob das "alte" Vorlagen sind .. woran kann ich das sehen ?
Wenns nur die englischen Variablen sind, Ja, die sind in English . Das ist korrekt. Aber das ist "schon immer" so ;)

Und wieso liegt es an der Vorlage, wenn in der Position Table alle Zeilen richtig angezeigt werden, nur (neuerdings) diese beiden nicht? Was sollte da anders sein ?
 

Mike73

Aktives Mitglied
19. Dezember 2019
124
19
Ich hab gerade nochmal geschaut... und nur herausgefunden, dass _gar nichts_ in dieser Tabellenzelle angezeigt wird. Auch die Zellen für Einheit und Artikelnummer beiben leer. Hat die Freitextposition oder auch der Versand jedoch einen Preis oder eine Menge, werden diese korrekt ausgegeben und berechnet.
Ich habe die Darstellungsbedingung auf "true or @PositionsColumnWidthName > 0" geändert, so dass dieses Feld immer angezeigt werden müsste. Den originalen Inhalt habe ich ergänzt, "SalesOrderPosition.ItemDescriptionBrief + SalesOrderPosition.PositionType ", so dass zumindest wohl PositionType ausgegeben werden könnte .. Nope.

Wie gesagt - das gilt für Freitextartikel und Versandpositionen. Das sind beides Positionen, die KEINE Artikelnummer haben. Vielleicht hängt es damit zusammen? Ich sehe das aber im Reportgenerator nicht .. zumindest finde ich es nicht .

Noch Ideen ?
 

fibergirl

Sehr aktives Mitglied
14. April 2016
697
187
Hamburg
Dass die Versandposition auf dem Lieferschein nicht dabei ist, hat wohl seine Richtigkeit. Sie kann ja auch nicht mit im Paket liegen ;)

Bei den Rechnungen (u. a.) hatten wir das gleiche Problem.
Wir haben das dann erstmal so gelöst, dass da, wo die SKU angezeigt wird, stattdessen eine Bedingung steht.

Kladde-Kurzform, auswendig:
Cond(IsNullOrEmpty(InvoicePosition.SKU), InvoicePosition.PositionType, InvoicePosition.SKU)
Dann steht da zwar z.B. " Shipping Position" beim Versand, aber immerhin ist der Platz nicht leer, sondern da steht etwas Verständliches.
 

wawi-dl

Sehr aktives Mitglied
29. April 2008
4.905
299
Um noch etwas mehr Licht ins dunkle zu bringen ;)

JTL arbeiten mit Typen, jede Position hat einen bestimmten Typ:
0 = Freitext
1 = Artikel
2 = Versand
3 = Gutschein
... gibt noch einige andere

In Lieferscheinen werden daher nur lieferbare Positionen angezeigt, was will denn ein Kunde mit einer Position "Versand" oder "Gutschein" auf dem Lieferschein?
Manche Kunden fangen vllt. sogar an danach zu suchen :D

Es ist also kein Bug, sondern ganz einfach richtig so.
 

Mike73

Aktives Mitglied
19. Dezember 2019
124
19
Hmm ...

also ich habe gerade zufällig was entdeckt und weiß noch nicht, was es bedeutet. Ich hatte irgendwann einmal probehalber einen zweiten Mandanten angelegt und hab das jetzt bei dem mal getestet. Interessanterweise werden da alle Positionen korrekt ausgegeben. Das ist insofern merkwürdig, als ich an den Vorlagen in den Positionen eigentlich nie was geändert hatte. ...

Im Screenshot der ersten Message sieht man sehr gut, dass nicht die kompletten Zeilen fehlen, sondern nur die Felder SKU und Name ( die Einheit ist bei beiden Positionen ohnehin ein Leerstring) - Ich finde eben nur nicht, wo die Bedingung definiert sein soll, dass diese Felder in diesen Positionen ( Typen?) nicht angezeigt werden sollen. Die Anzeigebedingung habe ich schon so geändert, dass sie immer wahr sind. Nu weiß ich nicht recht, wie weiter.


In Lieferscheinen werden daher nur lieferbare Positionen angezeigt, was will denn ein Kunde mit einer Position "Versand" oder "Gutschein" auf dem Lieferschein?
Manche Kunden fangen vllt. sogar an danach zu suchen :D

Es ist also kein Bug, sondern ganz einfach richtig so.
Ich stimme dir und auch fibergirl zu, aber es geht mir um die Auftragsbestätigung und die Rechnung. ;)
 

wawi-dl

Sehr aktives Mitglied
29. April 2008
4.905
299
Leider war dann für mich der Beitrag oben unklar, ich bezog mich auf Thema Lieferschein.

Im Bild ist leider nichts konkretes zu erkennen, was das für Positionen sind, da man auch manuell die SKU/ArtNr löschen kann.

Wir filtern in unseren Vorlagen ganz gezielt alle Typen, weisen somit die Versandkosten separat im Summenblock aus.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu 1.5.44.0 - Fehler bei Emailvorlagenbearbeitung und Versand JTL-Wawi - Fehler und Bugs 1
Neu Amazon Versand und JTL Shipping Label User helfen Usern 1
E-Mail-Versand mit SSL/TLS geht nicht Einrichtung JTL-Shop5 0
Neu Versand mit Europaket - Fehlermeldung 1101 - Die Angabe der Zeile ist nicht möglich JTL-ShippingLabels - Fehler und Bugs 0
Gelöst Versandbestätigung per Mail versenden über einen Eintrag unter Versand => Packtisch/WMS-Ausgabe Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 3
Neu mehrere Lieferungen zu einem Versand zusammenfügenv Arbeitsabläufe in JTL-Wawi 0
Neu Versand von Gefahrgut User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst Paket-Versand über WMS Rechnungsausdrucke fehlen sporadisch Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 9
Kostenlos Einsteigerschulung: Tag 4 - Versand & Retouren Messen, Stammtische und interessante Events 0
In Bearbeitung Seit Connector Update: Wenn Versand gesetzt, wird kein Lieferschein über den Connector an Shopware 5 übertragen Shopware-Connector 1
Neu Versand (F8) - unbezahlt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Email Versand Problem (Timeout?) bei Lieferantenbestellung JTL-Wawi - Fehler und Bugs 0
Neu Newsletter-Versand funktioniert nicht Betrieb / Pflege von JTL-Shop 0
Neu JTL Plugin für den Versand per Spedition Dienstleistung, Jobs und Ähnliches 4
Neu PayPal Plus - Keine Kreditkartenzahlung möglich bei Versand nach China JTL-Shop - Fehler und Bugs 0
Beantwortet Auftrag ohne Versand abschließen per SQL User helfen Usern - Fragen zu JTL-Wawi 1
Neu Versand bzw. -art nicht als Position auf Rechnung Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 4
Neu Gewicht Versand automatisch in WooCommerce Shop aus Wawi User helfen Usern - Fragen zu JTL-Wawi 0
Neu Aufträge an den Versand via dotliquid in einer Mail übergeben User helfen Usern - Fragen zu JTL-Wawi 0
Kostenlose Einsteigerschulung: Tag 4 - Versand & Retouren Messen, Stammtische und interessante Events 0
Neu Arbeitsablauf Versand bei teillieferbaren Bestellungen Arbeitsabläufe in JTL-Wawi 2
Neu Rechnung Vorlage - Zolltarifnummer auch bei Versand User helfen Usern - Fragen zu JTL-Wawi 1
Neu Im Popup "Versand" keine Inhalte aus OPC JTL-Shop - Fehler und Bugs 4
Neu Workflow: Versandklasse ändern nach WMS Versand User helfen Usern - Fragen zu JTL-Wawi 0
Neu Googleshopping-Fehlendes Unterattribut [Land (Unterattribut von [Versand])] User helfen Usern - Fragen zu JTL-Wawi 0
Neu Auftrag ohne Versand abgeschlossen JTL-Wawi - Fehler und Bugs 2
Neu TLS1.2 oder höher für JTL-POS E-Mail-Versand gewünscht. JTL-POS - Ideen, Lob und Kritik 4
Neu JTL-Wawi 1.5.46.0 - Firewallregeln (eingehend & ausgehend) am Server & Client, welche und welche Ports? User helfen Usern - Fragen zu JTL-Wawi 4
Leider nur 3 Kategorien und 2 Unterkategorie möglich. Einrichtung JTL-Shop5 9
Neu Produktstream Artikel und Sticker Betrieb / Pflege von JTL-Shop 1
Neu Auslandsversand und Shopware Shop JTL-ShippingLabels - Fehler und Bugs 0
Neu Ribbon GROß und kleinschreibung Templates für JTL-Shop 2
Neu Error 500 und Forbidden 403 Bei Plugin Backend Aufruf Plugins für JTL-Shop 0
Neu OSS und UID-Nummer auf der Rechnung User helfen Usern 0
Neu Wunschliste und Vergleichsliste unter dem Warenkorbbutton Allgemeine Fragen zu JTL-Shop 1
Neu Amazon Pay und Zahlungsmodul API 2.0 Arbeitsabläufe in JTL-Wawi 0
Neu JTL Shop 5 - Kategorienschriftgröße und Position in Megamenu ändern Allgemeine Fragen zu JTL-Shop 4
Neu Unterschied zwischen Swatches und textbox Allgemeine Fragen zu JTL-Shop 1
Neu Lagerbestand in WMS- und Standardlager 0, im FFN ist Bestand vorhanden JTL-Wawi - Fehler und Bugs 2
Vorkonfektionieren und Bestandsführung User helfen Usern - Fragen zu JTL-Wawi 1
Neu Differenzbesteuerung und JTL 2 DATEV User helfen Usern - Fragen zu JTL-Wawi 0
Neu Rätselhafte Listenanzeige nach Shopabgleich und unvollständige Aufträge JTL-Wawi - Fehler und Bugs 0
Neu Gewicht und andere "Stammdaten" gleich auf alle Marktplätze in den Ländern eBay-Anbindung - Ideen, Lob und Kritik 0
JTL Shop 5.0.1 - Kein richtiger Abgleich der Artikel-Fotos zwischen WAWI und Shop Einrichtung JTL-Shop5 4
Neu Ebay und Umsatzsteuer-Identifikationsnummer Business Jungle 0
In Bearbeitung Bei neuen Bon und Scanner Einsatz stürtzt POS ab. JTL-POS - Fehler und Bugs 3
Neu Dummy-Väter werden teilweise hochgeladen und verbleiben im Shop Shopware-Connector 1
Neu benötige dringend Hilfe nach Domainumzug und Verzeichnisswechsel Allgemeine Fragen zu JTL-Shop 5
Neu Gutscheine erstellen und im Shop verkaufen Arbeitsabläufe in JTL-Wawi 3
Neu Klarna und Paypal gleichzeitig nutzen Plugins für JTL-Shop 1

Ähnliche Themen