Neu Upgrade auf Wawi 1.4.35: customer_order.push wird nicht mehr ausgelöst

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Rolf

Aktives Mitglied
17. September 2015
28
0
Hallo zusammen,
ich weiß, das ist schon ein sehr spezielles Thema, aber vielleicht kann mich ja jemand in die richtige Richtung stoßen.

Vor einigen Jahren habe ich im Auftrag eines Kunden für einen selbst programmierten Shop einen Connector geschrieben. Jetzt wurde ich wieder von dem Kunden kontaktiert, weil der Support der Wawi-Version, die er benutzt, im Oktober ausläuft.
Also habe ich die Wawi 1.4.35 installiert und mit meinem alten Connector getestet. Produkte zum Shop übertragen (product.push) klappt weiterhin super, auch das Abrufen neuer Bestellungen (customer_order.pull). Nur wenn eine Bestellung in der Wawi auf bezahlt gesetzt oder versandt wird, geht das nicht mehr an den Shop raus (customer_order.push).

Erstmal das Offensichtliche:
Wenn man in der Wawi im Fenster der Onlineshop-Anbindung auf "Connector konfigurieren" klickt, ist der Haken bei "Daten zum Onlineshop senden" gesetzt.
Bei den Synchronisierungsoptionen wird angezeigt, dass Aufträge empfangen und gesendet werden dürfen.
Bei "Funktionen" steht: "Auftragsaktualisierungen möglich: Ja".

Hab schon die Logs kontrolliert und alle Daten abgefangen, die per POST an den Connector geschickt werden, ob die aktualisierten Bestellungsdaten unter einem anderen Schlüssel gesendet werden - nichts gefunden.
Die features.json habe ich mit dem aktuellen Connector von Shopware 5 verglichen, ob es da neue Entities gibt - hat nichts gebracht. Interessanterweise habe ich in den Connectoren von Shopware 5 und Prestashop jeweils unter Controller/CustomerOrder.php nur die "pull"-Funktion gefunden, aber keine "push"-Funktion. Das wurde doch nicht etwa deaktiviert?

Oder ist es abhängig von den Connector-Infos, die der Connector an die Wawi schickt? Bei mir sind das folgende:
Connector-Version: 1.3
Plattform: Shopware (Man braucht ja eine kostenlose Lizenz)
Plattform-Version: 4 (5 brachte keine Veränderung)
Protokoll-Version: 7 (hochsetzen auf 8 bringt die Meldung, dass 7 erwartet wird)

Danke an alle, die bis hierhin gelesen haben. Ich bin für alle Hinweise und Vermutungen dankbar.

Gruß
Rolf
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
784
152
Hallo @Rolf,

das ist aktuell ein Bug in der Wawi. Dieser führt dazu, dass kein StatusChange.push mehr ausgelöst wird. Dieser Call ist für die Aktualisierung des Bestell- und Bezahl-Status zuständig. Siehe auch WAWI-38794 in unserem Issue Tracker.
 

Rolf

Aktives Mitglied
17. September 2015
28
0
Hallo Immanuel,
vielen Dank für die schnelle Antwort. Also heißt es entweder abwarten und Tee trinken oder die nächst niedrigere Version installieren.
Ein Schelm hat den Status des Bugs bereits auf "gelöst" gesetzt. War bei meinem Test mit der aktuellen Version 1.4.35.2 aber unverändert. Nunja...
 

Rolf

Aktives Mitglied
17. September 2015
28
0
Verzeihung für's spammen, aber kann man abschätzen, wann eine gefixte Version veröffentlicht wird? Im Issue Tracker steht ja bei der Version "maintenance-1.5". Aber der Fix wird doch bestimmt so bald wie möglich, optimalerweise nächste Woche, per Update in 1.4.35 landen, oder?
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
784
152
Habe vorhin Rücksprache mit der Wawi Entwicklung gehalten: Der Fix wird im kommenden 1.5er Release enthalten sein, welche die 1.4 schon bald ablösen wird.
 

Rolf

Aktives Mitglied
17. September 2015
28
0
Super, damit kann man was anfangen.
Aber ich vermute, dass mein Kunde lieber eine ältere Version installiert als eine Beta-Version. Gibt es schon einen Release-Termin für 1.5 stable?
Und ist dieser Bug in allen Versionen von 1.4 oder hat er sich erst später eingeschlichen?

Vielen Dank jedenfalls schon mal, der Thread kann damit gerne schon als gelöst markiert werden.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Serverumzug der Wawi von altem Rechner auf neuem und client Instalation Installation von JTL-Wawi 4
Neu Fehler nach Update auf Shopware Connector 2.5.5 Shopware-Connector 1
Neu JTL-Shop 4.02 update auf 4.06, Backend nicht erreichbar Installation / Updates von JTL-Shop 14
Neu WAWI-47796 - Leistungsdatum auf der Rechnung - Wie solls sein? Umfragen rund um JTL 13
Neu Globale Filterung zum deaktivieren von Artikeln auf der Startseite Shop 5.0 Technische Fragen zu Plugins und Templates 0
In Bearbeitung Wawi hängt sich auf nach dem Login JTL-Wawi - Fehler und Bugs 1
In Bearbeitung "Verschieben" eines Artikels von einer Subkategorie in eine andere in der WAWI wird nicht auf POS synchroinisiert JTL-POS - Fehler und Bugs 1
Neu ebay managed payments - Zahlen auf Rechnung - Rechnungsvorlage? User helfen Usern - Fragen zu JTL-Wawi 4
Neu Versandkosten auf Null nach Auftrag fertigstellen JTL-Wawi - Fehler und Bugs 3
Neu Problem mit langem Artikelnamen auf dem BON JTL-POS - Fehler und Bugs 0
Neu Rabattierter Preis auf Artikeletikett Arbeitsabläufe in JTL-Wawi 0
Neu Problem mit Datenbank-Import nach Wawi (PC)-Neuinstallation Win 7 auf Win 10 User helfen Usern - Fragen zu JTL-Wawi 10
Neu Bilder auf Artikelliste einblenden Allgemeine Fragen zu JTL-Shop 14
Neu Container auf Startseite zufügen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Nettobeträge bei 2 Steuersätzen anzeigen auf der Rechnung User helfen Usern - Fragen zu JTL-Wawi 3
Neu JTL Wawi Desktop Programm auf RDP Hosting umstellen Arbeitsabläufe in JTL-Wawi 0
Gelöst Problem: Selbsterstellte Produkte automatisch auf Amazon UK, Spanien usw. Amazon-Lister - Fehler und Bugs 2
Neu DHL Versenden Telefonnummer des Empfängers wird nicht auf Label gedruckt JTL-ShippingLabels - Fehler und Bugs 4
Gelöst Momentan nicht auf Lager - trotz Lagerbestand Arbeitsabläufe in JTL-WMS 3
Neu Artikel ohne Bestandsführung nicht auf Lieferschein Arbeitsabläufe in JTL-Wawi 0
Neu Telefonnummer nicht auf Label + Firmenname manchmal erst bei zweiten Versanddatenexport JTL-ShippingLabels - Fehler und Bugs 0
Neu Kundenadressen lassen sich nicht auf dauer ändern User helfen Usern - Fragen zu JTL-Wawi 5
Neu Versandkosten werden auf Bestellabschlussseite nicht angezeigt Templates für JTL-Shop 2
Neu Die Währung wechselt nicht von EUR auf CHF Einrichtung von JTL-Shop 1
Neu Nach Update auf 1.5 - Aufträge ausliefern - Lieferscheinreihenfolge nur noch nach Auftragsnummer sortiert möglich User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst Installation Datenbank auf 1blu Fehler ! Gelöste Themen in diesem Bereich 2
Neu Vorlageneditor: PDF in Basis wird nur auf Seite 1 angezeigt User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung Rabatte werden nicht "deaktiviert", wenn diese auf gesperrt stehen - POS-878 JTL-POS - Fehler und Bugs 2
Gelöst 1.5.24.1 - Gesamte Pickliste auf einen anderen Lagerplatz buchen Arbeitsabläufe in JTL-WMS 13
Neu JTL POS auf Tablett mit USB auf großem Bildschirm Einrichtung / Updates von JTL-POS 2
Gelöst Nach update auf 1.5.26.0 keine gelösten Tickets mehr sichtbar Servicedesk (Beta) 2
Neu Worst Case eingetreten- SQL Server2019 Testzeitraum Ende, kein Zugriff mehr auf die Datenbank, Datenbank lässt sich nicht wiederherstellen (mit Bild) Installation von JTL-Wawi 12
Neu Workflows drucken auf falschem Drucker User helfen Usern - Fragen zu JTL-Wawi 3
Offen Vom WF Auftrag auf Rechnungsvariablen zugreifen JTL-Workflows - Fehler und Bugs 2
Neu JTL-Shop auf PHP 7.3 umstellen Installation / Updates von JTL-Shop 2
Neu Artikel auf Bestellvorschlägen, die bereits gepickt sind JTL-Wawi - Fehler und Bugs 0
Neu Neu im Sortiment erscheint nicht auf Startseite JTL-Shop - BETA - Feedback und Bugmeldungen 9
In Diskussion "No Session" Fehler nach Update auf modified 2.0.5.1 Modified eCommerce-Connector 4
In Bearbeitung Artikeltext aus dem Ausgabeweg "Drucken/Mailen/Faxen" auf Rechnungsbeleg Verkaufsbeleg drucken Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Ausweis der Tracking ID auf der Rechnung mit englischer Variablen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Gelöst Clients haben keinen Zugriff auf den Server mehr Gelöste Themen in diesem Bereich 2
Neu Suche Directquery Abrage für Lagerbestand auf Pickliste Dienstleistung, Jobs und Ähnliches 4
Neu Auf der Rechnung: falsches EAN bei Stücklisten Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Gelöst Logo wird nicht auf Bon gedruckt Einrichtung / Updates von JTL-POS 3
Neu Versandkosten werden bei RG-Storno auf Warenerlös gegengebucht, nicht aber gegen Aufwand Versandkosten User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shop verliert nach dem Bearbeiten Links und Bilder auf der Startseite Allgemeine Fragen zu JTL-Shop 3
Gelöst Varianten Artikel "momentan nicht verfügbar" - weiße Schrift auf weißen Hintergrund Gelöste Themen in diesem Bereich 5
In Bearbeitung Individueller Rabatt auf Bon (nicht %) - POS-852 Allgemeine Fragen zu JTL-POS 1
Neu Umstellung eines Artikels auf FBA Versand Amazon-Lister - Ideen, Lob und Kritik 3
Gelöst Shop verliert nach dem Bearbeiten Links und Bilder auf der Startseite Gelöste Themen in diesem Bereich 3
Ähnliche Themen