Gelöst Onlineshop-Abgleich übertrag KEINE Daten in die Wawi?

  • Fehler bei Bestellberichten im Amazon Seller-Central

    Soeben ging ein Newsletter an alle User heraus mit wichtigen Informationen zu diesem Fehler und dessen Beseitigung.

    Wir haben hier die Informationen noch einmal hinterlegt: Klick

  • Das Stable Release von JTL-Wawi 1.6 ist startklar: HIER gehts zum Forenbeitrag

Tonycross

Aktives Mitglied
25. Januar 2017
28
0
Hallo,

ich habe JTL WAWI auf einen neuen Rechner Installiert und bin gerade am einrichten. Wollte einen Shop-Abgleich machen aber bekomme keine Daten vom Shop?





Abgleich-Protokoll:
Prüfe Endpointkonfiguration.
Abgleich gestartet für 'Freiburgs Finest'.
Gesendet: Kategorien (1 Stück)
Onlineshop-Abgleich beendet für 'Freiburgs Finest'.

Fehler:
Exception: Call to a member function get_attributes() on boolean
Call to a member function get_attributes() on boolean
GlobalData-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Call to a member function get_attributes() on boolean
Call to a member function get_attributes() on boolean
bei jtlCore.ControllerClasses. Connector.Abgleich.Connector.JYmxOiHRRQT(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.qMqxOLrAFrP(String , List`1 model)
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.Push(String modelName, IEnumerable`1 model)
bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorGlobalDataPushTask.PushGlobalData(GlobalData globalData)
bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorGlobalDataPushTask.Run()
bei JTL.Connector.Business.SyncRunner.Run()

Warnungen:
Abgleich darf nicht weiterlaufen.Abgleich darf nicht weiterlaufen.Abgleich darf nicht weiterlaufen.Abgleich darf nicht weiterlaufen






An was könnte das liegen?

Grüße
 

Tonycross

Aktives Mitglied
25. Januar 2017
28
0
Hallo,

hat niemand eine Idee?

Ich würde gerne komplett auf JTL Wawi umsteigen aber es funktioniert nichts wie es sollte!? - Sehr Schade :(
 

Sven M.

Gut bekanntes Mitglied
14. September 2015
165
9
Hallo Tonycross,

der Fehler tritt dann auf, wenn ein Artikel versucht wird zu bearbeiten, der nicht mehr im Shop existiert. Connectorseitig sollte dieser Fehler mit der gerade erschienenen 1.3.6 übersprungen werden, was natürlich nicht den Datenfehlstand erklärt. Daher noch einmal der Hinweis: Ab dem Zeitpunkt der Einrichtung des Connectors ist JTL-Wawi federführend und es sollten keine Änderungen von Stammdaten im WordPress BAckend mehr vorgenommen werden.

Viele Grüße
 

Tonycross

Aktives Mitglied
25. Januar 2017
28
0
Hallo Sven,

ich habe extra JTL Wawi komplett entfernt um an meinem neuen Notebook es NEU einzurichten. Ich habe JTL Wawi installiert, einen Microsoft SQL Server 2014 installiert und das Plugin anschließend NEU in meinem WP installiert!

Ich erinnere mich nicht das ich einen oder mehrere Artikel habe die ich bearbeite obwohl sie nicht mehr im Shop existieren? Wenn ich einen Artikel nicht mehr herstelle, entferne ich diesen im Shop da JTL Wawi ja nicht funktioniert.

Aber warum der Connector solche schwierigkeiten macht kann ich nicht nachvollziehen?

Bei allen anderen scheint es ja zu funktionieren...

Grüße
 

Sven M.

Gut bekanntes Mitglied
14. September 2015
165
9
Guten Tag,

soweit ich Sie verstehe, haben Sie geschildert, dass das Löschen von Artikeln via JTL-Wawi nicht funktioniert und Sie daher diese im Shop löschen. Davon weiß die Wawi jedoch nichts und bei Bestandsänderungen oder ähnlichem wird der Artikel neu zum Shop gesendet um Aktualisierungen vorzunehmen. Zum löschen muss der Artikel lediglich beim entsprechendne Online Shop inder Artikeldetailansicht deaktiviert werden.

Viele Grüße
 

Tonycross

Aktives Mitglied
25. Januar 2017
28
0
Hallo Sven,

nein, dann habe ich mich falsch ausgedrückt!

Soweit ich verstanden habe, hole ich mit dem Connector (Beim erstmaligen Einrichten) alle Daten vom meinem Onlineshop in die Wawi!? Ab diesem Zeitpunkt steuere ich die Daten von der Wawi aus und nicht mehr vom Onlineshop.

Beim erstmaligen Onlineshop-Abgleich bekomme ich aber keine Daten vom Onlineshop in die Wawi?

Liebe Grüße
 

Sven M.

Gut bekanntes Mitglied
14. September 2015
165
9
Hallo Tony,

hast du auch die Online Shop Daten zurückgesetzt als du deine neue Installation auf dem Notebook getätigt hast. Der Connector merkt sich welche Daten schon übertragen wurden und nicht. Dementsprechend musst du bei einer Neuinstallation diese Daten zurücksetzen. Dafür findest du in der Konfiguration des Conenctors in der Wawi einen entsprechenden Button. Vorsicht: Dadurch gehen alle bisherigen Zuordnungen verloren.

Viele Grüße
 

Tonycross

Aktives Mitglied
25. Januar 2017
28
0
Hallo Sven,

habe den Button gefunden. Habe gerade gesehen das ich zwei Lizenzen für WooCommerce2 habe auf die gleiche URL! - Ist das problematisch?

Grüße
 
Zuletzt bearbeitet:

Tonycross

Aktives Mitglied
25. Januar 2017
28
0
Hallo,

ich habe nun alles zurückgesetzt! Auch der Connector habe ich entfernt und neu im WP installiert. Bekomme weiterhin bei einem Shop Abgleich folgende Fehlermeldung:


Abgleich-Protokoll:
Prüfe Endpointkonfiguration.
Abgleich gestartet für 'Freiburgs Finest'.
Hinweis: Artikel werden mit der Einstellung <Eingeschränkt> hochgeladen. Dadurch werden keine neu angelegten Artikel zum Shop geschickt, sondern nur Preise und/oder Bestände von bereits im Shop vorhandenen Artikeln.
Onlineshop-Abgleich beendet für 'Freiburgs Finest'.

Fehler:
Exception: Call to a member function get_attributes() on boolean
Call to a member function get_attributes() on boolean
Aufträge-Empfangen-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPuller.Pull[TEntity](Int64 quantity)
bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.ConnectorPullTask`1.Run()
bei JTL.Connector.Business.SyncRunner.Run()

Warnungen:
Das Varkombi-Kind '0024-0001' hat keine Variationen. Import kann nicht durchgeführt werden.
Das Varkombi-Kind '' hat keine Variationen. Import kann nicht durchgeführt werden.
Das Varkombi-Kind '' hat keine Variationen. Import kann nicht durchgeführt werden.
Das Varkombi-Kind '' hat keine Variationen. Import kann nicht durchgeführt werden.
Das Varkombi-Kind '' hat keine Variationen. Import kann nicht durchgeführt werden.
Das Varkombi-Kind '' hat keine Variationen. Import kann nicht durchgeführt werden.
Das Varkombi-Kind '' hat keine Variationen. Import kann nicht durchgeführt werden.
Abgleich darf nicht weiterlaufen.Abgleich darf nicht weiterlaufen.


Woran kann das nur liegen? - Hoffe auf eine schnelle Hilfe!

Grüße
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Onlineshop Abgleich (zu Shopware) Fehler Artikelmerkmale Farbe, Übersetzungen und Details Shopware-Connector 0
Neu Onlineshop via Connector (Xonic) Problem JTL-Wawi - Fehler und Bugs 0
Neu Verfügbarkeit und Lieferzeitanzeige im Onlineshop Shopware-Connector 0
Neu Workflow: Reiter Rechnung -> Bedingung bestimmter Onlineshop User helfen Usern - Fragen zu JTL-Wawi 0
Neu Lager für Filiale und Onlineshop Arbeitsabläufe in JTL-Wawi 0
Neu OSS-Verfahren + Versandkosten im Onlineshop JTL-Shop - Fehler und Bugs 0
Neu Fehler beim "An diesen Onlineshop binden" Plugins für JTL-Shop 1
Neu Haken in der Registerkarte Onlineshop/JTL-POS automatisch setzen Arbeitsabläufe in JTL-Wawi 1
Neu Daten aus Testumgebung vor dem Verbinden mit onlineShop löschen User helfen Usern - Fragen zu JTL-Wawi 5
In Diskussion Variable für "Ist im Onlineshop aktiv" gesucht JTL-Workflows - Ideen, Lob und Kritik 6
Neu Verbindung zum Onlineshop kann nicht hergestellt werden Onlineshop-Anbindung 5
Neu Kategorie verschieben für Onlineshop gerade nicht möglich ? Fehlermeldung User helfen Usern - Fragen zu JTL-Wawi 4
Neu Bestellungen im Online Shop werden nach Abgleich als Angebot abgelegt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Manueller Abgleich der Plaatformen mit der 1.6 JTL-Wawi - Ideen, Lob und Kritik 0
Neu Kritischer Fehler beim Abgleich mit dem Shop WooCommerce-Connector 0
Neu Abgleich geht nicht mehr User helfen Usern - Fragen zu JTL-Wawi 4
Neu JTL WAWI 1.6 Shop-Abgleich (JTL Shop) - BadRequest JTL-Wawi - Fehler und Bugs 2
Neu Fehlermeldung bei Abgleich wegen Germanized WooCommerce-Connector 2
Neu Amazon Sendungsnummer Abgleich mit JTL WAWI 1.5 JTL-Wawi - Fehler und Bugs 10
Neu Shopware Abgleich - JTL 1.6 Probleme Shopware-Connector 1
Neu Nach Umzug auf anderer Server kein Abgleich mehr möglich Shopware-Connector 0
Neu Fehler beim Online-Abgleich Onlineshop-Anbindung 0
Neu Amazon Abgleich funktioniert nicht Amazon-Anbindung - Fehler und Bugs 5
Verwiesen an Support Abgleich Fehler nach Shopware Connector Update Shopware-Connector 1
Neu Neue Preise werden beim Amazon-Abgleich nicht aktualisiert Amazon-Anbindung - Fehler und Bugs 2
Neu Connector Abgleich schlägt fehlt - Shopware 5 - Exception: The EntityManager is closed - Exception: The EntityManager is closed Shopware-Connector 2
Neu Fehler bei JTL FFN Abgleich Haupt WaWi und Mandant Onlineshop-Anbindung 0
Neu Abgleich mit neuem Mandanten nicht möglich WooCommerce-Connector 0
In Bearbeitung Korrekturbuchung durch POS-Abgleich, weil Artikel aus leerem Lager gebucht wird JTL-POS - Fehler und Bugs 2
Neu Fehler bei Abgleich JTL-WAWI und JTL SHOP JTL-Shop - Fehler und Bugs 13

Ähnliche Themen