Nach Abgleich alles doppelt!

  • Ersteller des Themas Ersteller des Themas dergerätehändler
  • Erstellungsdatum Erstellungsdatum

dergerätehändler

Guest
Hallo,

bis heute habe ich meine 2 Shops mittels zweier Mandanten/Benutzer geführt. Jetzt habe ich das Multishopmodul und alle Artikel unter einen Benutzer, mittels der Ameise zusammengeführt.
Für den 2 Shop habe ich die Connector Zugangsdaten einfach übernommen. Jetzt habe ich einen ersten Webshopabgleich gemacht und plötzlich sind alle Kategorien und Artikel doppelt vorhanden. Es wurden praktisch alle Art. noch einmal hochgeladen.
Wo liegt der Fehler und wie kann ich das jetzt am besten wieder gerade biegen?

In dem Zusammenhang interessiert mich auch noch, ob und wie man einen laufenden Webshopabgleich abbrechen kann. Ich habe den Fehler schon bemerkt als der Abgleich noch lief und keine Möglichkeit gefunden, die Aktion zu stoppen.

Vielen Dank
 

dergerätehändler

Guest
AW: Nach Abgleich alles doppelt!

Nachdem hier keiner eine Idee hatte, möchte ich mal meine Lösung präsentieren. Vielleicht hilft das dann mal irgendwen.
Nach ewig langem Basteln, habe ich das meiner Meinung nach einzig richtige gemacht.
Alle Artikel und Kategorien in beiden Shops gelöscht/entfernt. Dazu über phpMyadmin, folgende Tabellen leeren:

products;
products_attributes;
products_attributes_download;
products_content;
products_description;
products_extra_fields;
products_extra_fields_lookup;
products_graduated_prices;
products_images;
products_notifications;
products_options;
products_options_values;
products_options_values_to_products_options;
products_to_categories;
products_vpe;
products_xsell;
products_xsell_grp_name;
reviews;
reviews_description;
specials;

Dann noch die Tabellen welche mit categorie bezeichnet sind leeren und per FTP die Ordner mit den Bildern leeren:

images/product_images/info_images/
images/product_images/original_images/
images/product_images/popup_images/
images/product_images/thumbnail_images/

Außerdem noch die easysales_ m Tabellen "leeren"

Dann in der Warenwirtschaft die Kategorien und Artikel richtig zuordnen. Als letztes dann einmal Webshopabgleich und alles ist an seinem Platz!

Der Abgleich dauert dann natürlich etwas, da alles neu hochgeladen wird, aber wenn ich daran denke wieviel Zeit ich vorher für die Bastelei verpulvert habe, ist das ein Klacks.

MfG
 

Thomas Lisson

Administrator
Mitarbeiter
24. März 2006
15.574
300
Köln
AW: Nach Abgleich alles doppelt!

Das ist auch die einzig vernünftige Lösung nach deinem ersten Posting. Zu retten wär hier nichts mehr gewesen.
 

Liras

Aktives Mitglied
2. Oktober 2012
4
0
AW: Nach Abgleich alles doppelt!

Moin Moin,

ich hatte das selbe Problem mit den doppelten Kategorien und Artikeln.
Nachdem ich allerdings alle oben genannten Listen gelöscht habe, komme ich nicht mehr auf den Shop.

[h=1]Internal Server Error[/h]The server encountered an internal error ormisconfiguration and was unable to completeyour request.Please contact the server administrator, [no address given] and inform them of the time the error occurred,and anything you might have done that may havecaused the error.
More information about this error may be availablein the server error log.

Was hat dieser Fehler zu bedeuten?

Dieser Fehler kann viele verschiedene Ursachen haben. Die häufigsten Fehler sind:

bei PHP
  • das Script hat zu viel CPU-Ressourcen verbraucht und wurde beendet
  • das Script hat zu viel Memory-Ressourcen verbraucht und wurde beendet. In diesem Fall finden Sie eine Zeile ähnlich wie diese in Ihrem error.log "Unable to allocate X bytes"
  • .htaccess Datei mit falschen Befehlen (mehr Informationen im error.log)
weitere Informationen finden Sie in der Datei error.log im Ordner logs

bei Perl und anderen Scriptsprachen
  • das Script hat zu viel CPU-Ressourcen verbraucht und wurde beendet
  • das Script hat zu viel Memory-Ressourcen verbraucht und wurde beendet. In diesem Fall finden Sie eine Zeile ähnlich wie diese in Ihrem error.log "Unable to allocate X bytes"
  • Script wurde nicht im ASCII Modus hochgeladen
  • Script hat falsche Rechte (korrekt: 755)
  • der Pfad zum Interpreter in der 1. Zeile ist nicht korrekt
  • .htaccess Datei mit falschen Befehlen (mehr Informationen im error.log)
weitere Informationen finden Sie in der Datei error.log im Ordner logs

Dies ist die Einzige Meldung die immer wieder kommt.

Liegt es daran, dass ich noch keinen neuen Webshopabgleich gemacht habe?
Möchte ihn ungerne starten und Stunden warten nur um denn da zu sitzen und immer noch nichts zu sehen ist.

Ich bedanke mich schonmal vielmals für die Hilfe!

Mit bestem Gruß
 

Liras

Aktives Mitglied
2. Oktober 2012
4
0
AW: Nach Abgleich alles doppelt!

Tschuldigung, im Eifer des gefechts falsch ausgedrückt.
Sie sind geleert und nicht gelöscht.
 

Thomas Lisson

Administrator
Mitarbeiter
24. März 2006
15.574
300
Köln
AW: Nach Abgleich alles doppelt!

dann musst du im error.log des Apache schauen, welcher Internal Server Error exakt kommt.
 

Thomas Lisson

Administrator
Mitarbeiter
24. März 2006
15.574
300
Köln
AW: Nach Abgleich alles doppelt!

Es wird aber sicherlich einfacher den Shop neu aufzusetzen, als den Fehler zu suchen.
 

Liras

Aktives Mitglied
2. Oktober 2012
4
0
AW: Nach Abgleich alles doppelt!

Alles klar, denn aus dem error.log werd ich auch nicht wirklich schlau...

denn weiß ich erstmal bescheid und bedanke mich für die schnellen Antworten und der Hilfe!!!!
Wünsche noch einen angenehmen Restmontag!


und bis denn dann!
 

Ähnliche Themen