Neu JTL Wawi Verbindung von RDS-Server auf SQL Server herstellen funktioniert nicht

reberei

Neues Mitglied
9. September 2021
2
0
Hallo liebe Community,
wir haben folgendes Problem: Wir sollen von unserem RDS-Server aus eine Verbindung herstellen. Dafür haben wir auf dem RDS-Server standardmäßig "admin" und "pass" verwendet. Dabei entsteht die unten angeführte Fehlermeldung. Wir finden keine entsprechende Lösung, deshalb frage ich jetzt hier weiter nach. Vielen Dank im Voraus!
1631197611696.png
1631197485682.png

Dies ist der Fehlerlog:

Unbehandelte Ausnahme #761E037A5E9D6536 vom Typ jtlCore.Classes.CppConnector.CppException in
jtlCore.Classes.CppConnector.CppException: Fehler beim Zugriff auf die Datenbank (Exec Direct).



2021-09-09T16:24:13 DEBUG - Cache hit: JTL.Data.DataGateway.Gateways.Benutzer.LayoutDataGateway.GetAllUserLayoutsFromDatabase
2021-09-09T16:24:13 DEBUG - SELECT * FROM [tOptions]
2021-09-09T16:24:13 DEBUG - Dauer: 3ms, (bis zum Reader)
2021-09-09T16:24:13 DEBUG - Dauer: 4ms, 64 Zeilen
2021-09-09T16:24:13 DEBUG -
MERGE INTO
eazybusiness.[dbo].[tOptions] AS myTarget
USING (VALUES (@Key, @Value)) AS mySource(cKey, cValue)
ON mySource.cKey = myTarget.cKey
WHEN NOT MATCHED BY TARGET THEN
INSERT (cKey, cValue) VALUES (mySource.cKey, mySource.cValue);
SELECT
cValue
FROM
eazybusiness.[dbo].[tOptions]
WHERE
cKey = @Key;
@key = 'WawiSeed'
@value = '2.3.61830.12'
2021-09-09T16:24:13 DEBUG - Dauer: 12ms, (bis zum Reader)
2021-09-09T16:24:13 DEBUG - Dauer: 14 ms, 1 Zeilen
2021-09-09T16:24:13 DEBUG - SELECT * FROM eazybusiness.dbo.tMandant WHERE cDB = @DBName
@DBName = 'eazybusiness'
2021-09-09T16:24:13 DEBUG - Dauer: 3ms, (bis zum Reader)
2021-09-09T16:24:13 DEBUG - Dauer: 4ms, 1 Zeilen
2021-09-09T16:24:29 DEBUG - Neue Verbindungsparameter: Data Source=RRHBSQL01,1433\MSSQLSERVER;Initial Catalog=eazybusiness;Integrated Security=False;Persist Security Info=True;User ID=sa;Password=;MultipleActiveResultSets=True;Connect Timeout=120;Application Name="JTL-Wawi C#";Current Language=German
2021-09-09T16:24:29 DEBUG - [TableCache] Invalidate: Full Cache
2021-09-09T16:24:29 DEBUG - [TableTable] Eintrag TableCache.tfirma entfernt - Removed
2021-09-09T16:24:29 DEBUG - [TableTable] Eintrag TableCache.tbenutzer entfernt - Removed
2021-09-09T16:24:29 DEBUG - [TableTable] Eintrag TableCache.tOptions entfernt - Removed
2021-09-09T16:24:29 DEBUG - SELECT * FROM [tOptions]
2021-09-09T16:24:29 DEBUG - Dauer: 3ms, (bis zum Reader)
2021-09-09T16:24:29 DEBUG - Dauer: 3ms, 64 Zeilen
2021-09-09T16:24:30 DEBUG - IF OBJECT_ID('dbo.tErrorlog', 'U') IS NULL SELECT 0 ELSE SELECT 1;
2021-09-09T16:24:30 DEBUG - Dauer: 1ms, Result: 1
2021-09-09T16:24:30 DEBUG - SELECT TOP 1 * FROM dbo.tErrorlog WHERE cRechnername = @cRechnername AND nFehlerID = @nFehlerID ORDER BY dErstelltUtc ASC
@cRechnername = 'REINHARDT-NB'
@nFehlerID = 8511244169885082934
2021-09-09T16:24:30 DEBUG - Dauer: 3ms, (bis zum Reader)
2021-09-09T16:24:30 DEBUG - Dauer: 28ms, 1 Zeilen
2021-09-09T16:24:30 DEBUG - UPDATE [dbo].[tErrorlog] SET dErstelltUtc = @dErstelltUtc_0 WHERE kErrorlog = @kErrorlog_0;

@dErstelltUtc_0 = '2021-09-09 02:24:30'
@kErrorlog_0 = 1
2021-09-09T16:24:30 DEBUG - Dauer: 31ms, AffectedRows: 1
Zeitstempel: 2021-09-09T16:24:59
Locale: German (Germany)
Locale: German (Germany)
Version: 1.5.48.1
Plattform: Wawi
WawiSeed: 2.2.12070.67001
Prozessname: JTL-Wawi
Physikalischer Speicher: 85336064 / Peak: 345513984
Basispriorität: 8
Prioritätsklasse: Normal
CPU-Zeit (User): 0:00:13,625
CPU-Zeit (System): 0:00:02,765625
Page-Size (Sytem): 1742784 / Peak: 268541952
Page-Size: 268443648 / Peak: 268541952
Offene Handles: 1353
Database:
Build: 2108131024 5c5d5b88afa245cc26581fb20ee1724694718e4c
 

Kistenkolli

Aktives Mitglied
15. März 2018
16
1
Moin,

habe auch den Fehler...

Konntest du es lösen?

Benutzt du auch Windows 11?

Auf allen anderen Clients läuft es bei uns...
 

reberei

Neues Mitglied
9. September 2021
2
0
Moin,

habe auch den Fehler...

Konntest du es lösen?

Benutzt du auch Windows 11?

Auf allen anderen Clients läuft es bei uns...
Hallo. Ich weiß es ehrlich gesagt gar nicht mehr. Wir haben immer noch Probleme, allerdings scheinen wir das eine gelöst zu haben.. Denke ich. Jedenfalls hat uns das geholfen: Bei der Datenbank im SQL Management in der Datenbank unter Sicherheit - auf den Ordner Anmeldungen einmal Rechtsklick und dann haben wir eine neue Anmeldung erstellt. Diese hieß dann "Vordefiniert\Admnistratoren" (ganz wichtig Vordefiniert\ nicht zu vergessen) und haben bei den Serverrollen sysadmin hinzugefügt. Das hat komischerweise schon geholfen.

Grüße
 

Kistenkolli

Aktives Mitglied
15. März 2018
16
1
Moin,

konnte es lösen, habe das Datenbank Profil gelöscht und neu angelegt.
Wahrscheinlich war ein Leerzeichen das Problem....
 

Ähnliche Themen