Neu JTL Connector Plugin verschwindet in WordPress

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

pfeijue

Mitglied
14. April 2019
31
1
Hallo,

bei mir verschwindet nach einiger Zeit immer der JTL Connector in Wordpress und ich kann über die Wawi keinen Abgleich mehr machen. Das Plugin ist nicht mehr sichtbar in der Leiste und auch nicht über die installierten Plugins zu finden.
Wenn ich das JTL Connector Plugin erneut installieren will heißt es immer das Plugin ist schon vorhanden. Ist aber nicht sichtbar.
Auf dem FTP Server ist das Verzeichnis auch noch vorhanden. Wenn ich das Verzeichnis nun lösche und das Plugin erneut installiere ist er wieder sichtbar und der Abgleich mit der Wawi läuft. Allerdings ist es dann aber wieder nach ein paar Tagen verschwunden.
Hat jemand eine Idee an was das liegen könnte oder wie ich das Plugin in Wordpress wieder sichtbar mache?
Es kann ja nicht sein das man das immer neu installieren muss.

Wawi-Version: 1.4.30.2
Wordpress-Version : 5.3–de_DE
Connector-Version : 1.8.2.10
Plugins:
  • Cookie Notice
  • Germanized für WooCommerce
  • Germanized für WooCommerce Pro
  • Really Simple SSL
  • Really Simple SSL Pro
  • Vendidero Helper
  • WooCommerce
  • WooCommerce JTL Connector – dieser verschwindet nach einer Weile. Kann aber nicht sagen wann
  • WooCommerce PayPal Chekcout Gateway
  • WooCommerce Service
  • WP Maintenance Mode
  • WP-Matomo

Danke für Eure Hilfe
 

pfeijue

Mitglied
14. April 2019
31
1
Hallo Immanuel,

danke für deine Rückmeldung. Leider hat es eine Weile gedauert bis der Fehler wieder aufgetreten ist. Hier jetzt weitere Details.
Heute habe ich eine Mail von Wordpress erhalten dass das JTL Connector Plugin einen Fehler verursacht und nicht geladen werden kann. Jetzt ist auch meine Webseite gar nicht mehr erreichbar.
Hier der Inhalt dieser Mail:

--------------------------------------
Hallo!
Seit WordPress 5.2 gibt es eine eingebaute Funktion, die erkennt, wenn ein Plugin oder ein Theme einen fatalen Fehler auf deiner Website verursacht, und dich deswegen mit dieser automatisierten E-Mail benachrichtigt.
In diesem Fall hat WordPress einen Fehler in einem deiner Plugins, WooCommerce JTL-Connector, abgefangen.
Besuche zunächst deine Website (xxxxxx) und überprüfe sie auf sichtbare Probleme. Besuche als nächstes die Seite, auf der der Fehler aufgetreten ist (xxxxx) und prüfe, ob es sichtbare Probleme gibt.

Bitte kontaktiere dein Hosting-Unternehmen, um Unterstützung bei der weiteren Untersuchung dieses Problems zu erhalten.

Wenn deine Website fehlerhaft zu sein scheint und du nicht mehr wie gewohnt auf dein Dashboard zugreifen kannst, hat WordPress jetzt einen speziellen „Wiederherstellungsmodus“. Auf diese Weise kannst du dich sicher in deinem Dashboard anmelden und weitere Untersuchungen durchführen.

xxx

Um deine Website zu schützen, läuft dieser Link in 1 Tag ab. Aber keine Sorge: Ein neuer Link wird dir per E-Mail zugeschickt, wenn der Fehler nach Ablauf der Frist erneut auftritt.

Wenn du Hilfe bei diesem Problem suchst, wirst du möglicherweise nach einigen der folgenden Informationen gefragt:
#WordPress-Version 5.3
Aktuelles Theme: Twenty Seventeen (Version 2.2)
Aktuelles Plugin: WooCommerce JTL-Connector (Version 1.8.2.10)
PHP-Version 7.1.33###

#

Fehler-Details
==============
Ein Fehler vom Typ E_COMPILE_ERROR wurde in der Zeile 5 der Datei /mnt/web409/e1/90/59363290/htdocs/WordPress_SecureMode_01/wp-content/plugins/woo-jtl-connector/vendor/autoload.php verursacht. Fehlermeldung: require_once(): Failed opening required '/mnt/web409/e1/90/59363290/htdocs/WordPress_SecureMode_01/wp-content/plugins/woo-jtl-connector/vendor/composer/autoload_real.php' (include_path='.:/opt/RZphp71/includes')####

-----------------------------------------------


Im Anhang die Fehlermeldung in der Wawi. Leider wurde keine Logs geschrieben obwohl beide aktiviert waren. Keine Ahnung warum....
Ich habe auch noch ein Bild von Wordpress angehängt wo das deaktivierte Plugin sichtbar ist. Es gab die Möglichkeit ein Update zu machen was aber auch nicht erfolgreich war.

Danke für die Hilfe
 

Anhänge

tobiasgraeber

Aktives Mitglied
22. Januar 2017
36
5
Wenn du das connector Plugin erstmal deaktivierst, sollte die Seite wieder gehen. Dazu z. B per FTP einfach den Ordner

/mnt/web409/e1/90/59363290/htdocs/WordPress_SecureMode_01/wp-content/plugins/woo-jtl-connector/

Herunterladen (als Backup) und anschließend löschen (auf dem Server) - oder schlicht temporär umbenennen.

Anschließend müsste man sich das Problem mal genauer ansehen. Entweder das Autoloading ist defekt oder, wie der Meldung zu entnehmen, der Pfad ist auf dem Server falsch gesetz / Include Path falsch. Alternativ : einfach mal die neuste JTL Connector Version für WordPress herunterladen und gegen die aktuelle austauschen.
 
  • Gefällt mir
Reaktionen: pfeijue

pfeijue

Mitglied
14. April 2019
31
1
Das ist aktuell was ich mache. Auf dem FTP Server löschen und neu installieren.
Allerdings finde ich das nicht grad die beste Lösung auf Dauer....
 

tobiasgraeber

Aktives Mitglied
22. Januar 2017
36
5
Natürlich nicht. Das sollte nur ein temporärer Lösungsansatz sein. Funktioniert denn das Plugin wenn du es sauber neu installiert hast ohne Fehlermeldung im Plugin Manager? Wenn ja, dann deinstalliere es anscheinend nochmal via plugin Manager und installiere es denn nochmal neu (das entfernt ggf. Datenbank Rückstände). Danach sollte es laufen. Auf aktuellste Version achten.

Dann würde sich nur noch die Frage stellen, warum es scheinbar nach einiger Zeit "von alleine" verschwindet. Das kann eigentlich nicht sein und kann ich mir nur so erklären alsdas in bestimmten Abständen in irgendeiner Form auf dem Webserver eine Veränderung erfolgt, angestoßen durch was auch immer.... Das kann man so nicht bzw. nur schwer erraten da empfiehlt sich nur ein direkter Eingriff per FTP/Logs etc. Oder du wendest dich mal an deinen Hoster.
 
  • Gefällt mir
Reaktionen: pfeijue

pfeijue

Mitglied
14. April 2019
31
1
Wenn ich es neu installiert habe funktioniert es einwandfrei. Wie gesagt läuft es eine Weile und verschwindet dann. Kann es eventuell sein, wenn ein Wordpress update passiert?
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
940
201
Ein Fehler vom Typ E_COMPILE_ERROR wurde in der Zeile 5 der Datei /mnt/web409/e1/90/59363290/htdocs/WordPress_SecureMode_01/wp-content/plugins/woo-jtl-connector/vendor/autoload.php verursacht. Fehlermeldung: require_once(): Failed opening required '/mnt/web409/e1/90/59363290/htdocs/WordPress_SecureMode_01/wp-content/plugins/woo-jtl-connector/vendor/composer/autoload_real.php' (include_path='.:/opt/RZphp71/includes')####
Hallo @pfeijue,

es scheint als würde die Datei ".../wp-content/plugins/woo- jtl-connector/vendor/composer/autoload_real.php" durch irgendwas regelmäßig gelöscht. Das ist aber vermutlich nicht das Connector Plugin selbst.
 
  • Gefällt mir
Reaktionen: pfeijue

Immanuel

Moderator
Mitarbeiter
24. August 2016
940
201
Durch ein Wordpress Update passiert das wahrscheinlich nicht. Eventuell treibt ein anderes Plugin hier sein Unwesen. Eine andere Möglichkeit wäre, dass deine Wordpress Installation kompromittiert wurde und eine Malware dafür verantwortlich ist.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu How to connect example connector plugin to JTL wawi Allgemeines zu den JTL-Connectoren 1
Neu JTL-Connector (SW6) - Artikelpflege in JTL / SEO Pflege in Shop? Shopware-Connector 0
Beantwortet JTL Shopware Connector für Shopware 5.6.9 Shopware-Connector 3
Neu JTL Connector Deinstallieren Technische Fragen zu den JTL-Connectoren 1
Neu Suche Freelancer für JTL Connector - Shopware 6 Anbindung Dienstleistung, Jobs und Ähnliches 0
Neu Schopware jtl connector extrem langsam nach Server migration Shopware-Connector 5
Gelöst JTL Shop 5 Keine Verbindung zur WAWI möglich. Die Shop-URL verweist nicht auf einen gültigen Shop! Bitte prüfen Sie die Connector-Konfiguration Gelöste Themen in diesem Bereich 6
Neu WooCommerce JTL-Connector Version 1.14.0 / Woocommerce/Preis auf 0 gesetzt WooCommerce-Connector 3
Neu JTL Connector xtcmodified fehlende Datei configure.php Modified eCommerce-Connector 1
Neu Custom JTL-Connector Technische Fragen zu den JTL-Connectoren 1
Neu JTL Shopware Connector Fehler beim Import von Kunden und Bestellungen Shopware-Connector 2
Neu JTL-Connector WooCommerce Mediadateien Anzeigen lassen WooCommerce-Connector 1
**RELEASE: JTL-Connector (SaaS) für Shopware 6 startet in die Open Beta** Shopware-Connector 144
Neu Connector resetten? Alle Artikel aus JTL erneut zum Shop Modified eCommerce-Connector 4
Neu JTL WAWI & JTL-Packtisch druckt falschen EAN Code bei Etikettendruck Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Umstieg von Afterbuy auf JTL Fragen an die Community User helfen Usern - Fragen zu JTL-Wawi 0
Neu Nach Update JTL Wawi auf 1.5.34.0: Sortierungskonflikt / Kollationen verändert JTL-Wawi - Fehler und Bugs 1
Neu Kompatibilität JTL Shop 4.06 (Build9) mit JTL Wawi 1.4 oder 1.5 Allgemeine Fragen zu JTL-Shop 1
Neu Lizenzschlüssel lässt sich nicht in JTL Wawi eintragen Installation von JTL-Wawi 2
Neu Rechnung über JTL POS Allgemeine Fragen zu JTL-POS 1
Neu Neuer JTL SHOP - Version 4 oder 5? Allgemeine Fragen zu JTL-Shop 2
Neu Lieferschwelle in Wawi eingerichtet JTL-Shop berechnet trotzdem die deutsche USt. Steuer User helfen Usern - Fragen zu JTL-Wawi 0
Neu [JTL-Shop5.0.0 rc3] Benutzer anlegen - Errors JTL-Shop - Fehler und Bugs 0
Neu JTL Update von 1.3xxx auf 1.5.34.0 klappt nicht SQL Fehler JTL-Wawi - Fehler und Bugs 1
Neu Hilfe! Seit gestern kein Labeldruck mit DHL und Warenpost möglich - "Der JTL-ShippingLabelsServer kann nicht erreicht werden, bitte versuchen Sie..." User helfen Usern - Fragen zu JTL-Wawi 6
Neu Umzug von Shopware zu JTL.Shop - Artikel, Kategorien, Kunden, alles ohne die Umsätze mit zu nehmen, wie? User helfen Usern - Fragen zu JTL-Wawi 3
Neu Import Avocado-Auftragsdaten in JTL Wawi Schnittstellen Import / Export 0
Neu JTL-Ameise Import "verfügbar" JTL-Ameise - Ideen, Lob und Kritik 5
Beantwortet JTL-Shop 5 Preisansicht in der Katagorie Allgemeine Fragen zu JTL-Shop 2
Neu JTL Wawi Apple M1 Chip? Installation von JTL-Wawi 0
Beantwortet ist das ein JTL Shop? Templates für JTL-Shop 2
Gelöst JTL Konfigurator zeigt keine Konfigurationen an / kann jemand helfen? User helfen Usern - Fragen zu JTL-Wawi 5
Neu JTL und WooCommerce klappt nicht WooCommerce-Connector 4
Neu Problem Erstimport der Kunden Shopware 5.6.9 zu JTL-Wawi 1.5.33 Shopware-Connector 5
Neu JTL-Shop 4.05 (Build: 1) Hosten Betrieb / Pflege von JTL-Shop 3
Neu JTL Shop unter IIS / Docker? JTL-Shop - BETA - Feedback und Bugmeldungen 4
Neu JTL-Shop 5 - Impressum Allgemeine Fragen zu JTL-Shop 2
Neu Finanzamt Prüfung / JTL GUIDE User helfen Usern - Fragen zu JTL-Wawi 11
Beantwortet JTL Shop 5 - Sortierung Variationen bei KindArtikel Einrichtung von JTL-Shop 7
Neu Keine Zahlungsart an JTL WaWi übertragen bei bei Nullbon (Umtausch gegen Artikel gleichen Warenwertes) JTL-POS - Fehler und Bugs 1
Neu Artikelbezonge Attribute und Merkmale in ebay Desingvorlage JTL Adept anzeigen eBay-Designvorlagen - Fehler und Bugs 0
Gelöst Suche JTL Shop 4.06.11 Evo Template (Build 11) Gelöste Themen in diesem Bereich 1
Neu Jtl shop + jtl wawi Ende der Probleme? Allgemeine Fragen zu JTL-Shop 0
Beantwortet Jtl Workflow - "Werte setzen" Problem JTL-Workflows - Fehler und Bugs 9
Neu JTL Wawi 1.5.32.0 Amazon selbsterstelle Produktseite Fehler 8115 User helfen Usern - Fragen zu JTL-Wawi 1
Neu Kategoriesortierung / Sortiernummer 0 greift nicht im JTL POS JTL-POS - Fehler und Bugs 1
Neu Allgemeine Fragen zu JTL WaWi Client (Mehrplatzinstallation) User helfen Usern - Fragen zu JTL-Wawi 1
Neu JTL Ameise Import "langsam" JTL-Ameise - Fehler und Bugs 3
Neu Kategorie URL im JTL Shop ändern Allgemeine Fragen zu JTL-Shop 2
Gelöst Falls JTL nicht weiß was es mir zu Weihnachten 2020 schenken soll! Gelöste Themen in diesem Bereich 3
Ähnliche Themen