Neu Geschwindigkeit und Reaktionszeiten mit TSE

Karalanta

Gut bekanntes Mitglied
18. April 2020
260
87
Guten Morgen,

Letzten Sonntag habe ich es gewagt die TSE einzubauen und zu aktivieren (TM-M30F von JTL bezogen). Einrichtung und Verknüpfung hat soweit Problemlos funktioniert. Nun wurde ich jedoch auf folgendes hingewiesen.

- Die Zeit bis zum druck des Bons hat sich merklich erhöht. Ich gehe davon aus das hängt mit dem Prozess signieren und auf SD speichern zusammen.

das lässt sich ja noch verkraften auch wenn es nicht schön ist. Schlimmer finde ich folgendes Problem

- Erste Bon des Tages (nach Tagesabschluss) dauert Ewigkeiten zum öffnen. Ist jetzt der dritte Tag in folge mit diesem Problem. Es wird dann natürlich mehrfach neuer Bon gedrückt und nach 3-5min ist ein Bon offen und 20 sind geparkt.

Hat wer den die TSE auch funktionsfähig am laufen und kann ähnliche Hänger und Geschwindigkeitseinbußen beobachten?

Was mir auch noch aufgefallen ist. Nachdem die variable $tse_footer$ in der Vorlage eingefügt wurde, ist ein Testdruck nicht mehr möglich.
 

marine.art.2018

Aktives Mitglied
9. April 2019
61
3
Hallo Karalanta,

darf ich fragen mit welcher JTL-POS Version es bei Euch tut und unter welcher Android-Version auf welcher Hardware?
Und weisst Du auch welche Firmware-Version auf dem Bondrucker läuft (kann man mit der EPSON-Drucker App nachschauen)?
Bei uns war die Installation auch erfolgreich (und auch der Selbsttest), aber der Klick auf neuer Bon wird mit
Bon konnte nicht erstellt werden! Es konnte keine Verbindung zur Tse aufgebaut werden!
quittiert.

Es steht die "Behauptung" im Raum, dass es mit 1.0.1.13 ging und mit 1.0.1.14 nicht mehr...
(siehe https://forum.jtl-software.de/threa...nrichtungen-tse-in-jtl-pos.130505/post-742532)
Laut Changelog hat sich ja aber wohl in Bezug auf TSE in 1.0.1.14 nichts geändert...

Ich würde ja auch eine andere Hardware und andere Android-Version testen, aber dafür müsste ich den Epson TM-M30F erst wieder von der JTL-POS "deregistrieren"...
Hat das schon jemand erfolgreich gemacht?

Grüße,
Markus
 

Karalanta

Gut bekanntes Mitglied
18. April 2020
260
87
Huhu,
klaro kann ich dir alles nennen...

JTL POS ist Versin 1.0.1.14 (2890)
Firmware Drucker ist die 1.49A ESC/POS
Tablet ist das Samsung Tab A 10.5 (SM-T595) mit Android 10 Patchlevel 1. Juli 2020 - Allerdings kam heute eine neue Version raus, die lass ich aber erst heute Abend drüber laufen, bzw. teste es erst auf dem Kundendisplay (selbes Modell)

Hab quasi alles geupdatet vor dem Einbau. Das Problem besteht hauptsächlich nur beim ersten Bon des Tages. Dazwischen gibt es aber laut dem Log immer vereinzelt Fehler. So wirklich rund und ausgereift ist das alles ganz und gar nicht.



Ergänzung:
Letztendlich hab ich mich ja nur aufgrund der E-Mail von JTL "überreden lassen" das Ding einzubauen.

Epson-TSE in Epson Druckern
Mit der JTL-POS Version 1.0.1.14 haben wir einen Hotfix herausgegeben. Damit können Epson-Drucker auf die aktuelle Firmware aktualisiert werden und die Epson-TSE kann vollumfänglich genutzt werden.
 
Zuletzt bearbeitet:

Karalanta

Gut bekanntes Mitglied
18. April 2020
260
87
Hallo Janusch,
ich bin mir jetzt nicht sicher ob die Fragen mir galten, aber bin mal so frech und antworte und bekomme vielleicht ne Antwort :)

Das waren die Fehler gestern, die sich aber alle auf eine Fehlerhafte Verbindung zurückführen lassen und nicht auf die Funktion der TSE selbst.

Screenshot 2020-08-26 140136.png

Ich war da wohl wieder ein wenig voreilig und hab zu unrecht auf die POS geschimpft, das tut mir leid. Klar manche Funktionen fehlen und/oder einiges könnte besser laufen. Aber da wir das alles nur zweit neben den normalen Öffnungszeiten und auch noch eintreffen der HW Ware, bin ich aktuell mit WaWi, POS, JTL- Shop alles neu komplett ausgelastet und teils sehr gefrustet.


Der Epson ist über Bluetooth angebunden und genau da denke ich liegt das Problem. Ich werf mal die Begriffe Standbye und Energie sparen in den Raum.
Beim etwas recherchieren bin ich auf folgenden Hinweis zu den Swissbit TSE-SD-Karten gestoßen.
Nachdem die TSE vom Strom getrennt wurde (z.B. Ausschalten des Androidgeräts, längerer Standby, etc.) verlangt die TSE einen internen Selbsttest. Dieser Selbsttest dauert ca. 20-30 Sekunden. In dieser Zeit ist es nicht möglich, neue Belege anzulegen oder Belege zu kassieren.
Nun bin ich einfach mal davon ausgegangen das die Epson einen ähnlichen Mechanismus hat und habe auf Grundlage dessen mir die Optionen die zur Verfügung stehen mal genauer angeschaut.
Innerhalb Android hab ich die Akkuoptimierung für die JTL-POS App und - wahrscheinlich unnötig - die Epson TM Utility App abgestellt.
In der Epson Software hab ich folgende Option auf Kurz umgestellt.
Screenshot 2020-08-27 174115.png
Was soll ich sagen, heute nicht eine Fehlermeldung.
Alternativ kann man ja über den Druck auf das SD-Karten Symbol im POS die Verbindung zur TSE anscheinend manuell auslösen, das wollte ich das nächste mal Testen sollte das Problem nochmal auftreten.
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.803
223
Hallo,
ja, die Fragen betrafen den zu langsamen Druck und Fehler beim Bon anlegen.

Das Problem ist hier Bluetooth. Wenn möglich bitte den Drucker über LAN direkt anbinden. Dort sollte ein Beleg wieder sehr schnell gedruckt werden.

Falls kein LAN möglich, müsste einiges optimiert werden. Wlan und Bluetooth nutzen gleiche Frequenzen und stören sich gegenseitig. Man kann einiges optimieren in dem das Wlan auf 5GHz umgestellt wird. Am besten nach diesen Begriffen googeln "bluetooth wlan störung" so findet man sehr viele Tipps zur Optimierung.
Hat man viele Kunden im Geschäft können zusätzliche Störfelder entstehen durch deren aktive Bleuttooth, Wlan Hotspots usw. Unsere Empfehlung ist immer Drucker, Bezahlterminals immer über LAN anzuschließen, es sind die wichtigsten Zubehörteile die immer 100% verfügbar sein müssen.

Die geposteten Fehler in der POS bei Bons die nicht mit TSE erstellt wurden gebe ich weiter, das müsste verhindert werden.
 
Zuletzt bearbeitet:

Karalanta

Gut bekanntes Mitglied
18. April 2020
260
87
Vielen Dank für die Antwort. Ich bin ja schon froh das bei uns die TSE soweit läuft.
Drucker werde ich auf LAN umstellen sobald ich das nächste mal vor Ort bin und schauen kann wie ich das realisiere.
Beim EC-Terminal wird es schwieriger. Da müsste ich mich mal mit Concardis in Verbindung setzen ob man evtl. das Terminal tauschen kann. Unseres unterstützt nur 2,4GHz WLAN und GPRS über eigene Simkarte. Bei letzterem wäre OPI nicht mehr möglich. Aber der Drucker ist ja eher das Problem und das sollte sich gut umsetzen lassen.
 

Charip

Mitglied
9. November 2019
97
8
Düsseldorf
Hallo,
ja, die Fragen betrafen den zu langsamen Druck und Fehler beim Bon anlegen.

Das Problem ist hier Bluetooth. Wenn möglich bitte den Drucker über LAN direkt anbinden. Dort sollte ein Beleg wieder sehr schnell gedruckt werden.

Falls kein LAN möglich, müsste einiges optimiert werden. Wlan und Bluetooth nutzen gleiche Frequenzen und stören sich gegenseitig. Man kann einiges optimieren in dem das Wlan auf 5GHz umgestellt wird. Am besten nach diesen Begriffen googeln "bluetooth wlan störung" so findet man sehr viele Tipps zur Optimierung.
Hat man viele Kunden im Geschäft können zusätzliche Störfelder entstehen durch deren aktive Bleuttooth, Wlan Hotspots usw. Unsere Empfehlung ist immer Drucker, Bezahlterminals immer über LAN anzuschließen, es sind die wichtigsten Zubehörteile die immer 100% verfügbar sein müssen.

Die geposteten Fehler in der POS bei Bons die nicht mit TSE erstellt wurden gebe ich weiter, das müsste verhindert werden.
Hallo,

ich habe heute die Epson TSE Einheit installiert und bisher läuft alles stabil, bis auf die Geschwindigkeit.
Zu Beginn eines jeden Bons dauert es eine Weile “Bon wird gestartet” und beim Abschluss dauert es ebenfalls.
Hardware: Das Asus Chromebox Bundle.
POS Version: 1.0.2.4 (2985)
Epson Firmware: heute auf den neusten Stand gebracht.

Beste Grüße
 

Karalanta

Gut bekanntes Mitglied
18. April 2020
260
87
Hallo,

ich habe heute die Epson TSE Einheit installiert und bisher läuft alles stabil, bis auf die Geschwindigkeit.
Zu Beginn eines jeden Bons dauert es eine Weile “Bon wird gestartet” und beim Abschluss dauert es ebenfalls.
Hardware: Das Asus Chromebox Bundle.
POS Version: 1.0.2.4 (2985)
Epson Firmware: heute auf den neusten Stand gebracht.

Beste Grüße

Hallo,
ich weiss weder wie es an der Chromebox ist, noch wie der Drucker angebunden ist. Aber bei mir waren mit Umstellung von Bluetooth auf LAN sämtliche Geschwindigkeitsprobleme behoben. Die Chromebox sollte ja eine LAN Schnittstelle besitzen und selbst wenn die belegt ist mini-switch nutzen oder BON-Drucker wenn örtlich möglich an Switch oder Router anschließen.
 
  • Gefällt mir
Reaktionen: Charip

Charip

Mitglied
9. November 2019
97
8
Düsseldorf
Hallo,
ich weiss weder wie es an der Chromebox ist, noch wie der Drucker angebunden ist. Aber bei mir waren mit Umstellung von Bluetooth auf LAN sämtliche Geschwindigkeitsprobleme behoben. Die Chromebox sollte ja eine LAN Schnittstelle besitzen und selbst wenn die belegt ist mini-switch nutzen oder BON-Drucker wenn örtlich möglich an Switch oder Router anschließen.
Hallo,
Drucker und Chromebox befinden sich bereits im Netzwerk.
Ist alles über LAN verkabelt.
Beste Grüße

El Charip
 

Karalanta

Gut bekanntes Mitglied
18. April 2020
260
87
Hallo,
Drucker und Chromebox befinden sich bereits im Netzwerk.
Ist alles über LAN verkabelt.
Beste Grüße

El Charip

Ok, das finde ich interessant. Das von dir beschriebene kannte ich halt eins zu eins. Hab das ja oben beschrieben. Vielleicht kommen beim ChromeOS nun meine Theorien/Spekulationen wieder ins Spiel ;)
Ich drücke dir jedenfalls die Daumen und hoffe das die Ursache gefunden wird. Flüssiges arbeiten war da nämlich nicht mehr wirklich möglich bei uns.
 
  • Gefällt mir
Reaktionen: Charip

Charip

Mitglied
9. November 2019
97
8
Düsseldorf
Hallo,
falls noch die POS Version 1.0.2.0 benutzt wird, bitte auf die neuste 1.0.2.5 updaten, es gab noch kleiner Updates bzgl. TSE.
Hallo,
wir haben gestern von euch unsere zweite Kasse bekommen, Sumni T2 mit der TSE Swiss Bit.
Bei beiden Kassen haben wir jetzt eine kleine Verzögerung, ist nicht störend. Aber ist das bei allen so?? Oder sollte es zu keiner Verzögerung kommen?
Beste Grüße

Salah
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.803
223
Hallo,
wie groß ist die Verzögerung?
Laut Hersteller sollte sie kleiner als 250ms sein. In der Regel sollte es kaum merkbar sein.
 
  • Gefällt mir
Reaktionen: Charip

Charip

Mitglied
9. November 2019
97
8
Düsseldorf
Hallo,
schaut ob ihr mindestens die POS 1.0.2.4 einsetzt. Dort kamen weitere Optimierungen bzgl. TSE.
Hallo,

seit 1.0.2.9(3094) sind die Reaktionszeiten erheblich angestiegen.
Bei der Kasse Chromebox, ist unter Direkteingabe kein scannen mehr möglich (Bon wird nicht von der TSE erstellt).
Wenn man unter Favoriten scannt wird ein Bon erzeugt, allerdings muss ein Artikel manchmal mehrfach gescannt werden bis es angenommen wird.
Bei der Sunmi Kasse ist das scannen überall möglich, nur dauert es ewig bis die TSE ein Bon erstell oder abschließt.

Beste Grüße

Salah El Charip
 
  • Gefällt mir
Reaktionen: SeruKid

SeruKid

Aktives Mitglied
5. Juni 2014
9
2
Hallo,

seit 1.0.2.9(3094) sind die Reaktionszeiten erheblich angestiegen.
Bei der Kasse Chromebox, ist unter Direkteingabe kein scannen mehr möglich (Bon wird nicht von der TSE erstellt).
Wenn man unter Favoriten scannt wird ein Bon erzeugt, allerdings muss ein Artikel manchmal mehrfach gescannt werden bis es angenommen wird.
Bei der Sunmi Kasse ist das scannen überall möglich, nur dauert es ewig bis die TSE ein Bon erstell oder abschließt.

Beste Grüße

Salah El Charip
Wir haben seit dem letzten Update (auf 1.0.2.9 (3094) auch erhebliche Probleme. Wir arbeiten mit dem Samsung Tablet und Epson TM 30. Seit Samstag konnten wir keinem Kunden einen Bon mitgeben, da diese nicht zeitnah gedruckt werden. Hinzu kommt, dass sich für den Bezahlvorgang die Kassenlade nicht mehr öffnet. Um dem Kunden das Wechselgeld zu geben, müssen wir die Kassenlade mit dem Schlüssel öffnen.

Viele Grüße
Simone
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.803
223
Salah und Simone könnt ihr ein Supportticket erstellen? Falls nicht, sendet mir per Unterhaltung eure Tel. Nur. wo wir euch morgen erreichen können.
Die Kollegen müssen sich das genauer anschauen. Wir testen hier mit der gleichen Hardware bevor die Versionen rausgehen.
 
  • Gefällt mir
Reaktionen: Charip
Ähnliche Themen
Titel Forum Antworten Datum
Leider nur 3 Kategorien und 2 Unterkategorie möglich. Einrichtung JTL-Shop5 0
Neu Produktstream Artikel und Sticker Betrieb / Pflege von JTL-Shop 0
Neu Auslandsversand und Shopware Shop JTL-ShippingLabels - Fehler und Bugs 0
Neu Ribbon GROß und kleinschreibung Templates für JTL-Shop 2
Neu Error 500 und Forbidden 403 Bei Plugin Backend Aufruf Plugins für JTL-Shop 0
Neu OSS und UID-Nummer auf der Rechnung User helfen Usern 0
Neu Wunschliste und Vergleichsliste unter dem Warenkorbbutton Allgemeine Fragen zu JTL-Shop 1
Neu Amazon Pay und Zahlungsmodul API 2.0 Arbeitsabläufe in JTL-Wawi 0
Neu JTL Shop 5 - Kategorienschriftgröße und Position in Megamenu ändern Allgemeine Fragen zu JTL-Shop 4
Neu Unterschied zwischen Swatches und textbox Allgemeine Fragen zu JTL-Shop 1
Neu Lagerbestand in WMS- und Standardlager 0, im FFN ist Bestand vorhanden JTL-Wawi - Fehler und Bugs 2
Vorkonfektionieren und Bestandsführung User helfen Usern - Fragen zu JTL-Wawi 1
Neu Differenzbesteuerung und JTL 2 DATEV User helfen Usern - Fragen zu JTL-Wawi 0
Neu Rätselhafte Listenanzeige nach Shopabgleich und unvollständige Aufträge JTL-Wawi - Fehler und Bugs 0
Neu Gewicht und andere "Stammdaten" gleich auf alle Marktplätze in den Ländern eBay-Anbindung - Ideen, Lob und Kritik 0
JTL Shop 5.0.1 - Kein richtiger Abgleich der Artikel-Fotos zwischen WAWI und Shop Einrichtung JTL-Shop5 4
Neu Ebay und Umsatzsteuer-Identifikationsnummer Business Jungle 0
In Bearbeitung Bei neuen Bon und Scanner Einsatz stürtzt POS ab. JTL-POS - Fehler und Bugs 3
Neu Dummy-Väter werden teilweise hochgeladen und verbleiben im Shop Shopware-Connector 1
Neu benötige dringend Hilfe nach Domainumzug und Verzeichnisswechsel Allgemeine Fragen zu JTL-Shop 5
Neu Gutscheine erstellen und im Shop verkaufen Arbeitsabläufe in JTL-Wawi 3
Neu Klarna und Paypal gleichzeitig nutzen Plugins für JTL-Shop 1
Neu Positionsgewicht Artikelgewicht Druckvorlage Auftrag und Rechnung Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Übersicht in Verkaufskategorie nach "Bezahlt am" und "Nachnamen" sortieren Individuelle Listenansichten in der JTL-Wawi 2
JTL Themenwoche Heute: Packsize: Individuelle Versandkartons kleiner, schneller UND ökologischer Messen, Stammtische und interessante Events 0
JTL Themenwoche Heute: JTL-WMS - "Ja, ich will." │ Eine Entscheidung für Effizienz und Flexibilität Messen, Stammtische und interessante Events 0
Update 4.06 B17 auf 5.01 > Error 500 und Fehlerausgabe funktioniert nicht Upgrade JTL-Shop4 auf JTL-Shop5 2
Neu EU-weite Lieferschwelle und One-Stop-Shop ab 01.07.2021 Umfragen rund um JTL 204
Neu Weitere Währungen in der Wawi und die Probleme User helfen Usern - Fragen zu JTL-Wawi 0
Neu Kategorie Bilder und Beschreibeungen WooCommerce-Connector 3
Neu Charge und MHD bei Stücklisten Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Drucker Probleme mit HEX und Star mc-Print2 JTL-POS - Fehler und Bugs 0
Neu Artikelsticker Vorverkauf und Bald verfügbar User helfen Usern - Fragen zu JTL-Wawi 0
Neu Unterschidliche Mengen/Einheite Webshop und Ebay zu einem Artikel anbieten eBay-Anbindung - Ideen, Lob und Kritik 0
Neu JTL-Vouchers - Closed Beta | Jetzt Pilotkunde werden und aktiv mitentwickeln! Umfragen rund um JTL 0
Neu Werkstattaufträge erstellen und Tastatur-Bedienung User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung Datevübertragung aus POS und Wawi Allgemeine Fragen zu JTL-POS 7
Neu Versandlabel soll zur Sicherheit als ein PDF Dokument erzeugt und auf bestimmten Pfad gespeichert werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Bei Änderung in Kollektion werden in Shopify Title und Description in Englisch angezeigt (Langify) Shopify-Connector 1
In Diskussion Plausibilitätsprüfung für den Warenausgang über JTL-WMS und JTL-Packtisch+ [WAWI-30184] Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 0
Neu Shop5 und Adminbereich Einrichtung JTL-Shop5 7
Neu Logo und Vorgang Text Darstellung Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Fehler 403 und keine Bildübertragung WooCommerce-Connector 0
In Bearbeitung Kauf und Verkauf von Zustandsartikeln Allgemeine Fragen zu JTL-POS 5
Neu Hinweis zu CN22 und CN23 drucken User helfen Usern - Fragen zu JTL-Wawi 1
Gelöst WMS Probleme bei der Abbuchung und eventuelles verzichten auf Picklisten Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 3
Neu News-Übersicht und Rubriken Allgemeine Fragen zu JTL-Shop 0
Neu Kundengruppe hat individuelle Preise und kann nicht gelöscht werden. JTL-Wawi - Fehler und Bugs 0
Neu Suche SQL für die Ausgabe von Lieferländern mit wie vielen Paketen beliefert und welcher netto warenwert gestaffelt nach Jahr, Monat, Woche und Tag? User helfen Usern 3
Neu Kundenimport in Wawi 1.6, und dann per Online-Abgleich gleich weiter in den Shop 5? Arbeitsabläufe in JTL-Wawi 1

Ähnliche Themen