Gelöst Fehlerhafter Abgleich der Variationen von Artikeln

windkup

Aktives Mitglied
9. Juli 2018
16
3
Produkte, Variationen und Variationskombinationen wurden in der Wawi erstellt und an WooCommerce übertragen.
Wordpress 4.9.8
WooCommerce 3.5.1
JTL Connector 1.6.0

Hallo,
nach dem Abgleich (Produkt T-Shirts) wurden die Artikel mit den Variantenkomb. (Farbe&Größe) und deren Bildern richtig erstellt. Leider werden die Varianten (Farbe&Größe) und deren Variantenwerte (Rot,grün...M,L,XL) nicht global unter Woocommerce Produkteigenschaften hinterlegt sondern sind losgelöst vom System als benutzerdefinierte Eigenschaft (siehe Bild 1). Dadurch können den Varianten keine weiteren Infos und Swatches hinzugefügt werden (siehe Bild2 und Bild3). Andersherum erfolgt auch keine Zuordnung der Importvarianten zu bereits eingepflegten globalen Eigenschaften (siehe Bild3). Es zeigt sich auch das im Produkt-Backend die Eigenschaft Größe manuell ein zweites Mal hinzugefügt werden kann (dies ist normal nicht möglich) und dabei die gesetzten Werte (XS-XL) erkannt werden (siehe Bild1).

Bilder für die Variationen in der Wawi zuhinterlegen, hat nichts gebracht. Das primäre Problem bleibt die globale Zuordnung.

Das Thema wurde bereits in Thread https://forum.jtl-software.de/threads/variationskombinationen-varianten-und-attribute_farbe.100015/ besprochen und sollte durch Connectorupdate gelöst sein. Leider tritt es wieder auf.
Ähnlich ist dieser Fall, der über ein Ticket gelöst wurde: https://forum.jtl-software.de/threa...-nicht-korrekt-zugewiesen.105085/#post-581517
Danke für jegliche Hilfe.

Unbenanntes Bild.pngUnbenanntes Bild2.pngUnbenanntes Bild3.png
 

Jann

Aktives Mitglied
16. November 2017
5
0
Hi Windkup, das Problem in meinem Post, den du oben zitiert hast, wurde nicht gelöst sondern eher abgehakt.
Letztendlich habe ich einen relativ aufwendigen Workaround entwickeln müssen, bei dem eigene global definierte Swatches (per ACF) mit den "benutzerdefinierten" Eigenschaftsnamen gematcht wurden.
Das kann man aber nur machen, wenn die Swatches nur selten geupdatet werden müssen und erfordert trotzdem ein kleines bisschen Handarbeit für neue Produkte.
Letztendlich muss man JTL eingestehen, dass es nur in den Basisfunktionen mit WooCommerce kompatibel ist. Zumindest Stand Ende 2017. Danach habe ich das Thema lieber nicht mehr angefasst.
 

Jan Weskamp

Moderator
Mitarbeiter
19. August 2015
346
35
Hi Windkup, das Problem in meinem Post, den du oben zitiert hast, wurde nicht gelöst sondern eher abgehakt.
Letztendlich habe ich einen relativ aufwendigen Workaround entwickeln müssen, bei dem eigene global definierte Swatches (per ACF) mit den "benutzerdefinierten" Eigenschaftsnamen gematcht wurden.
Das kann man aber nur machen, wenn die Swatches nur selten geupdatet werden müssen und erfordert trotzdem ein kleines bisschen Handarbeit für neue Produkte.
Letztendlich muss man JTL eingestehen, dass es nur in den Basisfunktionen mit WooCommerce kompatibel ist. Zumindest Stand Ende 2017. Danach habe ich das Thema lieber nicht mehr angefasst.


Schade dies zu hören Jann, Es sind in diesem Jahr einige neue Funktionen hinzugekommen. Probier ihn doch nochmal ein einer Testumgebung aus ?
 

Jann

Aktives Mitglied
16. November 2017
5
0
Hallo Jan, ich habe gerade den Changelog seit Connector Version 1.4.8 überflogen, konnte aber zumindest keinen spezifischen Fix für globale Woocommerce Attribute entdecken. Und Windkup scheint ja auch immer noch das Problem zu haben. Ich würde mich natürlich freuen, wenn das jetzt unterstützt würde.

Haltet mich und die Nachwelt doch über eine eventuelle Lösung hier im Thread auf dem Laufenden :)
 

Jan Weskamp

Moderator
Mitarbeiter
19. August 2015
346
35
Hallo Jan, ich habe gerade den Changelog seit Connector Version 1.4.8 überflogen, konnte aber zumindest keinen spezifischen Fix für globale Woocommerce Attribute entdecken. Und Windkup scheint ja auch immer noch das Problem zu haben. Ich würde mich natürlich freuen, wenn das jetzt unterstützt würde.

Haltet mich und die Nachwelt doch über eine eventuelle Lösung hier im Thread auf dem Laufenden :)
Schick mir doch mal Bitte deine Kontaktdaten per pn rufe dann mal durch =)
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Gelöst > Hilfe am 24.12. > fehlerhafter Token JTL-Shop - Fehler und Bugs 2
Fehlerhafter Datev-Rechnungsdatenexport mit Ameise nach Update auf 1.6. JTL-Wawi 1.6 1
Neu JTL-Business Intelligence Abgleich ? Neue Funktion? Smalltalk 2
Neu Received invalid response: 8 Abgleich jtlshop 5 User helfen Usern - Fragen zu JTL-Wawi 1
Neu Abgleich Fehler total _paid_tax_excl. Fehler PrestaShop-Connector 0
Neu (500) Interner Serverfehler bei Abgleich - Shopware 6 Shopware-Connector 1
JTL Shop Abgleich nach Update auf 1.6.45.2 JTL-Wawi 1.6 5
Fehler bei Abgleich von Wawi und JTL Shop 5 JTL-Wawi 1.6 2
Neu Hilfe - Abgleich mit WooCommerce ca. 1 Stunde Zeitversetzt ? JTL-Wawi - Fehler und Bugs 1
Neu Amazon Abgleich Fehler Amazon-Anbindung - Fehler und Bugs 2
Neu WooCommerce Abgleich: Neue Bestellungen verzögert um eine Stunde WooCommerce-Connector 6
Beantwortet Ebay-Abgleich mit Eazy-Auction funktioniert nach Ebay 2-Faktor-Authentifizierung nicht mehr.....auch nicht nachdem das Rückgängig gemacht wurde User helfen Usern - Fragen zu JTL-Wawi 1
Neu ebay Abgleich funktioniert nicht mehr eBay-Anbindung - Fehler und Bugs 42
Freigabe zum Shop Abgleich? JTL-Wawi 1.6 1
Neu Kein Abgleich der Inhalt / Menge WooCommerce-Connector 0
Neu Fehler bei Abgleich mit SHOP 5 Onlineshop-Anbindung 1
Neu Shopify Abgleich Fehler - WaWi 1.6.45.0 - Zeilenumbrüche in single line text string JTL-Wawi - Fehler und Bugs 2
Neu Shopware 6 - Kundendaten-Abgleich hängt in Schleife, immer gleiche Kunden werden importiert Shopware-Connector 5
Neu JTL Worker 2.0 - Kein automatischer Abgleich trotz eingerichteten Hintergrunddienst Onlineshop-Anbindung 6
Gelöst POS Abgleich mit WaWi geht nicht mehr nach Update JTL-Wawi - Fehler und Bugs 3
Shop hat keine Antwort geliefert - Abgleich wurde abgebrochen JTL-Wawi 1.6 1
Neu Amazon Anbindung Abgleich Lagerbestand wird nicht aktualisiert Amazon-Anbindung - Fehler und Bugs 1
Neu SW6 Connector Artikel Abgleich bricht ab - Allowed memory Size Shopware-Connector 8
Neu Worker gleicht Daten nicht mit ebay und Amazon ab - Shop Abgleich funktioniert Einrichtung und Installation von JTL-eazyAuction 1
Neu Fehlermeldung beim Abgleich mit Shop WooCommerce-Connector 3
Neu Problem mit dem WooCommerce Abgleich nach Update auf 1.6.44.0 WooCommerce-Connector 0
Neu Amazon Pay Abgleich - Konnte keine Sitzung für den Zahlungsabruf erzeugen Amazon-Anbindung - Fehler und Bugs 1
Kein automatischer Abgleich mit Amazon und Ebay JTL-Wawi 1.6 8
Neu Abgleich WooCommerce geht nicht mehr bei Update Version 1.6.44.0 WooCommerce-Connector 7
Neu Abgleich defekt nach Update auf 1.6.44.0 Shopify-Connector 34
Neu Kein Abgleich wegen "System.OutOfMemoryException" kaufland.de - Anbindung (SCX) 0
Neu Shop Abgleich funktioniert nicht User helfen Usern - Fragen zu JTL-Wawi 0
JTL Wawi Abgleich, kein Import von Kunden und Bestellungen JTL-Wawi 1.6 0
Neu Ebay Abgleich Fehler Error calling EaEbaySynchronizeGet eBay-Anbindung - Fehler und Bugs 1
Neu Abgleich Amazon und JTL Amazon-Anbindung - Fehler und Bugs 4
Neu Shop-Abgleich nicht möglich: Die Merge-Anweisung hat versucht... JTL-Wawi - Fehler und Bugs 0
Neu Amazon Abgleich (Bestellungen fehlen) Amazon-Lister - Fehler und Bugs 2
Neu Amazon Abgleich überträgt die abgearbeiteten Bestellungen nicht an Amazon! Amazon-Anbindung - Fehler und Bugs 9
Neu Betreffzeile ändern in der Bestellbestätigung Mailvorlage führt zum Absturz JTL-Shop - Fehler und Bugs 0
Neu Ende der Beta Servicedesk (Beta) 1
Neu Export aller Preise incl. die der Marktplätze in EINE Tabelle/Zeile JTL Ameise - Eigene Exporte 0
Neu Bug in der Ameise? Scrollen zu weiteren Sprachen unmöglich User helfen Usern - Fragen zu JTL-Wawi 1
Wawi kommt in flickernde Endlosschleife nur durch "Auftrag erstellen" in der Kundenliste JTL-Wawi 1.6 1
Neu EK-Preis in der Artikelübersicht für jeden Benutzer sichtbar JTL-Wawi - Fehler und Bugs 1
Neu Fehler bei der Authentifizierung der Händler-ID Einrichtung und Installation von JTL-eazyAuction 1
JTL Wawi 1.6 Mailversand - Fehlermeldung = 'System.ArgumentNullException: Der Wert darf nicht NULL sein. Parametername: key JTL-Wawi 1.6 1
Gelöst Neuinstallation 5.2.2 - 404 Not found der Subseite /admin/wizard Einrichtung JTL-Shop5 0
Neu Variationsauswahl in der Artikelübersicht ausschalten ( 5.2 ) Allgemeine Fragen zu JTL-Shop 1
Neu Pickliste erstellen aus der Wawi - Auftragsübersicht? Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 1
Neu Bestimmte Artikel in der Shopsuche nicht anzeigen Betrieb / Pflege von JTL-Shop 2

Ähnliche Themen