Neu HILFE :( Warenkorb wird automatisch Gelöscht! Anschließend Fehlermeldung HTTP 500 Error

Jason

Aktives Mitglied
19. Dezember 2018
32
2
Hallo Community,

ich habe seit zwei Tagen das Problem bei mir im Onlineshop das die Artikel nach einer gewissen Zeit automatisch aus dem Warenkorb gelöscht werden. Anschließend kommt die Fehlermeldung HTTP Error 500

Habe hierzu schon den Shophoster befragt der sagt da läuft alles so wie es soll, dann hab ich den Template Hersteller gefragt der Schließt das Problem auch aus habe alle Plugins nacheinander Deaktiviert und getestet Fehlermeldung immer noch vorhanden.

Jetzt wird vermutet das der JTL Shop an sich einen Fehler hat. Support angeschrieben leider noch keine Antwort.

Ich hoffe ihr könnt mir helfen.

anbei Fehlermeldungen die mir die jeweiligen Ansprechpartner genannt haben.


Fatal error: Uncaught Error: Call to a member function gibAnzahlEinesArtikels() on integer in /home/pxcktavz/domains/paradise-shisha.de/public_html/includes/tools.Global.php:1293 Stack trace: #0 /home/pxcktavz/domains/paradise-shisha.de/public_html/includes/tools.Global.php(1485): pruefeFuegeEinInWarenkorb(Object(Artikel), 1, Array) #1 /home/pxcktavz/domains/paradise-shisha.de/public_html/includes/tools.Global.php(973): fuegeEinInWarenkorb(42598, 1, Array) #2 /home/pxcktavz/domains/paradise-shisha.de/public_html/index.php(26): checkeWarenkorbEingang() #3 {main} thrown in /home/pxcktavz/domains/paradise-shisha.de/public_html/includes/tools.Global.php on line 1293



Fatal error: Uncaught Error: Call to a member function gibGesamtsummeWarenExt() on integer in /home/pxcktavz/domains/paradise-shisha.de/public_html/includes/letzterInclude.php:60 Stack trace: #0 /home/pxcktavz/domains/paradise-shisha.de/public_html/artikel.php(301): require() #1 /home/pxcktavz/domains/paradise-shisha.de/public_html/index.php(68): require('/home/pxcktavz/...') #2 {main} thrown in /home/pxcktavz/domains/paradise-shisha.de/public_html/includes/letzterInclude.php on line 60

Fatal error: Uncaught Error: Call to a member function gibGesamtsummeWarenExt() on integer in /home/pxcktavz/domains/paradise-shisha.de/public_html/includes/letzterInclude.php:60 Stack trace: #0 /home/pxcktavz/domains/paradise-shisha.de/public_html/seite.php(154): require_once() #1 /home/pxcktavz/domains/paradise-shisha.de/public_html/index.php(89): require_once('/home/pxcktavz/...') #2 {main} thrown in /home/pxcktavz/domains/paradise-shisha.de/public_html/includes/letzterInclude.php on line 60

Fatal error: Uncaught Error: Call to a member function loescheDeaktiviertePositionen() on integer in /home/pxcktavz/domains/paradise-shisha.de/public_html/classes/core/class.core.Session.php:317 Stack trace: #0 /home/pxcktavz/domains/paradise-shisha.de/public_html/classes/core/class.core.Session.php(80): Session->setStandardSessionVars() #1 /home/pxcktavz/domains/paradise-shisha.de/public_html/classes/core/class.core.Session.php(54): Session->__construct(true, 'JTLSHOP') #2 /home/pxcktavz/domains/paradise-shisha.de/public_html/includes/globalinclude.php(146): Session::getInstance() #3 /home/pxcktavz/domains/paradise-shisha.de/public_html/index.php(6): require('/home/pxcktavz/...') #4 {main} thrown in /home/pxcktavz/domains/paradise-shisha.de/public_html/classes/core/class.core.Session.php on line 317



Ich weiß wirklich nicht mehr weiter jeder..
 

Jason

Aktives Mitglied
19. Dezember 2018
32
2
Hi,

Ja habe eine Ticketnummer:#2020111110001446

Shop Version : 4.06 (Build: 17)
Php Version: 7.2.34
Modifizierte Dateien zeigt er nicht an nur zwei verwaiste Kategorien.

Ich weiß leider nicht mehr weiter was ich tun soll niemand kann mir helfen.
 

Dustin

Sehr aktives Mitglied
14. Mai 2008
2.999
53
Enger
Wurde das Problem gefunden bzw. gelöst. Wir mussten gerade das gleiche Feststellen.

Gruß aus Bünde

Dustin
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
1.367
535
Hallo,

das Problem war wohl die Blindgrafik im Template:
Das Problem ist, dass durch die Ausführung der Blindgrafik die Session-ID überschrieben wird und dies verursacht das Problem auch. Diese habe ich nun deaktiviert. ... Ich würde Ihnen empfehlen diese Einstellung weiterhin deaktiviert zu belassen und statt dessen einen Cronjob für Ihre Exporte (die sowieso bessere Variante ist) einzurichten. Die Einrichtung des Cronjobs für den Shop wird im Guide detailliert erklärt: https://guide.jtl-software.de/jtl-s...richten/#aufgabenplaner-per-cronjob-anstossen

Viele Grüße
Michael
 
  • Gefällt mir
Reaktionen: egoist30

egoist30

Aktives Mitglied
11. Januar 2007
48
0
Roßtal
Hallo,

das Problem war wohl die Blindgrafik im Template:
Das Problem ist, dass durch die Ausführung der Blindgrafik die Session-ID überschrieben wird und dies verursacht das Problem auch. Diese habe ich nun deaktiviert. ... Ich würde Ihnen empfehlen diese Einstellung weiterhin deaktiviert zu belassen und statt dessen einen Cronjob für Ihre Exporte (die sowieso bessere Variante ist) einzurichten. Die Einrichtung des Cronjobs für den Shop wird im Guide detailliert erklärt: https://guide.jtl-software.de/jtl-s...richten/#aufgabenplaner-per-cronjob-anstossen

Viele Grüße
Michael
Vielen Dank!
 

Ähnliche Themen