Neu Versandart wechselt nicht im Shop

Ugenmeister

Gut bekanntes Mitglied
28. August 2013
458
9
Liebe Freunde.

Folgende Konstellation im 4.06er Build 15 Shop:

Versandart 1 angelegt: DHL, Versandklasse standard
Versandklasse 2 angelegt: GLS, Versandklasse GLS, GLS standard

Die Versandklassen sind den jeweiligen Artikel zugeordnet.
Sobald ein standard Artikel im Warenkorb liegt, wird DHL verwendet. Liegt ein GLS Artikel im WK, wird auch DHL verwendet (was falsch ist; hier müsste GLS verwendet werden). Auch Kombinationen von standard und GLS zeigt nur DHL an, und nicht GLS.

Beide Versandarten sind identisch angelegt, bis auf die Zuordnung der Versandklassen natürlich.
Wo könnte der Fehler liegen?
Danke euch!

Gruß
 

Ugenmeister

Gut bekanntes Mitglied
28. August 2013
458
9
Ups, sorry. Das war natürlich ein Schreibfehler. Es sollte nicht Versandklasse 2 heißen, sondern Versandart 2.
 

MichaelH

Sehr aktives Mitglied
17. November 2008
12.290
949
Vielleicht solltest du doch Screen-Shots posten, denn so wie du es "schreibst" müsste es funktionieren.
Irgendwo hast du einen Fehler drin ...
 

Ugenmeister

Gut bekanntes Mitglied
28. August 2013
458
9
Ja eben, das dachte ich auch. Aber vielleicht sehe ich den Wald vor lauter Bäumen nicht und hab etwas übersehen.
Screenshots anbei. Danke euch!
 

Anhänge

  • Versandart-1.png
    Versandart-1.png
    27,2 KB · Aufrufe: 12
  • Versandart-2.png
    Versandart-2.png
    28,1 KB · Aufrufe: 12

ARA-Marketing

Offizieller Servicepartner
SPBanner
2. Oktober 2008
902
92
Regensburg
Was wir nicht sehen.... hast du der GLS-Versandart auch eine Zahlungsart weiter unten zugewiesen ??.... ne sorry... ist blödsinn, dann gehts ja gar nicht.
Was passiert, wenn du die Kombination bei GLS rausnimmst ?

Ich kanns bei mir nicht nachstellen, hast du mal zwischendurch die ganzen Cache usw. gelöscht, auch mal die cookies ?

Vielleicht mal Link zum Shop ?

VG
Eas
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: Ugenmeister

Ugenmeister

Gut bekanntes Mitglied
28. August 2013
458
9
Wenn ich die KOMBI bei der GLS Versandart raus nehme, geht ein Artikel mit VK "GLS" mit DHL durch (was gar nicht sein dürfte). Lege ich einen standard und einen GLS Artikel in den WK, greift auch DHL.
Ich raff das nicht mehr. Cache habe ich komplett gefühlte 500 Mal geleert.

Gruß
 

MichaelH

Sehr aktives Mitglied
17. November 2008
12.290
949
Mach einen Komplettabgleich Stammdaten und Artikel (Bilder sind nicht nötig) ich vermute der Shop weiß nichts von deiner VersandKLASSE GLS bei den Artikeln.
 

Ugenmeister

Gut bekanntes Mitglied
28. August 2013
458
9
Das hab ich schon drei Mal gemacht, brachte aber nichts. Andererseits, wenn der Shop von den Versandklassen nichts wüßte, könnte man sie auch nicht in der Versandart auswählen.
Das ist wirklich komisch, warum die Versandart/-Klasse GLS nicht greift.
 

MichaelH

Sehr aktives Mitglied
17. November 2008
12.290
949
Na ja, die Artikel müssen die Versandklasse ja auch haben ... zeig mal einen Screenshot Versandklasse und eine beim Artikel, denn das ist alles ziemlich seltsam bei dir.
 

Ugenmeister

Gut bekanntes Mitglied
28. August 2013
458
9
Problem gefunden (besser gesagt EAS hat es gefunden):
Der Artikel hatte Kinderartikel, die NICHT mit der neuen Versandklasse ausgestattet wurden/waren; nur der Vaterartikel wurde auf GLS umgestellt. Somit ist der Fehler auch logisch.
Dank der Hilfe von EAS konnte das Problem gelöst werden.
Nochmals ein dickes DANKE an alle Helfenden!

Gruß
 
Ähnliche Themen
Titel Forum Antworten Datum
In Diskussion Versandart bei Check24 und Kaufland Aufträgen durch Worklow die richtige Versandart setzen lassen JTL-Workflows - Ideen, Lob und Kritik 8
Neu Gutschein an Versandart koppeln Plugins für JTL-Shop 2
Neu Versandart erst ab X Artikeln anzeigen Betrieb / Pflege von JTL-Shop 0
Issue angelegt Versandart an letzte Position schieben JTL-Workflows - Ideen, Lob und Kritik 2
Neu Versandart ab Warenwert xy nicht mehr anbieten Einrichtung von JTL-Shop3 0
Neu Workflow Versandart setzten User helfen Usern - Fragen zu JTL-Wawi 5
Gelöst Versandart änder auf "Fake-Versandart" Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 5
Neu Versandart nach dem Ausliefern ändern Arbeitsabläufe in JTL-Wawi 0
Neu Artikel Kurzbeschreibung in Rechnungstext, keine Versandart angezeigt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Versandart Checkbox Technische Fragen zu den JTL-Connectoren 7
Neu Zuordnung Versandklasse zur Versandart Arbeitsabläufe in JTL-Wawi 2
In Bearbeitung Falsche Umsatzsteuer beim setzten der Versandart über Workflow JTL-Workflows - Fehler und Bugs 1
Günstigste Versandart als Standard anbieten Einrichtung JTL-Shop5 0
Zahlungsart bzw. Versandart bei sofort lieferbaren Artikeln Einrichtung JTL-Shop5 0
Neu Nur Rechnungen von Nicht-Business-Kunden erstellen JTL-Workflows - Ideen, Lob und Kritik 8
Neu Amazon lieten nicht mehr möglich Amazon-Anbindung - Fehler und Bugs 0
Neu Beim Upload von Kinderartikel werden die Preise und Variationsbilder der Kinder nicht übernommen Modified eCommerce-Connector 0
Neu Zebra Drucker druckt nicht alle Versandetiketten JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
Neu VCS light, Satz "Es handelt sich um eine steuerfreie innergemeinschaftliche Lieferung." wird zeitweise nicht auf Rechnung gedruckt. Amazon-Anbindung - Fehler und Bugs 0
Neu Auftrag wird nicht in P+ geladen User helfen Usern - Fragen zu JTL-Wawi 1
Neu Shop - Abgleich funktioniert leider nicht mehr User helfen Usern - Fragen zu JTL-Wawi 1
Neu HILFE! Bestellungen werden nicht mehr importiert WooCommerce-Connector 2
Konfigurator zeigt nicht mehr alle Dropdown-Elemente an Upgrade JTL-Shop4 auf JTL-Shop5 3
In Diskussion FBA Rechnungen werden nicht mehr über den Workflow ausgedruckt JTL-Workflows - Fehler und Bugs 4
Sprachwechsel in Plugin Shop 5 Hook 140 sprachvariable nicht aktuell Upgrade JTL-Shop4 auf JTL-Shop5 0
Neu dot.liquid - Addieren zum Ergebnis einer Ganzzahlberechnung funktioniert nicht richtig JTL-Wawi - Fehler und Bugs 7
Neu EK lässt sich nicht ändern/setzen JTL-Wawi - Fehler und Bugs 1
Neu Amazon: Browse Node - Artikel nicht auffindbar!? Amazon-Anbindung - Fehler und Bugs 0
Neu Versanddaten Import Vorlage passt nicht JTL-Wawi - Fehler und Bugs 1
Shop 5: Nova / Lieferzeitenangabe für Kinderartikel passt nicht Einrichtung JTL-Shop5 0
Neu Firefox&Edge zeigt die Seite nicht richtig an - Chrome hingegen schon JTL-Shop - Fehler und Bugs 10
Neu Stückliste erstellen bzw. bearbeiten (Artikel auswählen, Status auswählen nicht möglich) JTL-Wawi - Fehler und Bugs 2
Neu "Aus Sortiment entfernen" funktioniert nicht Amazon-Anbindung - Fehler und Bugs 1
Neu "Erfolgreicher Import" bzw. "Aktualisieren" - Produkt nicht sichtbar, auch nicht im Export! JTL-Ameise - Fehler und Bugs 1
Gelöst Flexible Voucher lassen sich nicht erstellen JTL-POS - Fehler und Bugs 7
Neu Bilder werden nicht übertragen WooCommerce-Connector 0
Neu Paypal, Amazon Pay und Händlerbund Plugins lassen sich nicht installieren/aktivieren Plugins für JTL-Shop 0
Neu Netzwerkdrucker gehen nicht mehr Fehler 0x0000011b User helfen Usern 4
Testshop kann nach dem Anlegen nicht geöffnet werden Einrichtung JTL-Shop5 1
Beantwortet Alte Aufträge nicht auf Pickliste Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 5
Neu FBA Gutschriften werden nicht als Rechnungskorrektur erstellt Amazon-Anbindung - Fehler und Bugs 7
Neu Auswahlassistent nicht sichtbar (JTL Shop 5.03) Plugins für JTL-Shop 0
Neu Artikel kann nicht auf Amazon eingestellt werden - [Herkunftsland = null] Amazon-Lister - Fehler und Bugs 1
Neu Frankreich Umsatzsteuernummer ID nicht auf Rechnung - Vorschau schon ?!?! JTL-Wawi - Fehler und Bugs 4
Neu JTL-Shop 5.1.1 - Import der Postleitzahlen funktioniert nicht, was muß man tun? JTL-Shop - Fehler und Bugs 1
Beantwortet Nicht zusammenfassbare Aufträge mit der selben Adresse farblich kennzeichen JTL-Workflows - Ideen, Lob und Kritik 7
Gelöst Amazon Werbeaktion nicht richtig in JTL übernommen Amazon-Anbindung - Fehler und Bugs 2
Neu JTL Shop 5 gekauft Variationen sind nicht anwählbar JTL-Shop - Fehler und Bugs 2
Neu Wunschzettel-Funktionen funktionieren nicht JTL-Shop - Fehler und Bugs 2
Verwiesen an Support Produkte liegen im Pickwagen und können nicht verarbeitet werden Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 1

Ähnliche Themen