Neu Variantebilder werden nicht angezeigt / SQL Fehler

weinrank

Neues Mitglied
14. Dezember 2020
4
0
Hallo zusammen,

wir haben das Problem, dass wir in Artikeln keine (neuen) Zuordnungen von Konfigurationen zu Bilder einstellen können.
Beispielsweise haben wir einen Teppich in den Farben "Gelb" und "Pink" und möchten nun die entsprechenden Bilder den Farben zuordnen.
Das klappt aus der WaWi nicht mehr.
Wenn wir die Auswahl manuell abspeichern möchten, kommt eine Fehlermeldungen.

Code:
PDOException: SQLSTATE(23000): Integrity constraint violation: 1062 Duplicate entry '2147483647' for key 's_article_img_mapping_rules.PRIMARY' in /vendor/doctrine/dbal/lib/Doctrine/DBAL/Statement.php:167 Stack trace:
#0 /vendor/doctrine/dbal/lib/Doctrine/DBAL/Statement.php(167): PDOStatement->execute()
#1 /engine/Library/Doctrine/ORM/Persisters/Entity/BasicEntityPersister.php(287): Doctrine\DBAL\Statement->execute()
#2 /vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php(1088): Doctrine\ORM\Persisters\Entity\BasicEntityPersister->executeInserts()
#3 /vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php(401): Doctrine\ORM\UnitOfWork->executeInserts()
#4 /vendor/doctrine/orm/lib/Doctrine/ORM/EntityManager.php(371): Doctrine\ORM\UnitOfWork->commit()
#5 /engine/Shopware/Controllers/Backend/Article.php(3043): Doctrine\ORM\EntityManager->flush()
#6 /engine/Shopware/Controllers/Backend/Article.php(461): Shopware_Controllers_Backend_Article->createImagesForOptions()
#7 /engine/Library/Enlight/Controller/Action.php(182): Shopware_Controllers_Backend_Article->saveMediaMappingAction()
#8 /engine/Library/Enlight/Controller/Dispatcher/Default.php(478): Enlight_Controller_Action->dispatch()
#9 /engine/Library/Enlight/Controller/Front.php(228): Enlight_Controller_Dispatcher_Default->dispatch()
#10 /engine/Shopware/Kernel.php(191): Enlight_Controller_Front->dispatch()
#11 /vendor/symfony/http-kernel/HttpCache/SubRequestHandler.php(85): Shopware\Kernel->handle()
#12 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(477): Symfony\Component\HttpKernel\HttpCache\SubRequestHandler::handle()
#13 /engine/Shopware/Components/HttpCache/AppCache.php(261): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward()
#14 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(267): Shopware\Components\HttpCache\AppCache->forward()
#15 /engine/Shopware/Components/HttpCache/AppCache.php(102): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass()
#16 /var/www/www.primaflor.de/shopware.php(122): Shopware\Components\HttpCache\AppCache->handle()
#17

Nach etwas Recherche sind auf den Grund gestoßen.
Die Mappings werden in der Tabelle `s_article_img_mapping_rules` gespeichert.
Da ist nun der Primärschlüssel "vollgelaufen" und es können keine neuen Einträge erstellt werden.
Habt ihr eine Idee?
 

Anhänge

  • zuordnung.png
    zuordnung.png
    951,2 KB · Aufrufe: 4
  • zuordnung3.png
    zuordnung3.png
    345,8 KB · Aufrufe: 4
  • zurordnung2.png
    zurordnung2.png
    784,7 KB · Aufrufe: 4
Ähnliche Themen
Titel Forum Antworten Datum
Neu Produktbilder werden plötzlich mehrfach in Shopify bei Variationen angelegt Shopify-Connector 2
Neu Bilder werden nicht übertragen WooCommerce-Connector 0
Testshop kann nach dem Anlegen nicht geöffnet werden Einrichtung JTL-Shop5 1
Neu FBA Gutschriften werden nicht als Rechnungskorrektur erstellt Amazon-Anbindung - Fehler und Bugs 7
Neu Artikel kann nicht auf Amazon eingestellt werden - [Herkunftsland = null] Amazon-Lister - Fehler und Bugs 1
Beantwortet Können Amazon UK Rechnungen mittlerweile abgerufen werden? Ticket 48721 User helfen Usern - Fragen zu JTL-Wawi 2
In Bearbeitung Fehler "Typ " 'Decimal' für Eigenschaft 'Anzahl' konvertiert werden. " in Worflow mit DotLiquid JTL-Workflows - Ideen, Lob und Kritik 3
Verwiesen an Support Produkte liegen im Pickwagen und können nicht verarbeitet werden Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 1
Weiterleitungen können nicht eingerichtet werden Einrichtung JTL-Shop5 0
Verwiesen an Support Händlerpreise werden nicht an Shopware übergeben Shopware-Connector 2
Neu Steuern werden falsch in die Wawi importiert Shopware-Connector 1
Gelöst Konfigurator - Komponenten Namen werden nicht angezeigt nach Update auf 5.1 JTL-Shop - Fehler und Bugs 3
Gelöst 5.1.0 - VarKombi Bilder werden nicht angezeigt JTL-Shop - Fehler und Bugs 1
In Bearbeitung Pos Verkäufe werden nicht mehr an die Wawi übertragen JTL-POS - Fehler und Bugs 3
Neu Artikel werden dupliziert JTL-Wawi - Fehler und Bugs 0
Neu Allgemeiner Fehler wenn DHL Labels gleichzeitig erstellt werden JTL-ShippingLabels - Fehler und Bugs 0
Neu Kunden werden nicht gefunden Servicedesk (Beta) 1
Neu Wawi Bereich "Verkauf" in JTL5 ->Kundendaten werden falsch angezeigt und sogar falsch generiert JTL-Wawi - Fehler und Bugs 1
Neu Variantions Kombination - Bilder werden im Shop nicht angezeigt JTL-Wawi - Ideen, Lob und Kritik 11
Neu Wie ersetze ich Bilder, sodass sie auch angezeigt werden? Allgemeine Fragen zu JTL-Shop 3
Neu Bilder in Signatur werden nicht überall angezeigt Servicedesk (Beta) 5
Neu Kategorien können nicht aktiviert werden Modified eCommerce-Connector 1
Neu Seiten die in "Eigene Inhalte - Seiten" erstellt wurden, werden nicht mehr angezeigt und nicht bearbeitbar JTL-Wawi - Fehler und Bugs 0
Neu Laufendes Ebay Angebot - Varkombi - Festpreis kann nicht geändert werden eBay-Anbindung - Fehler und Bugs 0
Neu Versandetikett von DHL werden zu weit Links gedruckt JTL-ShippingLabels - Fehler und Bugs 4
Gelöst Bonvorlage - Anmerkung Artikel werden gedruckt Gelöste Themen in diesem Bereich 2
Neu Amazon Bestellungen werden seit 26.08 nicht mehr in die Wawi übertragen Amazon-Anbindung - Fehler und Bugs 1
Neu Artikelbilder werden unendlich oft dupliziert. WooCommerce-Connector 1
Neu Box konnte nicht entfernt werden JTL-Shop - Fehler und Bugs 0
Neu Warum Übersichtsseiten ohne Ende? Wie kann das deaktiviert werden? Allgemeine Fragen zu JTL-Shop 9
Neu Kategoriebilder werden nicht angezeigt Onlineshop-Anbindung 0
In Bearbeitung Wurzelkategorie - Artikel werden nicht nach POS übertragen Allgemeine Fragen zu JTL-POS 1
Neu Bug: Template Datein des Child-Templates werden nicht bei include anweisungen geladen JTL-Shop - Fehler und Bugs 2
In Bearbeitung Bons werden 2x gedruckt Allgemeine Fragen zu JTL-POS 7
Shop5 Export Idealo Artikel mit Umlauten werden in Idealo mit Sonderzeichen dargestellt Einrichtung JTL-Shop5 6
Neu Problem beim Shopware Abgleich/Artikel werden nicht übertragen Shopware-Connector 0
Neu Seit dem 13.07 werden die Rechnungen über VCS nicht die Aufträge zu geordnet. Amazon-Anbindung - Fehler und Bugs 7
Issue angelegt Wawi 1.6.29.2 - Auftragsfarben werden am Packtisch nicht mehr dargestellt [WAWI-57002] JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 4
Neu Inaktive Artikel werden im Shop angezeigt Arbeitsabläufe in JTL-Wawi 2
Neu Warum werden Rechnungen zu Amazon-Aufträgen doppelt angelegt? Arbeitsabläufe in JTL-Wawi 0
Neu Amazon VCS Light es werden keine Rechnungen erzeugt. Amazon-Anbindung - Fehler und Bugs 0
In Bearbeitung Auftragsfarben werden nicht angezeigt, Hinweis aus Auftrag fehlt in Infobox [WAWI-57002,WAWI-57014, WAWI-57462] JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 17
Neu Mehrsprachiger Shop: MerkmalNAMEN werden nur auf Deutsch angezeigt JTL-Shop - Fehler und Bugs 1
Neu ALLE Artikel werden bei jedem Abgleich nochmals an den Shop geschickt Arbeitsabläufe in JTL-Wawi 0
Neu Eigene Felder, Änderungen in Werteliste werden nicht übernommen JTL-Wawi - Fehler und Bugs 1
Neu Gewichte werden nicht geladen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 5
In Bearbeitung Aufträge von der POS werden NICHT mehr in der WAWI angezeigt Allgemeine Fragen zu JTL-POS 5
Neu Unfrankierte Versandetiketten werden nicht bei Auslieferung gedruckt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Varianten werden nicht mehr angezeigt Modified eCommerce-Connector 2
Gelöst Backup Datei kann nicht eingespielt werden! JTL-POS - Fehler und Bugs 2

Ähnliche Themen