Neu Steuersatz nicht gefunden trotz richtiger ISO

MoritzCHR

Neues Mitglied
9. November 2020
17
0
Hallo,
einer unserer Kunden kann seit einiger Zeit keine Bestellungen mit unserem benutzerdefinierten Connector importieren.
Der Kunde bekommt diesen Fehler wenn wir wie normal auch "DE" als ISO übergeben.
1629109977020.png
1629110016949.png
Darauf hat mir der Kunde den folgenden Hinweis gegeben.
"wir können vermutlich aufgrund der Umsatzsteuerreform und der erforderlichen Pflichteinstellung zum 01.07.2021 in JTL Wawi die Bestellungen nicht empfangen. Es wird nicht mehr zwischen EU und Nicht-EU Land unterschieden, sondern wir müssen wir jedes Land die einzelnen Steuersätze hinterlegen."
Hier sind die Steuereinstellungen des Kundens.
1629110093158.png

Da ich die Ursache nicht finden konnte habe ich probiert die ISO auszuschreiben.
Damit war der Fehler zwar weg aber es kam leider der nächste Fehler.
1629110065087.png

Ich weiß nun leider ob es funktionieren würde wenn die Umlaute nicht kaputt gehen würden.
Allerdings halte ich es auch für nicht korrekt die ISO auszuschreiben.
Woran könnte es noch liegen?
 

forumjtlolshopag

Sehr aktives Mitglied
6. Juni 2018
480
112
Wir nutzen bei unserem Connector neben dem ISO auch die Lieferlandbezeichnung. Bei uns kam es nicht zu einem Konflikt, wo die Umstellung war. Vllt. muss man beides angeben?
 

MoritzCHR

Neues Mitglied
9. November 2020
17
0
Hm, bei der Adresse welche ich bei der Customer_Order übergebe kann ich leider nur einen ISO Code übergeben und keine Landbezeichnung.

1629119681419.png
 

Immanuel

Gesperrter Benutzer
24. August 2016
1.542
323
Hallo @MoritzCHR,

bei "countryIso" sollte so wie es auch im PHPDoc steht der zweistellige Ländercode verwendet werden. Vielleicht hilft ein Update von JTL-Wawi.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu EU Rechnungskorrektung/Gutschriften ohne Steuersatz exportiert JTL-Ameise - Fehler und Bugs 1
Neu Zeichen werden nicht angezeigt... Im Frontend - nach Schrift Änderung!? JTL-Shop - Fehler und Bugs 0
Neu Versand mit UPS (API) funktioniert nicht JTL-ShippingLabels - Fehler und Bugs 0
Neu Neue Produkte werden nicht im Shop angezeigt. Shopware-Connector 4
Neu Nach SQL Server Upgrade, manche Artikel nicht mehr abrufbar JTL-Wawi - Fehler und Bugs 0
Neu Shop 5 - Artikelvariationen lassen sich nach Update nicht mehr auswählen JTL-Shop - Fehler und Bugs 0
Neu Kassenbuch Monatsauszug Endbestand - Anfangsbestand stimmen nicht überein JTL-POS - Fehler und Bugs 1
Neu Kategorie bearbeiten > Artikeländerungen > Versandklasse ändern >wird nicht gespeichert JTL-Wawi - Fehler und Bugs 0
Neu Rechnung Vorlage Bearbeiter Anzeigen nur wenn nicht Administrator JTL-Wawi - Ideen, Lob und Kritik 1
Beantwortet Epson Tm-T88V wird auf Chromebook nicht erkannt JTL-POS - Fehler und Bugs 1
Neu Amazon Pay - JTL5 Button im Warenkorb funktioniert nicht Plugins für JTL-Shop 0
Neu Lieferstatus / Bestellstatus wird nicht übermittelt bei DROP Sendungen Shopware-Connector 1
Neu Extension Store lässt sich nicht verknüpfen Technische Fragen zu Plugins und Templates 1
Neu Bestellbestätigung Email BCC wird nicht gesendet JTL-Shop3 0
Neu Artikel im Shop die in der WAWI nicht existieren? JTL-Wawi - Fehler und Bugs 2
Neu Seriennummern in Rechnung und Lieferschein nicht sichtbar (1.6) Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Datenbank konnte nicht angelegt werden. Installation von JTL-Wawi 4
In Bearbeitung JTL-POS Rechnungen werden nicht gedruckt JTL-POS - Fehler und Bugs 10
Neu Newsletter lässt sich nicht erstellen JTL-Shop - Fehler und Bugs 1
Neu WMS mobile - Stückliste nicht ausliefern, HILFE! JTL-WMS / JTL-Packtisch+ - Ideen, Lob und Kritik 8
Neu Automatisch stornierter Auftrag in Woocommerce wird in der Wawi nicht storniert und sogar ausgeliefert WooCommerce-Connector 0
In Diskussion Voraussichtlicher Liefertermin wird in WaWi 1.6 nicht mehr angzeigt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu Shopify Trackingnummern werden verzögert / gar nicht in die Bestellungen geladen JTL-Wawi - Fehler und Bugs 0
Neu Variablen _variables.scss werden im Kind-Template nicht angezeigt Templates für JTL-Shop 2
In Bearbeitung WORM_ERROR_AUT HENTICATION_PIN_BLOCKED - Beleg konnte nicht signiert werden. JTL-POS - Fehler und Bugs 2
Neu Artikel werden nicht auf eBay entfernt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shopware 5 Bilder werden nicht aktualisiert bzw. falsche zugeordnet Shopware-Connector 0
Neu Mollie Einrichten klappt nicht Plugins für JTL-Shop 0
Gelöst Lister gibt Daten falsch nach Amazon, Nakommaproblem und werden nicht gelistet Amazon-Lister - Fehler und Bugs 2
Neu Lieferscheine werden nicht gedruckt bei Auslieferung User helfen Usern - Fragen zu JTL-Wawi 0
Neu Gesamtsumme eines Auftrags wird nicht synchronisiert JTL-Shop - Fehler und Bugs 2
Neu Kernlbase.dll Absturz in Beschreibung | Versenden von Error Report nicht möglich JTL-Wawi - Fehler und Bugs 1
Nicht gewünschte Produktfelde (z.B. GTIN) aus Listenansicht und Detailansicht entfernen Einrichtung JTL-Shop5 1
Beantwortet Versandart ändern klappt nicht richtig wenn Stücklistenartikel JTL-Workflows - Ideen, Lob und Kritik 2
Neu Youtube Videos im Shop sind nicht verfügbar Allgemeine Fragen zu JTL-Shop 0
Gelöst Kassenbuch wird nicht angezeigt JTL-POS - Fehler und Bugs 2
In Bearbeitung Workflow wird nicht ausgeführt - Auslieferung nach Zahlung JTL-Workflows - Fehler und Bugs 1
Neu Artikel erscheinen nicht in WAWI Artikelliste User helfen Usern - Fragen zu JTL-Wawi 10
Beantwortet JTL Packtisch 1.5.48.2 Pickliste lässt sich nicht löschen/picken User helfen Usern - Fragen zu JTL-Wawi 1
Gelöst eBay-Anbindung funktioniert nicht mehr eBay-Anbindung - Fehler und Bugs 17
Neu WAWI 1.6.32.0 versendete Rechnungsmail wird nicht als versendet angezeigt JTL-Wawi - Fehler und Bugs 0
Neu Sollte Wawi 1.6.0 nicht eigentlich Wawi 2.0.0 heißen? JTL-Wawi - Ideen, Lob und Kritik 1
Neu Kundengruppen lassen sich nicht auswählen User helfen Usern - Fragen zu JTL-Wawi 1
Neu "Max. Bestand Neu" nicht befüllen Technische Fragen zu den JTL-Connectoren 0
Neu Kundengruppen werden vom Connector nicht mehr in die Wawi übertragen JTL-Wawi - Fehler und Bugs 0
In Bearbeitung Sunmi T2s komm nicht aus der Kiosksoftware raus JTL-POS - Fragen zu Hardware 2
Neu Rechnungen kommen nicht mehr bei AMAZON an Arbeitsabläufe in JTL-Wawi 2
Neu Kategorie Metadaten werden nicht übertragen WooCommerce-Connector 0
Neu Internetmarke mit Matrixcode, wird nicht an Amazon übermittelt JTL-ShippingLabels - Ideen, Lob und Kritik 3
Neu Bild-Upload zu WooCommerce funktioniert plötzlich nicht mehr WooCommerce-Connector 10

Ähnliche Themen