**RELEASE: JTL-Connector (SaaS) für Shopware 6 startet in die Open Beta**

Kaido

Aktives Mitglied
26. Februar 2018
78
16
Wir scheitern leider nach wie vor am Problem, dass wir nach der Nachricht "Verbindung zum Webshop OK" diese Fehlermeldung hier bekommen. :(. Gibt es denn wirklich keine Lösung dafür?
 

Anhänge

  • Bildschirmfoto 2020-09-23 um 14.20.45.png
    Bildschirmfoto 2020-09-23 um 14.20.45.png
    27 KB · Aufrufe: 16

Juergen_S

Neues Mitglied
4. September 2020
5
0
Hallo,

wir testen auch schon seit einiger Zeit den Connector.
Manchmal echt merkwürdig. Mal funktioniert es und mal wieder nicht.
Leerer Shopware 6 aufgesetzt.
Artikel importiert. Macht er einwandfrei. 8000 Artikel. / ca. 180 Kategorien.

Verschiebe ich die Kategorien in JTL und gleiche diese dann ab. (Nur die Kategorien) macht er das.
Kalkuliere ich die Preise und nehme ein paar Artikel neu dazu und importiere die in den Shop, bricht er mal bei 150 Artikel ab, dann mal wieder bei 400 dann mal wieder bei 650.
Irgendwann läuft er dann auch mal durch.

Aktuell kommen wir hier nicht weiter. Hat jemand evtl. eine Idee. Vielleicht sehen wir vor lauter Bäumen den Wald nicht. :(


Code:
Abgleich-Protokoll:
Bitte beachten Sie, dass JTL-Wawi federführend ist!
Im Shop-Backend vorgenommene Änderungen können nicht mehr automatisiert abgeglichen werden und führen somit zu Datenverlust.
Prüfe Endpointkonfiguration.
Abgleich gestartet für 'Shopware Shop'.
Onlineshop-Abgleich beendet für 'Shopware Shop'.


Fehler:
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Die ConnectionString-Eigenschaft wurde nicht initialisiert.
   bei JTL.Database.DbConnectionHelpers.Execute[T](IDbConnection connection, Func`1 func, Boolean keepAlive)
   bei JTL.Database.DbConnectionExtensions.ExecuteNonQuery(IDbConnection connection, String query, Object parameters)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.SetInBearbeitungFlagArtikel(Int32 kShop, Int32 value, SqlConnection connection)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.CheckForMeanwhileSync(Connector connector, AbgleichInfo abgleichInfo, AbgleichSyncContext abgleichSyncContext)
   bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPusher.Push[TEntity](IEnumerable`1 models)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.<>c__DisplayClass8_1.<Run>b__0(List`1 models)
   bei jtlTools.Linq.EnumerableExtensions.ExecuteInSetsOf[TInput](IEnumerable`1 source, Action`1 action, Int32 max)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.Run()
   bei JTL.Connector.Business.SyncRunner.Run()
 

redheadman

Gut bekanntes Mitglied
3. August 2016
135
16
Berlin
Hallo,

wir testen auch schon seit einiger Zeit den Connector.
Manchmal echt merkwürdig. Mal funktioniert es und mal wieder nicht.
Leerer Shopware 6 aufgesetzt.
Artikel importiert. Macht er einwandfrei. 8000 Artikel. / ca. 180 Kategorien.

Verschiebe ich die Kategorien in JTL und gleiche diese dann ab. (Nur die Kategorien) macht er das.
Kalkuliere ich die Preise und nehme ein paar Artikel neu dazu und importiere die in den Shop, bricht er mal bei 150 Artikel ab, dann mal wieder bei 400 dann mal wieder bei 650.
Irgendwann läuft er dann auch mal durch.

Aktuell kommen wir hier nicht weiter. Hat jemand evtl. eine Idee. Vielleicht sehen wir vor lauter Bäumen den Wald nicht. :(


Code:
Abgleich-Protokoll:
Bitte beachten Sie, dass JTL-Wawi federführend ist!
Im Shop-Backend vorgenommene Änderungen können nicht mehr automatisiert abgeglichen werden und führen somit zu Datenverlust.
Prüfe Endpointkonfiguration.
Abgleich gestartet für 'Shopware Shop'.
Onlineshop-Abgleich beendet für 'Shopware Shop'.


Fehler:
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Die ConnectionString-Eigenschaft wurde nicht initialisiert.
   bei JTL.Database.DbConnectionHelpers.Execute[T](IDbConnection connection, Func`1 func, Boolean keepAlive)
   bei JTL.Database.DbConnectionExtensions.ExecuteNonQuery(IDbConnection connection, String query, Object parameters)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.SetInBearbeitungFlagArtikel(Int32 kShop, Int32 value, SqlConnection connection)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.CheckForMeanwhileSync(Connector connector, AbgleichInfo abgleichInfo, AbgleichSyncContext abgleichSyncContext)
   bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPusher.Push[TEntity](IEnumerable`1 models)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.<>c__DisplayClass8_1.<Run>b__0(List`1 models)
   bei jtlTools.Linq.EnumerableExtensions.ExecuteInSetsOf[TInput](IEnumerable`1 source, Action`1 action, Int32 max)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.Run()
   bei JTL.Connector.Business.SyncRunner.Run()

Hi,
mein reden und für mich sieht es so aus als ob er sporadisch einfach die Connection verliert.
Haben den Fehler auch noch, meist wenn wir zwischen 400 bis 1000 Artikel hochladen.

Wenn man das ganze über den Worker laufen lässt, dann scheint es zu gehen.
Man müsste sich aber mal die Logs anschauen, denn hier werden ja Häppchenweise Pakete gesendet, so hab ich es jedenfalls in Erinnerung.

Beste Grüße
 

pbadmin

Aktives Mitglied
15. Oktober 2018
22
1
Wir bekommen immer folgenden Fehler, können das Plugin CustomizedProducts aber nicht deaktivieren da wir SW6 bei Shopware hosten bzw. Saas nutzen:
Code:
Fehler:
Exception: Controller = Product | Action = push | Wawi PK = 560 | SKU = sb10002m | Name = Hoodie - Albrecht | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Argument 1 passed to Swag\CustomizedProducts\Core\Content\Product\ProductWrittenSubscriber::parentHasTemplateAssociated() must be of the type string, null given, called in /var/www/html/vendor/swag/customized-products/src/Core/Content/Product/ProductWrittenSubscriber.php on line 66
Controller = Product | Action = push | Wawi PK = 560 | SKU = sb10002m | Name = Hoodie - Albrecht | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Argument 1 passed to Swag\CustomizedProducts\Core\Content\Product\ProductWrittenSubscriber::parentHasTemplateAssociated() must be of the type string, null given, called in /var/www/html/vendor/swag/customized-products/src/Core/Content/Product/ProductWrittenSubscriber.php on line 66
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei product.push: Controller = Product | Action = push | Wawi PK = 560 | SKU = sb10002m | Name = Hoodie - Albrecht | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Argument 1 passed to Swag\CustomizedProducts\Core\Content\Product\ProductWrittenSubscriber::parentHasTemplateAssociated() must be of the type string, null given, called in /var/www/html/vendor/swag/customized-products/src/Core/Content/Product/ProductWrittenSubscriber.php on line 66

Controller = Product | Action = push | Wawi PK = 560 | SKU = sb10002m | Name = Hoodie - Albrecht | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Argument 1 passed to Swag\CustomizedProducts\Core\Content\Product\ProductWrittenSubscriber::parentHasTemplateAssociated() must be of the type string, null given, called in /var/www/html/vendor/swag/customized-products/src/Core/Content/Product/ProductWrittenSubscriber.php on line 66

Response: {"jtlrpc":"2.0","id":"bf32cb6972694dbdba30e6b0004b29c5","result":null,"error":{"code":400,"message":"Controller = Product | Action = push | Wawi PK = 560 | SKU = sb10002m | Name = Hoodie - Albrecht | The Shopware 6 Admin API responded with an error: \nCode = 0 | Status = 500 | Detail = Argument 1 passed to Swag\\CustomizedProducts\\Core\\Content\\Product\\ProductWrittenSubscriber::parentHasTemplateAssociated() must be of the type string, null given, called in \/var\/www\/html\/vendor\/swag\/customized-products\/src\/Core\/Content\/Product\/ProductWrittenSubscriber.php on line 66","data":"Jtl\\Shopware6\\Client\\Exception\\ClientException (Code: 400) in ...\/ClientException.php:65"}}
Exception bei product.push: Controller = Product | Action = push | Wawi PK = 560 | SKU = sb10002m | Name = Hoodie - Albrecht | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Argument 1 passed to Swag\CustomizedProducts\Core\Content\Product\ProductWrittenSubscriber::parentHasTemplateAssociated() must be of the type string, null given, called in /var/www/html/vendor/swag/customized-products/src/Core/Content/Product/ProductWrittenSubscriber.php on line 66

Controller = Product | Action = push | Wawi PK = 560 | SKU = sb10002m | Name = Hoodie - Albrecht | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Argument 1 passed to Swag\CustomizedProducts\Core\Content\Product\ProductWrittenSubscriber::parentHasTemplateAssociated() must be of the type string, null given, called in /var/www/html/vendor/swag/customized-products/src/Core/Content/Product/ProductWrittenSubscriber.php on line 66

Response: {"jtlrpc":"2.0","id":"13ea819af9c64412bfcf53c40fe354cf","result":null,"error":{"code":400,"message":"Controller = Product | Action = push | Wawi PK = 560 | SKU = sb10002m | Name = Hoodie - Albrecht | The Shopware 6 Admin API responded with an error: \nCode = 0 | Status = 500 | Detail = Argument 1 passed to Swag\\CustomizedProducts\\Core\\Content\\Product\\ProductWrittenSubscriber::parentHasTemplateAssociated() must be of the type string, null given, called in \/var\/www\/html\/vendor\/swag\/customized-products\/src\/Core\/Content\/Product\/ProductWrittenSubscriber.php on line 66","data":"Jtl\\Shopware6\\Client\\Exception\\ClientException (Code: 400) in ...\/ClientException.php:65"}}
   bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.gf4XJlh8sv0(String  , Object  , Boolean  , NetworkCredential  )
   bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.afZXJ8PvBil(String  , Object  , Boolean  , NetworkCredential  )
   bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.gf4XJlh8sv0(String  , Object  , Boolean  , NetworkCredential  )
 
Zuletzt bearbeitet:

redheadman

Gut bekanntes Mitglied
3. August 2016
135
16
Berlin
Hallo,

wir testen auch schon seit einiger Zeit den Connector.
Manchmal echt merkwürdig. Mal funktioniert es und mal wieder nicht.
Leerer Shopware 6 aufgesetzt.
Artikel importiert. Macht er einwandfrei. 8000 Artikel. / ca. 180 Kategorien.

Verschiebe ich die Kategorien in JTL und gleiche diese dann ab. (Nur die Kategorien) macht er das.
Kalkuliere ich die Preise und nehme ein paar Artikel neu dazu und importiere die in den Shop, bricht er mal bei 150 Artikel ab, dann mal wieder bei 400 dann mal wieder bei 650.
Irgendwann läuft er dann auch mal durch.

Aktuell kommen wir hier nicht weiter. Hat jemand evtl. eine Idee. Vielleicht sehen wir vor lauter Bäumen den Wald nicht. :(


Code:
Abgleich-Protokoll:
Bitte beachten Sie, dass JTL-Wawi federführend ist!
Im Shop-Backend vorgenommene Änderungen können nicht mehr automatisiert abgeglichen werden und führen somit zu Datenverlust.
Prüfe Endpointkonfiguration.
Abgleich gestartet für 'Shopware Shop'.
Onlineshop-Abgleich beendet für 'Shopware Shop'.


Fehler:
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Die ConnectionString-Eigenschaft wurde nicht initialisiert.
   bei JTL.Database.DbConnectionHelpers.Execute[T](IDbConnection connection, Func`1 func, Boolean keepAlive)
   bei JTL.Database.DbConnectionExtensions.ExecuteNonQuery(IDbConnection connection, String query, Object parameters)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.SetInBearbeitungFlagArtikel(Int32 kShop, Int32 value, SqlConnection connection)
   bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.CheckForMeanwhileSync(Connector connector, AbgleichInfo abgleichInfo, AbgleichSyncContext abgleichSyncContext)
   bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPusher.Push[TEntity](IEnumerable`1 models)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.<>c__DisplayClass8_1.<Run>b__0(List`1 models)
   bei jtlTools.Linq.EnumerableExtensions.ExecuteInSetsOf[TInput](IEnumerable`1 source, Action`1 action, Int32 max)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.Run()
   bei JTL.Connector.Business.SyncRunner.Run()

Der Fehler soll laut Kundenservice bekannt sein und auch schon behoben, aber wann oder mit welchen Update es kommt?
Hat wohl aber nichts mit der Schnittstelle zutun.

Siehe hier: https://issues.jtl-software.de/issues/WAWI-49468

Beste Grüße
 

chrisg_mh

Neues Mitglied
25. September 2020
1
0
Shopware Version 6.2.2
JTLwawi Version 1.5.30

Erst kommt Verbindung zum Webshop ok, anschließend das hier
 

Anhänge

  • jtl.PNG
    jtl.PNG
    60,5 KB · Aufrufe: 9

yogi_10

Aktives Mitglied
5. Juni 2018
32
1
Hallo,

wir bekommen folgende Fehlermeldung beim Abgleich.

Fehler:
Exception: Controller = DeliveryNote | Action = push | Wawi PK = 18055 | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Argument 1 passed to Shopware\Core\Framework\Uuid\Uuid::fromHexToBytes() must be of the type string, int given, called in /var/www/vhosts/mackmode.jule.hostkraft.de/httpdocs/sw6/vendor/shopware/core/Framework/Uuid/Uuid.php on line 75
Controller = DeliveryNote | Action = push | Wawi PK = 18055 | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Argument 1 passed to Shopware\Core\Framework\Uuid\Uuid::fromHexToBytes() must be of the type string, int given, called in /var/www/vhosts/mackmode.jule.hostkraft.de/httpdocs/sw6/vendor/shopware/core/Framework/Uuid/Uuid.php on line 75
Lieferscheine-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei delivery_note.push: Controller = DeliveryNote | Action = push | Wawi PK = 18055 | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Argument 1 passed to Shopware\Core\Framework\Uuid\Uuid::fromHexToBytes() must be of the type string, int given, called in /var/www/vhosts/mackmode.jule.hostkraft.de/httpdocs/sw6/vendor/shopware/core/Framework/Uuid/Uuid.php on line 75

Controller = DeliveryNote | Action = push | Wawi PK = 18055 | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Argument 1 passed to Shopware\Core\Framework\Uuid\Uuid::fromHexToBytes() must be of the type string, int given, called in /var/www/vhosts/mackmode.jule.hostkraft.de/httpdocs/sw6/vendor/shopware/core/Framework/Uuid/Uuid.php on line 75

Response: {"jtlrpc":"2.0","id":"dff89b50d04445c297e2685b8361c243","result":null,"error":{"code":500,"message":"Controller = DeliveryNote | Action = push | Wawi PK = 18055 | The Shopware 6 Admin API responded with an error: \nCode = 0 | Status = 500 | Detail = Argument 1 passed to Shopware\\Core\\Framework\\Uuid\\Uuid::fromHexToBytes() must be of the type string, int given, called in \/var\/www\/vhosts\/mackmode.jule.hostkraft.de\/httpdocs\/sw6\/vendor\/shopware\/core\/Framework\/Uuid\/Uuid.php on line 75","data":"Jtl\\Shopware6\\Client\\Exception\\ClientException (Code: 500) in ...\/ClientException.php:65"}}
Exception bei delivery_note.push: Controller = DeliveryNote | Action = push | Wawi PK = 18055 | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Argument 1 passed to Shopware\Core\Framework\Uuid\Uuid::fromHexToBytes() must be of the type string, int given, called in /var/www/vhosts/mackmode.jule.hostkraft.de/httpdocs/sw6/vendor/shopware/core/Framework/Uuid/Uuid.php on line 75

Controller = DeliveryNote | Action = push | Wawi PK = 18055 | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Argument 1 passed to Shopware\Core\Framework\Uuid\Uuid::fromHexToBytes() must be of the type string, int given, called in /var/www/vhosts/mackmode.jule.hostkraft.de/httpdocs/sw6/vendor/shopware/core/Framework/Uuid/Uuid.php on line 75

Response: {"jtlrpc":"2.0","id":"102fe285f60d454ab0e0270f0a31aa8a","result":null,"error":{"code":500,"message":"Controller = DeliveryNote | Action = push | Wawi PK = 18055 | The Shopware 6 Admin API responded with an error: \nCode = 0 | Status = 500 | Detail = Argument 1 passed to Shopware\\Core\\Framework\\Uuid\\Uuid::fromHexToBytes() must be of the type string, int given, called in \/var\/www\/vhosts\/mackmode.jule.hostkraft.de\/httpdocs\/sw6\/vendor\/shopware\/core\/Framework\/Uuid\/Uuid.php on line 75","data":"Jtl\\Shopware6\\Client\\Exception\\ClientException (Code: 500) in ...\/ClientException.php:65"}}
bei jtlCore.ControllerClasses. Connector.Abgleich.Connector.O4PuQuwA4uL(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.fH1uQRWxK9p(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.O4PuQuwA4uL(String , Object , Boolean , NetworkCredential )
 

Immanuel

Gesperrter Benutzer
24. August 2016
1.542
323
@yogi_10
Interessanter Fehler. Der Connector kann eigentlich keine Integer Werte als Id (bzw uuid) setzen. Wäre super, wenn du mir den dazu passenden Onlineshop Abgleich Log per PM schicken könntest.

@mgoeben
Shopware 6 funktioniert etwas anders als Shopware 5, daher gibt es dort keine Sprachsubshops. Es ist möglich bspw. Artikel mit Übersetzungen zum Shop zu schicken.
 

Immanuel

Gesperrter Benutzer
24. August 2016
1.542
323
@pbadmin,, @janosch.pelzer,

mir wurde gesagt, dass seit der heute veröffentlichten Version von Custom Products (v2.6.3) das folgende Problem nicht mehr auftreten soll:
Code:
Argument 1 passed to Swag\CustomizedProducts\Core\Content\Product\ProductWrittenSubscriber::parentHasTemplateAssociated() must be of the type string, null given, called in /var/www/html/vendor/swag/customized-products/src/Core/Content/Product/ProductWrittenSubscriber.php[code]
 

redheadman

Gut bekanntes Mitglied
3. August 2016
135
16
Berlin
@Immanuel

wichtiger Hinweis: Artikel-Metadaten (Seo) dürfen nicht länger als 255 Zeichen sein. Der Artikel wird so nicht an den Shop übertragen. Vielleicht automatisch nur mit 255 Zeichen übertragen?

Beste Grüße
 
  • Gefällt mir
Reaktionen: ckOne

ui621as

Aktives Mitglied
22. Januar 2007
38
0
Hab gerade gesehen, Artikelattribute sollen übertragen werden. Es geht voran!
Hallo zusammen,

hab das gerade mit den Artikelattributen getestet. Wenn ich in der WaWi ein Showpare-Attribut nehme, dann bekomme ich das auch im Backend von SW6 beim entsporechenden Artikel unter Zusatzfelder angezeigt.

Mit den bereits bei mir in der WaWi vorhandenen Eigenen Attribute "tab2 name" oder "tab2 Inhalt" klappt das nicht. Für diese Attribute hatte ich zuvor in der Attributverwaltung den SW6 onlineshop aktiviert...

Code:
Fehler:
Exception: Controller = Product | Action = push | Wawi PK = 2339 | SKU = Art-1711-10 | Name = Neom Organics Candle Happiness, Duftkerze 420g | The Shopware 6 Admin API responded with an error:
Code = c1051bb4-d103-4f74-8988-acbcafc7fdc3 | Status = 400 | Detail = Dieser Wert sollte nicht leer sein. | Pointer = /1/name
Controller = Product | Action = push | Wawi PK = 2339 | SKU = Art-1711-10 | Name = Neom Organics Candle Happiness, Duftkerze 420g | The Shopware 6 Admin API responded with an error:
Code = c1051bb4-d103-4f74-8988-acbcafc7fdc3 | Status = 400 | Detail = Dieser Wert sollte nicht leer sein. | Pointer = /1/name
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei product.push: Controller = Product | Action = push | Wawi PK = 2339 | SKU = Art-1711-10 | Name = Neom Organics Candle Happiness, Duftkerze 420g | The Shopware 6 Admin API responded with an error:
Code = c1051bb4-d103-4f74-8988-acbcafc7fdc3 | Status = 400 | Detail = Dieser Wert sollte nicht leer sein. | Pointer = /1/name

Controller = Product | Action = push | Wawi PK = 2339 | SKU = Art-1711-10 | Name = Neom Organics Candle Happiness, Duftkerze 420g | The Shopware 6 Admin API responded with an error:
Code = c1051bb4-d103-4f74-8988-acbcafc7fdc3 | Status = 400 | Detail = Dieser Wert sollte nicht leer sein. | Pointer = /1/name

Response: {"jtlrpc":"2.0","id":"8b39d2cab1c44665a5ec002bf111c61b","result":null,"error":{"code":400,"message":"Controller = Product | Action = push | Wawi PK = 2339 | SKU = Art-1711-10 | Name = Neom Organics Candle Happiness, Duftkerze 420g | The Shopware 6 Admin API responded with an error: \nCode = c1051bb4-d103-4f74-8988-acbcafc7fdc3 | Status = 400 | Detail = Dieser Wert sollte nicht leer sein. | Pointer = \/1\/name","data":"Jtl\\Shopware6\\Client\\Exception\\ClientException (Code: 400) in ...\/ClientException.php:65"}}
Exception bei product.push: Controller = Product | Action = push | Wawi PK = 2339 | SKU = Art-1711-10 | Name = Neom Organics Candle Happiness, Duftkerze 420g | The Shopware 6 Admin API responded with an error:
Code = c1051bb4-d103-4f74-8988-acbcafc7fdc3 | Status = 400 | Detail = Dieser Wert sollte nicht leer sein. | Pointer = /1/name

Controller = Product | Action = push | Wawi PK = 2339 | SKU = Art-1711-10 | Name = Neom Organics Candle Happiness, Duftkerze 420g | The Shopware 6 Admin API responded with an error:
Code = c1051bb4-d103-4f74-8988-acbcafc7fdc3 | Status = 400 | Detail = Dieser Wert sollte nicht leer sein. | Pointer = /1/name

Response: {"jtlrpc":"2.0","id":"8620bea3a653428ea77baf9cb23f194a","result":null,"error":{"code":400,"message":"Controller = Product | Action = push | Wawi PK = 2339 | SKU = Art-1711-10 | Name = Neom Organics Candle Happiness, Duftkerze 420g | The Shopware 6 Admin API responded with an error: \nCode = c1051bb4-d103-4f74-8988-acbcafc7fdc3 | Status = 400 | Detail = Dieser Wert sollte nicht leer sein. | Pointer = \/1\/name","data":"Jtl\\Shopware6\\Client\\Exception\\ClientException (Code: 400) in ...\/ClientException.php:65"}}
   bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.w80sB8cUbdt(String  , Object  , Boolean  , NetworkCredential  )
   bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.nPmsBvO2vbY(String  , Object  , Boolean  , NetworkCredential  )
   bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.w80sB8cUbdt(String  , Object  , Boolean  , NetworkCredential  )

@Immanuel : Darf ich in der WaWi grundsätzlich nur die Shopware-Attrtibute nehmen? Oder werden künftig auch "Eigene Attribute" für den Sync zwischen WaWi und SW6 unterstützt?

Danke!
Grüße, Stefan
 

Immanuel

Gesperrter Benutzer
24. August 2016
1.542
323
Hallo @ui621as,

sicher, dass das Problem durch die Attribute versursacht wird? Ich würde vermuten, dass eine Übersetzung dieses Artikels unvollständig ist. Bitte schicke mir den dazu passenden Onlineshop-Abgleich- Log per PM zu. Dann schaue ich da mal drüber.
 

Kaido

Aktives Mitglied
26. Februar 2018
78
16
An sich ist es ja eine freiwillige Sache, dass JTL eine Open Beta anbietet, aber es bringt halt keinen Effekt, wenn die Beta angeboten wird, auf Mithilfe und Unterstützung unserer Seite gebeten wird, dann per E-Mail nachgefragt wird ob wir zufrieden mit dem Shopware 6 Connector sind und wir darauf antworten, sowohl hier als auch auf die Mail und keinerlei Rückantwort zu unseren Problemen bekommen. Dann brauch man keine Beta anbieten, geschweige denn um Mithilfe beten.

Der Connector funktioniert nicht. Und das seit Wochen … :-/. An sich wirklich eine tolle Sache, aber die Probleme häufen sich und der Großteil kann sich nicht verbinden, weil nach "Webshop OK" die zweite Fehlermeldung kommt. Wir sind ja so offen und testen den neuen Connector parallel zu unseren funktionierenden SW5-Shops während unserer Arbeitszeit, aber wir müssten dann auch eine Problemlösung erhalten, bzw. überhaupt eine Antwort darauf :)
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu JTL-Wawi 1.6 Open Beta Release 1.6.33.1 Releaseforum 3
Neu JTL Ameise Import Kundengruppenpreise nur teilweise!! JTL-Ameise - Fehler und Bugs 1
Neu Installation von JTL-Shop (gehostet bei JTL) Installation / Updates von JTL-Shop 2
Neu JTL Ameise - Bestandsexport für Buchhaltung (Artikeldatenexport) JTL-Ameise - Ideen, Lob und Kritik 1
Neu Fehler beim Abgleich mit JTL-Shop JTL-Wawi - Fehler und Bugs 2
Neu JTL Wawi 1.6 - Zahlung manuell buchen - Zahldatum setzen vor Erfassung + Skonto JTL-Wawi - Ideen, Lob und Kritik 0
Webinar: Unser neues Shopware5-Plugin für das JTL-Fulfillment Network inklusive Live-Demonstration Messen, Stammtische und interessante Events 0
Webinar: Page-Speed-Optimierung für JTL-Shop 5 Messen, Stammtische und interessante Events 0
Neu Wawi 1.6.33.1 Bilddarstellung Kinderartikel im Shop5 JTL fehlerhaft JTL-Wawi - Fehler und Bugs 0
Neu TestShop Hosting - Abgleich von JTL zum Shop HTTP Error: 502 Allgemeine Fragen zu JTL-Shop 1
Neu JTL Shop 5 Exportvorlage für Facebook Allgemeine Fragen zu JTL-Shop 6
Neu JTL-Wawi 1.6.33.1 im betrieb mit 2 Firmen wird eine nicht gefiltert. JTL-Wawi - Fehler und Bugs 0
Neu SyncException: 3 Nach update von JTL Shop 4 auf 5 , KEINE ANBINDUNG mehr möglich. HILFE Onlineshop-Anbindung 6
Neu Übertragen von zusätzlichen Feldern an JTL-WAWI aus WooCommerce Bestellung WooCommerce-Connector 0
Beantwortet JTL-Wawi 1.6.33.1 - nach Komplettabgleich Merkmale im Shop weg JTL-Wawi - Fehler und Bugs 2
Neu Welchen Server für JTL Shop 5 ? User helfen Usern - Fragen zu JTL-Wawi 12
Neu Fehler beim installieren von JTL Software Edition JTL-Wawi - Fehler und Bugs 0
Neu JTL Konfigurator - Lagerbestand bei Artikel Allgemeine Fragen zu JTL-Shop 4
Neu JTL-Wawi in Windows-Sandbox User helfen Usern - Fragen zu JTL-Wawi 1
Neu Shopify Store mit JTL Individuelle Listenansichten in der JTL-Wawi 6
Neu Marktplatz Amazon.com JTL EA User helfen Usern - Fragen zu JTL-Wawi 8
Neu Bilder-Slider auf Startseite JTL Shop 5 Punktnavigation / Pfeilnavigation Betrieb / Pflege von JTL-Shop 0
Neu Gambio Connector, JTL WAWI und Gambio EU-Steuersätze Modul - PROBLEM mit EU Standardsteuersatz Gambio-Connector 4
JTL Shop 5: Wunschzettel im Kundenkonto ausblenden Einrichtung JTL-Shop5 2
Neu JTL Wawi 1.5.53.0 online nicht mehr verfügbar JTL-Wawi - Fehler und Bugs 1
Neu Nach Update auf JTL-Wawi 1.6.33.1 - Fehler beim Onlineshopabgleich JTL-Wawi - Fehler und Bugs 4
Neu Gambio Connector, JTL WAWI und Gambio EU-Steuersätze Modul Onlineshop-Anbindung 0
JTL-SHOP 5.1.1 - Die Plugin-ID ist bereits in der Datenbank vorhanden (FEHLERCODE 90) Upgrade JTL-Shop4 auf JTL-Shop5 2
Neu Ein Kollege kann eine Bestellung in JTL WaWi nicht übernehmen JTL-Wawi - Fehler und Bugs 1
Neu Plugin Bonuspunkte Treuepunkte für JTL 5 Plugins für JTL-Shop 0
Neu JTL Fulfillment Artikel User helfen Usern - Fragen zu JTL-Wawi 5
Neu Achtung! Wichtige Umstellung für JTL-eazyAuction-Nutzer! Amazon-Anbindung - Fehler und Bugs 9
Installationsanleitung JTL-Shop in Unterverzeichnis Einrichtung JTL-Shop5 1
Neu DHL Wunschpaket Plugin für JTL Shop 5.0 lässt sich nicht installieren Plugins für JTL-Shop 2
Neu JTL Connector zu Shopware 6 gibt Fehler aus Shopware-Connector 2
Neu EBAY ANGEBOTE VERKNÜPFUNG LÖSEN OHNE DIE ANGEBOTE IN EBAY ODER JTL ZU LÖSCHEN eBay-Anbindung - Ideen, Lob und Kritik 0
Gelöst Absturz JTL-Pos mit Sunmi D2 Mini beim Bon-Druck Version 1.0.5.18 (4409) JTL-POS - Fehler und Bugs 4
Neu Adressverwaltung / CRM bei JTL geplant JTL-Wawi - Ideen, Lob und Kritik 3
Neu Kann man in JTL 5 verlinkte Shopable-Bilder einstellen? Allgemeine Fragen zu JTL-Shop 0
Neu JTL-WaWi - Variationen mit eigenen Bilder Beschreibungen ? User helfen Usern - Fragen zu JTL-Wawi 12
Neu JTL-Shop 5.1.1 mit JTL-Wawi 1.6.33.1 Onlineshop-Anbindung 6
Beantwortet JTL Workflow Versand Email Zustellinfo JTL-Workflows - Fehler und Bugs 1
Gelöst JTL POS stürzt beim Starten ab und Zeigt Fehler: JTL POS muss beendet werden 1.0.5.17 (4390) JTL-POS - Fehler und Bugs 4
Neu JTL WaWi Workflows Versand Sendestatus User helfen Usern - Fragen zu JTL-Wawi 10
Gelöst Fehler: Sie besitzen keine Lizenz für JTL-WMS JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 1
Neu JTL WAWI Update 1.46x auf 1.48x Installation von JTL-Wawi 2
JTL Update nach Plugin aktivierung ist der admin bereich weiß Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu JTL Shop 5 - Cronjob funktioniert nicht im Wartungsmodus JTL-Shop - Fehler und Bugs 0
Neu Bestellung werden nicht aus Woocommerce ins JTL Wawi übertragen WooCommerce-Connector 1
Neuinstallation JTL-Shop5 (Subdomain vs. Ordnerverzeichnis ../shop) Einrichtung JTL-Shop5 3

Ähnliche Themen