**RELEASE: JTL-Connector (SaaS) für Shopware 6 startet in die Open Beta**

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Optimondo

Mitglied
2. April 2019
8
1
Hallo @redheadman,

danke für den Hinweis. Es wäre super, wenn du mir den dazu passenden Onlineshop-Abgleich Log per PM schickst. Mit dem Log ist warhscheinlich besser nachvollziehbar was das Problem bei dir verursacht.

@ckOne,
Artikel- und Kategorieattribute werden zukünfitg vom Connector unterstützt.
Ich hab gar keine Probleme mit irgend welchen Abgleichen, läuft alles Zucker.

Nur wäre es schön zu wissen in wann etwa die Attribute zur Verfügung stehen. Ohne geht ja schon fast nicht mehr ;)

LG
 

redheadman

Gut bekanntes Mitglied
3. August 2016
110
13
Berlin
Hi @Immanuel,

die Kundengruppenpreise werden übernommen, also alles Super. Hatte versehentlich nicht auf Brutto und Netto geachtet :rolleyes:

Wie gesagt, beim normalen Shop-Upload bricht er nach einer bestimmten Zeit ab und beim Worker läuft es erste Sahne!!!

Log hab ich dir gesendet.

Beste Grüße
 
  • Gefällt mir
Reaktionen: Immanuel

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.052
222
Ich hab gar keine Probleme mit irgend welchen Abgleichen, läuft alles Zucker.

Nur wäre es schön zu wissen in wann etwa die Attribute zur Verfügung stehen. Ohne geht ja schon fast nicht mehr ;)

LG
Dauert nicht mehr lange.

@Alle die Kategorien über JTL-Wawi im Shop steuern: Wir haben gerade ein Update eingespielt, damit die Kategoriensortierung im Shop über JTL-Wawi funktioniert. Dafür sollte am besten ein Komplettabgleich von Kategorien durchgeführt werden.
 

SHAAN

Aktives Mitglied
26. August 2020
178
37
Kann mir einer sagen, ob es möglich sein wird individuelle Kundenpreise, Stücklisten, Guthaben und Kontoanlegen aus JTL Wawi abzugleichen/erstellen?
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.052
222
Kann mir einer sagen, ob es möglich sein wird individuelle Kundenpreise, Stücklisten, Guthaben und Kontoanlegen aus JTL Wawi abzugleichen/erstellen?
  • Kundenindividuelle Preise sollten jetzt schon gehen.
  • Stücklisten werden in JTL-Wawi gepflegt und im Shop wie Einzelartikel behandelt. Wenn eine Bestellung mit einem Stücklistenartikel in JTL-Wawi importiert wird, dann erkennt JTL-Wawi, dass es sich um eine Stückliste handelt.
  • Erstellen von Guthaben und Konten für einen Shop in JTL-Wawi geht nicht, Shop Kunden über JTL-Wawi pflegen geht.
 

redheadman

Gut bekanntes Mitglied
3. August 2016
110
13
Berlin
Moin @Immanuel ,

seit gestern Nachmittag scheint der Artikelexport nicht richtig zu funktionieren.
Bin dabei nach und nach Kategorien und Artikel hochzuladen und jetzt lädt er keine Varianten mehr hoch, nur den Vaterartikel.

Kannst ja mal schauen: https://uneek.explosiv24.com

Kategorien Shirts bis Sweater waren noch Top. Die gestern Nachmittag angeschubsten Kategorien Jacken und Westen gingen dann nicht mehr.
Ein Artikel unter Jacken ist noch mit Varianten durchgegangen.

Eine Frage an alle Shopware 6 Nutzer:

Bei der Artikelbezeichnung im Listing (z.B. unter Shirts - Link oben), müsste da nicht die Bezeichnung des Vaterartikels stehen?
Jetzt wird da anscheinend eine Standardauswahl (Größe) getroffen und der Arikel im Listing wird mit dem Bezeichnungstext eines Kinderartikels angezeigt.
Hat Shopware da was geändert?

Beste Grüße
 
Zuletzt bearbeitet:

mgoeben

Aktives Mitglied
29. September 2015
23
0
Hi!

Gibt es aktuell ein Problem mit dem Connector, das hat soweit, alles funktioniert, aber beim heutigen Testupload kam folgende Fehlermeldung:

Fehler bei der Verbindung. Exception bei connector.identify: Der Remoteserver hat einen Fehler zurückgegeben: (502) Ungültiges Gateway.
Der Remoteserver hat einen Fehler zurückgegeben: (502) Ungültiges Gateway.
Response: <Empty>

Synchronisation mit Webshop nicht möglich!
Identify-Call fehlgeschlagen!
1: Der Remoteserver hat einen Fehler zurückgegeben: (502) Ungültiges Gateway.
2: Der Remoteserver hat einen Fehler zurückgegeben: (502) Ungültiges Gateway.
Gruß

Marco
 

Kaido

Aktives Mitglied
26. Februar 2018
50
8
da sind wir zum Glück nicht die einzigen :D. Wir dachten schon, wir haben beim einbinden einen Fehler gemacht … versuchen es schon seit gestern Vormittag. Dann heißt es warten :)
 

derwinter

Neues Mitglied
14. September 2020
2
0
Also der Abgleich läuft nun wunderbar.
Bei uns werden allerdings noch keine Hersteller-Fotos hochgeladen.
Zudem lädt die Wawi noch keine Bestellungen herunter.
--
Was mir noch aufgefallen ist, das er leider nicht den Streichpreis bzw UVP an Shopware überträgt.
Zudem wird die Lieferzeit aktuell leider auch nicht übertragen.
 
Zuletzt bearbeitet:

thomashummer

Neues Mitglied
4. März 2020
4
0
Hätte soeben versucht den Connector anzubinden. Verbindungstest liefert noch das gewünschte OK.
Bevor sich dann aber das Konfigurationsfenster öffnen sollte erhalte ich folgenden Fehler:
mehrwert_online.png
Hat hier jemand vielleicht einen Tip für mich?
lg
 

Kaido

Aktives Mitglied
26. Februar 2018
50
8
Wir haben auch nach wie vor den gleichen Fehler. Wir können absolut nichts mit dem Connector anfangen, weil er sich nicht einbinden lässt :(
 

redheadman

Gut bekanntes Mitglied
3. August 2016
110
13
Berlin
Huhu,

also hatten die Tage ab und an mal Ausfälle und das wird höchstwahrscheinlich daran liegen, dass an der Schnittstelle gearbeitet wird, weil es ist ja eine BETA Version.

@Kaido das war bei uns auch der Fall, weil wir bei der Vorgehensweise beim anbinden einen Fehler gemacht haben. Haben uns dann neue API Schlüssel erstellt und sind nochmal alles peinlich genau durchgegangen. Dann hat es auch geklappt.

Ansonsten läuft es ganz gut und auch der Fehler beim Hochladen (über den normalen Abgleich) größerer Datenmengen kommt nicht mehr.
Hatten zwischendurch das Problem, dass keine Varianten angelegt wurden, aber auch dieser Fehler scheint behoben.

Heute hatten wir ein neues Problem:
Haben Artikel für den Shop freigegeben, doch die wurden nicht hochgeladen. Der Abgleich hatte die hochzuladenden Artikel nicht erkannt. Im Status stand immer Artikel 0 / 0.
Ein Komplettabgleich hat diese Artikel dann jedoch übertragen.

Beste Grüße
 

trensen24

Aktives Mitglied
8. März 2016
3
0
Hallo zusammen,

wir haben ebenfalls ein Problem. Wir versuchen eine große Anzahl Artikel in den neuen Shop zu laden. 32000 Artikel mit 10000 Bildern.


Fehler:
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Die ConnectionString-Eigenschaft wurde nicht initialisiert.
bei JTL.Database.DbConnectionHelpers.Execute[T](IDbConnection connection, Func`1 func, Boolean keepAlive)
bei JTL.Database.DbConnectionExtensions.ExecuteNonQuery(IDbConnection connection, String query, Object parameters)
bei jtlCore.ControllerClasses. Connector.Abgleich.ConnectorAbgleichHelper.SetInBearbeitungFlagArtikel(Int32 kShop, Int32 value, SqlConnection connection)
bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.CheckForMeanwhileSync(Connector connector, AbgleichInfo abgleichInfo, AbgleichSyncContext abgleichSyncContext)
bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPusher.Push[TEntity](IEnumerable`1 models)
bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.<>c__DisplayClass8_1.<Run>b__0(List`1 models)
bei jtlTools.Linq.EnumerableExtensions.ExecuteInSetsOf[TInput](IEnumerable`1 source, Action`1 action, Int32 max)
bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.Run()
bei JTL.Connector.Business.SyncRunner.Run()


Kann mir jemand sagen, was hier der Fehler ist?. Der Log ist auch nicht wirklich aussagekräftig.

Vielen Dank
 

seml0R

Aktives Mitglied
6. September 2012
57
4
Bei den Cross-Sellings scheint auch noch was falsch übertragen zu werden:

Exception: Controller = Category | Action = push | Wawi PK = 1390 | Parent Wawi PK = 1384 | Name = Aroma | The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = The transport fails to send the message due to some internal error.
Controller = CrossSelling | Action = push | Wawi PK = 8233 | Argument 1 passed to Jtl\Shopware6\Client\Entity\ProductCrossSellingAssignedProducts::setProductId() must be of the type string, null given, called in /var/www/swc.jtl-connector.de/source/vendor/jtl/connector-shopware6/src/Controller/CrossSellingController.php on line 125
EDIT: Könnte natürlich sein, dass da Artikel X-verknüpft sind, die nicht mehr in Shopware aktiv sind - müssten dann im Sonderfall beim Übertragen übersprungen werden :) Danke!

LG,
Felix
 
Zuletzt bearbeitet:

redheadman

Gut bekanntes Mitglied
3. August 2016
110
13
Berlin
Hallo zusammen,

wir haben ebenfalls ein Problem. Wir versuchen eine große Anzahl Artikel in den neuen Shop zu laden. 32000 Artikel mit 10000 Bildern.


Fehler:
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Die ConnectionString-Eigenschaft wurde nicht initialisiert.
bei JTL.Database.DbConnectionHelpers.Execute[T](IDbConnection connection, Func`1 func, Boolean keepAlive)
bei JTL.Database.DbConnectionExtensions.ExecuteNonQuery(IDbConnection connection, String query, Object parameters)
bei jtlCore.ControllerClasses. Connector.Abgleich.ConnectorAbgleichHelper.SetInBearbeitungFlagArtikel(Int32 kShop, Int32 value, SqlConnection connection)
bei jtlCore.ControllerClasses.Connector.Abgleich.ConnectorAbgleichHelper.CheckForMeanwhileSync(Connector connector, AbgleichInfo abgleichInfo, AbgleichSyncContext abgleichSyncContext)
bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPusher.Push[TEntity](IEnumerable`1 models)
bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.<>c__DisplayClass8_1.<Run>b__0(List`1 models)
bei jtlTools.Linq.EnumerableExtensions.ExecuteInSetsOf[TInput](IEnumerable`1 source, Action`1 action, Int32 max)
bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.Push.ConnectorPushTaskProduct.Run()
bei JTL.Connector.Business.SyncRunner.Run()


Kann mir jemand sagen, was hier der Fehler ist?. Der Log ist auch nicht wirklich aussagekräftig.

Vielen Dank
Hi,

also wenn du die Artikel über den normalen Shopabgleich in JTL durchführst, dann scheint Ihr das gleiche Problem wie wir zu haben.
Über den Worker haben wir keine Probleme feststellen können.

Beste Grüße
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
In Bearbeitung Updatet Release JTL-Wawi 1.5.35.0 schlägt Installation von JTL-Wawi 5
Neu Shop5 - Nutzung des PapeSpeed-Mod auch nach dem Release nicht möglich JTL-Shop - Fehler und Bugs 1
Gelöst Release 1.6 Gelöste Themen in diesem Bereich 2
Neu JTL Shop Versandarten - Versandklassen einrichten Betrieb / Pflege von JTL-Shop 0
Neu JTL Shop 5 - Datenbank optimieren Allgemeine Fragen zu JTL-Shop 0
Neu Sprachvariablen in JTL-Wawi Artikelbeschreibung aus dem JTL-Shop Allgemeine Fragen zu JTL-Shop 0
Neu JTL Shop 5 Bug - Mobile Version Menü Unterkategorien verschwinden beim scrollen JTL-Shop - Fehler und Bugs 0
Cache aktiviert = Fatal error: Uncaught Error: Class 'JTL\Cache\Methods\CacheAuto' Einrichtung JTL-Shop5 7
Fehler Bugs Jtl Shop 5 Einrichtung JTL-Shop5 2
Neu JTL Shop Artikel durch den Inhalt von "Eigene Felder" finden User helfen Usern - Fragen zu JTL-Wawi 0
Neu SKR03 Buchungskonto Datev Export JTL-POS Einrichtung / Updates von JTL-POS 1
JTL Shop5 Nova Template Top Angebote unter den Artikeln Einrichtung JTL-Shop5 2
Neu JTL Wawi gleicht auf Ebay stornierte Aufträge nicht ab. eBay-Anbindung - Ideen, Lob und Kritik 1
Neu JTL Shop 5 ... Benutzer-Steuerung möglichst über Merkmale ... Ideen/Lösungen gesucht Allgemeine Fragen zu JTL-Shop 2
Neu Produkte doppelt / Komplettabgleich Produkte aus JTL Shopware-Connector 4
Feedback zu OPC in JTL Shop 5 JTL-Shop - Ideen, Lob und Kritik 3
JTL Shop5 Nova Template keine Responsive Ansicht TOP Angebote und News Einrichtung JTL-Shop5 4
Neu Probleme bei Hinzufügen von Bildern in JTL-Wawi JTL-Wawi - Fehler und Bugs 16
JTL Shop 5 - OPC: Akkordeon Responsive Design Einrichtung JTL-Shop5 2
Neu Umstellung auf JTL Wawi & JTL Shop hosting Starten mit JTL: Projektabwicklung & Migration 0
Neu Fragen zu JTL POS Hardware wechsel Allgemeine Fragen zu JTL-POS 1
Neu Newsletter Versand funktioniert nicht JTL Shop 5.0 JTL-Shop - Fehler und Bugs 1
Neu Initialer Auftragsimport eBay - kann ich sehen welche Aufträge schon verschickt wurden (ohne JTL) Einrichtung und Installation von JTL-eazyAuction 0
Issue angelegt JTL-Ameise Konfiguration lässt sich nicht dauerhaft speichern - Absicht? JTL-Ameise - Fehler und Bugs 2
In Bearbeitung Sunmi Hardware nur von JTL? JTL-POS - Fragen zu Hardware 10
Neu JTL WAWI Lokaler Rechner Installation von JTL-Wawi 1
Neu Artiklezuweisung JTL -> Shopify Kategorien Shopify-Connector 9
Offen User-Unterstützung durch AR-Datenbrillen in JTL-Workbench JTL-Workbench - Ideen, Lob und Kritik 8
Neu OnPage Composer "Not found" - JTL Shop 5 Installation / Updates von JTL-Shop 3
Neu JTL shop 5 PLugin Fehlerhaft Installation / Updates von JTL-Shop 2
Neu JTL Workflow: Attribute in eine Beschreibung einsetzen Arbeitsabläufe in JTL-Wawi 2
Neu Freshdesk Widget in JTL Shop Plugins für JTL-Shop 0
Neu Shopware Syncronisiert nicht mit JTL Shopware-Connector 2
Neu JTL-Shop5 Bugs JTL-Shop - Fehler und Bugs 2
Neu Kundendatenimport in den JTL-Shop 5 Allgemeine Fragen zu JTL-Shop 1
Neu JTL Shop5 bei JTL gehostet. Nova-Template ist nicht mit Smartphone zu nutzen . welche Einstellung muss da noch gemacht werden Templates für JTL-Shop 8
Neu Firmenübernahme JTL Datenbank aus csv Dateien richtig aufsetzen Installation / Updates von JTL-Shop 0
Neu JTL Search funktioniert im 5er Shop nicht Plugins für JTL-Shop 1
Neu JTL Shop 5 - Demos? Allgemeine Fragen zu JTL-Shop 27
Neu Nach JTL Shop 5 Update nicht mehr in google zu finden ? Allgemeine Fragen zu JTL-Shop 24
Beantwortet Verbindung von JTL-Plan&Produce mit Webshops JTL-Plan&Produce - Ideen, Lob und Kritik 3
Neu JTL-WaWi auf neuen Laptop einstellen User helfen Usern - Fragen zu JTL-Wawi 4
Neu Aufträge: zugehörige Shopware Subshop-Namen in JTL-Wawi vorhanden? Shopware-Connector 2
Neu JTL Ameise sehr langsam JTL-Ameise - Fehler und Bugs 2
In Diskussion Frage wegen Umstieg zu JTL-POS Allgemeine Fragen zu JTL-POS 17
Neu Einloggen bei JTL WAWI funktioniert nicht Installation von JTL-Wawi 7
Neu JTL Shop Schriftgröße und Hintergrundfarbe User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst "Artikel existiert nicht" wird in JTL-POS und JTL-WMS Mobile angezeigt Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 23
Neu Google Pagespeed motzt über die OPC Gallerie im JTL Shop 5 Allgemeine Fragen zu JTL-Shop 0
Neu JTL-Wawi löscht Produktfotos bei Varianten Artikel Shopware-Connector 0
Ähnliche Themen