Neu Probleme mit Update auf 1.4.23.2

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

Dennis103

Aktives Mitglied
19. April 2018
101
6
#1
Nabend zusammen,

in einer Firma hat das Update schön geklappt.

In der 2-ten Firma leider nicht, da Kriege ich nen Fehlerbericht.

Kann mir jemand ne Info geben, wo das Problem liegt?

mfg Dennis

Unbehandelte Ausnahme #959190594F6282F vom Typ System.Exception in
System.Exception: Die Prüfung der Datenbank ist fehlgeschlagen
Eine Datenbank-Momentaufnahme kann aufgrund eines Fehlers beim Starten nicht erstellt werden.
Eine Datenbank-Momentaufnahme kann aufgrund eines Fehlers beim Starten nicht erstellt werden.
Bei CREATE FILE wurde beim Versuch, die physische Datei "C:\Program Files\Microsoft SQL Server\MSSQL12.MSSQLEXPRESS\MSSQL\DATA\eazybusiness.mdf_MSSQL_DBCC6" zu öffnen oder zu erstellen, der Betriebssystemfehler 5(Zugriff verweigert) erkannt.
Die Datenbankmomentaufnahme für Onlineüberprüfungen konnte nicht erstellt werden. Die Ursache wird in einem vorherigen Fehler beschrieben, oder eines der zugrunde liegenden Volumes unterstützt keine Sparsedateien oder alternativen Datenströme. Es wird versucht, exklusiven Zugriff zu erhalten, um die Überprüfung offline auszuführen.

2019-03-14T20:48:23 DEBUG - [TableTable] Eintrag TableCache.tversion entfernt - Removed
2019-03-14T20:48:23 DEBUG - [TableCache] Invalidate: [tversion]
2019-03-14T20:48:23 DEBUG - SELECT [cVersion] FROM [dbo].[tVersion]
2019-03-14T20:48:23 DEBUG - Dauer: 0ms, Result: 1.4.19.0
2019-03-14T20:48:23 DEBUG - SELECT [cDB] FROM [eazybusiness].[dbo].[tMandant]
2019-03-14T20:48:23 DEBUG - Dauer: 0 ms, 1 Zeilen
2019-03-14T20:48:23 DEBUG - sp_helpdb
2019-03-14T20:48:23 DEBUG - Dauer: 215 ms, 5 Zeilen
2019-03-14T20:48:23 DEBUG - SELECT [cVersion] FROM [dbo].[tVersion]
2019-03-14T20:48:23 DEBUG - Dauer: 0ms, Result: 1.4.19.0
2019-03-14T20:48:23 DEBUG - SELECT (CASE WHEN SERVERPROPERTY('MACHINENAME') = HOST_NAME() THEN 'local' ELSE 'remote' END) AS instance
2019-03-14T20:48:23 DEBUG - Dauer: 0ms, Result: local
2019-03-14T20:48:33 DEBUG - SELECT COUNT(*) FROM [eazybusiness].[dbo].[tMandant]
JOIN [eazybusiness].[dbo].[tBenutzerFirma] ON [eazybusiness].[dbo].[tBenutzerFirma].kMandant = [eazybusiness].[dbo].[tMandant].kMandant
WHERE [eazybusiness].[dbo].[tBenutzerFirma].kBenutzer = @kBenutzer AND [eazybusiness].[dbo].[tMandant].cDB = @cDatenbank;
@kBenutzer = 1
@cDatenbank = 'eazybusiness'
2019-03-14T20:48:33 DEBUG - Dauer: 9ms, Result: 1
2019-03-14T20:48:33 DEBUG - SELECT * FROM [tversion]
2019-03-14T20:48:33 DEBUG - Dauer: 0 ms, 1 Zeilen
2019-03-14T20:48:33 DEBUG - SELECT TOP 1 tRechtBenutzerGruppenZuordnung.kRechtBenutzerGruppe
FROM eazybusiness.dbo.tRechtBenutzerGruppenZuordnung tRechtBenutzerGruppenZuordnung
JOIN eazybusiness.dbo.tRechtBenutzerGruppe tRechtBenutzerGruppe ON tRechtBenutzerGruppe.kRechtBenutzerGruppe = tRechtBenutzerGruppenZuordnung.kRechtBenutzerGruppe
WHERE tRechtBenutzerGruppenZuordnung.kBenutzer = @kBenutzer
AND tRechtBenutzerGruppe.nIsAdmin = 1
@kBenutzer = 1
2019-03-14T20:48:33 DEBUG - Dauer: 0 ms, 1 Zeilen
2019-03-14T20:48:33 DEBUG - IF(OBJECT_ID('tempdb..#TMP_DRIVES') IS NOT NULL)
BEGIN
DROP TABLE #TMP_DRIVES
END
CREATE TABLE #TMP_DRIVES
(
DRIVE CHAR(1) NOT NULL,
MBFREE INT NOT NULL
)
INSERT INTO #TMP_DRIVES
EXEC xp_fixeddrives
SELECT * FROM #TMP_DRIVES
2019-03-14T20:48:33 DEBUG - Dauer: 73 ms, 2 Zeilen
2019-03-14T20:51:15 DEBUG - SELECT (CASE WHEN SERVERPROPERTY('MACHINENAME') = HOST_NAME() THEN 'local' ELSE 'remote' END) AS instance
2019-03-14T20:51:15 DEBUG - Dauer: 0ms, Result: local
2019-03-14T21:03:40 DEBUG - [TableTable] Eintrag TableCache.tversion entfernt - Expired
2019-03-14T21:03:40 DEBUG - [TableTable] Eintrag TableCache.tbenutzer entfernt - Expired
2019-03-14T21:03:40 DEBUG - [TableTable] Eintrag TableCache.tOptions entfernt - Expired
Zeitstempel: 2019-03-14T21:04:34
Locale: German (Germany)
Locale: German (Germany)
Version: 1.4.23.2
Plattform: Wawi
WawiSeed: 0.8.70011.98001
Versionshash: AABBF846
Prozessname: JTL-Wawi
Physikalischer Speicher: 306987008 / Peak: 309964800
Basispriorität: 8
Prioritätsklasse: Normal
CPU-Zeit (User): 0:00:16,234375
CPU-Zeit (System): 0:00:02,75
Page-Size (Sytem): 1806248 / Peak: 276430848
Page-Size: 276090880 / Peak: 276430848
 

Dennis103

Aktives Mitglied
19. April 2018
101
6
#3
Also ich habe alle Wege Versucht, auch als Admin Ausgeführt. Die Installation geht durch, beim Backup machen hängt er sich schon auf bevor das Update von der DB effektiv beginnt. Sehr komisch das ganze.
 

Rico Giesler

Administrator
Mitarbeiter
10. Mai 2017
10.084
943
#4
Scheinbar kann er nicht in den Ordner schreiben.
Gibt es den Dateipfad denn überhaupt?
C:\Program Files\Microsoft SQL Server\MSSQL12.MSSQLEXPRESS\MSSQL\DATA\
 

Dennis103

Aktives Mitglied
19. April 2018
101
6
#6
So ich habe mal weiter geforscht. Ich habe Aktuell die 1.4.19.0

Wenn ich dort eine Datensicherung machen möchte, kommt der selbe Fehler.

Aber effektiv mache ich Täglich eine Sicherung per Script. Das klappt und bringt keine Fehler. Sehr komisch.

Code:
osql.exe -S SERVER\MSSQLSERVER01 -U sa -P XXX -Q "BACKUP DATABASE eazybusiness TO DISK = 'd:\Datensicherung-JTL\%date%.bak'"
Das scheint also nicht mit dem Update zusammen zu hängen, sondern eher mit der möglichkeit die Daten zu sichern.
 

MichaelH

Sehr aktives Mitglied
17. November 2008
10.162
178
#7
Es gibt MSSQL\DATA\ und MSSQL\Backup\ dorthin gehört normalerweise das Backup und nicht in das DATA.
 

Dennis103

Aktives Mitglied
19. April 2018
101
6
#8
Ich habe es schon auf der 2-ten Festplatte, im Root Verzeichnis etc. Versucht. Auch Update ohne Sicherung.

Es klappt irgendwie garkeine Sicherung, egal welchen Ordner.
 

Rico Giesler

Administrator
Mitarbeiter
10. Mai 2017
10.084
943
#11
Prüfe bitte mal ob die Ordner eventuell eine Archivierung eingestellt haben.
C:\Program Files (x86)\Microsoft SQL Server und C:\Program Files\Microsoft SQL Server
Prüfen kannst du das in dem du per Rechtsklick die Eigenschaften aufrufst und dann auf Erweitert klickst.
Es gibt da eine Checkbox "Ordner kann archiviert werden" - dieser darf nicht gesetzt sein - bei beiden Dateipfaden und auch nicht in darin liegenden Ordnern.
 

Anhänge

Dennis103

Aktives Mitglied
19. April 2018
101
6
#15
Auch geändert, Problem leider nicht gelöst.

Habe den Server mal neugestartet, hatte Vermutung da greift noch etwas drauf zu. Leider auch Vergebens.

Noch jemand eine Spontane idee?
 

Rico Giesler

Administrator
Mitarbeiter
10. Mai 2017
10.084
943
#16
Wenn ihr Supportanspruch habt, dann erstellt bitte mal ein Ticket im Kundencenter damit die Kollegen aus dem Datenbankteam da mal ein Auge drauf werfen können.
 

Ähnliche Themen