Neuer Connector für VM 2.0.X / Erfahrungswerte

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

testjo

Sehr aktives Mitglied
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Zur Lösung einfach den Connector denistallieren und wieder installieren. Dann einen Webshopabgleich und es passt wieder. Problem sind die Product und Kategrie ID´s. Wenn die, aus welchem Grund auch immer, nicht mehr zusammen püassen, dann überträgt der Connestor nicht mehr richtig.
Steht auch so einiges in JTL WIKI über dieses verhalten, weil es nicht immer oder durch settings connector einer tatsachliche löschen/verschieben in Shop Datenbank gibt, wen man in WAWi so etwas macht.
Hängt dan von arbeitsvorgang ab welche settings man in den connector einsteld, wegen tatsachlich löschen.
Wen nicht dan lauft am besten in wawi nur webshop inaktiv setzen , weil dan kan man dieser rückgangig machen, wen die connector passend steht.
Mit viele Artikel / Kategorien die sich schnell ändern / nicht mehr vorhanden sind, naturlich nicht den optimale ;)

Da muss man sich einlesen und für jeden selbe entscheiden welches am besten ist
 

fkeller

Aktives Mitglied
10. Februar 2010
71
1
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Ich glaube ich hab die Ursache für ein das Problem gefunden dass manche Artikel einfach nicht mehr übertragen werden.
Bei mir läuft die SQL-Datenbank auf einem Server auf den ich per Internet zugreife.
Wenn ich aus irgendeinem Grund während der Shop-Uploads die Verbindung verliere (Absturz des JTL-Rechner, der Server oder Internet-Verbindung unterbochen) dann sind einige/alle ?? Artikel die bei diesem Transfer dabei waren in JTL zwar ganz normal drin. Aber die können nicht mehr übertragen werden.
Das einzige das hilft ist den Artikel zu kopieren, den alten Artikel löschen und den neuen Artikel wieder hochladen.

Da die SQL Datenbank woanderst läuft ist ein Backup/Restore noch etwas umständlich. Aber vermutlich würde auch nur ein Backup und sofortiges wieder einspielen des Backups reichen...?


Gruss
Flex
 

testjo

Sehr aktives Mitglied
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Kanst Du direkt auf den Server wo die Datenbank drauf ist auch den WAWI frontend mittels ein "Virtueles Desktop" zu greifen und dort direkt die Shopabgleich laufen lassen, ja oder nein mit/aus den Command/ worker?
Damit ist ein mögliche fehler quele beseitigt, wen es sich häufiger vortut
 

Tentaurus

Gut bekanntes Mitglied
25. Februar 2010
374
14
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Die Synchronisation von Wawi Variationskombis ist ja nicht möglich (ich glaube, das ging im alten Connector auch nicht...).
Ich kann zwar den Vater und die Variationskombis als eigenständige Produkte synchronisieren, aber es gibt dann keine Vater / Kind Zuordnung in VM.
Und eine nachträgliche Zuordnung von Produkten zu einem Vater ist in VM leider nicht möglich (ausser per SQL in der DB)

Ich habe jetzt folgenden Workaround: ich synchronisiere nur die Vaterprodukte, und die Kinder (= die zuvor exportierten Wawi Variationskombis) importiere ich dann per CSV (mittels der Komponente CSVI). Das funktioniert, die Kinder werden dem entsprechendem Vater zugeordnet.

Aber vielleicht hat jemand eine bessere Idee?
 

testjo

Sehr aktives Mitglied
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Das funktioniert, die Kinder werden dem entsprechendem Vater zugeordnet.
Wie , oder wie ist den Struktur ins VM , also sind es dort dan allen eigenständige Produkte?
Und ist es so wie mit Atribute oder so etwas wie MAster Slave?
Wen man den Funktionsatribute von WAWI benutz, dort/damit beim Vater und Auch Kind den verbindung legt. Die mittels den Atribute.php und case dan zuweisen an geht vielleicht auch, kenne VM nicht ;)

Weis auch nicht wieviel Arbeit / Artikel es sind, dan welche Arbeitsvorgang dort für dich besser ist.

Oder den @admorris fragen die macht den einbau beim XTforkS mit anpassung dass Varkombis laufen können
 

Doctor Who

Aktives Mitglied
12. April 2013
7
0
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Hallo zusammen,

wir haben zurzeit große Probleme mit dem neuen Connector.
Wir verwenden noch das alte Wawi 099780. Joomla 2.5.9 und Virtuemart 2.0.20b.

  1. Die Synchronisation der Kategorien erfolgte ohne Übertragung der Bilder.
    Erst nachdem wir in den Optionen des Connectors im Joomla-Backend die Einstellung zur Bilderübertragung deaktiviert und nach erfolgtem Speichern erneut aktiviert hatten, funktionierte dieser Vorgang hin und wieder.
  2. Kategorien, die im Wawi deaktiviert werden, sind nach dem Webshopabgleich in Virtuemart immer noch aktiv geschaltet und müssen manuell dort deaktiviert werden.
  3. Artikel, die in Wawi und Shop aktiviert waren und im Wawi deaktiviert wurden, sind im Shop und der Datenbank gelöscht worden.
    Eine erneute Aktivierung dieser Artikel im Wawi mit anschließender Synchronisation bringt keinen Erfolg, die besagten Artikel werden nicht mehr im Shop übernommen.
  4. Das ganze mit der neuesten Wawi durchgespielt bringt die gleichen Ergebnisse.
  5. Teilweise werden neue Kategorien falsch abgelegt.

Vor 2 Stunden haben wir den Entwickler angeschrieben, leider aber noch keine Antwort enthalten.
Wir waren gerne bereit, für dieses Produkt 79,- € zu bezahlen, aber erwarten selbstverständlich keine Bananensoftware.
 

testjo

Sehr aktives Mitglied
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Teilweise werden neue Kategorien falsch abgelegt.
Wen wirklich alles 100% nur im wawi gemacht worden ist den Install und umgang mit connector 100% laut Anleitung ist sollte dies eigentlich nicht so ein.

Aber wen etwas irgendwo im Shop geänderd worden ist, wie in den Punkten zum beispiel 2 dan hat man solche risiken.

Punkt 3 sind so einiges Connectoren mit anpassungen ja oder nein inaktiv und ja oder nein wikrlich loeschen, da muss man aufpassen welche Arbeitsvorgang / einstellungen ins Connectoren man benutzt/ setzt..

Finde selbst in jedenfall bei "wenige" Artikel nur den inaktiv setzen in WaWi und Shop und connector einstellungen bei Uns die mit wenigste Risiken. ( eigentlich kein wen man von den Shopbackend weg bleibt ;)
Wir loeschen also nirgendwo!
Wen man dass doch macht/möchtet muss man wirklich die richtige settings / connector anpassungen machen dafür und auch den Arbeitsvorgänge abstimmen!


OK ist ein jtl connector mit anpasungen und kein vm, aber trotzdem ein xtfork.
 

Doctor Who

Aktives Mitglied
12. April 2013
7
0
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Ich habe alles entsprechend der Anleitung gemacht und sogar verschiedene Virtuemartversionen neben der empfohlenen Version 2.0.20a ausprobiert.
Auch mit dem neuen Wawi läuft es nicht.

Mir ist noch ein Punkt aufgefallen, den ich neben der auftretenden Problematik richtig übel finde:
Falls man nicht in den Optionen des Connectors die Einstellung "Copyright" deaktiviert, findet sich in den Artikelbeschreibungen unten rechts ein groß gestaltetes Logo des Anbieters.
Für bereits in den Shop übertragene Artikel ist das im Nachhinein auch nicht mehr zu ändern (siehe obenstehenden Punkt 3).
Dieses Logo ist schon in meinen Augen eine sehr dreiste Sache.
 

testjo

Sehr aktives Mitglied
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Hmm kenne die connector nicht.
Copyright ist dass wirklich wie es sein soll ( Vertrag Connector Lieferant), oder eher ein option um sein eigenes SHOPLogo dort zu plazieren mit den Copyrightinfo ? ;)
 

rbaier

Gut bekanntes Mitglied
28. September 2008
227
1
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

@testjo,

eine freundlich gemeinte Bitte - weil mein Lesefluss zusehens gestört wird:
Wenn du diesen Connector bzw. Virtuemart oder Webshops allgemein nicht kennst, dann wäre es ggf. hilfreicher, wenn du deine Kommentare auf die Themen beschränken könntest, von denen du etwas verstehst.

Ich zumindest kenne überhaupt keine Webshop-Lösung, bei der eine Einbindung des Shoplogos (bzw. des Logos vom Shop-Anbieter) bei jedem Artikel - also auf der Artikeldetailseite - vorgesehen ist.
Dafür dient zumeist ein Impressum.

--
mfg
rbaier
 
Zuletzt bearbeitet:

Doctor Who

Aktives Mitglied
12. April 2013
7
0
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Hallo Herr Baier,

so ein Desaster haben wir bei Ihnen nicht vorgefunden, Ihr Connector lief stets einwandfrei.

Davon abgesehen wird in der Artikelbeschreibung mitnichten das Logo des Shopbetreibers eingebaut, sondern des Anbieters des Connectors.

connector.jpg
 

Anhänge

testjo

Sehr aktives Mitglied
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

@testjo,

Ich zumindest kenne überhaupt keine Webshop-Lösung, bei der eine Einbindung des Shoplogos (bzw. des Logos vom Shop-Anbieter) bei jedem Artikel - also auf der Artikeldetailseite - vorgesehen ist.
Dafür dient zumeist ein Impressum.

--
mfg
rbaier
Ich auch nicht deswegen mein "? ;)"
Aber sehe doctors printscreen dort kan man doch einfach ein .... logo ändern.

Weiter tja connector und jtl auf basis in anfang von den "alte" jtl connector mit verschiedene xtforks da habe ich doch so einiges an erfahrungen gemacht und sehe auch dieser beitrag http://forum.jtl-software.de/virtue...fuer-vm-2-0-x-erfahrungswerte.html#post330117 auf so ähnliches ist also kein einzelfall und und wen man die beiträge leest oder Forumsuche benutzt ;)

Die zum beispiel war nur ein Antwort auf dieser von FKeller http://forum.jtl-software.de/virtue...fuer-vm-2-0-x-erfahrungswerte.html#post327437
 

Doctor Who

Aktives Mitglied
12. April 2013
7
0
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Hallo zusammen,
hier ein kleines Update:

Ich habe von meiner Seite aus das Problem ein wenig einkreisen können.
Die Problematik besteht darin, dass wir unsere Installation von Joomla 1.5.26 auf 2.5.9 bzw. Virtuemart 1.1.16 auf 2.0.20a bringen müssen.
Da ich einem Tipp im Virtuemart-Forum gefolgt bin und einen Zwischenschritt über Virtuemart 2.0.0 eingebaut hatte, kam es zu Verwirrungen, die der Connector nicht auflösen kann und muss.
Denn so waren alle Produkt- und Kategoriedaten in der Datenbank dreifach vorhanden.

Ich werde jetzt eine neue Testumgebung erstellen und vor der sofortigen Migration auf Virtuemart 2.0.20a alle Tabellen bezüglich der Produkte und Kategorien leeren.
Wichtig sind für uns eh nur die Kundendaten.

Werde euch auf dem Laufenden halten.
 

Doctor Who

Aktives Mitglied
12. April 2013
7
0
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Im Moment übernimmt er nur die Login-Daten und leider nicht die Adressen etc.
Das große Problem ist, dass hier mehrere Fakten zusammen kommen:
Altes Joomla, altes Virtuemart, neuer Connector.
 

fmrathmanner

Aktives Mitglied
20. Januar 2012
45
1
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Hallo,

wir verwenden den Connector seit September. Wir hatten auch ein kleines Problem bei einem Update von Joomla und VM. Da wurde uns von ProTech geraten, den Connector zu deinstallieren und wieder zu installieren. Dann machen wir einen Vollabgleich (alle Daten zum Shop übertragen) und es passte wieder.
Das Logo kann man in der Kaufversion ausschalten. In der Testversion, die kostenlos ist, nicht. Dient also zum Schutz für den Connector. Hat uns jetzt nicht weiter gestört. Und wenn vergessen wurde das Logo zu deaktivieren, dann einfach im Connector nachholen und alle Daten zum Shop senden ( auch alle Bilder) dann ist auch das Logo wieder weg. ( So war es zumindest bei uns nach Kauf des Connectors)

LG

Jörg Rathmanner
 

Doctor Who

Aktives Mitglied
12. April 2013
7
0
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Es gibt eine Testversion?

Wir stehen in Kontakt zum Entwickler, dieser überarbeitet den Connector zurzeit.
Demnächst also mehr.
 

pro-tech

Aktives Mitglied
14. April 2008
50
0
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

Update auf Version 2.0.20 verfügbar:

Bugfix
Variationen wurden mit der neuen Version komplett überarbeitet und funktionieren einwandfrei (leider wird nur die Selectbox von JTL übertragen).
Kategorien werden nun korrekt Webshopaktiv und deaktiv gestellt
Produkte werden nun korrekt Webshopaktiv und deaktiv gestellt
Produkte die in JTL auf inaktiv gestellt würden werden in VM 2 nur deaktiviert nicht gelöscht
Grundpreise werden nun korrekt an die Kurz-, Langbeschreibung angehängt


Erneuerungen

Variationen:
Im Connector Backend Option zum Ignorieren von Variationen um die selbsterstellten Felder in VirtueMart 2 zu verwalten.
Im Connector Backend - unter Option – wählbare Möglichkeit zum Importieren von Bestellungen mit Status „confirmed“
Bestellimport:
Bei bestellten Artikel werden nun auch die Variationen korrekt aufgelistet
Bei bestellten Artikel mit Rabatten werden die Prozent (%) gelistet
Möglichkeit bereits importierte Bestellungen nochmals zu importieren


Kunden, die den Connector in den letzten 6 Monaten erworben haben, können ihn kostenlos über Ihren Downloadlink downloaden und aktualisieren.
Kunden die den Connector vor 6 Monaten erworben haben bekommen auf Anfrage einen Gutschein von 40%
 

markito

Aktives Mitglied
11. Mai 2008
11
0
Schweiz
AW: Neuer Connector für VM 2.0.X / Erfahrungswerte

....Dieses Logo ist schon in meinen Augen eine sehr dreiste Sache.
Die Metaangabe "autor" wird vom Conector bei jedem Produkt auf:

<meta name="author" content="JTL WAWI CONNECTOR BY PRO TECH IT SOLUTIONS WWW.PRO-TECH.BZ.IT" />

gesetzt!

Das finde ich ziemlich krass und dreist...

Ist das beim der neusten Version des Connector immer noch so?
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Gelöst Neuer Artikel - eBay-Vorlage beinhaltet keine Kategorie Einrichtung und Installation von JTL-eazyAuction 2
In Diskussion "Neuer Bon"-Taste löst weiter neue Bons aus, wenn ein noch leerer Bon schon aktiv ist JTL-POS - Fehler und Bugs 4
Neu Excel Profi gesucht - 4 Zeilen aus einer Zelle mit neuer Zelle verketten User helfen Usern 8
Neu Nachrichten - stylesheet einbinden - Neuer html Editor JTL-Wawi - Fehler und Bugs 0
Neu eBay ... VORSICHT vor neuer Betrugsmasche! User helfen Usern 5
In Bearbeitung My DPD neuer CSV Import JTL-ShippingLabels - Ideen, Lob und Kritik 1
Neu Neuer HTML-Editor mit neuen Features - JTL-Wawi 1.5.21.0 (Video) Umfragen rund um JTL 22
Neu Connector übermittelt keine Produkte mehr WooCommerce-Connector 0
Neu SW Connector bucht bei Bestellimport Positionen ins Standardlager Shopware-Connector 1
Gelöst Connector hinzufügen > fortfahren > Es ist ein Fehler aufgetreten. Technische Fragen zu den JTL-Connectoren 1
In Bearbeitung Connector Version 2.5.0 Shopware-Connector 2
Neu User-Dokumentation Shopify Connector Shopify-Connector 2
In Diskussion Connector mit WP Multisite für Sprachsteuerung? WooCommerce-Connector 2
Neu JTL-Connector und alter Oxid 4.8.5 Oxid-Connector 1
In Bearbeitung Connector-URL liefert 404 WooCommerce-Connector 3
Neu Plugin für den WooCommerce JTL-Connector (Zahlungsart überschreiben mit setPaymentModuleCode()) WooCommerce-Connector 1
Neu JTL Connector 1.6 und 1.8 fehlermeldung: Exception bei core.connector.auth Modified eCommerce-Connector 2
In Diskussion WooCommerce Connector Übertragung der Lagerbestände mit dem jeweiligen Lager WooCommerce-Connector 3
Neu JTL Connector findet den Shop im Unterverzeichnis nicht Modified eCommerce-Connector 17
In Diskussion Shopabgleich - Connector Geschwindigkeit langsam? Modified eCommerce-Connector 1
Neu Kundengruppen Connector + Woocommerce + B2B Market + German Market WooCommerce-Connector 2
Neu Shop Connector: Was passiert mit alten Bestellungen beim Erstimport? User helfen Usern - Fragen zu JTL-Wawi 1
Offen Woocommerce / connector funtioniert nicht mehr??? WooCommerce-Connector 2
Neu Shopify Shop fehlende 16% im Connector Shopify-Connector 3
Neu Steuerfehler im Connector Shopify-Connector 10
Offen Shopware 5.6.7 - JTL Connector Requirements Shopware-Connector 1
Neu wie richtig updaten ? Wawi, connector, shopware Shopware-Connector 1
Offen was wird von SecuPay Texte über Connector zu Wawi übertragen Shopware-Connector 1
Neu Gambio 4 - Connector Installation startet nicht Gambio-Connector 1
Offen Gambio 4 Connector Installation Fehler Gambio-Connector 1
Neu JTL Shopify Connector - Steuer Problem Shopify-Connector 6
In Bearbeitung Drittshop Connector überträgt die Ausgabewege-Artikelname nicht Technische Fragen zu den JTL-Connectoren 1
Neu Connector Version 2.4.0 Shopware-Connector 8
Neu MwSt-Senkung und Gambio-Connector Gambio-Connector 4
Neu Shopify Connector Backlog - Teilversand / Transfers / Refund etc Shopify-Connector 3
In Bearbeitung Connector deaktiviert die Archivbarkeit von Schlagwörtern WooCommerce-Connector 2
Neu Riesen Problem mit neuem Connector Gambio-Connector 29
Neu Woocommerce 4 und JTL-Connector WooCommerce-Connector 4
Neu JTL Connector (WooCommerce) Keine Ausbuchung trotz erstelltem Lieferschein WooCommerce-Connector 1
Neu JTL Shopware Connector Shopware-Connector 2
Offen [Suche] Servicepartner mit Erfahrung mit Connector -> Shopware5 Dienstleistung, Jobs und Ähnliches 1
Neu Wer hat Interesse an einem Magento2 Connector Allgemeines zu den JTL-Connectoren 25
In Bearbeitung Connector bricht bei Artikelabgleich ab Modified eCommerce-Connector 1
Neu Connector funktioniert nicht mehr Gambio-Connector 1
Neu Welche Auflösung für die vier wechselnden Hintergrundbilder im (externen) Display? Allgemeine Fragen zu JTL-POS 2
Neu Neue Platform in tplattform für Otto.de JTL-Wawi - Fehler und Bugs 1
Neu Programm für vorfrankiertes Rücksendeetiketten von Amazon User helfen Usern - Fragen zu JTL-Wawi 0
Neu Wünsch für das Artikel-bearbeiten Fenster im WMS JTL-WMS - Ideen, Lob und Kritik 0
Neu Picklistensortierung, jüngstes Mhd für FBA Umlagerungen zuerst JTL-WMS - Ideen, Lob und Kritik 0
Gelöst Variationskombinationen können nicht bestellt werden im JTL SHOP 4.05 - Es steht keine Versandart für Ihre Bestellung zur Verfügung. Gelöste Themen in diesem Bereich 4
Ähnliche Themen