Neu Merkmale werden nicht vollständig dargestellt

mastertango

Sehr aktives Mitglied
10. Oktober 2009
2.299
11
Wustrow
Hallo,

ich weis nicht ob das gewollt ist oder nicht, aber auf den Artikeldetailseiten werden die Merkmale nicht vollständig dargestellt.
Es werden trotz Einstellung Bilder + Test bei den Mermalwerden nur die Bilder der Werte dargestellt und bei den Merkmalen nur der Text.
In der Merkmalbox links wird es jedoch vollständig dargestellt.

Ist das ein Fehler? Wenn nicht, welcher Sinn steckt dann hinter dem Wirrwar der Anzeige auf den Artikeldetailseiten? Oder habe ich hier eine Einstellung falsch gesetzt?
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
591
166
Hallo,

ich finde die Darstellung nicht so abwegig. Hat man für die Merkmalwerte z.B. Select eingestellt, ist es im Gegensatz zu den Filtern an dieser Stelle (Artikeldetailseite im Beschreibungstab) wenig sinnvoll ein Select darzustellen, genauso wäre Bild + Text bei dieser Art der Auflistung auch eher ungünstig.
Die Einstellung "Merkmale anzeigen als" befindet sich unter "Merkmalfilter", bezieht sich also nicht auf die Darstellung in den Artikeldetailtabs.

Viele Grüße
Michael
 

mastertango

Sehr aktives Mitglied
10. Oktober 2009
2.299
11
Wustrow
naja wenn ich die Merkmale rein als Filter nutzen möchte mag das so sein, wenn ich jedoch mit den Merkmalen den Artikeln optisch eigenschaften verleihen möchte sieht die Sache wieder etwas anders aus.

Als Beispiel: Wir möchten unseren Artikeln ahnlich wie du hier sehen kannst Merkmale mitgeben damit der Kunde sowohl obtisch an den kleinen Bildern über dem Hauptbild, wie auch unten in der Beschreibung erkennen kann, welche Eigenschaften oder eben Merkmale der Artikel besitzt. Daher fände ich es schon ganz gut wenn man dieses hier etwas schicker bzw. einheitlicher gelöst hätte und nicht mal so mal so.
So macht die Einstellung in der WaWi halt eben nicht ganz so viel Sinn wenn Sie nicht überall das gleiche Ergebnis liefert
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
591
166
Ich verstehe deine Argumente nicht so recht. Wenn du es einheitlich haben möchtest dann kannst du die Merkmale doch einheitlich einstellen?
Ansonsten kannst du es dir natürlich über Templateanpassungen auch selbst gestalten wie du es haben möchtest. Dafür kannst du die productdetails/attributes.tpl in einem Child-Template anpassen.
In Zeile 14 siehst du die Unterscheidung:
HTML:
{if $characteristic->cTyp === 'TEXT' || $characteristic->cTyp === 'SELECTBOX' || $characteristic->cTyp === ''}
Was es für Typen gibt: "TEXT", "SELECTBOX", "BILD", "BILD-TEXT".
 

mastertango

Sehr aktives Mitglied
10. Oktober 2009
2.299
11
Wustrow
Naja , vielleicht habe ich mich bissl undeutlich ausgedrückt. Ich finde die Darstellung sehr unglücklich gelungen. Mal so mal so, egal wie man es einstellt.
Klar kann ich das über das Template dementsprechend anpassen. Nichts desto trotz sollte die Darstellung aber immer gleich sein bzw. einstellen können.
Im Backend unter Einstellung 614 kann ich das ja definieren während ich unter Einstellung 482 nur ein ja oder nein habe.

Anbei zur Verdeutlichung warum ich das ungünstig finde.

Wenn man hier die Merkmale nutzen will um Informationen kurzgefasst und visuell aufgepeppt rüber bringen zu wollen ist das halt bissl unschön.
Im filter ist ja gut aber wenn ich dann beim Artikel bin und schnell die Übersicht aller Merkmale des Artikels haben will.... naja ... halt unschön ....
Aber mehr auch nicht :)
 

Anhänge

  • merkmale1 artikel.png
    merkmale1 artikel.png
    20 KB · Aufrufe: 3
  • merkmale1 filter.png
    merkmale1 filter.png
    18 KB · Aufrufe: 3
Ähnliche Themen
Titel Forum Antworten Datum
Neu Woocommerce connector | in Wawi "Merkmale", in Woo "Attribute"| Bug Synchronisation werden Änderungen in Bezeichnung nicht übernommen WooCommerce-Connector 0
Neu Merkmale importieren nicht möglich Wawi 1.5.46.3 JTL-Ameise - Fehler und Bugs 2
Neu Nur bestimmte Merkmale in Artikellisten anzeigen lassen Templates für JTL-Shop 0
Neu Merkmale in Sitemap anzeigen JTL-Shop - BETA - Feedback und Bugmeldungen 2
Neu Merkmale automatisiert hinterlegen? User helfen Usern - Fragen zu JTL-Wawi 2
Neu Artikel - Attribute/Merkmale Versandkosten User helfen Usern - Fragen zu JTL-Wawi 1
Neu Exportvorlage Merkmale Allgemeine Fragen zu JTL-Shop 0
Neu JTL Debug kann nicht aufgerufen werden Allgemeine Fragen zu JTL-Shop 0
Neu WMS FiFo Prios werden nicht mehr berücksichtigt seit 1.5.47.3? Zwischenlösungen? JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
Neu Nach dem Upgrade Shop4 > Shop5 - Wawi-Syncdaten müssen manuell abgespeichert werden? JTL-Shop - Fehler und Bugs 2
Neu Änderungen an Pfandartikeln werden nicht übernommen JTL-POS - Fehler und Bugs 0
Neu Einrichten von Servicedesk - Postfächer können nicht eingerichtet werden Servicedesk (Beta) 1
Neu JTL Shop 5 WebP Bilder werden nicht erzeugt Betrieb / Pflege von JTL-Shop 0
Neu OPC Elemente werden durch Pagination nur teilweise neu geladen Einrichtung JTL-Shop5 2
Neu Variantebilder werden nicht angezeigt / SQL Fehler Shopware-Connector 0
Neu Wie kann sichergestellt werden, dass der eingerichtete Workflow auch wirklich greift? User helfen Usern - Fragen zu JTL-Wawi 3
Neu Ebay: Es werden keine Aufträge mehr abgeholt eBay-Anbindung - Fehler und Bugs 16
Neu USTID-Nr. von Lieferadresse von einem Kunden werden im Auftrag nicht gezogen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Artikel werden beim Upload immer erst gelöscht Shopware-Connector 0
Neu Für die aktuelle Transaktion kann kein Commit ausgeführt werden. / Fehlermeldung JTL-Wawi - Fehler und Bugs 1
Neu NOVA Child: Artikeldetailseite Tabs werden untereinander dargestellt anstatt zu faden Templates für JTL-Shop 2
Neu Artikel können nicht gesendet werden - Call to a member function getIso() on null Shopware-Connector 3
Neu Bestandskunden werden zu Schnellbestellern Shopware-Connector 2
Neu Bilder werden beim Abgleich gelöscht seit 6 Tagen WooCommerce-Connector 0
Gelöst VCS Lite Amazon Rechnungen werden hochgeladen aber nicht in der Wawi erstellt Amazon-Anbindung - Fehler und Bugs 1
Neu SW5 - Nach Connector Update - Bilder werden Artikel nicht zugewiesen Shopware-Connector 2
Neu Lieferscheine werden nicht erstellt JTL-Wawi - Fehler und Bugs 3
In Bearbeitung Es werden keine Aufträge mehr für Verkäufe an der Kasse in der WAWI erstellt Allgemeine Fragen zu JTL-POS 7
Neu Auf das verworfene Objekt kann nicht zugegriffen werden: Objektname: "jtlTextBox". eBay-Anbindung - Fehler und Bugs 1
Neu JTL Shop 4 - Artikel mit Pfand kann nicht in EU verschickt werden Allgemeine Fragen zu JTL-Shop 1
Neu Ältere Rechnungen und Aufträge werden nicht mehr angezeigt User helfen Usern - Fragen zu JTL-Wawi 6
Neu Alle Artikel werden übertragen bei Shopabgleich nach Datenbankumzug JTL-Wawi - Fehler und Bugs 1
Neu Amazon-Bestellungen werden in WaWi nicht übernommen Amazon-Anbindung - Fehler und Bugs 6
Neu Produktdaten für rich snippets werden von Shop5 (NOVA) nicht geliefert Allgemeine Fragen zu JTL-Shop 1
Neu Auftrag kann nicht ausgeliefert werden, obwohl das Häkchen bei "Auslieferung vor Zahlungseingang möglich" gesetzt wurde. User helfen Usern - Fragen zu JTL-Wawi 2
Neu Bilder auf Woocommerce werden nicht dargestellt. WooCommerce-Connector 0
Neu Bilder werden von Amazon nicht richtig erkannt. Amazon-Anbindung - Fehler und Bugs 0
Verwiesen an Support WorkflowAktionId 100 der Auftrag darf nicht verändert werden JTL-Workflows - Ideen, Lob und Kritik 2
Neu Fehlermeldung: "Es sind Steuersätze im Online Shop vorhanden, die keinem Steuersatz in der JTL WaWi zugeordnet werden können" Onlineshop-Anbindung 1
Neu Rechnungen werden nicht hochgeladen (bekanntes Thema...) Amazon-Anbindung - Fehler und Bugs 2
Neu Overlays werden nicht benutzt Templates für JTL-Shop 2
Neu Set-Artikel - bei einer bestimmten, enthaltenen Zeichenfolge soll der TARIC-Code ein- bzw. ausgeblendet werden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Abgelehnt Zahlarten werden in Wawi Auftrag nicht aktualisiert JTL-POS - Ideen, Lob und Kritik 3
Neu JTL-Wawi 1.5.46.0 - Kunde hat Paket im Paketshop nicht abgeholt - Rückläufer soll nach Wareneingang erneut versandt werden, wie vorgehen? User helfen Usern - Fragen zu JTL-Wawi 2
Neu Var. Kombinationen werden nicht unterstüzt Gambio-Connector 1
Neu JTL-Vouchers - Closed Beta | Jetzt Pilotkunde werden und aktiv mitentwickeln! Umfragen rund um JTL 0
Neu Shopware 6: HTML-Tags in Attributen werden nicht übertragen? Shopware-Connector 0
Neu Aufträge werden nicht synchronisiert. Shopify-Connector 4
In Bearbeitung Hakt in der Schnittstelle - Amazon-Aufträge werden seit 1.7.'21-0:00Uhr falsch in externe Rechnungen übernommen -> kein Rechnungsdruck mehr möglich! Amazon-Anbindung - Fehler und Bugs 138
Neu Bestimmte Konfigurationsartikel sollen nicht als "Empfohlen" angezeigt werden User helfen Usern - Fragen zu JTL-Wawi 0

Ähnliche Themen