Neu Konfigurator: Komponenten ohne Preis von der Ameise importiert -> Fehler

crahlfs

Aktives Mitglied
21. April 2010
72
0
Ich denke es handelt sich um einen echten Bug im Konfigurator und konnte es eingrenzen. Dieser hat ein Problem mit Artikeln ohne Preis, wenn diese per Ameise importiert wurden:

Damit ich Lagerbestand führen kann, habe ich einen Universalartikel in 5 farblichen Ausführungen bei ca. 2000 spezifischen Artikeln als Komponente hinzugefügt. Dazu habe ich:
Nach Anlage der Konfigurationsgruppe wurden die Komponenten per Ameise importiert.
-> 4 Komponenten ohne Preis importiert
-> 1 Komponente mit Preis importiert

Problem 1+2: Bei Kontrolle ist mir aufgefallen, dass der manuelle Preis der einen Komponente einfach nicht für den Onlineshop übernommen wird. Ich habe auf ein Komma Punkt Problem getippt und versucht die Preise mit Punkt oder Komma zu importieren, jedoch blieb der Preis beim Onlineshop auf 0,00. Nachdem ich zum Test einmal 0,00 importieren wollte, hat mir die Ameise erzählt, dass man keine 0 Importieren darf !? Ich musste also 0,00001 importieren um eine 0 zu bekommen.
-> Warum darf man keine Konfigurationsartikel importieren die nichts kosten? Ohne die Spalte Preis wird ja auch eine 0 eingetragen.
-> Ich habe es nun endlich geschafft die Onlineshop Preise zu importieren: Nur diese eine Spalte für den Onlinehshop erwartet die englische Notation! Man muss den Onlineshop Preis mit 0.00001 importieren oder 3.6 für 3,6€

Problem 3:
Nun ist mir aufgefallen, dass beim manuellen Anlegen eines Auftrags und der Auswahl der Komponenten nicht bei allen Komponenten eine Anzahl angezeigt wird. Man muss den Haken und die Anzahl setzen.
Daraufhin habe ich die Konfigurationsgruppen Verwaltung aufgerufen und wollte bei den Min und Max Mengen einfach nochmals eine 1 abspeichern. Leider wird in dem Augenblick ein Fehler angezeigt. Bei der einen Komponente mit einem manuellen Aufpreis wird kein Fehler angezeigt.
-> Nun habe ich einmalig den Haken gesetzt bei "Preise vom Artikel beziehen", gespeichert und den Haken wieder raus genommen und siehe da: Der Konfigurator schmeißt keinen Fehler mehr! Ich kann die Mengen Ändern und 0€ speichern.

-> Ich habe nun versucht es per Ameise nach zu stellen und habe alle Komponenten mit "Preise vom Artikel beziehen" importiert, dann in der Wawi eine Gruppe geöffnet, einen Kompoente geöffnet: Es ist korrekt hinterlegt, jedoch kommt der gleiche Fehler wieder, wenn man nun auf speichern drückt. Sobald man aber den Haken "Preise vom Artikel beziehen" raus nimmt und dann speichert, dann kommt kein Fehler.

--> Es scheint die Ameise irgend was falsch zu setzen!?

Problem 4
Genau nach Import von 300 Konfigurationsgruppen + dazugehörigen Komponenten bekomme ich einen Fehler beim Webshopabgleich. Es werden Artikel geschickt und auch Aufträge abgeholt, jedoch finde ich im Log diesen Fehler:

(InternalServerError) Es ist ein serverinterner Fehler aufgetreten. Bitte prüfen Sie die Logdateien des Shops.
Sollte kein allgemeines Webhosting-Problem bestehen, wenden Sie sich bitte an den JTL-Support. Angeforderte PHP-Datei: Konfig_xml.php(InternalServerError) Es ist ein serverinterner Fehler aufgetreten. Bitte prüfen Sie die Logdateien des Shops.
Sollte kein allgemeines Webhosting-Problem bestehen, wenden Sie sich bitte an den JTL-Support. Angeforderte PHP-Datei: Konfig_xml.php

Es muss irgendwas "faul" sein beim Import von Komponenten ohne Preis und ohne den Haken "Preise vom Artikel beziehen".
Liebe Grüße
Christoph
 

Anhänge

  • Gleiche Konfigurationsgruppe Versuch Anzahl zu ändern.jpg
    Gleiche Konfigurationsgruppe Versuch Anzahl zu ändern.jpg
    90,5 KB · Aufrufe: 8
  • Konfigurationsartikel_Auswahl_Manueller_Auftrag.jpg
    Konfigurationsartikel_Auswahl_Manueller_Auftrag.jpg
    103,5 KB · Aufrufe: 5
Zuletzt bearbeitet:

crahlfs

Aktives Mitglied
21. April 2010
72
0
Die Lösung zu diesen Problemen:
Man darf nur 3 Nachkommastellen importieren. Ansonsten wird in die Datenbank ein E... eingetragen, da die Warenwirtschaft nicht mehr als 3 Stellen verarbeiten kann. Daher kommt es dann auch zu Fehlern und der Shop Abgleich klappt nicht, da es eben keine Preise mit Ziffern geben darf.
-> Falls jemand also Preise Nullen möchte, muss man 0,001€ importieren. Die Unterpreise für Wawi Endkunde, Händler und Onlineshop müssen nach englischer Notation mit Punk eingelesen werden, da sonst aus 3,60 schnell 360,00 werden.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Konfigurator/Script für "welches ist das richtige Produkt für mich" Allgemeine Fragen zu JTL-Shop 2
Neu Bug? Sofortauftrag Konfigurator Sprache JTL-Wawi - Fehler und Bugs 1
Neu BUG Konfigurator Lagerbestand Abfrage JTL-Shop - Fehler und Bugs 0
Neu Reservierung von Komponenten JTL-Plan&Produce - Fehler und Bugs 0
Neu Installation JTL-Shop5 ohne die PHP-Erweiterung "php-imagick" Installation / Updates von JTL-Shop 0
Neu OPC Kategorieseite ohne Produkte - Inhalte verschwunden Allgemeine Fragen zu JTL-Shop 0
Shopware 6 - Artikel ohne Bestand nicht sichtbar Shopware-Connector 4
Neu Soft 404 wegen Hersteller-Seiten ohne Artikel Betrieb / Pflege von JTL-Shop 1
URL-Pfad ohne Bindestriche JTL-Wawi 1.6 1
Neu Exportvorlage Lieferantenbestellung ohne EK des Liefernaten User helfen Usern - Fragen zu JTL-Wawi 0
Neu Produkt in versch. Packungsgrößen ohne Kindartikel verkaufen möglich? User helfen Usern - Fragen zu JTL-Wawi 0
Neu jtlShop 5 lokal (docker): https://localhost/Kontakt -> 404 Not Found (ohne ssl geht es) Technische Fragen zu Plugins und Templates 1
Neu Variationskombinationen ohne Kinder exportieren User helfen Usern - Fragen zu JTL-Wawi 1
Neu Wieder ohne Autorisierung... JTL-Track&Trace - Fehler und Bugs 2
Neu Auftrag auf Versand setzen ohne Versandbenachrichtigung User helfen Usern - Fragen zu JTL-Wawi 2
Artikel und Artikelbilder ohne Bestand nicht in JTL Shop synchronisieren Einrichtung JTL-Shop5 0
Neu Amazon.com Bestellungen ohne Name Amazon-Anbindung - Ideen, Lob und Kritik 1
Neu Artikel ohne Lagerplatz ein- bzw. umlagern User helfen Usern - Fragen zu JTL-Wawi 1
Wawi 1.6.43.0 Maximaler Bestand neu setzen ohne Funktion JTL-Wawi 1.6 9
Neu Plötzlich uralte Artikel im Amazon Artikelbestand verfügbar - ohne Zutun von uns Amazon-Anbindung - Fehler und Bugs 0
Neu Artikel ohne Lagerbestand werden in der Suche angezeigt JTL-Shop - Fehler und Bugs 0
Neu Seller Fulfilled Prime nutzen ohne Amazon insgesamt anzubinden Einrichtung und Installation von JTL-eazyAuction 1
Neu Sofort-Auftrag ohne Kunden anzulegen? User helfen Usern - Fragen zu JTL-Wawi 4
Artikel ohne Preis für schneller Abwicklung in POS JTL-Wawi 1.6 5
Neu Amazon Verkäuferkonto freigeschaltet - Produkte in JTL eingspielt, nun die Frage, 50.000 Artikel wie bekommt man diese mit EAN und teils ohne EAN Amazon-Anbindung - Ideen, Lob und Kritik 5
Neu Preselect Attribute ohne Funktion WooCommerce-Connector 2
Neu Favicon unter Einstellungen NOVA hochgeladen ohne Erfolg Allgemeine Fragen zu JTL-Shop 4
Issue angelegt Zahlungsarten deaktivieren ohne sie zu deinstallieren JTL-POS - Fehler und Bugs 2
Neu Shop lief ohne Wawi, Bestellungen manuell angelegt, wie weiter machen? Arbeitsabläufe in JTL-Wawi 0
Neu FBA Aufträge ohne Rechnungen Amazon-Anbindung - Fehler und Bugs 3
Neu PayPal Checkout Zahlung ohne Bestelleingang in der Wawi JTL-Shop - Fehler und Bugs 0
Neu 1.6.40.0 Kritische Sicherheitslücke Fehlerhafte Rechtevergabe Zugriff auf sensible Daten ohne Berechtigung möglich JTL-Wawi - Fehler und Bugs 11
Neu Merkmale ohne Treffer ausblenden Allgemeine Fragen zu JTL-Shop 0

Ähnliche Themen