Neu Kategoriebilder werden nicht angezeigt

Hackmesser24.com

Neues Mitglied
28. August 2021
2
0
Hallo zusammen,

ich benutze JTL WAWI seit einigen Monaten und bin nun dabei einen JTL- Shop aufzusetzen. Grundsätzlich bin ich auch sehr zufrieden.

Seit ich den Shop 5.0.3 vor 4 Wochen ganz frisch auf einem neuen Webserver installiert habe, lade ich die Kategoriebilder aus der WAWI zwar ohne Fehler hoch, jedoch kommen sie nicht auf dem Server an.

Weder im alten Verzeichnis <shopverzeichnis>/bilder/kategorien

noch im "neuen" <shopverzeichnis>/media/image/category

sind sie vorhanden. Verzeichnisrechte stimmen.

Ich betreibe einen eigenen Linux Webserver mit Debian10. Der Shop läuft einwandfrei, Artikelbilder werden hochgeladen und angezeigt, nur bei den Kategoriebildern hakt es. In den Kategorien der WAWI ist alles korrekt markiert.

In einem Testshop den ich vor ein paar Wochen von JTL zur Verfügung bestellt bekommen habe lief das mit den selben Bildern problemlos.

Allen bisher im Forum gelesenen Empfehlungen gefolgt, Komplettabgleich mit vorheriger Cache Löschung, Bildgrössen verkleinert, vergrössert, auch mal Artikelbilder als Kategoriebilder verwendet die sich einwandfrei hochladen und im Artikel anzeigen lassen...
Bei den Kategoriebildern klappt das einfach nicht.

Bei meiner Recherche bin ich auf folgenden Codeblock in der productlist/header.tpl gestossen:

{block name='productlist-header-subcategories-image'}
{link href=$subCategory->getURL()}
<div class="subcategories-image d-none d-md-flex">
{image fluid=true lazy=true webp=true
src=$subCategory->getImage(\JTL\Media\Image::SIZE_SM)
alt=$subCategory->getName()}
</div>
{/link}
{/block}

Hier wundert mich in der Pfadangabe der String "\JTL\" etwas. So existiert der Pfad bei mir nicht. Muss hier etwas angepasst werden? Ist das noch ein Rest des von JTL mir zur Verfügung gestellten Test Shops?

Bin für Anregungen dankbar. Reite schon seit Tagen darauf herum.


Gruss Roland
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Kategoriebilder auf SunMi T2 fehlen JTL-POS - Fehler und Bugs 3
Neu Einige Kategoriebilder fehlen Upgrade JTL-Shop4 auf JTL-Shop5 0
Neu Fehlermeldung beim einpflegen der Kategoriebilder in Wawi User helfen Usern - Fragen zu JTL-Wawi 3
Neu Suchanfrage werden nicht gespeichert. Wo kann man es freischalten? Allgemeine Fragen zu JTL-Shop 0
Neu Warum werden veraltete Inhalte immer wieder im Suchindex aufgeführt? Allgemeine Fragen zu JTL-Shop 5
Neu Teillieferungen werden als komplett versendet gemeldet (again) Shopify-Connector 0
Gelöst Mediafiles werden nicht in Wawi angezeigt JTL-Wawi - Fehler und Bugs 1
Neu Shop 5.1.1 Artikel werden nach Wawi Wareneingang von allen Shop Wunschlisten gelöscht JTL-Shop - Fehler und Bugs 1
In Bearbeitung Telecash Belege werden nicht an der Kasse gedruckt JTL-POS - Fehler und Bugs 2
Neu Lagerbestand in Variationen werden nur die letzten gezeigt und in Gambio geleitet Gambio-Connector 0
Neu [Shopware 6] Erstelltes Menu im JTL-Wawi kann im Shop keinem Layout zugewiesen und gespeichert werden Shopware-Connector 1
Neu Bilder werden nach Änderung vertauscht (unbenannt.png) Modified eCommerce-Connector 0
Neu Nach Datenabgleich werden automatisch Rechnungskäufe als bezahlt eingetragen. WooCommerce-Connector 1
Neu Lieferadresse soll auf jedefall ausgedruckt werden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Shop 4: Bilder werden nicht automatisch generiert Einrichtung von JTL-Shop4 2
Neu Metadaten werden nicht an Gambio-Shop übermittelt Gambio-Connector 3
Neu Artikel werden nicht aktualisiert Shopware-Connector 8
Neu Artikel in Auftrag werden nicht verknüpft JTL-Ameise - Fehler und Bugs 2
Neu Bestellungen werden nicht in Aufträge gewandelt eBay-Anbindung - Fehler und Bugs 0
Neu Abfrage, ob der Warenkorb aus einem oder aus mehreren Lägern versendet werden muss Betrieb / Pflege von JTL-Shop 0
Neu Vater Kind Preise werden zum Teil einfach addiert? Gambio-Connector 0
Neu Shop 5.1.1 kann nicht installiert werden Installation / Updates von JTL-Shop 15
Neu Nur ausgewählte Artikel können direkt ins Ausland bestellt werden Betrieb / Pflege von JTL-Shop 0
Neu Weiterleitungen können nicht angelegt werden nach Update auf JTL 5 JTL-Shop - Fehler und Bugs 3
Neu Nach einem Domainumzug und anschließendem Update auf Shop 5.1 werden die deutschen Umlaute nicht richtig dargestellt Installation / Updates von JTL-Shop 2
Neu Beim Upload von Kinderartikel werden die Preise und Variationsbilder der Kinder nicht übernommen Modified eCommerce-Connector 2
Neu HILFE! Bestellungen werden nicht mehr importiert WooCommerce-Connector 2
In Diskussion FBA Rechnungen werden nicht mehr über den Workflow ausgedruckt JTL-Workflows - Fehler und Bugs 4
Neu Produktbilder werden plötzlich mehrfach in Shopify bei Variationen angelegt Shopify-Connector 9
Neu Bilder werden nicht übertragen WooCommerce-Connector 0
Testshop kann nach dem Anlegen nicht geöffnet werden Einrichtung JTL-Shop5 1
Neu FBA Gutschriften werden nicht als Rechnungskorrektur erstellt Amazon-Anbindung - Fehler und Bugs 7
Neu Artikel kann nicht auf Amazon eingestellt werden - [Herkunftsland = null] Amazon-Lister - Fehler und Bugs 1
Beantwortet Können Amazon UK Rechnungen mittlerweile abgerufen werden? Ticket 48721 User helfen Usern - Fragen zu JTL-Wawi 2
In Bearbeitung Fehler "Typ " 'Decimal' für Eigenschaft 'Anzahl' konvertiert werden. " in Worflow mit DotLiquid JTL-Workflows - Ideen, Lob und Kritik 4
Verwiesen an Support Produkte liegen im Pickwagen und können nicht verarbeitet werden Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 1
Weiterleitungen können nicht eingerichtet werden Einrichtung JTL-Shop5 0
Verwiesen an Support Händlerpreise werden nicht an Shopware übergeben Shopware-Connector 2
Neu Steuern werden falsch in die Wawi importiert Shopware-Connector 1
Gelöst Konfigurator - Komponenten Namen werden nicht angezeigt nach Update auf 5.1 JTL-Shop - Fehler und Bugs 3
Gelöst 5.1.0 - VarKombi Bilder werden nicht angezeigt JTL-Shop - Fehler und Bugs 1
Gelöst Pos Verkäufe werden nicht mehr an die Wawi übertragen JTL-POS - Fehler und Bugs 16
Neu Artikel werden dupliziert JTL-Wawi - Fehler und Bugs 3
Neu Allgemeiner Fehler wenn DHL Labels gleichzeitig erstellt werden JTL-ShippingLabels - Fehler und Bugs 0
Neu Kunden werden nicht gefunden Servicedesk (Beta) 1
Neu Wawi Bereich "Verkauf" in JTL5 ->Kundendaten werden falsch angezeigt und sogar falsch generiert JTL-Wawi - Fehler und Bugs 1
Neu Variantions Kombination - Bilder werden im Shop nicht angezeigt JTL-Wawi - Ideen, Lob und Kritik 11
Neu Wie ersetze ich Bilder, sodass sie auch angezeigt werden? Allgemeine Fragen zu JTL-Shop 3
Neu Bilder in Signatur werden nicht überall angezeigt Servicedesk (Beta) 6
Neu Kategorien können nicht aktiviert werden Modified eCommerce-Connector 1

Ähnliche Themen