JTL-Shop Abgleiche geht nicht mehr

  • Ersteller des Themas Ersteller des Themas winni
  • Erstellungsdatum Erstellungsdatum

winni

Gut bekanntes Mitglied
25. Oktober 2011
249
2
Hallo,

bei mir geht seit paar tagen Abgleich nicht mehr. Shop sowie Wawi auf dem aktuellsten Stand.


Der Abgleich wurde abgebrochen. Alle im Abgleich entstandenen Fehler finden Sie im Logbuch.

DbeSInitStep | Failed getting InitializeEntity! Aborting sync... [!]

JTL.Wawi.Sync.Core.Domain.dbeS.DbeSProtocolException: Received invalid response: 3
5.4.1
bei JTL.Wawi.Sync.Core.Domain.dbeS.DbeSResponse..ctor(HttpResponseMessage message, String content)
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSClient.<ProcessRequestInitResponseAsync>d__46.MoveNext()
--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSClient.<RequestInitAsync>d__43.MoveNext()
--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSClient.<SendInitRequestAsync>d__42.MoveNext()
--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSClient.<SendInitAsync>d__32.MoveNext()
--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
bei JTL.Wawi.Sync.Core.Services.DbeSStepAbstract.<ExecuteDbeSCallAsync>d__36.MoveNext()

[DbeSClient]Received invalid response: 3
5.4.1 [!]Received invalid response: 3
5.4.1


weit einer voran es liegt?

danke

Johann
 

Anhänge

  • b68962f0-e13b-40ee-9073-59b4178c69bc.jpg
    b68962f0-e13b-40ee-9073-59b4178c69bc.jpg
    98,6 KB · Aufrufe: 55

winni

Gut bekanntes Mitglied
25. Oktober 2011
249
2
Hallo,

Passwort habe ich nicht geändert. Bei Shop-URL von http:// auf https:// geändert, dann war Verbindung ok.
Abgleich geht leider trotzdem noch nicht.

Mit der Lizenz stimmt was nicht.

sieh Bild im Anhang
 

Anhänge

  • jtl1.jpg
    jtl1.jpg
    23,8 KB · Aufrufe: 48

Michi001

Sehr aktives Mitglied
15. Dezember 2020
163
40
Hallo,

bei mir geht seit paar tagen Abgleich nicht mehr. Shop sowie Wawi auf dem aktuellsten Stand.


Der Abgleich wurde abgebrochen. Alle im Abgleich entstandenen Fehler finden Sie im Logbuch.

DbeSInitStep | Failed getting InitializeEntity! Aborting sync... [!]

JTL.Wawi.Sync.Core.Domain.dbeS.DbeSProtocolException: Received invalid response: 3
5.4.1
bei JTL.Wawi.Sync.Core.Domain.dbeS.DbeSResponse..ctor(HttpResponseMessage message, String content)
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSClient.<ProcessRequestInitResponseAsync>d__46.MoveNext()
erhalten seit Tagen dieselbe Fehlermeldung beim Shopabgleich. PW geändert und auch in der Wawi eingetragen, bringt jedoch keine Besserung. Haben ein update von Shop und Wawi auf die neuste Version gemacht, hilft auch nichts.

Hat jemand einen Lösungsansatz?
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.665
2.715
Berlin
Firma
css-umsetzung
Das kann alles mögliche sein, fang da gar nicht lange an rumzufummeln.

Deaktiviere alle Plugins und wenn es dann noch immer nicht geht, dann mache ein Ticket auf bei JTL oder frag deinen SP sofern du einen hast.

Mit Cloudflare könnte es auch Probleme geben aber da bin ich jetzt nicht ganz sicher, welche Fehlermeldung da dann kommen würde.
 

wawi-dl

Sehr aktives Mitglied
29. April 2008
6.789
833
@css-umsetzung
Wir hatten einen Angriff von AMAZON, mein Hoster hat über Cloudflare versucht gewisse PHP zu blocken.
Aber der JTL Sync schießt dann genau diesen Fehler.

Wir tüfteln gerade, wie wir Bots und Amazon vom Shop fern halten können, weil wir 1Mio Zugriffe statt 65k haben, alles lahmgelegt wird.
Wir dachten wir schließen den Ordner "dbeS" aus, mit diversen PHP für den Sync, aber ohne Erfolg.

Hast du evtl. eine Idee? Ich bin da nicht so tief drin, was JTL Shop für den Sync braucht.
 

css-umsetzung

Offizieller Service Partner
SPBanner
6. Juli 2011
8.665
2.715
Berlin
Firma
css-umsetzung
Was heisst Angriff über Amazon.
Wenn Ihr Cloudflare einsetzt, müsst Ihr die IP der WAWI freigeben
 

wawi-dl

Sehr aktives Mitglied
29. April 2008
6.789
833
Wir sehen nur massiven Beschuss von Amazon, wir verkaufen seit kurzem auf Amazon, offenbar werden wir überprüft bzgl. Preise.

Wir haben die IP gesetzt, aber diese hat sich offenbar geändert, gegen Aussage von Anbieter, ich denke das war schon der Tipp, danke.
 

Ironyeti

Aktives Mitglied
18. Juli 2014
21
0
Hallo,

Ich beziehe mich auf das Problem von winni.
Bei mir funktioniert der WAWI - Abgleich seit heute morgen nicht mehr. (WAWI 1.10.15.0)
Folgende Fehlermeldung wird angezeigt:

DbeSInitStep | Failed getting InitializeEntity! Aborting sync... [!]

JTL.Wawi.Sync.Core.Services.dbeS.DbeSClientSolvableException: JTL-Wawi
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSExceptionHandler.CheckStatusCodeAndThrow(HttpResponseMessage response)
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSClient.<RequestInitAsync>d__43.MoveNext()
--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
bei System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSClient.<SendInitRequestAsync>d__42.MoveNext()
--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
bei System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSClient.<SendInitAsync>d__32.MoveNext()
--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
bei System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
bei JTL.Wawi.Sync.Core.Services.DbeSStepAbstract.<ExecuteDbeSCallAsync>d__36.MoveNext()

Der Verbindungstest funktioniert, so dass es wohl nicht am Benutzer oder Passwort liegen sollte. Ein manueller Abgleich funktioniert auch nicht.
Wie wurde das Problem von winni gelöst?
 

Ironyeti

Aktives Mitglied
18. Juli 2014
21
0
Hallo,

bei mir geht seit paar tagen Abgleich nicht mehr. Shop sowie Wawi auf dem aktuellsten Stand.


Der Abgleich wurde abgebrochen. Alle im Abgleich entstandenen Fehler finden Sie im Logbuch.

DbeSInitStep | Failed getting InitializeEntity! Aborting sync... [!]

JTL.Wawi.Sync.Core.Domain.dbeS.DbeSProtocolException: Received invalid response: 3
5.4.1
bei JTL.Wawi.Sync.Core.Domain.dbeS.DbeSResponse..ctor(HttpResponseMessage message, String content)
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSClient.<ProcessRequestInitResponseAsync>d__46.MoveNext()
--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSClient.<RequestInitAsync>d__43.MoveNext()
--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSClient.<SendInitRequestAsync>d__42.MoveNext()
--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
bei JTL.Wawi.Sync.Core.Services.dbeS.DbeSClient.<SendInitAsync>d__32.MoveNext()
--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
bei JTL.Wawi.Sync.Core.Services.DbeSStepAbstract.<ExecuteDbeSCallAsync>d__36.MoveNext()

[DbeSClient]Received invalid response: 3
5.4.1 [!]Received invalid response: 3
5.4.1


weit einer voran es liegt?

danke

Johann
Hallo winni,

habe seit heute das gleiche Problem.(gleiche Fehlermeldung)
Wie hast du deins gelöst?

Gruß Jörg
 

ARBEIT_Clausi

Aktives Mitglied
6. Februar 2018
4
0
Hallo,

bei uns das gleiche Problem.
Habt ihr schon ein Idee was es sein kann?
Warum die Frage nach domainfactory?

LG Chrsitian
 

vishes

Aktives Mitglied
11. Juli 2016
53
12
Es wird wohl der Abgleich bei unserem Hoster durch ModSecurity blockiert. Dies kann man leider bei unserem Tarif/Server nicht selber ausstellen.
 

mvh

Sehr aktives Mitglied
26. Oktober 2011
1.243
475
Es werden viele IP-Aufrufe wegen falscher WaWi-Abfrage blockiert.
Falls mod_security verwendet wird - dann über WebGUI vom Hoster die eigene IP-Adresse whitelisten: 192.xxx.xxx.100 zur Liste hinzufügen
oder direkt über .htaccess
SetEnvIfNoCase Remote_Addr ^192\.xxx\.xxx\.100$ MODSEC_ENABLE=Off
oder direkt mod_security.conf:
SecRule REMOTE_ADDR "^192\.xxx\.xxx\.100$" phase:1,nolog,allow,ctl:ruleEngine=Off
 

Ironyeti

Aktives Mitglied
18. Juli 2014
21
0
Es werden viele IP-Aufrufe wegen falscher WaWi-Abfrage blockiert.
Falls mod_security verwendet wird - dann über WebGUI vom Hoster die eigene IP-Adresse whitelisten: 192.xxx.xxx.100 zur Liste hinzufügen
oder direkt über .htaccess
SetEnvIfNoCase Remote_Addr ^192\.xxx\.xxx\.100$ MODSEC_ENABLE=Off
oder direkt mod_security.conf:
SecRule REMOTE_ADDR "^192\.xxx\.xxx\.100$" phase:1,nolog,allow,ctl:ruleEngine=Off
Ich gehe davon aus, dass Hosteurope mod_security verwendet.(Leider bisher keine Antwort)
in welche .htaccess Datei muss ich den Eintrag vornehmen?
 

mvh

Sehr aktives Mitglied
26. Oktober 2011
1.243
475
Im Hauptordner.
So ungefähr. Und ohne Gewähr. Und die richtige IP-Adresse verwenden. Und für Apache.
Code:
<IfModule mod_setenvif.c>
    SetEnvIfNoCase Remote_Addr "^192\.168\.100\.100$" MODSEC_ENABLE=Off
</IfModule>

# Ensure ModSecurity respects the MODSEC_ENABLE variable
<IfModule mod_security.c>
    SecRuleEngine On
    SecRule REMOTE_ADDR "@rx ^192\.168\.100\.100$" "phase:1,nolog,allow,ctl:ruleEngine=Off"
</IfModule>
 

Ähnliche Themen